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Overview

The NeoOffice User Guide is based on OpenOffice.org User's Guide. It attempts to
provide answers to questions about working with NeoOffice. It is focused on NeoOffice
2.x releases, but it should also be useful with NeoOffice 1.x releases. Graphics, for the
most part, use the newer style Akua icons rather than the older default iconset.

In addition, use of the NeoOffice Help facility is also covered. Through Help, users can
get detailed answers to all questions at any time by pressing F1, opening the Help menu
or clicking the Help buttons. More information on using Help can be found in Chapter
1, Workingwith NeoOffice.

Other sources of support are available through the trinity forum for NeoOffice users
http://trinity.neooffice.org/modules.php?name=Forums and the NeoOffice news page at
http://trinity.neooffice.org/index.php , the OpenOffice.org support newsgroups provided
by gmane.org and the latest news about OpenOffice.org at www.openoffice.org.

Using the Guide

This User's Guide is designed for users who are already familiar with the basic functions
of their Mac. Where there are differences in certain functions between the Mac and other
OpenOffice.org supported operating systems, these differences are explained. If functions
described here are not available on OS X, this is explained.

Wewill attempt to keep up with newer releases of NeoOffice by updating this guide and
informing users via the trinity NeoOffice forum. The guide's first edition is aimed at
users of NeoOffice 2.0 and later.

Using Abbreviations and Shortcuts
Throughout this Guide, we commonly use these OS X shortcuts and abbreviations:

○ The “control” key is referred to as Ctrl

○ The “command” key is referred to as Cmd. This is the key labelled with⌘
and .

○ The alt/option key is usually referred to as Option.

○ The Mac keyboard is the basis for our instructions. Those using a non-
standard mac keyboard may wish to note that in relation to keys such as Esc,
delete, Return

○ Where a right-click is referred to, users of a single-button mouse may use
Ctrl-click.

○ Keystrokes to be carried out simultaneously are linked by a dash, not by a plus
sig (e.g. when in Wondows one might put Ctrl+F9, here we would put Ctrl-F9

Screen pics in the Guide may use either blue or graphite for buttons, sliders etc.

US spellings are generally used throughout e.g. color, theater, meter. On the other hand,
the Guide has been prepared in A4 size, the most popular size outside North America.
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Overview

The pathway Tools > Options is exactly the same as selecting Preferences.... This is a
carry-over from Windows/Unix. Feel happy doing either. The result will be the same.

Highlighting and Bolding
The approach used in the Guide is as follows:

● Bold is used for instructions which appear on memos, tabs, toolbars (e.g. A14-
F12)

● Helvetica font is used to show entries in tables or the words quoted (e.g.
Heading1, Default)

● Italics are used for buttons or keys (e.g. OK; Cmd-F7)

NeoOffice User Guide for 2.x 3



New Features with NeoOffice 2.x

New Features with NeoOffice 2.x

Open Standards XML File Format (OASIS OpenDocument)
Beginning with version 2.0, OpenOffice.org uses the open standard OASIS
OpenDocument XML format as the default file format. Hence NeoOffice, which is
based on the OpenOffice.org code base, uses XML format as the default file format. The
OASIS OpenDocument format is a vendor- and implementation-independent file format,
and thus guarantees freedom and independence.

In addition to OpenOffice.org itself, the open source office suite Koffice, as well as
OpenOffice.org derivatives like the StarOffice software, support the OASIS
OpenDocument file format. The OASIS OpenDocument file format is also one of the file
formats recommended by the European Commission. From version 2.1, NeoOffice
allows Mac users to utilize OpenXML documents, opening, editing, and saving of
Microsoft Office 2007 OpenXML documents.

New Multi-pane View
The new Multi-pane view increases the productivity and usability of NeoOffice. The
Multi-pane view provides all important tools and windows through one coherent,
integrated, and simple user interface. Former Microsoft PowerPoint users should find
NeoOffice 2.x easy to use.

New CustomShapes (compatible with Microsoft AutoShapes)
NeoOffice now supports CustomShapes, which are very similar to Microsoft's
AutoShapes. As a consequence, AutoShapes are imported and displayed correctly.
CustomShapes are shapes that can change not only their size but also their appearance.

More Slide Transitions and Animation Effects
NeoOffice now supports many more animation effects and slide transitions. Now users
have more options to give their presentations a professional appearance. In addition, the
extended support for effects improves the Microsoft PowerPoint compatibility.

Enhanced PDF Export
NeoOffice 1.x introduced the PDF export feature. Version 2.x now extends the basic
export feature. With the new version, it is possible to define the compression levels of
embedded images. In addition, the PDF support now correctly handles thumbnail images
and hyperlinks.
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New enhanced Database Frontend
NeoOffice now includes a database program. OpenOffice.org always had database
frontend tools, but in past versions they were very hidden. NeoOffice 2.x starts to handle
databases like any other application, i.e. a new database can be created via the "File -
New" menu. For novice users, NeoOffice provides a new TableWizard that allows you to
create database tables without any knowledge of databases and SQL. The new embedded
Java-technology-based HSQLDB database engine allows users to create "database
documents". These simple database files don't require a backend database server like
MySQL or Adabas D. All information (table definitions, data, queries, forms, reports) is
stored in one XML file.

Mail Merge Wizard
The new Mail Merge Wizard will make it very easy to do mailings to hundreds of
recipients. The wizard guides you step by step through the process. Different data sources
can be used for the address information. There are differences though from previous
versions.

Enhanced Word Count Feature
With 1.x, it was only possible to find document statistics under "File > Properties ..." or
by installing a word count macro to count the number of words in a selection. NeoOffice
2.0 eliminates this restriction. Now a new word count dialogue can be found in the
"Tools" menu.

Support for Nested Tables
With NeoOffice 2.0 it is now possible to create tables within tables (nested tables). This
increases the overall usability, but also improves the Microsoft Word compatibility.
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Digital Signatures Support
Another new feature is the support of digital signatures. NeoOffice uses certificates
stored in the regular repositories. Os X certificates are available through Keychain
Access.

XForms Support
NeoOffice 2.x now allows you to create forms based on the open W3C XForms standard.
With XForms it is very easy to implement simple logic without any programming.

WordPerfect® Filters
NeoOffice 2.x includes a WordPerfect® filter developed by the open source community.
Developers are invited to contribute to this project.

Calc now has 65,536 Rows
NeoOffice 1.x supported only 32,768 rows in spreadsheet documents, which caused some
Microsoft Excel interoperability issues. The new version now takes NeoOffice to the
same level as Microsoft Excel.

Enhanced DataPilot Support
With the DataPilot in NeoOffice 2.x (similar to Microsoft Excel's PivotTable feature) it is
now possible to create new groups, filter data based on values, show differences and
percentages instead of absolute values, etc.

The new DataPilot features turn NeoOffice Calc into a very powerful tool for data
analysis.

Native Desktop Integration
NeoOffice 2.x integrates nicely into the OS X desktop environment. The programmers
have worked hard to make it behave as a native Mac program. Thus, NeoOffice looks
and behaves largely like any other Mac application. The level of integration into the OS
X GUI is increasing with each release.

Floating Toolbars
Toolbars are much more flexible in NeoOffice 2.x. It is now very easy to attach and
detach toolbars, move them around and customize them.

Icons
From release 2.1, a new default iconset, Akua, has been introduced. This has been
designed from the ground up to fit the OS X GUI. It replaces the old Default set. There
are still alternative iconsets available via the Toolsmenu, including the KDE Crystal
iconset and the expected Tango iconset (which replaces the Industrial iconset in later
versions of OpenOffice.org 2.x). A new icon has been added to the Standard toolbar.
This icon is a shortcut to the style painter in the Style and Formatting Window.

Solver
NeoOffice now provides support to Novell's Solver function.

NeoOffice User Guide for 2.x 6



Chapter 1: Help

Chapter 1: Help

NeoOffice User Guide for 2.x 7



Chapter 1: Help

Copyright and Trademark Information: NeoOffice User Guide for
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Chapter 1: Using NeoOffice Help

Different kinds of help are available in NeoOffice.

● Step-by-step instructions with full references via the Contents and Index
selections of NeoOffice Help

● Help Tips that pop up next to the mouse pointer

● Extended tips with more detailed explanations than provided with Tips

● The NeoOffice user forum at http://trinity.neooffice.org

Illustration: Help menu, NeoOffice Writer

NeoOffice Step-by-Step Help
To accessHelp, use the Help menu item or click the Help buttons in the individual
dialogues.

NeoOffice User Guide for 2.x 9

http://trinity.neooffice.org/


Chapter 1: Using NeoOffice Help

NeoOffice Help is context-sensitive. This means that, when Help is opened in Writer it is
specific to Writer. Similarly, to get help about Calc, either first open a spreadsheet and
only then look for help, or select Help for the specific module from the pull-down list at
the top of the Help window. The pull-down list at the top of the Help window sets the
selected module as the current section for searching.

Tips
Tips are on at installation by default and it is recommended that this feature should
always be switched on. With Tips activated one can , for example, let the mouse pointer
rest on an icon so that its name is displayed. Tips may also be seen in many other places
in NeoOffice. For example, when scrolling through a table, the tip shows the row or
column.

Turning tips on and off
Select Tools > Options > NeoOffice > General > Tips to enable or disable this feature.

Extended Tips
Switch on the Extended Tips during the first few weeks of NeoOffice usage. Enabling
this option gives a brief description of each item on the screen when the mouse pointer is
hovered over the item for a moment.

Turning extended tips on and off

Choose Tools > Options > NeoOffice > General > Extended Tips to turn extended tips
on and off. The command is checked when the Extended Tips function is switched on.

Press Shift-F1 to turn Extended Tips on temporarily. The pointer turns into the
Extended Tips pointer. Now see the Extended Tips for any element on the

screen as the mouse pointer is moved. As soon as the mouse is clicked or a key pressed,
the pointer returns to the normal mouse pointer.

Help Agent

When certain actions are performed in NeoOffice, the Help Agent
automatically appears. This is a small window in a corner of the
document. The Help Agent normally remains visible for 30 seconds.
When clicked, it is replaced by a help window providing some helpful
advice about the current topic.

If a Help Agent dealing with the same topic is repeatedly ignored or closed instead of
being clicked, it does not appear again for this topic. Resetting the Help Agent restores it
to the way it was when NeoOffice was first installed.
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Turning the Help Agent on and off
● Choose Tools > Options > NeoOffice > General and check Help Agent to have
the Help Agent appear. If the command is checked, the Help Agent is
automatically displayed when certain actions are performed in NeoOffice.

● Choose Tools > Options > NeoOffice > General to reset the Help Agent.
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Chapter 2: Working With NeoOffice

NeoOffice, like its parent OpenOffice.org, is reasonably intuitive but is sufficiently
different to other suites that a period of familiarization may be required before your use is
fluid and effective. This chapter starts with a general explanation of the most common
control features in NeoOffice, such as toolbars, floating toolbars and dockable windows.
This is followed by information on functions that can be used in most of the program
modules of NeoOffice.

The User Interface
NeoOffice provides not only the usual control elements found in other applications, such
as menus and icons, but a host of other special features besides. For example, many of the
special NeoOffice features can be accessed via a context menu, opened by right-clicking
on the selected objects. Other user-friendly functions are available by dragging and
dropping with the mouse. Throughout this guide, you will be reminded that right-clicking
can be achieved with a Ctrl-click on a one-button mouse.

Starting NeoOffice
In Mac OS X, start NeoOffice as you would any other native OS X program: i.e. by
double-clicking on its icon on the desktop or in the dock, or by using the “open”
command in the Finder. If you are starting afresh with a new document, start NeoOffice.
The program will load and you will be invited to begin a document. From the drop-down
“File” menu at the left of screen, choose what sort of document you wish to create or
work with:

For example, to create a blank text document in Writer, roll down and click Text
Document. For a blank spreadsheet in Calc, click Spreadsheet, and so on.
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As with other OS X applications, double-clicking on the icon of a NeoOffice document
will open both the program and the document – provided that NeoOffice has been set as
the default program for opening that sort of document. For instance, if you have set
NeoOffice as the default program for opening .odt documents, when you click on a file
with that .odt suffix, NeoOffice will start and will open the document.

NOTE: from the NeoWiki

Setting the default application to open NeoOffice or OpenOffice.org, Microsoft Office, WordPerfect, and
HTML, RTF or plain text documents

General method
1. Select a document of one of the types, i.e., foo.odt, in the Finder.
2. Select Get Info from the Finder's File menu (or type Cmd-I).
3. Click on the disclosure triangle next to "Open with:" to expand that section.
4. Choose the appropriate launcher application from the drop-down list.
5. Click the "Change All" button and "OK" in the resulting dialog. dialog

Note 2: You should be able to tell from the document's icon whether it will automatically open with
NeoOffice. If the icon is one of the NeoOffice icons, then double-slicking it will open and load the
document as a NeoOffice file.
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The NeoOffice Writer Window
A text document is displayed and edited in the Writer window. Spreadsheet, presentations
or drawings are displayed in very similar windows, except the menus and icons change
automatically depending on the context.

Illustration: major features of the NeoWriter window

Toolbars in the NeoOffice Window

The Title Bar

The title bar shows the name of the program, (Writer, Calc etc.), and usually the file
name of the current document. If a document title has been entered in File > Properties
> Description, this title is displayed rather than the file name.

The Menu Bar

Above the document window, immediately above the title bar, is the menu bar. This
provides drop-down menus in the traditional OS X manner.
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The menus are organized into basic functions. The Edit menu, for example, provides the
functions needed to edit the current document (cut, copy, paste, undo changes and so on),
while the Viewmenu has functions that allow control of the view of the elements
displayed on the screen. The commands used for editing, viewing, sequencing, formatting
and printing a document can only be used when the document is open and active. Active,
in this sense, means that the document is front of any others on the screen. If the
commands are to correspond to an object in the document, then that object has to be
selected.

In addition, the menus are context sensitive. This means that only those menu commands
that are relevant to the current work will be available . For example, if the cursor is
located in a text document, then only the text editing menu commands are available.
Likewise, if graphics are selected in a document, then only the menu commands that can
be used to edit graphics will be available. The other inactive menu items are hidden.

NeoOffice lets you change and customize the menu bar as desired. Many of the toolbars
and the status bar may thus be modified to suit personal requirements.

The Toolbars

Below the title bar is the Standard toolbar. This toolbar contains icons for several
important commands and functions that can be used in NeoOffice to open a document,
export to PDF, undo and redo, access the navigator or gallery, or print the current
document.

Immediately above the horizontal ruler is the Formatting toolbar. This offers features
that are always appropriate to the current context such as alignment, font styles, lists and
indenting. For example, if a piece of normal text is selected, you will see different icons
from those within a text table.

On the left edge of the document is the main toolbar. This varies depending on the
document type (text, spreadsheet, presentation, drawing or formula).

Other toolbars such as the color bar will be described later.

It is easy to change the position of the toolbars. For example, if you wish the position of
the main toolbar to be on the right edge of the document instead of on the left, simply
drag the knurled handle at the far left in the toolbar to a new location around the edge of
the main window.

NOTE: as with most OS X applications, toolbars may be docked at the edges of the screen.

Some icons have small triangles to indicate that there are more functions available. These
are called floating toolbars. When a long click is applied to these icons, a new window
opens giving access to all those features associated with that icon. Short clicks may
sometimes deliver different behavior to a long click but give the same functionality.
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Examples of Floating Toolbars

Illustration: shows examples of many different floating toolbars in NeoOffice Writer

Using Floating Toolbars
When editing a text document, the Insert icon is in the Tools toolbar. Click on the little
triangle next to this icon. This opens a floating toolbar containing further icons.
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Younow have a few choices to make: either to click the icon on this new toolbar to
activate the feature, or to grab the new toolbar window by its title bar and drag it away
from the main toolbar while holding down the mouse button (remember to first release
the mouse button that was clicked to open the popup, otherwise the title bar cannot be
grabbed with the mouse).

The document window

At the top left hand edge of the document window are the toolbars that are needed for
work, and these vary depending on the document type and context. At the bottom edge is
the status bar. The status bar contains different fields displaying information appropriate
to the type of document. Some of these fields give access to special functions, either by
double-clicking or by opening the relevant context menu. For more detailed explanations,
refer to Help.

Docking toolbars

All toolbars may be positioned as either floating windows or dockable panes. These
floating windows may be docked on any of the edges of the NeoOffice window. On each
edge several toolbars may be docked alongside each other. To undock and re-dock, hold
and drag the toolbar to the top or bottom menu bars or to the right or left of the screen.
When you hold and drag it to the top or bottom menu bars, you will notice that a grayed-
out frame appears to show you may release the mouse button. To undock, grab the
handle on the left hand edge of the tool box. Youmay also dock the tool bar by clicking
on the little black triangle on the top right of the toolbar. This will give you menu options
including dock and undock:

In the floating state, the toolbar floats above the workplace so that the windows below it
are partially covered. Switch to the locked state to display the docked window next to the
workplace. If the window is docked to the left of the workplace, the following menu can
be accessed by clicking on the little black triangle at the bottom of the toolbar:
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Illustration: the Tools toolbar docked to left of screen, and showing the lock/customize submenu

Docking windows

Some tools in NeoOffice open in popups that are dockable, such as the Styles and
Formatting toolbars. These floating windows may be docked at either the left or right
edges of the main NeoOffice window.

To dock one of these windows, drag the title bar of the window to the edge until an
outline appears. This outline indicates the size and position of the pane that will contain
the tool when the mouse button is released. Another window may also be docked
adjacent to one which is already docked. Users can choose to have one on top of the other
or side by side. As a window is moved, note that an outline displays showing where the
window will dock and how big it will be.

To undock a tool and make it a floating window again, point to the gray area of the tools
toolbar and drag the tool away from the edge until the outline indicates that it is no longer
attached.

Changing the Visibility of Buttons on Toolbars

Tools and functions are initially grouped together on a default set of toolbars. Not all
buttons are visible by default.

To quickly make a button visible or not on its toolbar:

1. Click on the small black triangle at the far right of the toolbar and select Visible
Buttons.
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2. Toggle the checked status of the button. Make sure to click the black triangle
appropriate to the toolbar because toolbars may be placed side-by-side.

Note: While buttons may be moved or duplicated across toolbars, or new toolbars may be created or
removed completely, we will start with just the NeoOffice provided toolbars.

Opening and Saving Documents

There are multiple methods of loading or opening documents: for example, by using the
File > Open dialog, the Open icon on the Standard toolbar or the File > New menu.

dialogdialogdialogNote: In OS X, you may also simply double-click on the icon of the document you wish to
open, provided that NeoOffice has been set as the default to open that type of document [see earlier in this
chapter]

Opening Documents
To open an existing document that was saved on the hard drive or on a
removable disk, there are four possibilities. Either choose File > Open, click
the Open File icon on the Standard toolbar, use the Cmd-O [ -O]⌘ shortcut

keys or double-click on the icon of the document.

In the last case, NeoOffice will load and the document will open automatically. In the
first three cases, the Open dialog is displayed.

This dialog is described in detail in the NeoOffice Help. However, here are a few tips:

Change the size of the dialog by dragging the handle in the bottom right
corner of the dialog with the mouse (see pic at left).

Change the width of the column by dragging the parallel bars at bottom-
right of the scroll bar for that column. Hold the mouse button down and
drag to the right: this helps when you want to read long file-names.
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Nested folders (where there is a gray arrow to the right of a file name)
are revealed by clicking once on the name.

The Templates and Documents dialog
The Templates and Documents dialog can be regarded as a kind of command center for
NeoOffice documents. It provides easy access to a user's work directory and to any
supplied sample documents. Here you will find all document templates - both the
supplied ones and any personally created ones. To open the dialog, choose File > New >
Templates and Documents or press Cmd[⌘]-shift-N or the Templates& Documents
icon under the New menu .

The dialog offers the following areas, which can be selected by clicking one of the
offerings in the shortcut bar on the left:

• New Document - A way to create a new, empty document from a set of prepared
templates.

• Templates - Choose from the many ready-to-use document templates.

• My Documents - A quick route to the documents in a work directory. A work
directory may be defined by selecting Tools > Options >NeoOffice > Paths and
entering the path required forMy Documents.
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• Samples – This is an empty folder when installed; however, some examples may be
downloaded from
http://documentation.openoffice.org/Samples_Templates/User/template/index.html.
(See New Document for example templates). Further samples are listed in the
NeoWiki, in the section headed Editing Default Styles and Using Templates.

Saving Documents

Saving the current document can be done in three ways: using File > Save command, the

Save Document icon on the Standard toolbar, or just press Cmd[ ]-S⌘ .

For a first time save, use File > Save as. A dialog box pops up to allow choosing where
to store the file.

NeoOffice User Guide for 2.x 23

http://documentation.openoffice.org/Samples_Templates/User/template/index.html


Chapter 2: Working With NeoOffice

With File > Save as, one assigns the document a name, whereas the other two options
save without asking for the file to be named. Therefore, using the Save as feature is
especially important when saving files for the first time. This is where you get the chance
to name your document. For the most part, choose any name desired (limited only by the
restrictions imposed by OS X). When the document is to be opened later, find it under
that name. Remember to save the document in a folder where you will be likely to find it
later. Youwill be given the option of saving in various “file types”. This allows you to
save in OpenDocument format, or Microsoft Word format, or even the new Microsoft
Word XML format. Notice that you also have the option of saving with a password, if
you want to keep your document confidential, or want strong control over editing.

Save documents regularly as work progresses. The simplest way is to save the current

document by pressing Cmd[⌘]-S or the Save icon . This replaces the document

you had saved previously with the current document.

Note: An untitled document must be given a unique name for AutoSave to obey the settings in Tools >
Options > Load and Save > General. Disabling AutoSave is not recommended.

Changing the Work Folder
When the Open dialog comes up, the work folder is displayed. You as the user can
change this folder as follows:

1. Select Tools > Options >NeoOffice > Paths.

2. Double-clickMy Documents to open the edit dialog.

3. Youwill be presented with a dialog window, where you can navigate to your preferred
“work” folder. Alternatively, in the Select Path dialog, enter the work folder wanted
and click Select.

4. Close with OK.

Likewise, other folders can be selected using the same method. For example, to display a
different default folder for inserting graphics, change the path for the entry Graphics.

Saving Documents Automatically

Backup a File Automatically

To create a backup copy of a document every time a document is saved:

1. Select Tools > Options > Load/Save > General.

2. Check Always create a backup copy.

If the current document is saved, using the same path and file name with which it was
first opened, using File > Save or Cmd-S [ -S]⌘ , or pressing the Save icon, the

old version will be overwritten by the new version. If the Always create backup copy is
checked, the old version is first copied to the backup directory.
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• The default backup folder is username/Library/Preferences/ NeoOffice 2-
x/user/backup/. Change this, as described above, in Tools > Options >NeoOffice >
Paths > Backups entry.

• The backup copy retains the same name as the document, but the extension is changed
to .bak. If the backup folder already contains such a file, it is overwritten without
warning!

Saving Recovery Information Automatically Every 'n' Minutes

1. Select Tools> Options > Load/Save > General.

2. Check Save AutoRecovery information every and then select the time interval in the
list box.

OpenOffice.org & NeoOffice File Formats

OpenOffice.org [and hence NeoOffice] uses an XML file format as the default for saving
and opening documents.

XML file format names
In saving and opening OpenOffice.org/ NeoOffice documents if no other file type is
selected, NeoOffice uses the following XML formats:

Application File extension

OpenOffice.org/NeoOffice Writer *.odt

OpenOffice.org/NeoOffice Writer
templates

*.ott

HTML Document *.html

HTML Document Template *.oth

OpenOffice.org/NeoOffice Calc *.ods

OpenOffice.org/NeoOffice Calc
templates

*.ots

OpenOffice.org/NeoOffice Impress *.odp

OpenOffice.org/NeoOffice Impress
templates

*.otp

OpenOffice.org/NeoOffice Draw *.odg

OpenOffice.org/NeoOffice Draw
templates

*.otg

OpenOffice.org/NeoOffice
Formula/Math

*.odf

Master documents *.odm
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These file name extensions permit reasonable differentiation when searching through a
lot of files in a folder. For instance, you may search for a Draw document by looking for
NeoOffice Drawing Document in the “Kind” column.

Note that, since these are compressed XML files, they must first be unpacked before
being manipulated (for example, by a text editor).

Note: If you want to work permanently with another file format, define this as the default. Select Tools >
Options > Load/Save > General for alternative file formats that can be selected for each NeoOffice
document type.For instance, you may be using NeoOffice largely to create Impress presentations. In this
case, set .otp as the default. If you are required to share all documents with WordXP users, you wish to
select .doc XP/97 as the default for saved documents.

OpenOffice.org/NeoOffice XML file structure
The OpenOffice.org/NeoOffice XML file formats follow the OASIS OpenDocument
standard and are compressed and packed using ZIP. Use a file expansion program such as
Stuffit Expander®, to unpack the contents of an XML file. The structure is similar to the
following illustration.
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Note: Once an .odt file has been unzipped/expanded, it cannot be opened by NeoOffice. It is suggested that
you duplicate any .odt file you wish to expand and then expand the copy to examine the contents

• The text content of the document is located in content.xml. This file can be viewed
with, for example, a pure text editor.

By default, content.xml is stored without indents or any other type of formatting, so
that the time needed for saving and opening is minimized. By unchecking Tools >
Options > Load/Save > General > Size optimization for XML format this
procedure can be changed so that the lines saved are structured in a more human
readable format.

• meta.xml contains the meta information on the document, which is entered via File >
Properties.

In documents saved with security,meta.xml remains unsecured.
• settings.xml contains further information on settings for this document, for example
on the printer, on the recording of changes, the associated data sources and so on.

• styles.xml retains the styles defined for the document. For example, these can be seen
in the Styles and Formatting window.

META-INF/manifest.xml file describes the structure of the XML file.

Additional files can be contained in the packed file format. For example, Graphics can be
found in the Pictures subfolder, Basic code in the Basic subfolder and linked Basic
libraries are found in further subfolders of Basic.

Definition of the XML formats
The DTD (Document Type Description) files can be found in
NeoOffice/Contents/share/dtd/officedocument/1.0/

Note that the formats are subject to certain licenses. Notes on the licenses are found at the start of the DTD
files. More detailed information can be found on the OpenOffice.org website.

Setting Tabstops
NeoOffice offers multiple ways by which one can set and edit the tabstops used in a
document. The procedures for setting and editing tabstops are described in Help >
NeoOffice Help > Index > Search term > tab stops and are quite complete.
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Sending Documents as E-Mail

Single Messages
Working in NeoOffice, you can send your current document as an e-mail attachment
providing that the default e-mail program up is set up correctly.

Note: To set up this feature, select Tools > Options >Internet > E-Mail and configure the program to use.

1. Choose File > Send > Document as E-mail.

2. When the e-mail composer window appears, enter a recipient, subject and any text and
send the e-mail.

MailMerge
As of NeoOffice 2.x, users have the opportunity to use email to send messages to
multiple recipients. This feature also allows printing of these for delivery by post.

1. Choose Tools > Mail Merge Wizard

2. Follow the dialogs. The second screen allows you to choose to send the file as email.
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Printing Documents

Once you have created a document, normally you will want to print it out on paper.

Print the current document either directly to a printer, or to file. When you are printing to
a file, all the information that would otherwise be sent to the printer is initially written to
a file. On another computer, the file can then be copied directly to the printer connected
to it.

Note: NeoOffice Writer always formats documents so that they are printed as well as possible with the
selected printer. Therefore, always define a default printer, even if the printer is not currently available .

Click the Print File icon on the Standard toolbar to print the current document
without the intervention of a dialog.

To retain finer control of printing, either select File > Print, or use the keyboard shortcut
Cmd-P.

In the File > Print dialog, select a specific printer (if there is more than one installed
printer). Under Print range, determine how many pages to print (or only certain pages),
and how many copies are wanted. After you have used the traditional menu for your
printer, NeoOffice will present you with more printer options with this menu:

In addition to the general printing options already mentioned, you can also choose special
printer options for the different document types in NeoOffice, using additional dialogs.
These dialogs allow you to control the way the contents or the pages of the document are
printed. Define these printer options for the current print job by selections in the first
dialog (that for your own printer).dialog To create a general definition for normal use,
select Tools > Options > (name of document type e.g. Writer, Calc) > Print
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Note: There are many different printers with widely varying properties. The printing functions differ
according to the operating system, printer driver and printer model used. The selected printer defines the
width and height of the characters, and hence also the line and page breaks. NeoOffice Writer and Calc
always format the pages in the way they will appear when printed. One thing to check when you first set up
NeoOffice is whether A4 or US Letter is the default paper size.

Displaying Print Previews
Before printing out a document. It is a goode idea to review how the printed document
will appear on paper. NeoOffice offers a Print Preview feature for this purpose, thereby
allowing adjustment of margin widths, optimization of page breaks, et cetera.

1. Switch to the document for preview.

2. Select File > Page Preview.

3. Use the icons on the object bar to zoom in or out.

4. Use the arrow keys or object bar icons to scroll through the
pages of the document and check how they will appear in print.

Reduced Printing of Documents

To get a reduced printout of a text document, choose File > Page Preview. Here, decide
whether to have two, four or any number of pages beside and on top of each other.

To print two pages beside one another on one sheet of paper

1. Choose File > Page Preview.

2. Locate the Page Preview icon . If there are more or fewer pages than desired,
long click the icon to the right of the grayed out Page Preview: Two Pages on the
object bar and select the number of pages needed for previewing.

3. Click on the Print page view icon.

4. Clicking the Print options page view icon opens a dialog where one can
enter settings for reduced printing.

5. Click OK to confirm.

Printing in Black and White
If there is a color printer installed but printing should be restricted to black and white
only, use one of the following options:

Printing text and graphics in black and white

1. Select File > Print. This opens the OS X Print dialog for your printer.
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2. Youmay select black and white printing in this dialog.dialog

3. Choose the option to print in black and white. For further information, refer to the
help for the printer or read the printer manual.

4. Confirm the Properties dialog and click Print in the Print dialog.

5. The current document will be printed in black and white.

Printing all documents in grayscale

1. Choose Tools > Options > NeoOffice or File > Preferences > NeoOffice , as
appropriate.

2. Then choose Print.

3. Check Convert colors to grayscale and click OK. From now on, all presentations or
drawings will be printed without color

Printing only text in black and white

In Writer,you can choose to print color-formatted text in black and white. This can be
specified either for all text documents to be printed subsequently, or only for a printing
process of the current text document.

Printing all Writer documents with black and white text

1. Choose Tools > Options > NeoOffice Writer or Tools > Options > NeoOffice
Web/Writer.

2. Then choose Print.

3. Under Contents mark Print black and click OK.

All text documents or HTML documents will from now on be printed with black text.

Printing the current Writer document with black and white text

1. Choose File > Print. This opens the Print dialog.

2. Check options as appropriate in the dialog for your printer. Select Print. This opens
the Printer Options dialog.

3. Under Contents mark Print black and click OK.

The text document or HTML document now being printed will be printed in black text.

Grayscale converts everything to a maximum of 256 gradations from black to white.

Black & White converts everything into the two values black and white.
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Printing Brochures
NeoOffice text documents consisting of more than one page can be printed automatically
as a brochure. Two pages of a text document will be reduced in size and printed next to
each other on a page in landscape (horizontal) orientation. Both sides of the page will be
printed (most printers require that users take out the paper after the first half of the
printing process and feed it in again in such a way as to print on the blank side, although
increasingly printers include an automatic duplexing function). NeoOffice will
automatically print the pages so that they can be read as a brochure. NeoOffice
automatically arranges the pages in such a way that the text can be read continuously by
laying the pages together, fold them in the center and stapling them in the fold.

Tomake a brochure using the current document, select File > Print. In the dialog that
opens, do the following;

1. In your printer's dialog make sure Orientation is set to landscape

2. While still in this dialog, set the Paper size of the document to A4 or US letter, as
needed.

3. Click Print to close the dialog and open the Printer Options menu.

dialog

4. In the Printer Options dialog select whether to print right and left pages all at
once, right pages or left pages. The following should provide sufficient
information to make a decision:

(a) If the printer is capable of duplex printing, choose Left and Right pages and
brochure.

(b) With a single sided printer:

i. Choose Left or Right and brochure.

ii. Click OK then go to step 6.
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iii. When printing is complete, take the pages from the output tray and put
them into the input tray in such a way as to print on the blank side and
choose the opposite Page setting as in step 1. Repeat step (ii).

5. Click OK

6. Click OK

Spellcheck

NeoOffice has an automatic spellcheck which can be active while typing, or activated
manually.

Automatic Spellcheck
The automatic spellcheck can be turned on and off by clicking the AutoSpellingCheck
on/off icon on the Standard toolbar. With automatic checking enabled, words recognized
as incorrect are highlighted with a wavy red underline.

Incorrect words are recognized as incorrect if all the following conditions are met:

• a spellcheck module is installed for the language of the word,

• this module is enabled,

• the word is not found in the installed dictionaries.

• the word is not in any active user dictionary.

Users can create any number of custom/user dictionaries.

Create a user dictionary by selecting Tools > Options > Language Settings > Writing
Aids.

As text is proofread, the wavy red underlines draw attention to possible spelling mistakes.
Of course, Spellcheck will not catch spelling mistakes that form other recognizable
words (such as “fun” instead of “run”). As long as the automatic spellcheck is activated,
the red markings can be seen on the screen but are not printed.
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The easiest way to correct a red-underlined word is to right-click it [or Ctrl-click]. This
opens a context menu (see screenpic above) that offers suggested corrected spellings, and
options to add the word to the dictionary or to ignore it. Simply click the correct
suggested spelling to replace the red-underlined word. Spellcheck not only replaces the
red-underlined word with the suggestion selected, it also remembers this replacement
while the document is open. If the same typing error is made again, Spellcheck
automatically replaces the mistyped word with the corrected spelling.

If the word is spelled correctly, it may be added to a dictionary by clicking Add and
specifying to which dictionary it is to be added. To ignore a correctly spelled, but
infrequently used word, click Ignore All.

Checking Multilingual Texts
NeoOffice Writer can manage spellcheck (plus thesaurus and hyphenation) in multiple
languages (33 at the time of writing). The NeoOffice setup program offers this at
installation via the the installation of many dictionaries.

Select the language of an entire text document with Tools > Options > Language
Settings > Languages. If it applies to the user's needs, check For the current document
only. For all paragraphs formatted with the same Paragraph Style, apply a language via
the Paragraph Style. A language can be defined for individual words via Character Styles,
or directly with Format > Character.
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In Tools > Options > Language Settings > Writing Aids , check the option Check in
All Languages. Now, Spellcheck will take all installed languages into account. Words
that are correctly typed in any of the installed languages are regarded as correctly typed,
irrespective of their language attribute. In multilingual texts, the automatic checking that
was enabled by clicking the icon on the Standard toolbar, offers another facility as well.
In the context menu of a red-underlined word that is recognized as incorrect, specify that
the word or the whole paragraph is one of the other installed languages. The language of
the underlined characters or all characters of the paragraph is automatically assigned as a
character format.

Starting Spellcheck
To check the entire text for spelling mistakes in the “classic” way (i.e. letting Spellcheck
go through the whole document on its own), either click on the Spellcheck icon in the
Standard toolbar or go to the Toolsmenu and choose Spellcheck. The Spellcheck dialog
will only appear if there are words in a text unknown to the Spellcheck. The various
options to be seen in the Spellcheck dialog are described in detail in the NeoOffice Help.

Note: The user dictionary can also be used to ensure that a word is not automatically
hyphenated, even though the automatic hyphenation function is turned on. Provided that
the word is included in the user dictionary, using the Spellcheck dialog, enter an equals sign
(=) at the end of the word. The equals sign ensured that the word will not be hyphenated.
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Excluding Text From the Spellcheck

If certain areas, words or tables should not be spell checked because they are, say, in a
foreign language for which there is no installed module, then specify "Unknown" as the
language to be checked by Spellcheck. Do this by either using direct formatting by
selecting the text and then choosing Format > Character > Font or by modifying the
corresponding Style for the text (e.g. open the context menu and choose Edit Paragraph
Style...).

Adding Writing Aids for Other Languages

NeoOffice offers users the opportunity to change the language of the user interface as
well as providing a wizard to install more dictionaries, hyphenation dictionaries and
thesauruses.

This allows use of more than one language in a document as an attribute of the entire
document or a group of words.

As an adjunct to the addition of writing aids in various languages, you can change the
default language used either generally or for a single document by means of selecting that
language in Tools > Options > Language settings > Languages. Remember that the
writing aids must be installed first.

Getting New Writing Aids
1. Select File - Wizards - Install new dictionaries ... to start the process to install
more languages. Youwill need to be connected to the internet for this process to
be successful.

2. Click the language needed on this page for instructions in that language.
3. Click the big button in the middle of the document page to start the installation
process:

4. The following dialog opens to begin the selection of the needed components:
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5. Click Next

6. Click “Retrieve the list” and select those dictionaries needed. Youmay use the
Previous button to go back to the lists.

7. Click Next and select the Hyphenation dictionaries needed and click Next when
done.

8. Click Next and select the Thesauruses needed and click Next when done

9. Clicking Next, starts the download and installation of the items selected in the
previous steps.

Using Automatic Functions

NeoOffice has all kinds of intelligent assistants to help, all of which have names
beginning with “auto”.

The section introduces a few of these auto-functions. For detailed explanations, refer to
the NeoOffice Help.

Using AutoCorrect and AutoFormat

In addition to catching typing errors, NeoOffice can format documents while typing - or
afterwards. AutoFormat and AutoCorrect permit the user to draft documents much more
efficiently by automatically formatting and correcting common errors while the user
types. Here are a couple of examples.
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• AutoCorrect is useful if you often make the same typing errors. For example, if you
tend to capitalize not only the first letter of some words but also the second, simply
select the AutoCorrect function that corrects mistakes of this sort while typing.

• AutoFormat formats texts. One AutoFormat feature automatically will detect
paragraphs beginning with a hyphen followed by a tab or space, and reformat the
paragraph as a bullet point. The automatic bulleting is then applied to any paragraphs
that follow as well. Automatic bulleting ends when you enter a blank paragraph
containing only a Return.

In text documents, toggle AutoFormat on or off by selecting Format > AutoFormat. A
submenu with three selections appears. To automatically format while typing, check the
While Typing selection. To have Writer automatically format the entire document or the
current selection at a later time, check the menu selection Apply. Selecting Apply and
Edit Changes lets you see all document changes made via AutoFormat. You then may
accept or reject all changes or may review each change separately.

Youmay also select and set the options in Tools > AutoCorrect. AutoCorrect offers
many options that can be selectively turned on and off. Some of these offer different
methods for formatting while typing and post-processing. The Replace and Exceptions
lists are language dependent. NeoOffice first searches in the list of the language of the
text, then the list for the higher-ranking language family, and finally in all installed
languages (for example, first in "English (US)", then in "English", then in "All
Languages").
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The following graphic shows the various functions available in this dialog under
Options. A detailed explanation of each function is given in NeoOffice Help.

In addition to the functions shown here, one can also select Custom Quotes. This means
that all quotation marks are automatically turned into correct typographer's quotes. Users
can choose the “quote” characters to be used for this purpose. Click on the appropriate
button for the default buttons you wish to define, and you will be taken to the menu for
custom quotation marks.

Turning off URL Recognition by AutoCorrect
When text is entered, NeoOffice automatically recognizes a word that may be a URL and
replaces the word with a hyperlink. NeoOffice formats the hyperlink with direct font
attributes (color and underline) the properties of which are obtained from certain
Character Styles. E.g. www.woolywilds.co.uk is recognized automatically, and shows as
a hyperlink.

If you don't want NeoOffice toautomatically recognize URLs while typing, turn off this
feature using one of the following methods.
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Undo URL recognition

1. Press Cmd-Z [ -Z]⌘ or press the Undo icon to undo text that has been

automatically converted into a hyperlink, but which you did not want as a hyperlink.

2. Select the hyperlink and choose Format > Default Formatting if this conversion is
not noticed until later.

Turn off URL recognition

1. Load a document of the type in which URL recognition is to be modified. For
example, if modifying URL recognition for text documents, open a text document.

2. In NeoOffice Writer select Tools > AutoCorrect ... .

3. In the AutoCorrect dialog, choose the Options tab.

4. Deselect URLRecognition, so that words will no longer be automatically replaced
with hyperlinks.

In Writer there are two checkboxes in front of URL Recognition. The field in the first
column [M] is for modifying in a post-edit session while the field in the second
column [T] enables AutoCorrect to make the corrections while typing.

Other AutoCorrect functions
The Tools > AutoCorrect > Replace tab has a default list of items that will be
automatically replaced provided that Use replacement table on the Tools >
AutoCorrect > Options tab page is checked. You can add all of your most frequent
typos to this list and have AutoCorrect replace them with the right text. Also use this
feature to enter special characters or phrases that are keyboard intensive or complicated
to do normally. For example, if you type (C) it is immediately turned into the copyright
symbol.

Note: The fonts supplied with NeoOffice include the Euro symbol. If working with other fonts, you can easily
insert the Euro symbol from another font using AutoCorrect. When working in a text document, choose
Insert > Special Character. Look for the Euro symbol and click OK.

Enter in the Abbreviation text box eu, for example. The Text only box should not be marked. Click New.
Now close the dialog. As soon as the eu is entered followed by a space or at the end of a sentence, a Euro
symbol will be inserted.

On the Exceptions tab, enter any exceptions for the two types of automatic correction:

• Assume the Replace option is enabled to automatically start each sentence with a
capital (uppercase) letter. If“e.g.” is entered and is followed by a lowercase “d”, then
the “d” would be capitalized. So, to compensate for this behavior, enter “e.g.” into the
Exception list to prevent this type of correction.

• Again, if the Replace option is enabled to automatically convert the second of two
capital letters at the beginning of a word to a lowercase letter, enter any exceptions
that are correctly written with two capital letters, such as UK, PC and CD.
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These exceptions can also be automatically included by selecting the Autoinclude
checkboxes on the Exceptions tab. When this feature is enabled and you then use an
idiom in the text that is automatically corrected but which should not be corrected,

immediately press Cmd-Z [ -Z]⌘ or use the Undo icon . Doing this not only
undoes the automatic “correction”, but also sees to it that this particular “correction” will
not be made automatically again in the session.

AutoCorrect can also be used to replace one word or abbreviation with something more
appropriate. For example, you can replace “ASAP” with the text “as soon as possible”.
However, the NeoOffice AutoText function is a better choice for doing this.

Activating the Writing Tools for Your Preferred Language
NeoOffice 2.0 ships with the same set of writing tools that the standard build of
OpenOffice.org supplies (see the list below). Other writing tools can be downloaded and
activated as described later in this section. In some cases, NeoOffice 2.0 can also use the
tools you installed in NeoOffice 1.x.

US English, UK English, Austrian German, Swiss German, and German all have the
dictionary, thesaurus, and hyphenation pre-installed in NeoOffice 2.0. Dictionaries for
Hungarian (also hyphenation), Italian (also hyphenation), Dutch (also hyphenation),
Swahili, and Thai, thesauruses for Czech and Slovak, and hyphenation for Danish and
Russian are also included.

In NeoOffice 2.0 Alpha, the download and activation of writing tools uses the standard
cross-platform OpenOffice.org Dictionary Wizard method. Choose Install new
dictionaries… from theWizards submenu of the File menu, then follow the steps in the
wizard.

Because the writing tools authors and their communities are always updating these tools,
you should run the Dictionary Wizard even if your language's writing tools were pre-
installed (or if you upgraded from NeoOffice 1.x).

Users of non-US or non-UK English
The new language tools system in NeoOffice 2.0 no longer maps other English variants
to the US or UK English tools; you must install the dictionary, etc., for your language to
have working writing tools. If you upgraded from NeoOffice 1.x, your list of installed
writing tools was preserved and may now be incorrect and cause problems. You can
safely delete ~/Library/Preferences/NeoOffice-2.x/user/wordbook/dictionary.lst to fix
potential problems.

Note: This advice may possibly apply to other languages with regional variants

Installing Third-Party Dictionaries

Due to licensing problems and other issues, there may be dictionaries for some languages
that are not available via the dictionary wizard. If you find a dictionary for your language
in either Hunspell (preferred) or MySpell format, it is possible to use this dictionary with
NeoOffice.

To install the downloaded dictionary (in .zip format),

NeoOffice User Guide for 2.x 41



Chapter 2: Working With NeoOffice

1. Quit NeoOffice if it is running

2. Copy the zip file into NeoOffice's share/dict/ooo folder

Known Sources of Third-Party Dictionaries

Check these out at http://neowiki.neooffice.org/index.php/Activating_Dictionaries

Selecting the Dictionary to be Used in a Document or Section

- From NeoWiki

If you have multiple languages and dictionaries enabled, you can control which
dictionary is used in a document (or section thereof) by setting the appropriate
preferences.

To set the language of an entire document, select Preferences… from the NeoOffice
menu, then click the "plus in a box" next to Language Settings to expand that section.
Next select the Languages item and set the "Default languages for documents" as desired
(either for all new documents, or for the current document only with the appropriate
checkbox).

To set the the language of a particular section of text, select the text and choose
Character... from the Format menu; set the appropriate language via the appropriate
Language box in the Font tab.

Be sure to set the language of the document and/or each section of text appropriately or
spell-check will not work.

Another approach is to click on the NeoOffice menu, and choose Preferences. In the
resulting dialog box, click on the triangle next to "Language settings" and then select
"Writing Aids." In the bottom box labeled "Options," scroll down to the option "Check
in all languages" and click to put a checkmark in the box. NeoOffice will now use all the
dictionaries you have installed when spell-checking, regardless of the language "setting"
of a given document or section.. The advantage of this approach is that you don't have to
set the language of the document and/or sections. The disadvantage is that NeoOffice will
not identify words that are misspelled in one language but correctly spelled in another.
For example: If I have installed English and French dictionaries, and I type the sentence:
"I went to the parc," NeoOffice will not identify "parc" as misspelled, because that is the
correct French spelling.

- End of section from the NeoWiki.neooffice.org
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Creating a Letter Template With the Wizard
If you are writing a personal letter, the Wizard and standard AutoTexts are not essential,
but in formal business correspondence these aids can save a lot of time and make work
much easier.

Note: To produce a standard letter, have a look at the supplied templates. Simply press the shortcut keys
Cmd-shift-N [⌘-shift-N] or choose File > New > Templates and Documents.

Start the Wizard with the File > Wizards > Letter menu command.

Treat this section as a tutorial on the NeoOffice template Wizard. Although the Wizard
does produce a document that can immediately be filled in, printed, and sent, using the
Wizard is really meant to help create customized templates. You can use customized
templates for such things as business letters, faxes and other types of documents for
which there is a Wizard. This ensures that correspondence has a consistent format.
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While you may do so if you wish, there is no need to go through all the steps of the
Wizard each time you want to write a letter. However, in order to get the most from the
following, it is recommended that you accept all the defaults provided without changing
them, and then print the result. Click Next on each dialog page, so that you see every
page during the learning process. Examine each of the Wizard pages while going through
the process of creating a letter template. Enter data or modify options on each page as
necessary. Each page allows modifications according to your preferences including
sender and recipient addresses, both of which can also be entered manually. (For
example, sender information is automatically taken from the personal details that each
user enters at the time of installation. These details may be changed at any time by
selecting Tools > Options >NeoOffice > User Data and entering new information or
editing existing details.) Predefined elements will appear but users always have the final
say on what to include in their letter.

Thanks to the Wizard, you don't have to start from scratch but can use pre-existing texts
when creating custom templates, whether for business letters, faxes, memos, or other
documents.

Find & Replace

When working with a computer it is often useful to be able to locate certain pieces of text
quickly. The Find function in NeoOffice Writer, Calc, Impress and Draw is the tool to
use for this purpose. Find can also locate variations in the given search term or limit the
search to certain places in the document, such as the beginning of a word or the end of a
paragraph.

Text strings found in the text can be replaced by other strings with or without
confirmation, although sometimes manual editing is still necessary where, for example,
there are deviations in gender found in other languages.

Note: in OS X, you may prefer to use Spotlight, which works with NeoOffice.
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Finding a Word in Text
Let's say the word “Holland” appears somewhere in a long text and you wish to locate it.
Activate the Find function with Cmd-F. Enter the string you want to find in the Search
for field and press Return. NeoOffice starts searching from the current cursor position
toward the end of the document. Upon reaching the end of the document, the program
opens a new dialog asking whether or not to continue the search at the beginning of the
document. Tap the Return key to confirm, or click OK. If the text string is found, it is
highlighted.

The Find & Replace dialog can remain open without interfering with text entry, and it
can be moved to any place on the screen. However, when it is closed, it remembers the
previously entered strings so they do not need to be re-entered for the next search, but
can be selected from the list box, a drop-down menu indicated by the “down” button on
the Search box.

One very useful feature is the multi-selection facility Find All. For instance, using Find
All, you could set every occurrence of the word “document” in the text to boldface. Enter
the search term in the Search for field and then click Find All. All occurrences are now

selected. Place the cursor in the Replace field, and click the Bold icon in the
Standard toolbar to boldface all occurrences of the search term.

The dialog graphic above illustrates that there are several ways of expanding or
restricting searches by combining selections from the Options group box and the buttons.
Examples for each option are described below.

Searching for Whole Words Only
Select theWhole words only option to find whole words that match the searched-for
word. For instance, if the word “in” is entered as the search term in the Search for field,
all instances of “in,” or “In,” as stand-alone words in the text will be found. Words like
“bin” or “chin” will not be found if thisWhole words only checkbox is selected. If
searching using regular expressions or for Styles, do not select this option.
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Match Case

When this checkbox is selected, the search is case-sensitive to uppercase and lowercase
letters. So if searching for “in,” it will be found, but not the word “In,” Combine aMatch
case search with theWhole words only option as needed. For instance, if both boxes are
checked, and you enter a search for “OK”, then the search will not find “ok” or “book” or
“Oklahoma”.

Searching for Text With Wildcards

1. Start Find by selecting Edit > Find & Replace dialog or use Cmd-F [⌘-F] or use the
Find & Replace icon

2. Check theMore Options > Regular expressions box.

3. Enter the search term with the desired wildcards and click Find.

Regular expressions are entered using text combined with keyboard characters and
symbols that have special meaning in this context:

• The wildcard for any number of a given character is the character itself followed by
an asterisk (*). Note that this is different to the way '*' is used in file names.

Example: Enter “Hawai*” in the Search for field. This means that any number of
“i's”, including none at all, may follow “Hawa”. Thus the words “Hawa”,
“Hawai” and “Hawaii” will be found.

• The wildcard for a single character is the period or dot (.). This is equivalent to the
wildcard '?' in file names.

• Combining the above two rules, the wildcard for several unspecified characters in
succession is '.*' (period and asterisk). This is equivalent to the wildcard '*' in file
names.

• A paragraph end can be found with the dollar sign ($), and the first character at the
beginning of a paragraph with the string '^.' (caret and period).

• Regular expressions may only be searched within paragraphs.

There are many other wildcards that can be used that are listed in Help > NeoOffice Help
with a search term of “Regular expression”. This complete List of Regular Expressions is
included in this document.

If you need more information about Regular Expressions, please see
http://www.opengroup.org/onlinepubs/009695399/basedefs/xbd_chap09.html.

Searching Backward

When locating a frequently-appearing word in a long text, you might click Find once too
often by mistake. Check the Backward box and click again on Find to return to the
location of the previously found item.
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Current Selection Only

Check the Current selection only box option in the Find & Replace > More Options
menu to limit the search rather than causing the entire document to be searched. The
search will be restricted to the lines that are highlighted in the document. Note that, if
text is selected before activating the Find command, the search will automatically take
place only within that selected range.

Searching for Styles

Quickly reformat all or part of a text using this feature. For example, text formatted with
the Style “Heading 2” can be replaced with the Style “Heading 3.” Check the Search
for Styles option in the Find & Replace > More Options menu. Select the Paragraph
Style in the list box under Search for. Then select the new Paragraph Style in the
Replace with field. Start the replacement process with the Replace button. All matching
styles found in the text will be displayed in sequence. You can decide each time whether
or not to do the single replacement, replace all matching styles found in the text, or to
cancel the process.

Searching for Text Attributes

In the Find & Replace > More Options menu, select Attributes to open a dialog from
which you can select those text attributes to be employed to search within a document.
NeoOffice then finds all attributes that differ from the format of the Paragraph Style. For
example, in this dialog, if the Font Weight checkbox is selected, the program can find all
words that have a heavier font than normal. These could be words that have the Bold
attribute applied, either through direct or indirect formatting, or that have been
highlighted with a font previously defined as a bold font, such as ones containing the
words "Bold" or "Black" in their name. By default, Find searches only for direct
attributes. However, after searching for the attributes, you may enable the Including
Styles checkbox in the groups section of the Find & Replace dialog where Search for
Styles was previously. Then, the search extends from the direct attributes we selected
previously to include indirect attributes, such as those set with styles.

Searching for Special Formats

By clicking the Format button, you open a dialog from which you can select the specific
formats in the search. For example, if you have manually centered a few lines in the text,
find them using the options of Format in the Find & Replace dialog. Now let's say that
the found attribute must be replaced with another: to do this take the following steps:

1. Position the cursor in the Replace with field.

2. Click the Format button.

3. Choose the replacement attribute.

The chosen attributes are listed under the Search for and Replace with fields. If no
replacement is indicated for the attribute found in the text, the default settings are
automatically applied.
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Similarity Search

This function seeks not only for the search term, but also for similarly-typed words. As
needed, fine-tune the degree of similarity by clicking the button immediately to the right
of the “Similarity search” checkbox.

List of Regular Expressions
This list is also in Help but is included here as a convenience.

Character Result/Use
. Represents any single character. The search term "sh.rt" finds both "shirt" and "short".

* Finds zero or more of the character immediately in front of the "*". For example,
"Ab*c" finds "Ac", "Abc", "Abbc", "Abbbc", and so on.

+ The character before this symbol must appear at least once: "AX+4" finds "AX4",
“AXX4”, but not "A4".

? Finds zero or one of the characters in front of the "?". For example, "Texts?" finds the
words "Texts" and "Text".

\ Only finds the character (no digits) that is specified. Used to turn off any special
interpretation of the character by NeoOffice. For example, if one searches for “\*+” ,
”*”, “**” and “***” will be found. That is, the regular expression interpretation of '*'
is turned off only for that one instance.

^ Using ^Peter will find this search term only if it appears at the beginning of a
paragraph. Special characters (for example, blank spaces and character-anchored
frames) at the beginning of a paragraph are ignored.

$ This symbol represents the 'paragraph break' for use in a regular expression. For
example, using $ will only find the search term if it appears at the end of a paragraph.
So, if one searches for, say, Peter at the end of a paragraph, enters Peter$ in the Search
for box. Special characters (for example, blank spaces and character-anchored frames)
at the end of a paragraph are ignored.

^$ Finds empty paragraphs.

^. Finds the first character of a paragraph.

\n When searching for represents 'line break' that was inserted with the
Shift+Enter key combination but when replacing with represents 'paragraph break'.

\t Finds a tab space. Users can also use this expression in the Replace with box.

\> Only finds the search term if it appears at the end of a word. For example, "book\>"
finds "checkbook", but not "bookmark".

\< Only finds the search term if it appears at the beginning of a word. For example,
"\<book" finds "bookmark", but not "checkbook".

& Use this character in the Replace with box to add the characters that matched the
search criteria when a replacement is made.

For example, if one enters "window" in the Search for box and "&frame" in the
Replace with box, the word “window” is replaced with "window frame".
Users can also enter a “&” in the Replace with box to modify the Attributes or a
different Format of the search criteria entered in the Search for box.

[abc123] Finds the characters that are between the brackets.

[a-e] Finds the characters that are between a and e.

[a-eh-x] Finds the characters that are between a-e and h-x.

[^a-s] Finds all characters except for a-s

\xXXXX Finds a special character based on its four-digit hexadecimal code (XXXX).
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Character Result/Use
The code for the special character depends on the font used. Users can view the codes
by choosing Insert - Special Character.

| Finds the search terms that occur before and after the "|". For example, "this|that" finds
both "this" and "that" in the search.

{2} Defines the number of times that the character in front of the opening bracket occurs.
For example, "tre{2}" finds "tree".

{1,2} Defines the number of times that the character in front of the opening bracket can
occur. For example, "tre{1,2}" finds both "tree" and "treated".

( ) Defines the characters inside the brackets as a reference. One can then refer to the first
reference in the current expression with "\1", to the second reference with "\2", and so
on.

For example, if the text contains the number 13487889 and one searches using the
regular expression (8)7\1\1, "8788" is found.

[:digit:]? Finds a single digit number. To find a number with more than one digit, use [:digit:]*.

[:space:]? Finds white space such as spaces and tabs.

[:print:]? Finds printable characters.

[:cntrl:]? Finds nonprinting characters.

[:alnum:]? Finds alphanumeric characters (numbers and text characters).

[:alpha:]? Finds alphabetic characters.

[:lower:]? Finds lowercase characters ifMatch case is selected in the Options area.

[:upper:]? Finds uppercase characters ifMatch case is selected in the Options area.

Note: The longest possible text within the paragraph is always found. If the paragraph contains the text
“AX4 A4”, the search term “A.*4” finds the first A to the last 4, i.e. “AX4 A4”.

Note: The '()' and '\1..\9' reference RE combinations will be familiar to programmers who have used
standard RE's, however the NeoOffice version is confined to the search term. The '\1..\9' cannot be used in
the replace term as would normally be expected for standard REs. Use '&' to transfer the entire matching
search term to the replace term

Using Clipart

(From the NeoWiki at http://neowiki.neooffice.org)

Like document templates, clipart plays a big part in many uses of an office suite like
NeoOffice. Unlike document templates, which many people can make for themselves,
most users of office suites aren't artists who can fire up their favorite drawing tool (like
NeoDraw) and create clipart, so third-party collections of clipart are even more
important.

Commercial software like MS Office or AppleWorks often license commercial clipart
collections to include in the package, but commercial licensing and free/open source
software don't interact well on this point. NeoOffice includes a small collection of
graphics in its Gallery, but don't worry; the clipart picture is not as grim as it might seem.
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Sources of clipart
First of all, if you have existing clipart collections, either a collection that came with
another piece of software or that you purchased separately, in most cases you'll be able to
use them with NeoOffice. Changing software doesn't render existing clipart obsolete!

If you don't have any clipart, don't worry; the open source community has clipart that is
freely available, too!

Freely-available clipart
The NeoWiki maintains a list of freely-available Clipart. This points the way to literally
hundreds of thousands of pieces of clipart: cartoons, pictures, drawings, prints,
photographs and so on. Go to this address:
http://neowiki.neooffice.org/index.php/Using_Clipart

In some cases, there may be restrictions on the use of these images, so always check the
"Read Me" first. In particular, there are often situations where you can freely use images
provided that you don't use them for commercial purposes, when you may be asked for a
fee by the copyright holder.

Sources of photographic imagery
There are numerous sites on the web where you can find free photos to populate your
Gallery for NeoOffice. Always check to see what conditions there are regarding
copyright, usage, and licensing: these vary from site to site. And don't use these images
for commercial purposes without checking copyright conditions very carefully - this may
require payment to the copyright holder.

There are, to the best of our knowledge, no completely copyright-free photography
collections to compare with the clipart collection available for download as one package
at www.openclipart.org, since almost all photography sites only allow shot-by-shot
downloads.

Other Resources
You can also use resources you probably already have on your hard drive to make a new
Theme:

• open source collections
• your iPhoto collection(s),
• any free, non-restricted program collections elsewhere on your hard drive.
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Using clipart or photos within NeoOffice
The first step to using clipart in NeoOffice is to make sure your clipart is in one of the
types of graphics file formats that NeoOffice can read. Check out on NeoWiki the list of
vector and bitmap file formats NeoDraw can open; all of the formats in the left-hand
(Open) column can be used as clipart. (If you need to use Computer Graphics Metafiles
(.cgm), simply create a new NeoImpress document, open the CGM via Impress's Open...
menu, then copy the content and paste it into your Writer, Draw, or Calc document.
Similarly, you can copy graphics from existing documents and paste them into new
documents—but please respect the copyright and licensing of those images or graphics.)

If you just use clipart occasionally, you can simply use the Insert Graphics… function
(Insert > Graphics > From File… option) to select a piece of clipart and insert it into
your document. There's one caveat here: unlike opening "text-like" documents, the
OpenOffice.org graphics code in use here can't guess which type of file something is; the
filename extensions of the files have to match exactly the ones in the list referenced
above.

Listing your clipart or photos in the Gallery
The following instructions assume that you've downloaded part of the Open Clip Art
Library mentioned in the links above, but the steps are the same for any clipart or photo
collection, including those already on your Mac.

Download the clipart of your choice from one of the links noted above and decompress
the archive. Please respect the terms of usage established by the respective sites.

1. If NeoOffice is the only software you want to use the clipart with, you might want
to strip any file formats that are not useful from that folder now:

■ Open the folder in the Finder.

■ Select "List view" from the Finder's Viewmenu or from the folder's
toolbar.

■ Click the "Kind" heading so that the files appear sorted in order by their
format (e.g., .jpg, .png, .svg file types) and delete the formats you do not
need; again, consult the list of supported vector and bitmap file formats;
the Gallery can also contain WAV,AIFF, and AU audio files for
presentations).

■ Repeat the above steps for any subfolders within those folders, and don't
forget to empty trash afterwards.

2. Organize your clipart in folders based on subjects (e.g., holidays, sports, borders).
This will help you find items later and allow you to create separate groups
("Themes") for each subject in the NeoOffice Gallery; you may have to search
through and rearrange your downloaded clipart before proceeding.

3. Move the clipart folder to a place of your choice, e.g. your user's ~/Documents
folder (keeps the clipart easily available for use with applications other than
NeoOffice) or to a location on the disk or network that's accessible to others (if
you wish to make the clipart available to all users of your Mac or your network).

4. Launch NeoOffice.
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5. Click the Gallery icon on the toolbar (top-right, looks like a picture frame) ,
or select Tools on the drop-down menu and then click on Gallery to select it.

7. Click the New Theme button directly above the list of existing collections (again,
top left). If this area is hidden, it can be revealed by clicking and dragging on the
knurled area just below the Gallery icon at the bottom of the toolbars.

8. In the resulting dialog, click the General tab and add a name for your Theme
(e.g., Sports).

9. Click the Files tab to prepare to select the clipart files you want in this Theme.

10. Click the Find Files button to search for and select the clipart folder whose
contents you want in this Theme. When the correct folder is highlighted, click the
Select button.

* N.B. Selecting a folder which contains sub-folders will cause the contents of the folder and all sub-
folders (recursively) to be added to the new Theme. If your clipart folder contains sub-folders for different
subjects (e.g., holidays, sports, borders) intended to be in different Themes, be sure to choose the sub-folder
(e.g., Sports) rather than the main clipart folder in this step.

11. Click Add All to add all the files showing in your list to the new Theme, and then
OK to close the dialog.

* Repeat steps 7-11 for each folder/Theme you wish to add. Other NeoOffice users on your Mac will
have to follow these steps to add the clipart to their Gallery as well.
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12. If you want to change a Theme's name later on, just Ctrl-click or right-click the
Theme from the list of Themes and you can rename it (you may want to give it a
name which reminds you where it came from, e.g., "Animals_oca_collection" or
"Animals_aa42").

Using the Gallery to insert clipart into a document
To insert a piece of clipart into your document, just open the Gallery (if it's not already
open), select your Theme from the list at the left, and select the piece of clipart you want
to use. Then drag the graphic into your document (or Ctrl-click on it to set additional
options when inserting). That's it; your existing clipart collections are now readily
available from within NeoOffice!

– end of NeoWiki section

Printing or Exporting Documents

There are many print options for putting documents on paper, including printing to file.
Other ways of distributing documents are to publish in HTML format, XHTM, TeX, bib,
docbook or as PDF files. These should be familiar to most users as they have been a part
of NeoOffice for some time.

Note: This section, concerning a feature of OpenOffice.org 2.0, is not relevant to NeoOffice 2.0. It may be
relevant in part to later versions of NeoOffice.

What is new is that, as of OpenOffice.org 2.0.4, and NeoOffice 2.x, export to PDF has
some added security features beyond digital signing. These are encryption and some
digital rights management (DRM) features such as copy, printing options, changes
options and accessibility. For more information on PDF export, see the specification.

The following graphic shows these options.

Note: This section, concerning a feature of OpenOffice.org 2.0, is not relevant to NeoOffice 2.0 through 2.2.
It may be relevant in part to later versions of NeoOffice.

With the new PDF Export security tab the user has the following possibilities:

● create a PDF document that can be opened only with the correct password, once
password-opened the user can do whatever it likes with it (see Only “open
password”, no restriction);

● create a PDF document that can be opened only with the correct password, but
with restricted permissions; for example the document cannot be printed, or any
of the selections from 6 to 9 in ( see “open password”, restricted);
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● create a PDF document that can be opened by anyone, but with restricted
permissions; for example the document cannot be printed, or any of the
selections.

● create a PDF document without restrictions, everything is allowed (see PDF
without restriction).

Methods of Exporting PDF compared
- From NeoWiki. This section is relevant to NeoOffice.

Why do PDFs created by NeoOffice's Export as PDF… feature lower-quality than those
created by Mac OS X's Save as PDF… (in the Print dialog box)?

Export Directly as PDF

The Export Directly as PDF toolbar button creates a PDF file using the quality and
compression settings in the OpenOffice.org-provided PDF Options dialog, which is not
displayed when using the toolbar button. If you have not changed these settings, the
default is Screen optimized, which uses a resolution of 72 DPI.

In comparison, the native Mac OS X PDF export (using the Print dialog) has a default
resolution of 300 DPI.

While the difference in file size may be trivial for many text documents, the difference in
the size of the resulting PDF is huge when there are images in the source document. In
general terms, the Export Directly as PDF button is used to quickly export PDF files
that are small enough to be mailed, whereas the files created using the native Print dialog
are designed to print at a consistently high quality.

Experience in "real-life" suggests that, with few exceptions, NeoOffice's "Print
optimized" quality generally offers the best compromise between print quality and file
size, often producing smaller file sizes than Mac OS X's native Print dialog while
producing comparable print quality from most office printers. (In order to select this
option, you must first follow the steps below.)

Both the built-in OpenOffice.org Export as PDF… function and the native Mac OS X
Save as PDF… function offer ways of adjusting the size and quality of the final PDF.

Exporting as PDF

Export as PDF… menu item and Export Directly as PDF toolbar button
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As noted above, the Export Directly as PDF toolbar button uses current settings in the
PDF Options dialog when it creates a PDF (much as the Print toolbar button uses the
current Print Options settings when printing and does not display that extra dialog
during the printing process). The PDF Options dialog is accessed through the Export as
PDF… item in the file menu. By selecting this item, you will be able to specify one of
five compression (75, 150, 300, 600 or 1200 DPI) or quality settings, in either lossless or
jpeg versions, as well as the print range, for your resulting PDF. (Counter-intuitively, the
PDF Options dialog only appears after the Export dialog in which you provide the name
and location for saving the resulting PDF.)

In the PDF Options dialog, you can select from Screen optimized (smallest file size),
Print optimized, and Press optimized, with the latter giving both the highest quality PDF
and the largest file size of the three settings. Any future use of the Export Directly as
PDF toolbar button will use the settings you have selected after exporting the current
PDF.

Saving as PDF
Save as PDF… button in the Print dialog

To access the file-size and compression options of the Mac OS X PDF generator, select
ColorSync from the third drop-down box in the Print dialog. This will in turn present
two other drop-down boxes; the bottom one, labeled Quartz Filter allows access to the
desired features. There is a built-in Reduce File Size filter, but you can adjust the
settings, or add a new filter, by selecting the Add Filters… option (this will launch
ColorSync Utility after most of the printing process is complete, so launching ColorSync
Utility from /Applications/Utilities first and setting up your filters is often a better idea.)

-end of NeoWiki.neooffice.org section.

Only “open password”, no restriction
To create a PDF document that can be opened by users having the correct password and
to enable those users to do anything they want with the PDF, do as follows:

1. Select Encrypt the PDF document
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2. Click Set Open Password to set and confirm the password; the password can be
empty or up to 32 characters long;

3. Deselect Restrict permission

Note: An empty open password means that the PDF document can be opened by anyone.

“open password”, restricted
1. Select Encrypt the PDF document

2. Click Set Open Password to set and confirm the password; the password can be
empty or up to 32 characters long.

3. Select Restrict permission to set and confirm the password. As above, the
password can be empty or up to 32 characters long.

4. Select the permissions as desired, see Permissions available. for a description of
available permissions.

Permission restricted only
1. Deselect Encrypt the PDF document

2. Select Restrict permission to set and confirm the password. As above, the
password can be empty or up to 32 characters long.

3. Select the permissions as desired, see Permissions available. for a description of
available permissions.

PDF without restriction (Default behavior)
1. Deselect Encrypt the PDF document

2. Deselect Restrict permission

Permissions available

Note: This section, concerning a feature of OpenOffice.org 2.0, is not relevant to NeoOffice 2.0 and later. It
may be relevant in part to later versions of NeoOffice, beyond 2.2.

The following is a description of the available permissions. These will only effect the
PDF document where the chosen viewer respects the settings.

Printing
Point (6) in . The user can choose if the document can be printed or not. The “Not
permitted” selection will disable the printing.

Changes
Point (7) in . The changes allowed to the PDF document can be selected here, they are
self descriptive.

The “Not permitted” selection will disable all the changes (but copy, see Enable copy).
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Enable copy
Point (8) in . Enable copy (selection) of text and images to be used in other documents
(through paste). It can be selected independently from the other permissions.

Enable accessibility
Point (9) in . Enable the use of accessibility tools with the PDF document. It can be
selected independently from the other permissions.

Programming PDF Security in Macros
The following table lists the property values that can be used in programming. For more
information on programming with macros, see Chapter 10.

Note: The following table, concerning a feature of OpenOffice.org 2.0, is not relevant to NeoOffice 2.0 to
2.2. It may be relevant in part to later versions of NeoOffice beyond 2.2.
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Name Type Default
value

Notes

EncryptFile boolean false specifies that the PDF document should be
encrypted while exporting it, meaningful only
if the “DocumentOpenPassword” property is
not empty.
It corresponds to item (1) in .

DocumentOpenPassword String empty the password that a user will need to read the
exported PDF, should be in clear text. Must be
used with the flag “EncryptFile” above.
It corresponds to item (2) in .

RestrictPermissions boolean false specify that PDF related permissions of this
file must be restricted. It is meaningful only if
the “PermissionPassword” property below is
not empty.
It corresponds to item (4) in .

PermissionPassword String Empty the password that a user will need to change
the permissions of the exported PDF, should
be in clear text. Must be used with the flag
“RestrictPermissions” above.
It corresponds to item (5) in .

Printing int 2 specifies what printing is allowed:
• 0 meaning that the document cannot

be printed
• 1 meaning the document can be

printed at low resolution only,
• 2 meaning the document can be

printed at maximum resolution.
It corresponds to item (6) in .

Changes int 4 specifies the changes allowed to the
document.

• 0 meaning the document cannot be
changed

• 1 meaning inserting, deleting and
rotating pages is allowed

• 2 meaning filling of form field is
allowed,

• 3 meaning filling of form field and
commenting is allowed,

• 4 meaning all the changes of the
previous selections are permitted,
with the only exclusion of page
extraction.

It corresponds to item (7) in .

EnableCopyingOfContent boolean true specifies that the pages and the document
content can be extracted to be used in other
documents (copy from the PDF document,
paste elsewhere).

It corresponds to item (8) in .

NeoOffice User Guide for 2.x 58



Chapter 2: Working With NeoOffice

Name Type Default
value

Notes

EnableTextAccessForAcce
ssibilityTools

boolean true specifies that the document content can be
extracted to be used in accessibility
applications.
It corresponds to item (9) in .
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Chapter 3: Managing Text Documents With Writer

In this chapter, you will learn about the NeoOffice word processing module, called
Writer. Starting with the basics, we will introduce the more sophisticated functions and
lastly provide an explanation of some of the templates and sample documents that are
part of the distribution.

Remember to examine other chapters in the Guide for other important information on
working in Writer:

• Usage of menus, windows, floating toolbars et cetera is described in Chapter 1.

• A separate chapter, Advanced Techniques, provides information about customizing the
user interface of NeoOffice, working with data sources, e.g. form letters, and about the
revision marking function.

The NeoOffice Writer Functions

This section contains a brief overview of the functionality and capabilities of NeoOffice
Writer.

Writing
Writer helps you to create all sorts of written documents. You can produce personal
letters, form letters, brochures, faxes, and even professional manuals. Documents that are
used often can be saved as templates: for example, an invoice form. Spellcheck and
thesaurus functions are at your disposal. If desired, you may have the AutoCorrect and
hyphenation functions active while typing.

There is no restriction to the length of a text document in NeoOffice. For instance, this
book was prepared wholly as an OpenOffice.org/ NeoOffice document. Use the
Navigator to move around easily and quickly within the document. NeoOffice Writer
comes with a variety of templates for almost every purpose. And you can create you own
templates using the Wizard.

Designing and Structuring
NeoOffice offers a wide variety of options to design documents. Use the Styles and
Formatting window to create, assign and modify styles for paragraphs, individual
characters, frames and pages. In addition, the Navigator can help create structured texts
and also allows modification of the structure: for instance, by shifting paragraphs from
one position to another.

Additionally, various indexes and tables can be created in text documents. You can define
the structure and appearance of the indexes and tables according to your individual needs.
Live hyperlinks and bookmarks allow jumping directly to the corresponding items in the
text.
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Desktop Publishing with NeoOffice Writer
NeoOffice Writer contains numerous functions to assist in creating perfectly styled
documents. Text can be formatted multi-columnar, and have text frames, graphics, tables,
etc. integrated into it. The text frames can be linked all over the place, even beyond page
limits to create a newspaper format. Functions such as making lines register-true, flow of
contours through and around graphics, and defining of characters, paragraphs and tables
in any color complement the tools to lend documents a professional look.

Calculations
Text documents in NeoOffice have an integrated calculation function that helps you to
execute sophisticated calculations or logical links. Tables in a text document can easily be
created in order to perform calculations.

Creating Drawings
Draw, NeoOffice's vector drawing tool, lets you create drawings, graphics, legends, et
cetera, directly in text documents.

Inserting Graphics
Pictures with different formats can be inserted into a text document, including graphics
with a JPG or GIF format. The most common formats can be edited directly in a text
document with the image editor. In addition, the Gallery provides a collection of clipart
graphics organized by theme, and clipart collections may be imported into NeoOffice.

Customizable Program Interface
The design of NeoOffice's program interface is such that each user can configure it
according to individual preferences. The various windows (Styles and Formatting
window, Navigator, et cetera) can be positioned as floating windows anywhere on the
screen and some can be docked to an edge. Visible icons and menus can be customized as
well.

Drag&Drop
The drag-and-drop feature enables you to work even more quickly and efficiently with
text documents in NeoOffice. For instance, you can drag graphics directly from the
Gallery into an active document.

Extensive Help Functions
The program provides an extensive Help function which serves as a reference guide to
the program elements in NeoOffice and also includes a variety of instructions for simple
and complex tasks.
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The NeoOffice Writer Window

Windows of NeoOffice Writer
The graphic below shows the various windows and toolbars available for use in
managing documents and where their associated icons are located. For clarity, the
windows, listed counter-clockwise from the top, are Insert floating toolbar, Insert Fields
“submenu, Insert Object floating toolbar, Form Controls floating toolbar, Drawing
floating toolbar, NavigatorWindow and Styles and Formatting windowWindow.
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Entering and Formatting Text

There is no prescribed sequence in which to work. You can enter text and, let's say,
underline it or italicize it while typing - or choose to do this later. You can also decide
whether or not to split a section of text into two columns immediately, or to delay the
action. Youwill never have to delete and retype text simply because formatting needs
changing.

Basically, to edit text, first select it and then choose the relevant command, such as the
command to format the text in italics. There are several ways of selecting text: for
example, using the arrow keys whilst holding down the Shift key, or with the mouse
whilst keeping the mouse button depressed. Often there are different ways of choosing a
command, for example, with a menu command, with a toolbar icon or with shortcut keys.

Entering New Text

To enter new text

1. Open an existing text document or create a new one.

2. Enter text using the keyboard.

When special characters (such as the copyright symbol or accented characters that are
not available on the keyboard are to be entered) select Insert > Special Character and
choose what is needed from the table.

3. Press Return to begin a new paragraph.

Line breaks

Younever need to worry about line breaks as the software inserts these automatically.
Only press Return to start a new paragraph.

Automatic correction

NeoOffice Writer includes a configurable auto-correction tool that can make various
corrections while typing: for example, automatically capitalizing the start of every
sentence.

Word completion

The automatic word completion function helps when entering text. For example, let's say
there's an often-used long word. In this case, once you have typed three letters or more,
Writer suggests a word it recognizes as matching what has been typed so far. If the
suggestion is what is wanted, press Return (or define another key) to accept it. To reject
it, simply keep typing.

Word Completion for Text Documents

NeoOffice collects words that you frequently use in the current session. When you later
type the first three letters of a collected word, NeoOffice automatically completes the
word. If you want, you can also save the current list of collected words so that it can be
used in the next session.

If there is more than one word in the AutoCorrect memory that matches the three letters
that you type, press Cmd-Option-Tab to cycle through the available words.
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Note: in OS X, it appears that there is no keystroke combination to cycle in the opposite direction, unlike
Windows/Linux.

Switching off the Word Completion Function

1. Choose Tools > AutoCorrect > Word Completion .

2. Clear Enable word completion .

Inserting Text
1. Open an existing document.

2. Place the cursor at the point where text is to be added, using either the mouse or the
arrow keys, and enter the new text.

Entering Text Anywhere on a Page
Writer enables you to enter text at any position within the typed area in the text
document. This is the direct cursor function, a feature turned on/off via Tools - Options -
NeoOffice Writer - Formatting Aids.:

1.
Click the Direct Cursor on/off icon on the Tools toolbar. Clicking the
icon turns the direct cursor on and off. When the icon appears pressed,
the direct cursor is enabled.

2.
Click on a free space in the text document. The shape of the mouse
pointer shows how the text that is entered will be aligned.

Align Left Centre Align Right

3.
Enter the text. NeoOffice automatically inserts the requisite number of
blank lines, tabs and spaces.

Selecting and Deleting Text
Some basic steps to start.

Deleting characters

• To delete one character to the left of the cursor, press Delete (above the Return key).

• To delete one character to the right of the cursor, press the Delete Forward key (below
the F14 and help keys, and labelled with the word “delete” and a forward arrow).

Deleting text

Selecting text to delete with the mouse

1. Click to set the cursor on the first character to be deleted.
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2. Keeping the mouse button depressed, drag the pointer to the last character to be
deleted. The characters will be highlighted.

3. Release the mouse button.

4. Press the Delete key to delete the selected text.

Selecting text to delete with the keyboard

1. Click to show the location of the cursor on the page, then use the arrow keys to go to
the first character to be deleted.

2. Hold down the Shift key.

3. Using the arrow keys, move the cursor to just after the last character to be deleted.

4. Release the Shift key. The text is highlighted.

5. Press the Delete key to delete the selected text.

Note: To put the selected text into the clipboard for use later or to put elsewhere in the document, press
Cmd-X ( -X)⌘ rather than Delete. This “cuts” out the text and places it on the clipboard. To paste it
back in, wherever and as often as desired, press Cmd-V ( -V)⌘ when the cursor is set to the correct
location.

Deleting non-adjacent pieces of text.

1. Press Cmd ( )⌘ and keep it pressed.

2. Click to set the cursor at the first character of the first piece of text to be deleted.

3. Press and hold the mouse button and drag the pointer to the last character of the text
to be deleted.

4. Release the mouse button and the Cmd ( )⌘ key.

5. Repeat steps 1 to 4 for each piece of text to be deleted.

6. Press the Delete key to delete the selected text.

Status bar uses

Setting the Viewing Zoom Factor

By double-clicking or right-clicking in the area shown above, you can select the display
Zoom factor for the document. The “Optimal” setting is particularly useful when the
Styles and Formatting window or Navigator are docked and opened at various times
during a session, in that the full width page of text is always displayed.
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Editing or Activating Hyperlinks

Display Effect

HYP Click a Hyperlink to load the corresponding URL.

SEL Click a Hyperlink text and edit it, as with normal text.

To edit the URL instead of the Hyperlink text, the status bar must have HYP displayed in
this field. Highlight the Hyperlink, then right-click or Ctrl-click to bring up this context
menu:

If the Hyperlink is inserted as a button rather than as text (see Link button), the
Hyperlink can only be edited if you change the properties of the control field: select the
button, open its context menu and choose the Control command and then edit the text on
the button and the URL from the Properties dialog of the button.

Clicking a hyperlink in a document loads a browser and opens the linkdialog.

Applying Various Fonts
Modify the Paragraph Style to permanently change the font size and style for all
paragraphs with that particular paragraph format. First, position the cursor in the text that
is to be modified and Ctrl-click or right click to bring up a context menu similar to that
above. Select the command Edit Paragraph Style in the context menu.

The Paragraph Style dialog opens, with various tabs. Click on the Font tab and specify
the type, size, and style of the font.
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Note: If you want to emphasize a particular passage in a letter, simply select the text and click the Bold or
Italic icon. To format only a single word, simply place the cursor anywhere in the word and click Bold or
Italic.

Make any other necessary changes, then click the Save Document icon and close the
document template.

Note: When creating a template, remember not to type a text for an actual letter. The main purpose of a
template is to define the general layout of a document. Use the documents based on the template to add text
for a letter.

Keyboard Navigating and Selection in Writer
Navigating and selection using the keyboard is done using the arrow keys. You can also
use home, end, page up and page down. Certain keys have different functions depending
on whether they are simply pressed, or are used in combination with the Cmd key. The
following table provides an overview of the keys used for navigation.

Key Function With Cmd key
Right/left arrow
keys

Go one character to the left or right Go one word to the left or right

Up/down arrow
keys

Go one line up or down Move the current paragraph up or
down

Home Go to the beginning of the current line Go to the beginning of the
document

Home In a
table

Go to the beginning of the current cell 1. Go to the beginning of the
current cell 2. Go to the beginning
of the table 3. Go to the beginning
of the document

End Go to the end of the current row Go to the end of the document

End In a table Go to the end of the current cell 1. Go to the end of the current cell
2. Go to the end of the table 3. Go
to the end of the document

Page Up Scroll one page up the screen Switch to the header and back

PageDown Scroll one page down the screen Switch to the footer and back

Inserting Special Characters
This is how to insert special characters (such as check marks, boxes, telephone symbols
etc.) in text:

• Select Insert > Special Characters to view the selection of characters available.

• In the large selection field select the desired character (or more than one) by clicking
with the mouse or by navigating by keyboard in succession. The characters are
displayed at the bottom of the dialog box, and/or below the “Delete” button, as here
(below). Upon closing the dialog with OK, all displayed characters in the selected font
are inserted in the current document at the cursor.
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dialogdialog

Inserting Protected Spaces, Hyphens and Conditional Separators

Non-breaking spaces

To prevent two words from being separated at the end of a line, press the Option key
while typing the space between the words. This is important, for example, between a title
and the person's name e.g. Sir Humphrey Appleby, where you do not wish the words
“Sir” and “Humphrey” to be separated.

Non-breaking hyphen

An example of a non-breaking hyphen would be in a company name such as A-Z.
Obviously having A- appear at the end of a line and Z at the beginning of the next line is
not usually desired. To solve this problem, press Shift-Cmd-minus sign. In other words,
hold down the Shift and Cmd keys and press the minus key on the numerical keyboard.

Hyphen, em-dash and en-dash

To enter longer dashes, add the character sequences and replacement under Tools >
AutoCorrect > Replace, as below.

Note: There is a Replace dashes under the Options tab but be aware that this selection is for creating
paragraph borders. When a sequence of three hyphens or three equals signs are entered, these are replaced
by a single line border and a double line border respectively.

Here is a method to use:

1. Open a text document and place the cursor in a convenient location.

2. Use the Special Character dialog to find the long (em) dash to use and insert it in the
document.

3. Copy the character.

4. Open Tools > AutoCorrect > Replace.
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5. Paste the dash character into the With field

6. Enter the desired character sequence into the Replace field. For example, two hyphens
(- -) to trigger the replacement.

Now you have defined a shortcut that automatically replaces your defined input sequence
with the optional dash selected. This dash can also be in another font.

Manual Hyphenation

Although NeoOffice offers automatic hyphenation by entering a separator inside a word,
users can override this feature by entering Cmd-minus. Thus the word can be hyphenated
at the end of the line regardless of the state of automatic hyphenation for this paragraph.

Emphasizing Text
There are many ways of emphasizing text in a special way. Here are some of them:

• Use the icons in the Formatting toolbar for regular formatting needs. For example,
use the icons to change the text to bold or to another font style, to change the text
color and background, or centre the text.

• Whole paragraphs can be emphasized using borders. Place the cursor in the paragraph
that is to be emphasized, right-click or Ctrl-click to its context menu and select
Paragraph, then click on, for example, the Borders tab. At this point, a border may
be selected to frame the paragraph, and also with shadow shading, if desired. If
necessary the distance between the border and the paragraph text can be adjusted
under Spacing to contents.

• Using a Text Frame, provides the following possibilities:

a) Text can receive a border

b) Text can be placed outside of the text margin on the side of the page.

c) Text frames can be linked when text should flow from one frame to another.

• Choose Format > Paragraph > Background to apply a background color to the
paragraph.

• Use the Draw Text function: Open the Draw function toolbar (on the Standard
toolbar), select the Text icon , drag open a frame and enter the text. This text

can be positioned as desired, which includes rotating at various angles, or curving and
slanting the text with the help of Format > Object > FontWork.

Changing the Color of Text
Click the little black triangle (down arrow) of the Font color icon in Writer
and other modules to obtain a floating toolbar with a range of colors from
which to choose. Alternatively, long-click the icon itself to drop down the

color selection.

Note the currently selected font color is shown in the bar at the bottom of the icon: in the
picture above it is dark red.
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Note: The following OpenOffice.org function does not appear to work in quite this way in NeoOffice 2.x:
when using a short-click in OpenOffice.org with no text selected, the mouse pointer changes its appearance
to a tilted paint can pouring paint. Drag the hot spot of the mouse pointer across the target text area. This
text area now takes on the selected color. The function remains active for as long as the icon is active (looks
depressed), or until simply clicking without dragging, or until the (Esc) key is pressed.

Rotating Text
Text can be rotated by entering it into a text frame as follows:

Open the Show Draw Functions floating toolbar on the Standard
toolbar.

On the Draw Functions toolbar, click on the Text icon. The mouse
pointer changes to a '+' which indicates that a text frame may be defined
and opened.

Open up a text frame, release the mouse button and type in any text.

Click on the edge of the text frame. Now see the Drawing Object
Properties toolbar, which contains the Object Rotation Mode icon,
appears. Click on that icon.

Now, if you click on one of the (red) handles in the corners of the text
frame and drag the mouse, the whole text frame turns with the text.

dialog

Defining Borders
Borders of pages, paragraphs, tables and other objects can be defined in two places:

• Choose Format > (object name) > Borders where <object name> is either page or
paragraph.

• In tables, use the Borders floating toolbar on the object bar.

Choose Format from the menu bar, Borders tab page

To set a border, select Format > Page > Borders or Format > Paragraph > Borders
which opens the following dialog:
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On the left of the dialog panel is the Line arrangement group. Below that is an intuitive
aid to formatting, the User-defined box. Notice that the four outer edges of the User-
defined area are marked with small gray angles. To edit an outer margin, click in the
appropriate position between the small angles. Above this area are four predefined
Default borders which may also be used. The User-defined box gives you a graphical
representation of what will happen on your page. You can set up your borders here very
quickly.

In both cases, the selected border elements will be indicated by black triangles. Now
choose a line style or a color. It will be applied to the selected part of the border.

Note: If an empty line is selected in the preview, the condition “No Line” appears. This means that the
relevant part of the border will be deleted.

Clicking repeatedly on an element in the Borders User-defined dialog switches between
three alternative modes:

The element is displayed as a line Clicking OK will apply the format to the
element.

The element is displayed as a thick
black line

If OK is clicked, the object remains unchanged.

The element is not displayed Clicking OK deletes the element.
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Use the Borders floating toolbar with Tables

Suppose the following table border is required for a document:

Berlin New York London

Country Germany USA Great Britain

River Spree Hudson Thames

Population > 3 Million Citizens > 7 Million Citizens > 6 Million Citizens

1. Place the cursor at the position in the document where the table is to be inserted.

2. Choose Insert > Table to open the Insert Table dialog, and insert a table of the
required size, i.e. 4 columns and 3 rows.

3. Select the whole table by pressing Cmd-A twice, then click the Borders icon on the
object bar. On the floating toolbar click the icon at top left, which means “No Border”.

Now, with the mouse, select the whole of the first row, open the context menu and
choose Table to open the Table Format dialog.
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5. Open the Borders tab page.

6. In the line field select the required line thickness, e.g. 2.50 pt.

7. First select full bordering from the Defaults

8. In the large User-defined box, click once in the area between the two top angles (see
illustration) to remove the top line and then click on OK.

9. Now select the second row of the table and again open the Table Format dialog by
choosing Table in the context menu.

10. In the User-defined box, click the areas between the two bottom angles (see
illustration) to remove the bottom line between the rows and then click on OK.

11. Now select the third row of the table and again open the Table Format dialog by
choosing Table in the context menu.

12. In the User-defined box, click the areas between the two top angles (see illustration)
to remove the top line between the rows and then on OK.

13. In the Style field select the required line thickness and click OK.

14. Now the table is finished.

Superscripts and Subscripts
Youhave the following options for superscripting or subscripting text:

1. Use the keyboard shortcuts Cmd-Shift-P and Cmd-Shift-B
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2. Choose Format > Character > Position.

3. Use the TextObject toolbar Superscript/Subscript buttons. If these buttons are not
visible in the toolbar, expose them using the method described later (Changing the
Visibility of Buttons on Toolbars).

Making text superscript/subscript while typing

Suppose you want to type 1 m2 (superscript 2):

1. Type the character “m”.

2. Press Cmd-Shift-P. Cmd-Shift-P is the keyboard shortcut for superscript text.

3. Type the 2.

4. Press the keyboard shortcut, Cmd-Shift-P again to disable superscripting.

Note: At the end of a paragraph, an easier way to disable superscripting is to press the right arrow key
once.

5. Continue entering the text.

Suppose that entering H2O with a subscript 2 is wanted:

1. Type the H.

2. Press Cmd-Shift-B. Cmd-Shift-B is the keyboard shortcut for subscript text, Cmd-
Shift-P for superscript text.

3. Type the 2.

4. Press the keyboard shortcut again.

There is an even easier way when the cursor is at the end of a paragraph: Press the
right arrow key once.

5. Type the O.
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Applying subscripts/superscripts retrospectively

Let's say that while proofing text, you decide that the text H2O needs to be altered to
include a subscripted “2” giving (H2O). To do so, use either the key shortcut method,
described above, or use this method method via the menu command:

1. Highlight the character that should be in subscript/superscript. For example, select the
2.

2. Choose Format > Character. This opens the Character dialog.

3. Click the Position tab.

4. Select Subscript and click OK.

The 2 now appears in subscript.

Writing in Uppercase or Lowercase
Writer has the following methods for re-formatting text in uppercase or lowercase.

• To display in uppercase: Highlight the text and choose Format > Character > Font
Effects tab, and under Effects select Capitals.

• Displaying in lowercase: Highlight the text and choose Format > Character > Font
Effects tab, and under Effects select Lowercase.

• Converting to uppercase: Highlight text, then choose Format > Case/Characters >
Uppercase or right-click (Ctrl-click) and make the same selection from the popup
menu.
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• Converting to lowercase: Highlight text, then choose Format > Case/Characters >
Lowercase or right-click and make the same selection from the popup menu.

Moving Text Sections in Documents
1. Select the text that is to be moved.

2. Place the mouse pointer in the selected text, then press the mouse button and keep it
pressed.

3. Drag the mouse until a hand symbol replaces the pointer, indicating that the selected
area will be moved. In addition, a gray text cursor moves with the mouse pointer,
indicating where the selection is to be inserted.

Resetting Font Attributes While Typing
Youmay apply direct formatting while typing text and later decide to reset all formatting
and continue entering text using the default format. Text is entered using direct character
formatting. To reset the formatting to default, Ctrl-click to bring up a context menu and
amend the Paragraph Style. Now, continue entering text at the end of the current
paragraph.

Example procedure for resetting Font Attributes

Suppose you want to type the words “Enter this in bold italic”, and set the last two
words to bold italic while typing. First type Enter this in, then click on the Bold and
Italic icons on the Formatting toolbar followed by entering the words bold italic. To
continue with normal setting, simply press the right arrow key once and finish the
paragraph. This is simpler than clicking on the two icons again.

Quick Formatting Using the Adjacent Paragraph Format
When there are two consecutive paragraphs with different paragraph formats that should
be formatted the same way, do it quickly with the following method:

Delete the paragraph mark between two paragraphs.

NeoOffice User Guide for 2.x 78



Chapter 3: Managing Text Documents With Writer

a) Press Return.

Both paragraphs now have the same format with the same Style.

Note: to see paragraph marks, enable View > Non printing Characters or press Cmd-F10

Delete paragraph marks in the following two ways:

1. Go the end of the first paragraph and press the Delete key. This action merges the second paragraph
into the first (known as ”deleting to the right”). To turn the text back into two paragraphs, Press the
Return key twice and the second paragraph has the same format as the first.

2. Go to the beginning of the second paragraph and press delete (usually above the Return key). the second
paragraph merges with the first paragraph but keeps its format (known as “deleting to the left”).
Pressing Return creates two paragraphs but both have the format of the second paragraph.

Using Sections
Sections in NeoOffice Writer text documents isolate blocks of text for special purposes.
One example of their use in Writer is in preparing complete documents using Master
documents. Another is in preparing contracts from a set of fixed codicils.

The following are the ways that sections can be incorporated in a Writer document:

• Sections of text that have a different number of columns than the master text.

• Sections protected from further editing.

• Sections that are only to be shown under certain circumstances or hidden.

• Sections that are to be inserted into a document as files or parts of files.

•

A section must consist of at least one paragraph. When selected text is defined as a
section, it automatically ends with a paragraph break.

Another text document may be inserted as a section within a text document. A section
from another text document can also be inserted as a section. Sections can be linked,
within a single document, to other locations. To insert a new paragraph immediately
before or after a section, place the cursor at the very beginning or end of the section and
press Option-Return.
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Sections and Columns
Multicolumn section: A section can contain other sections. This feature allows the user,
for example, to create a two-column section on a page of text, and then create a three-
column section within that section.

Multicolumn page: The page format (Format > Page > Columns), which always
applies to all pages with the current Page Style, is independent of the sections.

Illustration: Format > Page > Columns calls up this menu. allowing you to set the number of columns,
their width and spacing

Multicolumn frame: Frames containing columns of text may be inserted. These can be
moved freely around the page (from Tools toolbar, long-click to open Insert floating
toolbar, click Insert frame icon). For these frames, for example, you can select that the
text in the frame be positioned a certain distance from the edge of the frame (Choose
Format > Frame > Wrap).

Inserting Sections
1. Place the cursor at the point to insert the new section, or select the text that is to form
a new section.

2. Choose Insert > Section. In the dialog, define other settings for the section.

3. Click Insert.
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Other documents, or sections from other documents, can be inserted. In this case, Links
must be checked. Enter a file name in the text box, or click the box “...” to search for a
file. Select a named section of the document in the Section pull-down list.

When opening a document that contains linked sections, a popup asks you to update these
sections. If the answer is yes, the current versions of the linked sections will be updated.

Editing Sections
Edit the sections in the text document by choosing Format > Sections. This dialog
allows you to protect sections, unprotect sections, reveal hidden sections, change the
conditions and remove sections; that is, turn them back into normal text.
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Formatting TextWith and Without Styles

Plain text can be too bland unless you apply visual effects to it, such as giving overall
structure to the text, emphasizing individual words, quotations or references, or breaking
up solid areas of text. Thus you should consider giving special formatting to sections of
text.

Direct Formatting or Formatting With Styles
When working with Writer, you can choose between direct formatting and formatting
with Styles, to apply text attributes such as bold, italics, font type and font size.

Apply direct format by directly setting a certain attribute(s) to the selected text area. For
example, clicking the Bold icon on the Formatting toolbar applies the bold format
directly to a selected text area or to subsequent characters after the cursor while typing.
Direct formatting is more appropriate for one-time use. For example, to make a word
bold, just position the cursor in the word and click the Bold icon. This works quickly and
intuitively.

Styles, on the other hand, apply attributes to text in an indirect manner. A Style is a
labelled collection of default settings that format text. Indirect formatting, with the help
of Styles, is much preferable when formatting lengthy documents in a uniform fashion.

Styles do require some advance preparation. First you must create the Style, then apply
the Style to the text. Both tasks are best done using the Styles and Formatting window.

By way of example, let's assume that each of the headings is formatted with a 24 point
Helvetica font but this now needs to be changed in all the headings to a 20 point Times
font and in bold. Doing this manually requires time and patience; however, had the
format been defined as a Style, say with the name “Head1”, that was applied to the
headings in the document, you could simply modify the “Head1” Style, and all headings
would be automatically changed to match the new settings.
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The Style Concept in NeoOffice

Styles for characters, paragraphs, frames, numbered lists and pages (or cells in tables) are
always saved with the document. If you wish, you can copy the Styles of one document
to another document and choose whether or not to overwrite (replace) Styles of the same
name.

One nice feature of NeoOffice is that you can turn any document, (including the
Character, Paragraph, Frame, Numbering and Page Styles it contains) into a template.
When a new document based on this template is opened, all those Styles are available to
the user.

NeoOffice comes with predefined Styles for all document types. Thus, when you want a
new text document, use File > New > Text Document. A new, blank document is opened
with these fixed settings. Youmay add or modify the styles used with a document as
work progresses and, if desired, this document can be turned into a default template by
saving it via File > Templates > Save. Any Styles that are custom defined and are
contained in the default template will then apply to all new documents created with this
template.

This is particularly useful when you are producing documents in a series, or when you
want all of your documents to portray a “corporate image”.

The Styles in the Styles and Formatting Window
Open the Styles and Formatting window by selecting Format > Styles and
Formatting or by clicking the Styles and Formatting icon on the Formatting toolbar.
All the Styles and Formatting window functions are explained in NeoOffice Help.

At the top of the Styles and Formatting window are icons for selecting the Style type to
display. These are, from left to right: Paragraph, Character, Frame, Page, Numbering
Styles, Fill Format Mode, New Style from Selection and Update Style.

The scrolling frame of the Styles and Formatting window lists available styles in the
active Style category. That is specified in the list box at the bottom of the Styles and
Formatting window.

For example, in the graphic below, the word “Automatic” is selected in the list box at the
bottom of the window. Writer offers the Styles in that “Automatic” category. To see all
the Styles of a Style type, select “All Styles” from the list box.

Paragraph Styles
Select Paragraph Styles, if it is not already selected, by clicking the Paragraph Styles icon
in the Styles and Formatting window. The list of Paragraph Styles appears.
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Double-click an entry in the list of Paragraph Styles. The paragraph in which the cursor
is positioned will now be formatted with that Paragraph Style (eg “Default” in the
example above). Double-click in the Styles and Formatting window on another
Paragraph Style, and the formatting of the current paragraph changes accordingly.

To format a paragraph as a heading, follow this procedure:

1. Type the line to be formatted as a heading and press the Return key.

2. Set the cursor in that line.

3. Open the Styles and Formatting window: for example, by pressing the Styles and

Formatting icon in the Formatting toolbar.

4. Double-click the Paragraph Style “Heading 1”.
This one paragraph now has the paragraph format “Heading 1”. If you want to know
which attributes are included in this paragraph format, click “Heading 1” in the Styles
and Formatting window, then right-click (Ctrl-Click) to open the context menu. Then
chooseModify to open the Paragraph Style: Heading 1 dialog, which tells everything
about the properties of this Paragraph Style.

If you decide not to modify this Paragraph Style, simply close the dialog by clicking the
Cancel button. But if you modify the style, note how this Paragraph Style defines the
corresponding modifications. Then close the dialog with the OK button. These modified
settings will now apply to all paragraphs (old and new) having the “Heading 1”.
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Paragraph Style.
Changes can also be applied the to all Paragraph Styles that are derived from the
Paragraph Style “Heading 1”. The Paragraph Styles “Heading 1” to “Heading 10” are
all hierarchically derived from the Paragraph Style “Heading”. By selecting
“Hierarchical” from the click-down list box at the bottom, you can immediately see
where a selected Style fits in the hierarchy of styles. Simply put, the style immediately
higher up is the one from which the style is derived and the following one, which is
derived from the custom style.

By way of example, if you change the left indent to 2.54 cm (1 inch) in the Paragraph
Style “Heading”, for example, that this will change the left indent for all Paragraph
Styles “Heading 1” to ”Heading 10” to 2.54 cm. Changes that you make directly in one
of the Style dialogs have priority over the properties “inherited” from higher-ranking
Styles. Right click (Ctrl-click) on a style and open it with Modify to get the Paragraph
Styles dialog and then choose the Organize tab. If the Linked with list box is checked,
you will see from which Style the selected Style is derived.
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Character Styles
In the following illustration, the Styles and Formatting window displays a list of
available Character Styles. These Styles do not modify the whole paragraph, but only the
single word in which the cursor is currently positioned (or a selected text range).

Use or modify the supplied Styles, or define custom Styles and use those. The best way is
to start by selecting a Style from the Styles and Formatting window (with a single
click), which may then be used as the starting point for creating a custom Style. You then
merely have to enter the properties that are different from the selected Style, since the
other properties are “inherited” from the parent Style.

The following table describes the base Styles and the various attributes available .

Style Type Attribute Selection

Paragraph Styles Indents and Spacing, Alignment, Hyphenation,
Tabs, Font, Language, Initials

Character Styles Font, Font Size, Language

Frame Styles Position, Anchoring, Borders

Page Styles Header, Footer, Margins, Columns

Numbering Styles Numbering Type, Outline, Bullets, Assigning
Numbering Styles
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Hierarchical Styles
Styles can be hierarchically linked to each other. Thus, one defined Style can be derived
from another with the result that the new Style contains only the differences from the
“basic” Style. This is convenient, if you later change the “basic” Style, to have all text
with the derived Style also updated accordingly.

For example, start with the Paragraph Style “default”. It uses the font “Times New
Roman” in “12” point to create a Style called “indented text” where the only addition
is a a left indent with no other changes. Later, if you decide to change the font in “text
body”, then the font is automatically changed in the “indented text” Style as well.
Sticking with this example, if you redefined the left indentation in the “default”, it would
have no effect on the paragraphs formatted with “indented text” because, in the
hierarchy, the more closely associated format always has priority. That is, because the
indentation is the only attribute of that style, it is not over-ridden by that [indenting]
aspect of the default.

Numbering Styles
Simple bulleting and numbering in a document can be easily set using the icons on the
Writer Formatting toolbar. Likewise, the icons for bold, italic etc. can be used to assign
direct formatting that is not already part of the Style. The Styles and Formatting
window, too, offers various Numbering Styles that may be applied by double-clicking the
name of the Style.

For more control of numbering in a document, use Format > Bullets and Numbering
which offers several other options that may be more suitable and which can be used to
create custom styles.

Illustration: the Bullets and Numbering window offers the possibility of changing the types of bullets, the
use of graphics as bullets, the use of Roman or Arabic numbering styles, starting or re-starting a list with
a number other than 1, etc.
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Creating New Character Styles or Paragraph Styles
Creating a new Style on the basis of an existing Style is a straight forward process. The
following is a step-by-step procedure with which to start:

a) First of all, apply new, direct formatting to any characters or any paragraph, which
will become the Style. To do this, either use the Formatting toolbar or go to the
Format menu and choose Character or Paragraph.

b) Select the text or paragraph containing the new formatting. For words or paragraphs,
simply position the cursor in the respective word or paragraph.

c) At the top of the Styles and Formatting window, click the Paragraph Styles icon to
create a new Paragraph Style. Likewise, click the Character Styles icon to create a
new Character Style.

d) At the top of the Styles and Formatting window, click New Style from Selection.
This opens the Create Style dialog.

e) Enter a name for the new Style and click OK

As can be seen in the Styles and Formatting window, a new Style has been created in
the “Custom Styles” group making it available for use for indirect formatting in
documents.

Youmay also create a new Style without using an existing Style as the starting point.
Here is a method by which to create a new paragraph style.

a) In the Styles and Formatting window, choose Paragraph Style by clicking its icon.
(the one farthest to the left in the Styles and Formatting windows toolbar.)

b) Call the context menu of the Styles and Formatting window (click right mouse
button or Ctrl-click)).

c) Choose New...
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d) Enter the data for the desired Style

e) Close the dialog with OK.

Yet another example shows how to define a Paragraph Style for a subtitle and assumes
there are several subtitles in the text that are candidates for formatting with a custom
Paragraph Style.

1. Position the cursor in a paragraph in the text that is to be formatted with the new
Paragraph Style.

2. Apply a Paragraph Style to the paragraph as an initial format. This way you do not
need to define all of the attributes yourself. For example, double-click on the
“Heading 1” Paragraph Style in the Styles and Formatting window.

3. The paragraph is now formatted as “Heading 1.”
4. Highlight the entire paragraph. It will appear highlighted.

5. Modify the type of characters by selecting an italic font in the Character dialog
(Choose Format > Character > Font) or by clicking the Italics icon on the text
object bar.

6. In the Styles and Formatting window, click on the New Style by Example icon and
enter a name for the new Style in the dialog box, for example, “Head1”

7. Click OK.

8. Now apply the new “Head1” Paragraph Style by placing the cursor in the paragraph
and double-clicking the “Head1”Style name in the Styles and Formatting window.

Where the desired Style already exists in a document, select and apply it from the Apply
Style pull-down list on the object bar.

Creating Document Templates
For any user-defined Paragraph or Character Styles to be available in other documents,
first create a template. It is best if you use a current document so that the template will
contain all the Styles you want and need. The following steps will help create a new
template:

1. Have the documents open. If desired, delete all text from the current document,
leaving only the Styles.

2. Call the menu command File > Templates > Save.
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In the dialog Templates, select the category into which you want to save the template. In
the New Template text field, enter the name for the template.

3. Click OK to complete the process of creating a template.

With the template saved, the next time when File > New > Templates and Documents is
used to select a template for creating a document, this template will be selectable from
those available. All the user-defined Text and Paragraph Styles will then be available for
the new document.

The Advantages of the Styles and Formatting Window
From the preceding instructions you now know how to apply the styles in the Styles and
Formatting window to text, how to apply custom Styles and how to create a template
that uses these custom styles. This gives an advantage in that Styles do not have to be
redefined every time. Plus, you can apply Styles from one text document to another text
document by selecting Format > Styles > Load. In this way, the desired formatting can
be applied to the document quickly and easily. But the Styles and Formatting window
offers still more possibilities.

Formatting Multiple Paragraphs
In the work described above, the same Paragraph Style “Heading 1” was applied to each
of several paragraphs. The Styles and Formatting window can save a lot of time on this
task:

1. In the Styles and Formatting window, select the Style that should be applied on
multiple paragraphs by clicking the name of the Style once.

2. At the top of the Styles and Formatting window, click on the Fill Format Mode

icon. The mouse pointer changes to a grayed line indicating this mode as soon as it
moves back into the document.

3. Click once on every paragraph in the text to which you want to apply the selected
Style.

4. Finally, to switch off this mode, click the Fill Format Mode icon again or press the
Escape key.
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Changing a Style the Easy Way
The section provides a scenario for making a style change quick and easy. To start, you
have used the custom Style made in the previous sections to format a document with the
new “Head1” Style. However, later, you may decide that it would look better if the
headings were spaced with slightly wider gaps between the letters (this is known as
kerning). The following gives the steps to making this change:

1. Locate the longest heading formatted with the “Head1” Style in the document and
click three times in that heading to select the entire line.

2. Make the desired changes. To lock the character spacing, use this method:

a) Choose Format > Character, or choose Character from the context menu
for the selected line.

b) In the Character dialog, click the Position tab and in the Spacing list box
select “Expanded”. In the spin button, increase the spacing (from the 0.0pt
spacing shown above to say 1.5pt or 2.0pt) to make the heading wider.

c) Close the dialog with OK.

3. Now additional direct formatting has been applied on one of the headings formatted
with the Style “Head1”. All direct and Style formatting should now be added to the
“Head1” Paragraph Style. This style is still selected in the Styles and Formatting
window.
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4. At the top of the Styles and Formatting window, click the Update Style icon (hold
down on the little black triangle next to the New Style from Selection icon). All
headings formatted with “Head1” will be automatically reformatted with the modified
Style.

Styles can also be configured to adapt to any changes automatically. In the Properties
dialog for the Style, click the Organizer tab and mark Auto-Update. This allows you to
change the formatting of, say, a paragraph formatted with this Style and have the
formatting of all other paragraphs with the same Style be automatically changed as well.

Page Styles and Page Numbers
Often you may create text documents without a page number on the title page but with
lowercase or uppercase roman numerals on the pages of the Table of Contents (you may
not know how many yet), but you will want to start numbering the rest of the pages with
Arabic numerals. So you want the sequence to be (no number on title page), i. ii. iii....,
1,2,3... etc

Note: Different Page Styles are the NeoOffice Writer equivalent of “section changes” in other text programs.

Page numbers are better located in footers or headers rather than in the running text, to
ensure that they do not change their position when text is inserted or deleted. The steps
below show how to do this:

1. Create a new Page Style

2. Apply the new Page Style

3. Edit the Page Style

4. Use the footer Paragraph Style to format page numbers.

Note: Do not use the Offset box under Insert > Fields > Other > Document tab to change the page number
of a page. The offset is only used, for example, at the end of a page to display the number of the next page,
i.e. to offset the display; it does not change the page number itself.

The manually entered page number (in contrast to the automatically numbered page numbers) is an attribute
of that particular page. This property is set as direct formatting in the first paragraph of that page.

Create Page Styles

1. Open the document in which you would like to enter or change the page numbers. Or,
begin with a new text document (although you will need to first enter some text and
page breaks to be able to follow the steps described here).
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2. Open the Styles and Formatting window.

3. Select the Page Styles view in the Styles and Formatting window.

4. Call up the context menu of one of the Page Styles by right-clicking or Ctrl-clicking
on its name and select the New... command.

Youwill now see the Page Style dialog with the Organizer tab page. The cursor will
be blinking in the Name text box.

5. Enter the name of the first new Page Style: enter Title Page and press the Return key.
The properties of the new Page Styles can be changed later.

6. In the context menu of the Styles and Formatting window (reached by a right-click
or Ctrl-click as described above in 4.) click the New... command again and define the
Page Style with the name “Table of contents”.

7. Repeat the whole procedure again for the newMain text Page Style. (Of course, the
names used here are only meant as examples. In a real situation, you would naturally
enter the names of choice.)

With the completion of the above steps, there should now be three new Styles that have
been created.
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1. Place the cursor on the first page of the document. Double-click the Title page entry
in the Styles and Formatting window.

So, now the first page is assigned this Page Style. To confirm this, you will see the
name Title page in the Page Style field on the status bar below at the bottom of your
NeoOffice window. By the way, you can also edit (double-click) and assign existing
Page Styles via the context menu of the Page Style field on the status bar.

If, however, you now scroll through the pages of the document, you may notice that
the Title page Page Style has been applied to every page. If all the pages had been
defined by the Standard Page Style, they are now all defined by the new Style. Page
Styles always apply to all preceding as well as following pages, unless a page break
occurs with a change of Page Style.

On the Organizer tab page, if a Next Style for a Page Style is entered, this means that
after a page break (whether it is entered manually or occurs automatically) the Next
Style will be taken as the Page Style. In the example described here, for the Page Style
Title page you can select the Next Style Table of Contents. The Table of Contents
Page Style is then always applied to the next page after the title page. This saves you
from having to go through the procedure described below involving theManual
Break dialog.

Note: Always choose the Table of Contents Page Style as the Next Style to follow the Table of Contents,
since no one can be sure yet about the number of pages that the Table of Contents will require.

2. Now place the cursor at the beginning of the page where the Table of Contents should
begin. Go ahead and enter a manual page break with a change of Page Styles.

3. Select Insert > Manual Break. The Insert Break dialog appears.
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4. Select as Type the Page break option. In the list box select the Table of Contents
Page Style which will then begin at this point in the document.

5. Click OK.

6. Place the cursor at the beginning of the first line in the main text.

7. Choose Insert > Manual Break. The Insert Break dialog appears.

8. Select as Type the Page break option. In the pull-down list, select theMain text Page
Style, which should be applied after this point. Mark the Change page number check
box and select the new page number 1.

9. Now click OK.

Note: For headers or footers to contain different contents on the right and left sides, just uncheck the Same
content left/right check box under Format > Page > Footer.

Under Format > Page > Page, you can select the page layout “mirrored”. This lets you
define an inner and an outer margin for the text. The left and right pages of the main text
often have different Page Styles so that, for example, the left pages have a header, but the
right ones do not. There are already Left page and Right page Page Styles provided for
use; so use these instead ofMain text. The first page of the main text is page 1 and
contains the Right page Style; assign the Left page Style as the Next Style and vice
versa. These Styles can be assigned to the corresponding pages in the Styles and
Formatting window context menu with theModify command. On the Organizer tab
page, choose the Next Style.

Caution: There is an active issue in OpenOffice.org that inserts
blank pages where one least expects them. If this is a problem in
your version of NeoOffice, please use the workaround described
elsewhere in this book.

Editing Page Styles

Note: this following advice does not appear to apply to NeoOffice, but has been included because ti appears
in the OpenOffice.org 2.x User Guide.

The newMain text Page Style can have a page number in the middle of the footer. To
make it so, do the following:

1. SelectMain Text in the Styles and Formatting window, right-click or Ctrl-click to
open the context menu and selectModify.

2. The paragraph Style dialog window opens to display the definitions forMain Text.

3. Click the Footer tab.

4. Check the Footer on box.

5. Click OK which places an empty footer on the document page.

6. Click the mouse cursor in the footer area of the page to enter data.

7. Choose Insert > Fields > Page Number. If View > Field Shadings is enabled, the
page number appears in a gray field otherwise with no shading.
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8. To have the word “Page” precede the page number, place the cursor in front of the
field and enter “Page”.

9. Click the Centred icon on the object bar to centre the current paragraph.

10.The appearance of the footer and its contents are now defined.

Page Breaks as Paragraph Formats

In the first paragraph of the main text, direct paragraph formatting was automatically
applied, determining that the text automatically begins on the new Page 1. This will also
apply if no text exists after the manual break on the new page. To check this for the first
paragraph after the manual break, choose Paragraph... from the context menu (not Edit
Paragraph Style, since this is a direct formatting attribute for a paragraph), by right-
clicking or Ctrl-clicking within the paragraph.

If a particular paragraph should be on a new page with a new Page Style, then that would
be a property of that particular paragraph. Assign this property under Format >
Paragraph > Text Flow.

Changing the Format of Page Numbers

Page numbers may be specified as either direct or as a property of the Page Style, just
like other text attributes. Using direct formatting, however, should only be employed in a
few instances. When direct formatting, you edit the the field directly as follows:
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1. Double-click the field with the page number. The Edit Fields: Document dialog
opens. Select the desired field format.

2. Click OK.

Better than the direct formatting method, just described, is to make the page number
format a property of the Page Style as explained below:

1. Open the context menu on the page by placing your cursor somewhere in the page and
right-clicking or Ctrl-clicking. Select Page:

2. Then the user will see, for example, the Page Style: default dialog. Instead of
“default”, the title bar of the dialog contains the name of the current Page Style.

3. Go to the Page tab.
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4. In the Format (numbering) pull-down list, determine how the numbering should
appear on all pages with this Style.

5. Close the dialog with OK.

6. Now select the As Page Style format for the field which shows the page number (see
the Edit Fields screenshot and description of direct formats above).

Youmay change other properties in the footer, such as the font, by editing the Footer
Paragraph Style so that the changes will apply to all footers.

• Place the cursor in the footer. Call the context menu and choose Edit Paragraph
Style.

Increasing the spacing of the footer from the text above is also a format attribute of the
Page Style:

1. Select the page style in the Styles and Formatting window.

2. Right click or Ctrl-click and select theModify... command in the the context menu.

3. In the Page Style dialog set the desired width and height of the footer.

Page Styles Summary

Unlike assigning a character style or paragraph style, where you first select the text then
double-click in the Styles and Formatting window on the name of the style in order to
apply that style, applying page styles is different.

A page style is always a property of the first paragraph of a page whether or not this is
the first paragraph of the current page or the first paragraph of a previous page. However,
not every first paragraph has the Page Style attribute. Since this is the case, NeoOffice
Writer searches for the page style attribute of the current page by starting at the current
cursor position and continues to search toward the beginning of the document, checking
each first paragraph of a page to locate a page style as attribute.

To change from one page style to another, use the context menu of the field in the Status
bar which displays the current page style .

Right-click or Ctrl-click on this field: you will see a popup containing a list of page
styles. Select the page style wanted for this page and Writer searches backwards until the
first paragraph at the beginning of a page has been found. This paragraph is now given
the newly selected page style and this style will be applied from this point up to the end
of the document, or until a new first paragraph containing another page style is found.
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Defining Default Templates
Whenever you find that you are forever changing the formatting of new documents to
suit requirements, it is time to use a separate template. In Writer, this is known as the
default template. If you choose, this default template can be set so that it appears every
time a new text document is opened, and this is the template that is employed upon
selecting File > New > Text Document. The following demonstrates one way that this
can be done:

1. Create or open a document that contains your favorite styles and formatting.

2. Delete the text of the document, as desired, so that only the styles and other settings
remain.

3. Save the document as a template by choosing File > Templates > Save. Doing so
saves the document as a template in user/Library/Preferences/NeoOffice-
2.x/user/template/ . This is the user's default template directory.

4. Select File > Templates > Organize.

5. In the left list box of templates, double-click “My Templates”. The expanded list
view will include the name of the default template that was saved. Click the name.

6. Open the context menu and choose Set as default Template. Close the dialog. This
template will now be used as the default template.
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Templates and Styles

NeoOffice templates are files that you can use as a base for creating personal, custom
documents, in the manner of a road map. Templates can contain text, logos, other graphic
objects and other constructs. Also, every template contains a set of styles that are
viewable in the Styles and Formatting window. For each document type (text, table,
drawing, presentation etc.), a single template file is defined, called a default template
(file). This template is always used as the default when, for example, you create a new
(usually empty) document with File > New.

Nearly every document type has its own template. Lists of the different templates for text
documents can be found in the NeoOffice Help about text documents, as can those that
apply to drawings, presentations and spreadsheets.

Copying Styles Between Templates and Documents
By selecting File > Templates > Organize..., the following dialog appears.

Use this dialog to copy the Styles contained in a particular template or in a particular
document individually to another document. Double-clicking the name of a folder in the
left window expands to list all the templates contained in that folder. Double-clicking one
of these files in turn causes the category Styles to appear as a sub-menu. Once again,
double-click to expand the list of the styles contained in the template document. In the
case of a document you only see the Styles that are actually used in that document.

When dragging and dropping elements from one template or document to another, the
mouse pointer shows the location to which the content may be dragged. Either the mouse
pointer is a circle with a line through it, in which case the content cannot be moved to
that place, or the mouse pointer has an insert line that marks the place where the content
will be moved to when the mouse button is released.
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Creating New Styles From Selections
Create a new style by copying an existing style, as follows:

1. Open the Styles and Formatting window.

2. In the document, select formatted text or a paragraph that has the format from which
to create the new style.

3. Click the New Styles from Selection icon on the Styles and Formatting
window toolbar.

New Style from Selection
New styles can also be created from a selection by dragging and dropping it:

1. Select the type of style to be made by clicking the corresponding icon at the top of the
Styles and Formatting window (e.g. Paragraph, Character , Frame, Page or
Numbering).

2. Select that part of the paragraph, text or object from which to form the new style.

3. Drag this to the main Styles and Formatting window area and release the mouse
button over a free area when the insertion line is no longer visible. Give the style a
name and click OK

Transferring Formats With Fill Format Mode
Applying a new Style in Fill Format Mode:

1. Open the Styles and Formatting window.

2. In the Styles and Formatting window, select the style to copy.

3. Click the Fill Format Mode icon (the paint can pouring icon).

4. Position the cursor on the object to which to apply the style selected.

5. Press the mouse button.

Note: There is an exception to this procedure: when applying a Character Style in the Fill Format Mode,
select the character with the mouse (paint can pouring) while holding down the mouse button instead of only
clicking.

To quit the fill format mode, click the icon again or press Esc.

Updating Styles From Selections

This is how to update a Style:

1. Open the Styles and Formatting window.

2. In the document, select a formatted text or paragraph with the format to adopt as a
style.

3. In the Styles and Formatting window, select the style to update (single-click, do not
double-click!)

NeoOffice User Guide for 2.x 101



Chapter 3: Managing Text Documents With Writer

4. In the Styles and Formatting window, click on the little triangle next to the New
Style from Selection Icon to get the sub-menu allowing a selection of Update Style:

Style can also be updated by using drag and drop:

1. Select the style to be updated in the Styles and Formatting window.

2. Select the section of paragraph text, whose format is to be used to update the style
selected in the Styles and Formatting window.

3. Drag the text into the main Styles and Formatting window area and release the
mouse button when the insertion line is seen above an entry.

With this procedure, the paragraph style directly above the insertion line is given the new
format.

Entering and Formatting Text Automatically
This section deals with certain automatic functions that involve entering and formatting
text.

Disabling the AutoCorrect Function

Writer has functions that are turned on by default to correct many common typing errors
as you work. However, this behavior may not always be desirable. Any automatic
correction can be reversed immediately after it is made by pressing Cmd-Z ( -Z⌘ ).

Below is a description of the places in NeoOffice where you can disable automatic
corrections (and re-enable them):

ASCII Quotation marks are replaced with Custom Quotes

1. Open a text document.

2. Choose Tools > AutoCorrect.

3. Click on the Custom Quotes tab. Uncheck Replace.

Sentences always begin with a capital letter

1. Open a text document.

2. Choose Tools > AutoCorrect.

3. Click on the Options tab. Unmark Capitalize first letter of every sentence.

A word is replaced with another word

1. Open a text document.

2. Choose Tools > AutoCorrect.
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3. Click on the Replace tab. Look for the word pair and delete it.

Three identical characters will become a whole line

When three of the following characters ( - _ = * ~ #) are entered at the start of a
new paragraph and Return is pressed, a page-wide line of various thickness results. The
line is a border of the previous paragraph. Choose Format > Paragraph > Borders to
edit or delete it.

To turn this feature off:

1. Open a text document.

2. Choose Tools > AutoCorrect.

3. Go to the Options tab. Uncheck the Apply border check box if this automatic
conversion should no longer occur.

Automatic Spellcheck

• From within a text document, click the AutoSpellcheck on/off icon on the
Standard toolbar. All words marked as incorrect by the spelling checker will then be
underlined in red.

• Click on words underlined in this way with the right mouse button, or do a Ctrl-click.
A context menu then appears.

• The context menu often provides a list of suggested words, one of which you may
click to select it. The suggested word then replaces the word underlined in red.

If the wrongly typed word is replaced using the AutoCorrect function in the context
menu, the word pair will be entered in the AutoCorrect replacement table. To call up this
table, choose Tools > AutoCorrect > Replace tab.

If the word underlined in red is correct, it can be stored in a custom dictionary using the
Add command.

To exclude words from Spellcheck
For words marked as incorrect, you can exclude them from spell checking as follows.

1. Right click (Ctrl-click) on the word to open the context menu.

2. Choose Ignore All.
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Using AutoText

Writer contains an AutoText function which helps you with shortcuts and
abbreviations to add expanded words to letters, faxes or any other NeoOffice

documents.

To insert AutoText do the following:

• Enter the shortcut for an AutoText item and press the F3 key.

There is a set of predefined AutoText blocks already in existence. For example, enter
DT and press the F3 key to insert a dummy text which can be used to check the look
of a page filled with text (and other objects). Likewise entering FN and pressing F3
will insert a NeoOfficeMath formula that is sequentially numbered at the right page
margin.

• Choose Edit > AutoText.

• The AutoText dialog contains a number of AutoTexts. As can be seen above,
AutoTexts can even contain graphics and tables.

Use the procedure above, or click on the little triangle next to the AutoText icon on the
Insert toolbar and select an AutoText category as shown below:

Use the (left) mouse button to select the AutoText for insertion. Upon releasing the
mouse button, the text is inserted in the document at the cursor position.

Note: Use the AutoComplete function in a similar manner. Directions for doing this function are found in
Help.
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Defining AutoText
Write the desired text. It may contain formatting and embedded graphics. Select the text.
Now select Edit > AutoText. In the large list box, select the category (e.g. 'default'),
assign a name for the new text component in the text box and correct the abbreviation if
necessary.

Now save the text component via AutoText > New and close the dialog.

Using AutoText in Networks
Multiple AutoText lists can be used. An example would be in a typical NeoOffice
network installation:

A read-only company-wide AutoText list might be located on the server and a user-
defined AutoText list located in a user's individual work area. Both can be read and used
while typing.

• Choose Tools > Options > NeoOffice > Paths.

• Double-click AutoText. Two paths are entered here. The first path will take the
selected AutoText list from the server installation while the second path takes the
AutoText list from the user work area. When two AutoText lists from the different
locations have the same name, NeoOffice uses the one from the user location, rather
than the network.
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Printing AutoTexts
To print a list of all AutoTexts, run the AutoText macro from the NeoOffice Basic
Gimmicks library . This macro lists all AutoText names and shortcuts in a new text
document.

1. Select Tools > Macros > Run Macro.

2. Double-click NeoOffice Macros and then double-click Gimmicks in the expanded left
hand list.

3. Select AutoText thenMain in the newly expanded list.

4. Click Run.

AutoTextWith AutoComplete

To enable AutoCompletion of selections in the AutoText dialog, check Display
remainder of name as suggestion while typing (top left of menu below).

Then while typing, enter a word in the text that exists as an AutoText name; this sequence
is recognized after the third matching letter is typed and a Help tip appears containing the
whole name of the AutoText entry. If the offering is acceptable, press Return to insert the
AutoText.

Note: Help tip sometimes contains several AutoText names that begin the same way; use Cmd-Option-Tab to
scroll forwards. In OpenOffice.org there is a keyboard combination to scroll backwards through the list to
select the text wanted, but this appears not to be the case in NeoOffice.

Exceptions in AutoCorrect
Should AutoCorrect correct a word that is entered but this correction is not what you
wanted, restore the original word by using the Undo function. This action will also add
the word to the list of exceptions in AutoCorrect proving that AutoInclude is checked in
the AutoCorrect dialog. (By default it is checked.)

NeoOffice User Guide for 2.x 106



Chapter 3: Managing Text Documents With Writer

Example

By default, AutoCorrect automatically corrects two capitals at the start of a word.
However, in the case of product names and other similar texts, two initial capitals may be
exactly what is needed.

Suppose there's a new product called “ESt”. Under normal settings, AutoCorrect
automatically changes this to “Est”; however, by pressing the Cmd-Z key sequence the
automatic replacement is reversed (Undo) and the word “ESt” is automatically added to
the list of exceptions in the AutoCorrect dialog.

Note: See also the functions for automatic numbering of headings in Help.

Text Frames

Making text look as good as it as reads is desirable. To achieve this, users can customize
the document appearance for maximum impact.

Inserting, Editing and Linking Text Frames
A text frame is a bounded area that can contain text, graphics and other objects and be
placed anywhere on a page; for example, to make columns for a newsletter.

Linking the content of a frame to another, lets the text flow backward and forward
between them.

Click the edge of any text frame to select it and eight handles appear, four of which are
located in the corners and one in the middle of each side.

Inserting Text Frames

Existing text may be put into a frame, or an empty frame opened into which text can be
added later. Follow these steps to create a frame. If using existing text, highlight the text
for the frame then proceed as shown below:

1. Long-click the Insert icon on the Tools toolbar and open its floating toolbar.

2. On the Insert floating toolbar, press the mouse button on the Insert frame manually icon to open
the column preview.

3. In the preview, drag the mouse to select the desired number of columns.

4. With the crosshair cursor, create a selection frame to define the new location and area
for the paragraph. Press the Esc key to cancel frame formation.

Any text that was highlighted is now automatically deleted from the normal, continuous
text and inserted into the text frame.
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Editing Text Frames

Select a text frame by clicking on one of its edges. Once it is selected, you can drag and
drop to change its position by grabbing an edge and thus move the whole frame. If you
do the same action using one of the handles, the size of the frame changes. So, dragging a
handle on one of the sides enlarges or compresses the text frame in one direction only,
whereas dragging a corner handle enlarges or reduces it in two dimensions.

Right clicking within a selected frame pops up the context menu. The options in this
menu allow you to make further adjustments.

As seen in the above graphic, a number of selections can be made. For example, choose
Alignment, which positions the frame relative to other frames, drawing objects, graphics
et cetera. Use theWrap submenu to choose if normal text should wrap around the frame,
wrap on one of the sides, or not wrap at all. Selecting Frame in the context menu is the
same as choosing Format > Frame from the menu bar, and opens a dialog that gives
access to managing all properties of the frame.

The contents and functions available for use in text frames are the same as in text
documents and can contain pictures, multiple columns, tables, drawings et cetera.

Linking Text Frames

Several text frames may be linked to each other over different pages of a document. The
text automatically flows from one to the next.

1. In order to create a link, click the edge of the frame to be linked. Eight handles appear
around the edges.

2. Click the Link icon on the object bar.

3. Click the frame that is to be linked.

When a linked frame is selected, any existing links are indicated by a connecting line.
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Note: The height of a frame that is linked with a subsequent frame is automatically fixed. The height is no
longer automatically adapted to the content of the frame. Only the height of the last frame of a chain can be
adapted to the text content.

Click the Link of the object bar when a frame is selected and the cursor changes. The
cursor can display as on of two icons: a chain with an arrow when two frames can be
linked by clicking, or a chain with a stop sign when linking is not possible where the
cursor is positioned. A note is displayed in the status bar in each case: for example, why
linking is possible or not possible.

Note: Linking is only possible from one frame to the next. That means that a frame that is already
linked to a frame cannot be linked to another frame which follows. Therefore, the link icon cannot
be activated if a frame already has a next link. Also, two frames can only be unlinked with the

Unlink Frames icon from the first frame.

Linking of frames cannot happen under the following conditions:

• The target is not empty. Automatically captioned frames are not considered empty
and, thus, can not be the target of a link.

• The target already has a previous link.

• Source and target are in different sections. For example, one frame is in a header and
the other frame is in a footer.

• The source already has a next link.

• Source and target are the same.

• Closed chains or chains from the inside out or from the outside in are also not
permissible. The latter is the case if a frame is inserted into another frame and these
must be linked with each other.
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Using TextAnimation

Writer's Text Animation feature enables composition of applications with colored,
animated text. This may be useful, for example, for a simple web site. The following
step-by-step procedure shows how to do it:

1. Open a new, blank NeoOffice Writer document.

2. Select Format > Page to select a background for the whole page.

3. Open the Draw Functions toolbar using the Show Draw Functions icon in the
Standard toolbar

4. Click the Rectangle icon.

5. Create a rectangle in the centre of the page.

6. Open the context menu for the rectangle object by right-clicking (Ctrl-clicking)
somewhere within it.

7. Choose Area to open the Area dialog and then select the Area tab.

8. In the Fill section list box choose either Color or Gradient if the one wanted isn't
currently selected.

9. Select a color or a gradient.

10.Close the dialog with OK.
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11.Open the context menu once more.

12.Select the Line... command to define the border properties of the rectangle and choose
a color and a width.

13.Close the dialog with OK.

14.Double-click in the middle of the rectangle and enter any text regardless of whether
the text extends beyond the width of the rectangle or not.

15.Click again on the border of the rectangle in order to select it.

16.Open the context menu and select Text.

17.In the Text dialog, click the TextAnimation tab.

18.Under TextAnimation, select Effects
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19.Select from the pull-down list the option “Scroll Through”.
20.On the Text tab page, set the distance from the left and right borders. (The border of a
frame goes half inside and half outside.)

21.Click OK.

22.The text animation will start to run immediately.

23.To alter the size of the animated text, select the rectangle again and double-click in the
center. Now select the text and apply a larger font size.

24.A suitable text color can also be chosen by opening the context menu and choosing
Character.

Note: Enlarge or reduce the page view either by choosing View > Zoom or via the context menu of the scale
field (the field which reads 100% or 150% etc) on the status bar. If the screen display is to be refreshed,
press Shift-Ctrl-R.
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Drawing Lines in Text

There are a number of ways to add lines to a page of text and any lines that are
incorporated in a document can have attributes defined, such as the angle, width, color, et
cetera, whatever you choose.

Here are some ways to add lines.

• Use the shortcuts described under Three identical characters will become a whole line
on page 103.

• Apply the preset paragraph style Horizontal Line by placing the cursor on a blank
line and double-clicking the Horizontal Line style in the Styles and Formatting
window. If the entry for horizontal lines is not visible in the list of Paragraph Styles,
switch the view in the Styles and Formatting window from “Automatic” to “All
Styles”.

• Draw a line above, beside or below a paragraph by choosing Format > Paragraph >
Borders. This function is explained in detail in the NeoOffice Help.

• To personally define the line attributes and direction, use the Line drawing object as
follows:

1. On the Standard toolbar, click the Show Draw Functions icon to open the
Draw Functions toolbar.

2. Click the Line icon. The mouse pointer changes to a cross-hair symbol with a line
beside it.

3. In a document, locate where the line should begin, click, hold down the mouse
button and drag to the point where to end the line. Holding down the Shift key,
restricts drawing to horizontal, vertical, and diagonal lines only.

4. Release the mouse button once the line has the desired direction and length.

5. To draw more lines, repeat steps 2 and 3.

6. End this function by pressing the Esc key or by clicking the Selection icon from
the Draw Functions floating toolbar.

7. Once all lines are complete, select all of the lines at the same time by clicking each
line while holding down the Shift key. By using this multiple selection method,
you can assign all of them a common color, width or any other attribute as needed.

Note: If these lines or other draw objects are exported in a text document to HTML, be aware that such
objects are not defined as part of the Internet page description language HTML and are therefore not
exported directly into HTML format but are exported as graphics.
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Editing TextWith FontWork

The FontWork program module is used for graphical text effects in a similar manner to
the WordArt® function available with Microsoft Office. If this functionality is needed,
here is the procedure to follow:

1. Open the Drawing Functions floating toolbar from the Standard toolbar.

2. Select the Text icon.

3. Draw a text frame on the page.

4. Enter the text, for example “FontWork”.

5. Choose Format > Object > FontWork. This opens the FontWork window, from
which to select the desired effects:

6. Click the upper-left icon with the semicircle to display the text as a curve.

7. Click Vertical in the Shadow options. Specify 0.10 inches for the x-axis shadow
distance. The text should now appear similar to the illustration.
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8. Since the first and last letters may not be easy to see, insert two blank spaces before
and after the text. Double-click the text, edit it, and then click outside the object.

9. Selecting the FontWork object causes eight handles appear which can be used to
change the size and shape of an object. For example, drag one of the handles in the
desired direction.

10. Finished FontWork objects can be copied to the clipboard and so pasted into other
documents for modification, sizing or other attributes.
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Aligning TextWith Lines

Aligning text on a free form line
1. Draw a free form line using the free form line function on the Draw
Functions floating toolbar.

2. Double-click on the line.

3. Enter the desired text or copy it from the clipboard.

4. Choose Format > Object > FontWork.

5. Click for example on the Rotate icon.

Aligning text with straight lines

Slanting text so that it follows an angle from one point on the text page to another point
uses a similar procedure to aligning text on a free form line. Here's how:

1. Using the draw functions, draw a straight line from one point to another.

2. In the list box on the object bar, select the line style “Invisible”.

3. Double-click on the line, which is now invisible (but the two ends may still be seen).

4. Double-click exactly between them.

5. Enter the text.

6. Click outside the line object.
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The Navigator

The Navigator is another important feature of NeoOffice which, along with the Styles
and Formatting window, helps manage formatted documents.

Activate the Navigator by clicking the corresponding item in the Edit menu, or
click on the Navigator icon on the Standard toolbar.

In particular, the Navigator helps one to navigate, or move accurately, to the parts of a
document required and provides detailed information about the content of the document
in an understandable manner.

In text documents, the Navigator provides complete lists of all heading, graphics, tables
et cetera in a document. Simple navigation, such as going straight to a specific place in a
document, only requires double-clicking the desired entry in the Header list. Besides
simple navigation, the Navigator can do much more in assisting you to manage
documents. For example, a document is structured using headings so, through the
Navigator, you can change the sequence and hierarchical levels of whole chapters and
sub-chapters quite easily by clicking the appropriate icons in the Navigator.

The Navigator can be docked to the edge of a window using the procedure described
elsewhere in this guide.

Jumping From One Object to Another in Text
Clicking the Navigation icon in the Navigator window toolbar opens the Navigation
window.

This Navigation window has functions to allow movement in a document from one object
(graphic, table, et cetera) to the next or previous one of the same type.
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For example, click the Navigation icon in the Navigator window and in the Navigation
window click the Graphics icon. The graphic object type will be selected and the
Navigation window will disappear immediately so that you can access the Previous and
Next icons in the Navigator window toolbar. Press either the Previous or Next icons to
search for the next nearest graphic in that direction.

In the Navigation window, the double-arrows at the right-hand end of the toolbar may
also be used to search.

Note: To have the Navigation window stay open, first grab its edge and drag it away from its initial position.
Any distance will do. Now it will stay on top until closed.

Another way to access the Navigation window can be found in the vertical
scroll bar at the bottom right-hand side of the document window.

When the Navigation double arrows in the vertical scroll bar appear black, a
user can move through the document page-by-page. Likewise, if the arrows
appear blue, as here, you can search to each object of the same category that
has been last selected in the Navigation window.

Jumping From One Reminder to Another
Use the Navigator to set temporary reminders that stay in effect until the document is
closed. This is handy when looking up or adding something later, as it makes it easy to
move between particular locations in the document. For example:

1. Position the cursor where the reminder is to be set .

2. Click the Set Reminder icon in the Navigator. The reminder will not be visible in the
document.
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3. When jumping to a reminder, select the Reminder entry in the Navigation window
and you can now move through the reminders by clicking the Previous and Next
arrows.

Jumping to a Specific Page
Moving quickly to particular pages in long documents is easy even if the Navigator is not
opened or docked.

Double-click the current page number on the Status bar, and the Navigator window
switches between open and closed.

Enter the number of the target page number into the spin button at the top of the
Navigator panel. After a short delay the page is automatically displayed. Press Return and
the cursor is automatically placed at the top of that page.

A keyboard shortcut, Cmd-shift-F5, places the cursor in the Navigator page spin button.
If the Navigator is inactive it is opened first.

Chapters in Navigator
In long documents, use the Navigator to obtain an overview and change the sequence of
chapters or their level in the hierarchy of chapters and sub-chapters. The only condition is
that “Heading” Paragraph Styles must be applied to the chapter headings (or choose the
Paragraph Styles which will be recognised as headings under Tools > Outline
Numbering).

Drag and drop to change the sequence of chapters. You can also do this by clicking on the
Promote Chapter and Demote chapter icons. The content of the chapters and of the
relevant subsections is of course also moved.

Tomove the chapter headings without moving their contents, drag and drop while
holding down the Cmd key. (The Drag Mode icon only affects drag and drop behaviour
between Navigator and document). When using this function, switch on Heading Levels
Shown by clicking on the relevant icon in the Navigator, to see what is happening in the
document.

Other Navigator Features

When you want to know about the objects in a document, the Navigator can be very
helpful, particularly in longer documents. For example, if there is an HTML page open,
the Navigator tells at a glance which hyperlinks the page contains, including any hidden
hyperlinks. However, hidden hyperlinks will be without reference text.
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Indexes and Tables of Contents in Writer

Writer documents can contain any number of predefined or user-defined indexes. For
example, you can have a table of contents, alphabetical index, illustration index and/or
bibliography.

Defining Index/Table of Contents Entries
The first step in preparing indexes, such as a table of contents or other index, is to
determine which entries in the document should be included.

First define entries for the index(es) as entries in the document in the following manner:

1. Select the word or words in the document which are to be listed in the index. Several
words can be selected by holding down the Shift key if they are listed one after the
other, or by holding down the Cmd key if they are spaced apart. When selecting a
single word, simply position the cursor in the word – it does not need to be
highlighted. For a Table of Contents, using Headings is easiest.

2. Enter the selected words in an index by choosing Insert > Indexes and Tables >
Entries. If a different term is to appear in the index, enter it in the Entry field. For
example, you could enter “dictionary, defining”, whereas only the word “dictionary”
appears in the text.

To define all similar words in a text as entries, select Insert > Indexes and Tables >
Entry and check Apply to all similar texts.

To include the words in a separate index with a name of your choice, click on the New
User-defined Index icon in the Insert Index Entry dialog. This opens a dialog in
which you can enter a name for the index. This name later appears as the title of the
index. The title of an index can be changed without the content of the index changing.
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Editing or Deleting Index and Table Entries
All defined index entries are shaded gray in the document for easy recognition, but this
shading is not printed. If you do not wish to display the shaded entries on-screen, switch
the highlighting on or off using View > Field Shadings.

1. To edit an entry, place the cursor immediately before or inside it.

2. Then choose Edit > Index Entry.

3. Alter the text in the Entry text box as needed.

4. Click on the Delete button to delete this entry from the list.

If the displayed text of the entry is modified, the altered text is inserted into the generated
index. Only a thin gray mark in the document remains where the entry was. To edit an
entry such as this, place the cursor directly after the thin mark and choose Edit > Index
Entry.

Use the arrow buttons in the Edit > Index Entry dialog to switch to the next or previous
entry of the same index type.

NeoOffice User Guide for 2.x 121



Chapter 3: Managing Text Documents With Writer

Creating a Table of Contents
1. Place the cursor at the location where you wish to create the table of contents.

2. Choose Insert > Indexes and Tables > Indexes and Tables.The Insert Index/Table
dialog appears. Click the Index/Table tab and select “Table of Contents” as Type
(the first time this dialog is started, this tab page and type are already selected).

3. Click on OK to create the table of contents from the headings and entries already
defined. These are defined by their Styles: eg Heading 1, Heading 2, Heading 3.

4. To insert additional paragraphs of another paragraph style into the table of contents,
check Additional Styles

5. Click the icon next to the box to open the dialog

6. Define the paragraph styles that are also to appear in the table of contents and the level

they are to be shown. Click the icon near Outline to open the Assign Styles
dialog. This dialog sets paragraph styles for each level of the index, starting at the top
level.

Select one of the existing document paragraph styles from which to generate each entry
at this level of the index.

When changing headings, rearranging their sequence or inserting new chapters,
remember to update the table of contents as follows:

• Place the cursor in the Table of Contents.
• Right click or Ctrl-click to activate the context menu

• Select Update Index/Table.

• Select Tools > Update > All Indexes and Tables to update all the indexes and tables
of contents in a document.

Note: there is an excellent step-by-step guide to working with tables of contents, called “How to Create and
Maintain a Table of Content”, from the OpenOffice.org authors. Go to
http://documentation.openoffice.org/HOW_TO/index.html and look for that title.
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Creating Alphabetical Indexes
1. Place the cursor in which to create the index.

2. Select Insert > Indexes and Tables > Indexes and Tables.

3. The Insert Index/Table dialog appears.

dialog

On the Index/Table tab, select “Alphabetical Index” in Type.
Click OK to generate the alphabetical key word index using the default settings.

There are several options that can enhance the usability of any index. For example, to
highlight letters under which entries exist as subtitles (”alphabetical delimiter” in the
Entries tab), or to allow case-sensitivity to be taken into account when sorting, and much
more.

Editing the paragraph styles in the Styles and Formatting window is the best method for
changing the formatting of the individual lines in the index, as all direct formatting is
overwritten at the next update.

Creating User-Defined Indexes
You can create as many user-defined indexes as needed.

Step 1… Create a named index entry collection:

a) Open Insert > Indexes and Tables > Entry
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Step 2… Select User-Defined from the Index list box
a) Click the New User-Defined Index icon in the dialog

i. Name the new index.

ii. Click OK.

b) Add entries for this new index. At least one entry must be inserted into the
new index before closing the Index Entry dialog, or the index won't be
created:

i. In the document, find a candidate location or text for the new index.

ii. Position the text cursor at that position, or select a word or phrase that
will go into the index.

iii. In the Index Entry floating window click the button Insert.
iv. Repeat this process from step 2.b.i. or continue with step 2.c.

c) In the Index Entry floating dialog click the button Close.
Step 3… Finally, create the index in the document:

Position the cursor on the place where the user-defined index is to be created.

a) Choose Insert > Indexes and Tables > Indexes and Tables.... to open the
dialog Insert Index/Table.

b) In the Type list box, select the entry matching the name that was given to the
index collection in step 2.b.i. Give the index a title by editing the Title box.

c) Check the Styles box

d) Click the icon to open the Assign Styles dialog. This dialog sets
paragraph styles for each level of the index, starting at the top level.
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Step 4… Select one of the existing document paragraph styles from which to
generate each entry at this level of the index.

i. Click the >> button to record that style and move to the next index level.

ii. For each index level, repeat this process from step 2.f.i, or continue with
step 2.g.

b) Click OK.

c) Mark the other check boxes under Create from to create the index from all
the objects of a certain type.

d) Assign names to the objects in the Options tab of the corresponding property
dialog.

e) Click OK to generate the index from marked entries.

Making Index Entries
Much of the information about concordance files is relevant to alphabetical index entries
generally. Consider the entry menu below. If you have a word “automatic” in the text
and you want it to feature in the alphabetical index, in the form, “cash, automatic”, then
you proceed as follows:

1. First select the word in the text. Then select Insert > Indexes and Tables > Entry...
to bring up the menu below.

2. The word “automatic” should be in the Entry line. If not, type it in there.

3. Put “cash” in the 1st key box. This is the term that it will appear under in the index.

4. In this case don't check main entry, because you want “cash” to be the main entry.

5. Check “apply to all similar texts” if you want to pick up “automatic” every time it
appears.
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6. Youwill probably want to select “whole words”, rather than have parts of words
selected. That way, “automatically” won't be selected.

7. You probably don't want to match the case here, because you do want “Automatic
Cash” and “Automatic cash” to be picked up as well.

8. Click Insert to enact.

To edit entries, place your cursor next to the entry in the text. Select Edit > Index Entry.
Youmay delete an entry (not delete the word in the text, just delete its appearance in the
index), change the first and/or second keys (see below for an explanation of keys) or make
it a Main Entry via this menu.

Using a Concordance File
A concordance file is a variation of an index in that it provides exact references to words
in the document and permits cross-referencing and sub-indexing. Thus a concordance file
contains a number of key words and information as to how these words are to be seen in
an index.

One way to create an alphabetical index is to use a concordance file. Youwill need to
know what terms are wanted in the index, and how these should be displayed. NeoOffice
allows an index to have up to three levels: parent, sub-parent, indexed item.
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Preparation

Place the cursor in the document where the index is to be inserted then select Insert >
Indexes and Tables > Indexes and Tables. On the Index/Table tab, enter into the Title
box the name that will be displayed at the beginning of the index. In the Type box,
choose Alphabetical Index. Under Options check Concordance file and after clicking
on File, choose New. A Save As dialog box pops up and a name must be assigned to the
index and saved. The extension automatically given to the concordance file is .sdi. The
other fields and tabs in the Insert Index/Table screen are used to design the layout of the
index.

Entering Data

The 'Edit Concordance File' screen is now displayed with seven columns: Search term,
Alternative entry, 1st key, 2nd key, Comment, Match case, and Word only.

● 'Search term' is the actual term to be searched for in the document. The search
term can be more than one word.

● 'Alternative entry' is the term that will be shown in the index. If the Search
and Alternative terms are the same, Alternative can be left blank.

● '1st key' is the parent term that the current term should be listed under in a
multi-level index and is left blank if the term is to stand on its own.

● '2nd key' is the sub-parent term that the current term should be listed under in a
multi-level index and is left blank if the term is to stand on its own or if it only
has one parent.

● The information in the Comment field does not get printed in the index and
can be used for any additional information.

● 'Match case' means that uppercase and lowercase letters are considered when
searching for a term and is 'No' by default.
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● 'Word only' means terms will only be picked up if the full search term word(s)
are found in the correct order. For example, if the search term is 'in present'
every instance of the word 'in' followed by the word 'present' will be indexed
but 'in presentation' or 'in a present' will not be indexed. 'Word only' is 'No' by
default.

After entering the terms press 'OK' to save the concordance file.

To review or change entries, right click or Ctrl-click anywhere in the the document and
choose Edit > Indexes and Tables to bring up the Indexes and Tables dialog. Then
choose 'Edit' under the 'File' button.

A concordance file can also be created or modified manually. (An example is shown
below). Follow the above steps to create a concordance file, though it is only necessary
to enter one line of data. Save the file to create the .sdi file. This file can now be opened
in Writer, and additional entries can be made, or existing entries can be modified. When
saving the modified document, you may see a warning message about formatting; answer
'Yes' to save in the Text file format. This will keep the .sdi extension.
The text document displays each entry of the concordance file as a separate line and the
items are separated by semi-colons. The fields are: Search term;Alternative entry;1stKey
or Parent 1;2nd Key or Parent 2;Match Case;Wordonly

If there is no information for a specific field, that spot should be left empty.

Commented lines begin with # and are ignored by the indexing system.

'Match case' and 'Word only' are interpreted as 'No' or 'False' if they are empty
or contain a zero. All other contents are interpreted as 'Yes' or True.
If the search term and alternative entry are the same, leave the alternative entry blank. If
the user wants to make sure the term is displayed a particular way, enter it in the
Alternative entry field exactly as it should be displayed. For example, searching for the
word 'e-mail' in the document, it should be indexed regardless of whether it is upper or
lower case; however, display of the index entry must be upper case. Thus, the
concordance file entry should be e-mail;E-mail;;;0;1 OR E-mail,E-mail;;;0;1.
Without the alternative entry, the index will display the first instance of 'e-mail' found in
the document so it may or may not be capitalized.

If the search term has no parent, leave Parent 1 and Parent 2 blank. Parent 1 is the
highest parent, Parent 2 is a sub-parent of Parent 1.

Example file

In a document on animals the index could have a listing for cat breeds. Parent 1 would
be 'cats', Parent 2 would be 'longhaired', 'shorthaired' or 'semi longhaired'
Examples of entries (the commented lines are given for explanation and are not required)
:

#American Shorthair is the search term and the #alternative entry so only
needs to be listed #once
#Cats is the highest level parent with #shorthaired as a sub-parent.
#Match case is 0 which means false, so all upper #and lower case instances
will be selected
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#Word only is 1 which means true, so only #instances of the full words will be
selected.
#It would not #include American shorthaired.
American Shorthair;;cats;shorthaired;0;1
Himalayan;;cats;longhaired;0;1
Maine Coon;;cats;semi longhaired;0;1
Norwegian Forest;;cats;semi longhaired;0;1
Persian;;cats;longhaired;0;1
Abyssinian;;cats;shorthaired;0;1
Bengal;;cats;shorthaired;0;1
#feed cats and cat treats are both search terms #that will be included in the
following index #entry:
#cats
# care
# feeding
feed cats;feeding;cats;care;0;1
cat treats;feeding;cats;care;0;1

Once entries are made in the concordance file, it may be necessary to make sure only the
desired text is indexed. You can either look at the index results or use 'Find and
Replace' in the document and enter each search term to see what text will be indexed. If
something is being indexed that is not wanted, you will need to modify the search term to
eliminate the unwanted text.

For example, a document on nature could include information about trees and animals.
An index entry for bark would pick up tree bark and text about animals barking. To
ensure that only the tree bark text is indexed, a user might have to change the entry from:

bark;;tree;;0;1
to:

tree bark;bark;tree;;0;1
and:

bark of the tree;bark;tree;;0;1
The order of entries in a concordance file does not affect the display order,which is
alphabetical. However, keeping like items together makes it easier to track down any
errors or to find an entry that needs to be changed.

Turning on View > Field Shadings allows users to see which terms are indexed and
might help determine what index items have been forgotten.

Creating Bibliographies
Bibliography entries are often in the form of: “Smith [Smith 1995] has also carried out
research on this matter” or similar, so that the reader knows that more detailed information
can be found in the bibliography under “Smith 1995” with the full name of the author, title
of the book, publisher, date of publication and a myriad of other possible terms.

Decide what details should appear in the bibliography and then use Insert > Indexes and
Tables > Indexes and Tableswith a Type of Bibliography to define how the entries will
look when displayed.
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Select Tools > Bibliography Database to open the bibliography database. Examine the
columns and find one labelled Type then use different entries for magazine articles than
for entries concerning books. For this reason, the bibliography database is divided into
different types of sources of literature. A new record can be inserted in the Insert
Bibliography Entry (by clicking the New button), but these “ad hoc” records will be
saved only in the current document, not in the Bibliography Database, and then only if
the relevant new entry is actually inserted.

Note: When saving a document with bibliography entries, all information belonging to the entries will
automatically be saved in a hidden field. In this way, all data will be included when the document is
distributed, for example, on a disk. It does not matter whether the bibliography was created in the document
or not.

1. To insert the bibliography entries into the text, position the cursor in the text where the
entry is to appear and then choose Insert > Indexes and Tables > Bibliography
Entry. The following dialog will appear:

2. First decide whether to select the entry from the records contained in the bibliography
database, or from the entries that are contained in the current document (and which
can differ from entries of the same name in the bibliography database). An entry in the
document content can be identical to an entry in the Bibliography Database. The entry
in the document has precedence.

3. If the required entry already exists as a data record, select it in the list box Short
name and click Insert. If the desired entry does not yet exist, create a new entry. If the
New button is used to do this, you can define a new record, but this will only be
recognized in the current document.

If the record should be included in the bibliography database, choose Tools >
Bibliography Database, enter the new record and then insert the bibliography
database entry in the document.
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Updating, Editing and Deleting Indexes and Tables of Contents
Indices and Table of Contents are snapshots of what is present at the time they are
created. Obviously there are occasions when these need updating, editing or deleting. The
following instructions give the steps needed to accomplish any of the above tasks.

1. Place the cursor in the index/table and right click or Ctrl-click to open the context
menu.

2. Select the desired command:

a) Update Index/Table

b) Delete Index/Table

c) Edit Index/Table

d) Edit Paragraph Style

Note: (d) Edit Index/Table is only available if Insert > Indexes and Tables > Indexes and Tables >
Index/Table > Protected from manual changes is selected. This is because, by default, indices and tables of
contents are protected from changes.

Editing the Format of an Index/Table of Contents
The Entries tab on the Insert > Indexes and Tables > Indexes and Tables dialog
permits editing the format of an index. In this tab, alter the way in which entries, tab
stops and page numbers are arranged et cetera. Using the Styles tab, assign other
Paragraph Styles. For detailed instructions, refer to the NeoOffice Help.

Hyperlinks can be automatically assigned to the entries in the table of contents using the
following method:

1. Go to the Entries tab page,

2. Place the cursor in the structure row before the entry <E#>
3. Click the Hyperlink button, then place the cursor after <E> and click Hyperlink
again.

Where the list is a table of contents for the document, click a hyperlink to go straight to
the first occurrence; however, for this to work, the table of contents must be generated
from headings.

Indexes Covering Multiple Documents
There are several ways of creating an index covering multiple documents:
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• Create an index in each individual document, then copy the indexes into a document
and post-edit them.

• Amore elegant solution is to select each individual index as a section (Insert >
Section) and insert these sections in a common index document as a link.

• If you are working with a master document, common indexes are possible across all
sub-documents.

More information about master documents can be found later in this manual.

Headings and Numbering

Most text documents benefit from use of headings and numbering. Writer provides
automatic functions that help you manage the structure and formatting of documents via
headings and numbering.

Numbering and Numbering Styles
Numbering in a document may be applied either as direct formatting or by using a Style,
in the same manner as is done with other paragraph attributes such as “Justified” or
“Line Spacing”. The icons on the Bullets and Numbering toolbar and the options in
the Format > Bullets and Numbering dialog apply direct formatting. Direct formatting
is also applied when automatic numbering is used via the AutoFormat/AutoCorrect
function.

Note:The AutoNumbering of AutoCorrect is not applied to the Styles listed in the Styles and Formatting
window under “Special Styles”.

ANumbering Style can be applied as part of certain Paragraph Styles or applied directly
to the paragraphs. With the former case, you can take advantage of the paragraph
formatting system for numbering as well. Changing a Numbering Style ensures that all
numbering created with this Style will be automatically reformatted. Numbering Styles
are described in the NeoOffice Help.

Turning Bullets On and Off
Bullets may be turned on and off in a document. The following is one method to turn a
bulleted list on and off:

1. Place the cursor in a paragraph to be marked with a bullet symbol, or select a number
of paragraphs.

2. Click on the Bullets on/off icon on the Bullets and Numbering toolbar or on
the Formatting toolbar. The paragraph or paragraphs will be formatted as a bulleted
list.

3. In an existing bulleted list, if you click the Bullets on/off icon, the paragraphs will
turn back into normal text.

4. The Bullets and Numbering toolbar contains icons for moving and rearranging
numbered paragraphs, e.g. up or down one level, and with or without subpoints.
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You can select further settings for the bulleted list in which the cursor is positioned with
the Format > Bullets and Numbering dialog.

• Choose different bullet symbols under Format > Bullets and Numbering > Options.
Select “Bullet” in the Numbering pull-down list. Click on the button with three dots.
This opens the Special Characters dialog.

Turning Numbering On and Off
Turning numbering on and off can be accomplished as follows:

1. Highlight the paragraphs to be numbered or returned to normal text.

2. Click on the Numbering on/off icon on the Formatting toolbar or the Bullets
and Numbering toolbar . The paragraphs are formatted as a numbered list or, with an
existing numbered list, the paragraphs will turn back into normal text.

Numbered lists are best controlled in the same manner as bulleted lists, i.e. with the icons
on the Bullets and Numbering toolbar. When a numbered list is moved down a level,
the subordinate numbered list at this level starts from one again. Using the Show
sublevels box in Format > Bullets and Numbering > Options, select which previous
levels should be included in the numbered list.

Example numbered list with sublevels:

1 Line one
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2 and line two. If you enter a return the next the new paragraph will automatically be
numbered 3. Pressing a Tab at this point increments the list sublevel, indents and
changes the number to 1 at which point you can add text.

1. and now there is a sub level of line 2. To decrement the sublevel of a list
paragraph, put the cursor at the beginning of the paragraph text and press Shift-
Tab.

The above list is not numbered as fully as it might be, but serves as an example.
Normally the full number of the last line should indicate the sublevel as 2.1 as well. To
do this, apply Format > Bullets and Numbering > Outline to that level. This will be
reflected in Format > Bullets and Numbering > Options.

Outline Numbering
Choose Tools > Outline Numbering to number headings automatically. By default, the
Paragraph Style “Heading 1” is assigned to the highest level of Outline Numbering.
For custom paragraph styles that should be used, apply these styles in this dialog on each
individual level.

Note: If a Numbering Style is selected from the Number pull-down list, then all paragraphs in a document
that have the “Heading 1” format will have consecutive numbers placed in front of them.

With respect to custom styles where there is, currently, a Paragraph Style “Head1” that is
used for headings at level 1.

1. In the Level list box select 1

2. In the Paragraph Style pull-down list select Head1.
3. Click OK.
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Now, all paragraphs to which Head1 is applied will be listed in the Navigator under
“Headings”.
Remember that chapters can be rearranged in the Navigator (see the section on the
Navigator) when changing their order or their placing in the hierarchy. Using this feature
also updates the numbering.

Click on one of the icons Promote Chapter, Demote Chapter, Promote Level and
Demote Level (the four icons shown darker above), or

Move the chapter heading in the Navigator using the mouse.

The result is that numbering of all affected chapters is adjusted automatically.

Automatic Bullets and Numbering
Writer also automatically recognizes bullets and numbering during entry if Format >
AutoFormat > While Typingwas previously chosen. Numbering that uses Roman
numerals is also recognized and continued.

Note: A list can start with any value: i.e., it does not have to begin with I.

A step-by-step example with Roman numerals:
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1. Enter I. (with a period after it), also followed by a space and text. A right parenthesis
may also be used as a substitute for a period.

2. Press the Return key to create a new paragraph.

3. The new paragraph will begin with II., i.e., the Roman numeral for two.

4. Enter some text, press the Return key and the next paragraph will begin with III.

5. Repeat as needed.

Roman numbering can begin with any numeral desired: for example, with ci
(corresponds to 101), which will be followed by cii (102) et cetera.

Numbering Illustrations by Chapters
Numbering illustrations by chapter, so that illustrations are labelled “Illustration 1.1”,
“Illustration 1.2”, and so on in the first chapter and “Illustration 2.1”, “Illustration 2.2”,
et cetera. in the second, is easily done. Use the following procedure to do this:

1. Organize a document in chapters.

Choose Tools > Outline Numbering to number the chapter headings that are formatted.
For example, where there is the Paragraph Style “Heading 1”, select the ”Heading 1”
Style from the Paragraph Style list box and the option “1, 2, 3,..” from the Number
list box below it.

2. Select the first illustration for numbering.

3. Choose Insert > Caption....

4. In the dialog that appears, select Illustration as the category and Arabic (1 2 3) as the
numbering. Caption text can also be entered in this dialog.

5. Click Options.

6. Specify the chapter numbering in the Number Range Options dialog. For example,
select option “1” under Level and specify the separator wanted for chapter numbering.

7. Click OK.

8. In the Caption dialog, click OK. The illustrations are now numbered by chapters.

9. Repeat 1-7 for all other illustrations in the document.
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Numbering now occurs automatically: all illustrations within one chapter level are
numbered appropriately, and the chapter level numbering desired can be changed in the
Number Range Options dialog.

Note: Choose Tools > Options > NeoOffice Writer > AutoCaption, or Preferences > NeoOffice Writer >
AutoCaption, where you can check several boxes to set up the appropriate options. Here you can, for
example, determine that all illustrations in text documents from now on receive captions automatically.

Defining Number Ranges
Define separate number ranges, or sequences to number each group of elements in a
document that belong together: for example, notes, warning messages, quotations, et
cetera. The following procedure shows how to do this:

1. For example, type “Note Number” in front of the first note.
2. Choose Insert > Fields > Other....

3. On the Variables tab page, select the “Number Range” field.
4. For the Name, enter “Note.”
5. Click Insert

6. Close the dialog.

This “Note” number range enables you to automatically number all the notes in a
document. In the field Value, select a new initial value for the entire number range. This
is useful when dealing with a document in a series of connected documents.

Number ranges and captions can be restarted with each chapter. In the Caption and
Fields dialogs you can choose the chapter level at which to begin renumbering.

Using Master Documents and Subdocuments

Amaster document and subdocuments will usually be a book and its chapters. The book
is the master document and the subdocuments are chapters. A new empty master
document is created by choosing File > New > Master Document, or creating a master
document from an existing document by choosing File > Send > Create Master
Document.

Note: Existing master documents have the extension .odm, thus distinguishing a master document from
“normal” Writer documents (.odt) in the Open File dialog.

Open a master document by choosing File > New > Master Document and the new
master document is opened as an empty text document. Providing that the Navigator is
not docked and collapsed, the Navigator opens immediately in global mode.

The Navigator provides the functions needed for navigating and editing a master
document.
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Double-click a document in the Navigator to load it for editing. Now you can either

enter text, such as headings, or insert subdocuments, by clicking the Insert icon
and choosing the desired entry Text or File. A new document can also be inserted by a
long click on the icon to get the context list and selecting New document whereupon you
first enter the name and path for the document, and then continue on to write the new
document and save it.

Paragraph Styles that you define and use in the subdocuments are automatically adopted
in the master document. If the master document is saved afterwards, these Styles will be
available everywhere in the master document. The Styles defined in the master document
have priority over Styles with the same name in subdocuments.

Note: When using master documents, use the same template as a base for all subdocuments and the master
document itself. When a new Style is needed in the document, simply add it to the document template and
reload the master document so that the new Style can be applied to all documents automatically.

Use Page Styles to ensure that all subdocuments (e.g. all chapters in a book) always start
on a new page (i.e. always on a new right-hand page). There is a built-in Page Style
called “Right page” that could, for example, be linked to the Paragraph Style “Header
1”. For example, by assigning a page break to the Paragraph Style “Header 1”, every
“Header 1” will always be at the top of a right page. If the Next Style is assigned to the
Page Style “Right page” select “Left page” instead and vice versa.
If the cursor is positioned in a text in the master document, the entry Text is shaded gray
because consecutive texts are always combined to one single text. New text can be
inserted between individual inserted documents. The new documents or texts are always
inserted above the current entry. However, you can easily change their order with
Drag&Drop or with the iconsMove down andMove up.

NeoOffice User Guide for 2.x 138



Chapter 3: Managing Text Documents With Writer

Documents are inserted in the master document as protected areas. That means these
documents cannot normally be edited within the master document but it is possible to
navigate through the document with the cursor and read them.

All indexes are created directly in the master document and, automatically, include all
subdocuments.

When one or more subdocuments (e.g. chapters in a book) are changed after
creating an index, the indexes in the master document should also be updated.
To do this, click the icon Update (as shown to the left) on the Navigator for
master documents and select the entries to be updated from the submenu.
Likewise, references work in a Master Document and its subdocuments, in the
same manner as in subdocuments themselves when these are defined in the
documents involved. For example, if figures in a subdocument are numbered
from “Figure 1” to “Figure 10”, figures in the next subdocument can
numbered starting at “Figure 11”.

AMaster document, together with all its parts, can be saved as a combined NeoOffice
Writer document. To do so, do the following:

1. In the Navigator, click the Toggle icon.

2. In the Navigator list, double-click "Sections".

3. Right-click a section name and choose Edit.

4. Select all of the sections in the Section list, and then click Remove.

5. Click OK.

6. Choose the command File > Export. and select the normal NeoOffice Writer text
format in the list box File type.

Printing a master document with all subdocuments, texts, and indexes is the same as
printing any other NeoOffice document. Simply use the print direct icon on the Standard
toolbar or via File > Print dialog.

To check if a link exists for a single subdocument or all subdocuments, position the
mouse pointer in the Navigator on the corresponding entry. The path information for the
original document appears in a small popup window. Should the file no longer be found
at the original path, a warning File not found is shown, along with the original path, and
the entry is displayed in red in the Navigator.

Warning: In OpenOffice.org [and also in NeoOffice], Graphics inserted in a
sub-document and anchored "to page" will not be displayed in the master
document even though the graphic always appears correctly in the
subdocument. According to the closing entry on issue 50669, this is expected
behaviour. To quote:

NeoOffice User Guide for 2.x 139



Chapter 3: Managing Text Documents With Writer

“It's a limitation of the OpenOffice.org master document concept. It is not
possible to use reference to a certain "page" defined in a subdocument
because the master document reorganizes the page flow, page number and
references to collate all documents together. This way, the absolute reference
to a page X in a sub doc is lost in the master doc. The graphic loses its anchor
reference and simply disappears.”

WORKAROUND To avoid this problem do the following:

a) Set the anchor to "ToCharacter" or "To Paragraph" and

b) Choose suitable horizontal and vertical references to the page in
the properties dialog, under "Type > Position".
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Importing Lists From Other Text Programs

Each word processor internally organizes bulleted and numbered lists in a unique manner,
such as using special fonts or graphics that may not be available in NeoOffice. So, should
NeoOffice import foreign text and present this information incorrectly, use the following
steps to overcome these import problems:

1. Import the document from the other application (File > Open and then the Files of
type list box). Where bullets are not applied correctly, use the other application to try
saving the document in another export format, such as in RTF format, and then import
this new document.

2. Use the Find & Replace dialog.

a) Select the string of characters which now appears at the start of each list and
copy to the clipboard. This could be, for example, an asterisk (*) followed by
a tab.

b) Start Find & Replace.

c) Insert the contents of the clipboard in the Search for field (Cmd-V).

Note: To ensure that the search text is only found at the start of the paragraph, insert a caret (^) before
the search text and check the Regular expressions box.

d) Click on Find All to select all imported lists, but do not close the Find &
Replace dialog at this time.

e) Click on the Bullets on/off icon on the Bullets and Numbering toolbar to
convert all the imported lists to NeoOffice lists.

f) Back in the Find & Replace dialog, click on Replace All. Since the Replace
with field is empty, all selected strings will be deleted. For example, the
asterisk * and tab, used above, will disappear.

g) In the Bullets and Numbering dialog, define the type of bullets for bulleted
lists.

Changing Numbering via the Keyboard
• Tomove the numbering down a level in the hierarchy (or further to the right), place
the cursor at the beginning of the numbered paragraph and press the Tab key.

• Press Shift and Tab together to move an indented bulleted or numbered list up one
level (to the left).

• May not work in NeoOffice: To insert a tab stop at the beginning of a numbered line,
press (Ctrl-Tab).
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Interrupting and Continuing Numbering

Sometimes, with a series of automatically numbered paragraphs, there is one paragraph
that must not have a number as the following example demonstrates:

1. First paragraph.

2. Paragraph two.

An unnumbered paragraph.

3. Paragraph number three.

To do this, choose from the following methods:

Delete the automatic numbering
1. Select all paragraphs 1 to 4 and click on the Numbering on/off icon.

2. Place the cursor before the first character of the third paragraph.

3. Press the Delete key to delete one character to the left.

Note: The paragraph remains indented but loses its number. The fourth paragraph now
has the number 3. This method also produces the desired result after saving in HTML
format.

Formatting the paragraph
1. Select all paragraphs 1 to 4 and click on the Numbering on/off icon.

2. Place the cursor in the third paragraph.

3. Click again on the Numbering on/off icon.

This is how the unnumbered paragraph was produced in the example above. However,
with HTML format, the interruption creates two separately numbered lists.

Continuing numbering with a new starting value
1. Number paragraphs 1 and 2 with the Numbering on/off icon.

2. Place the cursor in the fourth paragraph.

3. Choose Format > Bullets and Numbering and go to the Options tab.

4. In the Numbering pull-down list select “1, 2, 3 ...”.
5. In the Start at spin box select the starting value – in this case 3.
6. Click OK.
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Numbering Lines

When lines are to be numbered within a document, select the line numbering properties
that are wanted via the Tools > Line Numbering. You can decide, for the whole of the
document, whether blank lines should be counted as well, and whether lines in text
frames should likewise be counted. Decide the intervals at which lines are numbered and
insert separators between these intervals to identify a particular line number. The line
numbering appears on the screen and is printed.

Other line numbering properties can be applied to the paragraph (Format > Paragraph >
Numbering) or to the Paragraph Style. Doing it this way ensures greater flexibility, as
you can exclude a paragraph from the line numbering or restart the numbering at a
paragraph with any value.

Line Numbering for All Paragraphs
1. Select Tools > Line Numbering.

2. Check the Show numbering check box.

This numbers all the paragraphs in the document.

Line Numbering for Particular Paragraphs
1. Enable the line numbering for all paragraphs as described above.

2. Open the Styles and Formatting window and click the Default paragraph style.

3. Right-click or Ctrl-click to open the context menu.

4. ClickModify to open the Paragraph Style: Default dialog.

5. Select the Numbering tab.
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6. Uncheck Include this paragraph in line numbering. As all paragraph styles are
derived from the Default style, no paragraph will be numbered unless a subordinate
paragraph style exists and was modified accordingly.

7. Now, in the document, highlight all the paragraphs that are to be numbered.

8. Select Format > Paragraph > Numbering, check the Include this paragraph in
line numbering check box.

9. Click OK when done.

Tables in Text

Tables and spreadsheets can be included in text documents.

Inserting Tables
There are a number of ways to insert tables in text documents:

Inserting an empty table using the mouse:

1. Place the cursor at the position in the text where you wish to insert the table.

2. Point with the mouse to the Insert table icon on the Insert floating toolbar.

3. Press the mouse button and move the mouse down and to the right until the required
numbers of rows and columns appear in the preview area under the icon.

4. Release the mouse button. (To abort the process, before releasing the button move the
mouse up or to the left until the word Cancel appears in the preview area.)

Inserting an empty table via the Insert menu or floating toolbar:

1. Place the cursor at the position in the text where to insert the table.

2. Select Insert > Table from the Function toolbar or click briefly on the Insert Table
icon on the Insert floating toolbar. Either opens the Insert Table dialog.

Inserting a single row table by typing ++... or ||...

Type a sequence of two or more '+' or '|' characters at the start of a new paragraph and
end it by pressing the Return key. The paragraph is automatically converted to a table
with a single row and the number of columns equal to one less than the number of '+' or
'|' characters.

Separate the '+' or '|' characters by one or more of any of (-, <tab>, <space>, =, _) in
order to determine the initial column widths.

This feature can be turned off/on via the Tools > AutoCorrect > Options dialog, by
toggling the Create Table check box.

Inserting from NeoOffice Calc with the clipboard

1. Open the text document and the Calc document from which you wish to insert a range
of cells.
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2. Select a range of cells from the spreadsheet. Copy it to the clipboard, for example with
Cmd-C.

3. Switch to the text document. There are now various options for inserting the range of
cells:

• Use the “normal” command Edit > Paste or Cmd-V to insert the range of cells as
an OLE object. Double-click on the OLE object in order to edit it with Calc tools
and commands. Click outside the object to quit edit mode.

Choose Edit > Paste Special to open the Paste Special dialog which has several
options from which to choose. The same options can also be found on the submenu
of the Paste icon on the Standard toolbar:

Options Is inserted as...
“Calc” OLE object — as with Cmd-V or drag-and-drop
GDI metaFile Graphic
Bitmap Graphic
HTML (HyperText
Markup Language)

A HTML table.

Formatted text [RTF] A standard NeoOffice Writer table object
Unformatted text Plain text with Tab delimiters

Inserting from NeoOffice Calc using drag-and-drop

Open the text document and the Calc document from which to insert a range of cells.

1. Highlight the range of cells from the spreadsheet that should be in the document.

2. Click in this selected range of cells and hold down the mouse button. Wait a moment
until the cursor changes to a hand.

3. Without releasing the mouse button, drag the selected range of cells into the text
document. Should the text document not be visible, first move the mouse pointer to
the text document icon on the task bar and wait a moment until the text document
opens. In the text document, a gray insertion cursor follows the mouse pointer to the
location of where the table is to be placed.

4. Release the mouse button when the gray insertion cursor is at the location where the
table is to be inserted.

Deleting Tables
When deleting a whole table from a text document, you have the following options:

1. By paragraph:

a) Select from the end of the paragraph before the table to the start of the paragraph
after the table.

b) Press (Delete).

2. By table:

a) place the cursor in the table.
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b) select all cells, for example by pressing Cmd-A

c) open the context menu, by Ctrl-click or right-clicking on the area selected

d) select Row > Delete.

Note: Method 2 (by table) also works at the beginning or end of a document.

Inserting Paragraphs Before Tables at Start of Page
Occasionally you may insert a table at the very beginning of a text document or
immediately after a fixed page break, and then decide you must insert text before this
table. This is not difficult - but working out how to do it can be puzzling. Here's how:

1. Place the cursor in the first cell of the table, right at the start of any content in that cell.

2. Press Return, which adds a paragraph before the table and moves the cursor to it.

Formatting Tables in Text Documents
A new table inserted into a text document can have the default format which means that
the first row has the Paragraph Style “Table Heading”, and all other rows will have the
“Table Contents” Style. Text entered in the first row will automatically be bolded and
centered. This section describes various formatting options that can be used to determine
the overall appearance of a table.

Resize columns, rows, and cells

Table columns and rows can easily be resized just by moving their borders. You can also
easily merge ranges of cells into a single cell, or split individual cells horizontally or
vertically. For this there are icons on the Table toolbar, calledMerge Cells and Split
Cells, which can be used, or use the corresponding entries in the Tablemenu. This gives
great flexibility in formatting any table.

Illustration: where the Merge Cells and Split Cells icons are located.

Table AutoFormat
To quickly set up existing tables, a number of predefined table styles are available via the
Table > AutoFormat dialog.

Auto formatting cannot be applied, however, if the table has already had its cell structure
modified (cells merged or split, even if cells were merged and then restored to their
original split state, et cetera).

Table properties in general

With the cursor in the table, open the Table Format dialog either with the menu
command Table > Properties or the Table command in the context menu.
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To change the table background, for example, proceed as follows:

1. Select the cells to which you wish to assign a background color.

2. Now, either choose Table > Properties or click Table in the context menu of the
selected cells.

3. In the Table Format dialog, click the Background tab.

Notice the two list boxes at the top of the dialog. In the left box, choose a color or
graphics as the background. In the right box, define whether to apply the background
to the selected cells, the whole row, or the entire table. Cell formatting takes priority
over row formatting.

4. Click OK upon making a choice.

5. Tables can be designed with even greater impact using thematically appropriate
backgrounds. While background colors and graphics are always inserted behind text
and values in a table, graphics and other objects can also be inserted into the table.

a. Set the cursor in the cell where the object is to appear.

b. To insert graphics, choose Insert > Picture > From File...

Sea Life Domestic Pets Insects

c. In the Insert Picture dialog, select the desired graphics file.

d. Click Open.

e. Click on the inserted graphic object and select the Picture command from the
context menu (or double-click on the graphic object). In the Picture dialog,
various settings can be defined for the graphic and its function in the document.
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For example, define how text is to wrap around, which will determine if the text
should flow around, through or beside the graphic object. You can also set a
hyperlink which can be loaded whenever the graphic object in the text document
is clicked. Furthermore, you may link a graphic object to a macro, and in so
doing assign various events to it. Youcould, for example, use this capability to
program certain functions, such as having a sound played when the mouse pointer
touches the graphic object.

Calculating in TextDocuments

Formulae in Text Documents
Pressing F2 opens the Formula toolbar under the Formatting toolbar.. Clicking the

Formula icon in the Formula bar opens a submenu from which you can insert a
formula.
The formula appears in the input line at the current cursor position. To specify a range of
cells in a table, select the desired cells with the mouse. The corresponding cell references
also appear in the input line. Enter additional parameters, as necessary, and click Apply
to confirm the entry. A formula can also be entered directly, if the appropriate syntax is
known. This is necessary, for example, in the Insert Fields and Edit Fields dialogs.

Note: The SUM function is only valid in formulae within a table cell.

Formula Options

Basic Calculation Functions

Addition + Calculates the total.
Example: <A1> + 8

Subtraction - Calculates the difference
Example: 10 - <B5>

Multiplicatio
n

MUL or * Calculates the product.
Example: 7 MUL 9

Division DIV or / Calculates the quotient
Example: 100 DIV 15

Basic Functions in the Submenu

Sum SUM Calculates the sum of the selected cells.

Example: SUM <A2:C2> displays the sum of the values
in cells A2 to C2

Round ROUND Rounds a number to the specified decimal places.

Example: 15.678 ROUND 2 displays 15.68
Percent PHD Calculates a percentage

Example: 10 + 15 PHD displays 10.15
Square Root SQRT Calculates the square root.

Example: SQRT 25 displays 5.00
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Power POW Calculates the power of a number.

Example: 2 POW 8 displays 256.00
Operators

Various operators may be inserted in a formula. Choose from the following functions:

List
Separator

| Separates the elements in a list.
Example of using a list:
MIN 10|20|50|<C6>|<A2:B6>|20

Equal EQ or
==

Checks if selected values are equal. If they are unequal, the
result is zero, otherwise 1 (true) appears.
Example: <A1> EQ 2 displays 1, if the content of A1
equals 2.

Not Equal NEQ
or !=

Tests for inequality between selected values.

Example: <A1> NEQ 2 displays 0 (wrong), if the content
of A1 equals 2.

Less than or
Equal

LEQ Tests for values less than or equal to a specified value.

Example: <A1> LEQ 2 displays 1 (true), if the content of
A1 is less than or equal to 2.

Greater than
or Equal

GEQ Tests for values greater than or equal to a specified value

Example: <A1> GEQ 2 displays 1 (true), if the content of
A1 is greater than or equal to 2.

Less L Tests for values less than a specified value

Example: <A1> L 2 displays 1 (true), if the content of A1
is less than 2.

Greater G Tests for values greater than a specified value

Example: <A1> G 2 displays 1 (true), if the content of A1
is greater than 2.

Boolean Or OR Tests for values matching the Boolean OR

Example: 0 OR 0 displays 0 (false), anything else results
in 1 (true)

Boolean X
Or

XOR Tests for values matching the Boolean exclusive OR

Example: 1 XOR 0 displays 1 (true)
Boolean And AND Tests for values matching the Boolean AND

Example: 1 AND 2 displays 1 (true)
Boolean Not NOT Tests for values matching the Boolean NOT

Example: NOT 1 (true) displays 0 (false)

Statistical Functions

Choose from the following statistical functions:

Mean MEAN Calculates the arithmetic mean of the values in an area or a
list.
Example: MEAN 10|30|20 displays 20

Minimum
Value

MIN Calculates the minimum value in an area or a list.
Example: MIN 10|30|20 displays 10

Maximum
Value

MAX Calculates the maximum value in an area or a list.
Example: MAX 10|30|20 displays 30.00
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Trigonometric Functions

Choose from the following trigonometric functions:

Sine SIN Calculates the sine in radians

Example: SIN (PI/2)
Cosine COS Calculates the cosine in radians.

Example: COS 1
Tangent TAN Calculates the tangent in radians.

Example: TAN <A1>
Arc Sine ASIN Calculates the arc sine in radians.

Example: ASIN 1
Arc
Cosine

ACOS Calculates the arc cosine in radians.

Example: ACOS 1
Arc
Tangent

ATAN Calculates the arc tangent in radians.

Example :ATAN1

More Defined Values

PI PI 3.1415...
Euler's
constant

E 2.7182...

True TRUE not equal to 0
False FALS

E
=sum<C4>

Calculating in Text
1. Place the cursor at the position in the text where the calculation result should appear.

2. Press (F2) to display the Formula bar at the top of the main edit window (above the
horizontal ruler if rulers are shown).

3. Enter the desired formula, for example (4+6)*100.
4. Press Return or click on Apply to insert the result.

Use the Formula icon to perform more complex calculations. Clicking on this icon opens
a branched submenu from which you can select a formula. The formulae are placed on
the formula bar at the cursor position, and you are free to switch between inputting
formulae and values from the keyboard and via the Formula icon.

As an example of a more complex calculation to be performed in a text, suppose we want
to calculate the mean value of three figures.

1. Display the Formula bar with (F2).

2. Open the submenu of the Formula icon.
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3. Choose “Mean” from the statistical functions. The input field will display ”=mean.”
4. Enter the first number and then a vertical bar (|) as the list separator.
5. Enter the second number, another separator and then the third number. The input field
may now show, for example, “ =mean 12|22|34.”

6. Press Return, to inset the result as a field in the text.

7. Double-click on the field to edit it.

Calculating With Formulae Located in Text
If the text already has a formula, the result can be entered into the text without using the
Formula bar as follows:

1. Select the calculation formula in the text. This text must not contain anything other
than figures, arithmetic operators and any currency symbols.

Example: 12 + 24 * 2

2. Hold the Cmd key down and press the numberpad plus (+) key, or choose Tools >
Calculate. The calculation result will be stored on the clipboard.

3. Set the cursor at the point where the result of the calculation is to be inserted.

4. Press Cmd-V, or choose Edit > Paste.

In this example, the result, 60, is inserted. If the formula is still selected at the time of
insertion, the result replaces the formula.
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Conditional Text
Fields can be used in a document to display text when a condition is met. For example,
you can define the conditional text that is displayed in a series of reminder letters.

Setting up conditional text is a two-part process:

1. Create a variable, then

2. Create the condition.

Illustration: Defining a conditional variable

Defining and using conditional text – by example

Defining a conditional variable

The first step in the process is defining a variable for the condition statement.

Type “Reminder” in the document, and then add space.

1. Select Insert > Fields > Other.

2. Click the Variables tab.

3. Click “Set variable” in the Type list.

4. Type a name for the variable in the Name box, for example “Reminder”.
5. Click “Text” in the Format list.
6. Enter “1” in the Value box,
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7. Click Insert.

To display integers, click the “-1234” format.

Defining a condition and the conditional text:

The second step in the process is to define the condition that must be met, the text to be
displayed when the condition is met or not met, and to insert the place holder for
displaying the conditional text in the document.

1. Place the cursor where the conditional text is to be inserted in the text.

2. Choose Insert > Fields > Other.

3. Click the Functions tab.

4. Click “Conditional text” in the Type list.
5. TypeReminder EQ "3" in the Condition box. In other words, the conditional text
will be displayed when the variable in the field that was defined in the first part of this
example is equal to three.

6. The quotation marks enclosing the number 3 indicate that the variable, defined in the
first part of this example is a text string. See above for a list of operators that can be
used when defining a condition.

7. Type the text to display when the condition is met in the Then box. There is no limit
to the length of the text that can be entered. You can even copy and paste a paragraph
into this box.
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8. Click Insert, and then click Close.

Displaying the conditional text:

In this example, the conditional text is displayed when the value of the conditional
variable is equal to 3.

1. Place the cursor in front of the field that was defined in the first part of this
example.

2. Choose Edit > Fields.

3. Replace the number in the Value box with "3".
4. Click Close.

5. If the field does not automatically update, press F9.

Calculating in Text Document Tables
NeoOffice Writer tables can also include calculations, and these can extend between
tables.

For example, there are two tables, labelled Table1 and Table2, in which the first cell of
Table1must be multiplied by the first cell of Table2 and the product returned in cell A2
of the current table. In this case, the table names serve as table identifiers.

Here's how:

1. Enter numbers into cells A1 of Table1 and A1 of Table2.
2. Position the cursor in cell A2 of Table2.
3. Press F2 to bring up the Formula bar. It already starts with an '=' ready for the user to
type a formula.

4. Click on cell A1 of Table1. NeoOffice will insert the cell reference <Table1.A1>
into the formula bar.

5. The formula bar is still waiting for you to continue entering the formula, so now type
* (the multiply operator).

6. Click on cell A1 in Table2. NeoOffice will insert the cell reference <A1> into the
formula bar with no user action. Note that this time the reference does not need the
table identifier.

7. Press Return now to complete the formula and the product is presented in Table2 cell
A2.

Note:With the help of the Navigation Bar you can navigate quickly and easily between
the table formulae in the document.

If a table formula refers to an invalid table cell, a “**Faulty expression**” is displayed in the cell. Invalid
table cells are either deleted cells or those which are themselves faulty.

It is only possible to refer to table cell values from within tables. One trick to inserting a
table calculation result within text is demonstrated by this next example.
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To add cells B1:B10 from Table1 and present the sum in a line of text, :
Create the text and Table1.
1. Place the cursor in the text where the sum is to appear.

2. Insert a frame (Insert > Frame menu command). In the Frame dialog select the
Anchor as As Character.

a) Deselect the border.

b) Click OK to close the dialog.

3. Deselect the frame by clicking outside it.

Note: when entering text in the frame, click in the very centre of the frame. The frame should not be selected,
but the text cursor should be inside the frame.

a) Insert a single-cell table inside the frame using Insert > Table.

b) Set a row and a column value of 1, uncheck Heading, and uncheck Border.

c) Click OK.

d) The cursor is positioned in Table2.
4. Define the formula by either pressing F2 or typing an equal sign (=) into the cell (this
is a short-cut), at which point the Formula bar will be displayed.

The formula for calculating the total of cells B1 to B10 is: “ = <Table1.B1:B10> ”.
But don't type this yet because there is a simpler way.

5. Highlight the cells in Table1 to be summed. Do this by keeping the mouse button
pressed as the pointer is dragged from the first to the last cell being summed.

6. Close the mathematical formula by clicking the Accept icon on the Calculation Bar.
The result of the calculation will be seen in Table2.

7. If there are changes in the cells being summed, update the result by pressing function
key (F9).

Note: Instead of first inserting the border and then inserting a table inside the border, start by inserting a
single-cell table, then select the whole of this cell - the only way to do this is with the shortcut keys Cmd-A
and then click on the Insert > Frame icon. The border automatically surrounds the table (incidentally, this
also works with any section of text). Now set the anchor to Character, cut the whole table to the clipboard
and paste it where it should go, remove the borders from the frame and table and apply further settings.

Calculating Across Multiple Tables
Calculations in any text document, where there is more than one table containing data
required for calculation, can be done in NeoOffice Writer. For example:

• Insert two tables each with several rows and columns.

• Enter a few figures in the tables, but leave at least one cell empty.

The tables should be automatically named “Table1” and “Table2”. If you choose, each
table can be given a different name (Table > Properties, Table tab, text box Name)
using only letters and numbers for naming.

1. Position the cursor in an empty cell.
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2. Press F2 to display the Formula bar.

3. As an example, enter SUM.

4. Individually click the cells containing figures in both tables that are part of the
calculation. After each click, enter a plus sign (+) from the keyboard, and continue to
the next cell containing a figure.

5. Finally, click the Apply icon on the Formula Bar. For example, if adding up the first
two rows of each table and showing the total in Table2, the formula is
=sum<Table1.A1>+<A1>.

Calculating Cell Totals in Tables
1. Insert a table with multiple rows (Insert > Table) into a new text document.

2. Enter a series of numbers into a column, one number per row, leaving the last cell of
the column empty.

3. Place the cursor in the last empty cell of the column.

4. Click the Sum icon in the Table toolbar.

5. The Formula bar appears, with the word “SUM”. Click and drag the mouse to cover
all celss that need to be added.

6. Press the Return key to confirm, or click Apply in the Formula bar. The sum will
appear in the last cell.

When numbers are changed in the table, the sum is automatically updated. If, for
example, formatting the numbers as currency, select the cells and choose Number
Format from the context menu. The Number Format dialog appears, where you can
choose a new format.

Merging and Splitting Cells
You can select adjacent cells together, then merge them into a single cell. Conversely, a
large cell that has been created by merging single cells can be divided back into
individual cells.

The commands are different in NeoOffice Writer and Calc.

Merging Cells in NeoOffice Writer

1. Highlight all the cells to be included in the merged cell.

2. Select Table > Merge Cells.

Splitting Cells in NeoOffice Writer

1. Set the cursor in the cell to be split.

2. Select Table > Split Cells.

A dialog allows splitting the cell into two or more cells, horizontally or vertically. This
can also be done using the icons on the Table toolbar.
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Merging Cells in NeoOffice Calc OLE Objects

1. Highlight all the cells to be included in the merged cell.

2. Select Format > Merge Cells. The state of this menu item is toggled on. Note that
this menu item reflects the state of the current selected cell.

Cancelling the merging of cells in NeoOffice Calc OLE Objects

1. Set the cursor in the cell to be split.

2. Select Format > Merge Cells. The state of this menu item is toggled off.

Repeating Multiple Heading Rows in a Table
If you wish to automatically repeat more than one row within a table following a page
break, this is how to do it:

1. Select the first table row.

2. Open the context menu and choose Cell > Split.

a) In the Split Cells dialog, select the “horizontal” direction.

b) Enter the number of rows that are to be repeated

c) Confirm with “OK”.

All rows at the beginning of a table that is created in this manner will now be repeated
after a page break.

Enlarging and Reducing Cells in Text Tables
The width and height of rows and columns are changeable using the keyboard, by
dragging and dropping with the mouse or by commands in the context menu. Column
widths can also be changed numerically via a dialog.

Rows and columns can also be evenly distributed with the icons on the
Optimize floating toolbar on the Table toolbar, by clicking on the small
black triangle to its right, or by long-clicking the Optimize icon.

Rows and columns can also be modified either in the table directly, or with the aid of the
rulers. If the mouse pointer is rested on a vertical dividing line in the table, the pointer
appears as a separator symbol, and you can simply drag the dividing line to the desired
position. (Youmay need to click once outside the table before this procedure will work.)
The dividing lines on the ruler can be moved in the same way.
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When the keyboard is used to enlarge and reduce a table, always hold down the Option
key while pressing one of the four arrow keys. The current column or row is enlarged or
reduced by whatever amount is set under Tools - Options > NeoOffice Writer > Table >
Keyboard handling. Rows and columns are handled separately.

When you make these adjustments, by pressing the Option and arrow keys, the current
row or column is enlarged or reduced at its right-hand or lower edge. If you press the
Shift key as well as Option, while clicking on one of the arrow keys, the left-hand or
upper edge will be moved. Here are two examples that expect that the cursor is set
somewhere in the middle of a medium to large text table:

1. Hold down the Option key, and press the right arrow key. The current column is
expanded by the amount specified in Tools > Options > NeoOffice Writer > Table.
The left edge of the column remains fixed while the right edge moves.

2. Now, hold down the Option key together with the Shift key and press the right arrow
key. The right edge will remain fixed while the left edge will move to the right,
thereby reducing the column.

The height of the rows can be adjusted in the same way. However, since the rows are
preset to a minimum height, you must first increase their size before the result is obvious.

Adapting Table Widths
The display attributes of a table are defined by the settings under Tools > Options >
NeoOffice Writer > Table.

• Behavior of rows/columns— Fixed means, for example, that if one cell is made
wider the adjacent cell will become narrower. Other cells will not be affected, and the
overall width of the table stays the same.

• Behavior of rows/columns— Fixed and Proportional means that all adjacent cells
become proportionally narrower. In other words, wide cells will shrink more than
narrow ones. Again, table width remains constant.

• Behavior of rows/columns— Variablemeans that the width of the entire table is
variable. Whenever an individual cell is made wider, the entire width of the table
expands as well.

When inserting or deleting (cells, rows or columns), the table mode decides how the
neighboring cells, rows or columns should behave. In the table mode, new rows and
columns are only inserted in a fixed way if there is sufficient space.
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Images, Drawings, Clipart and FontWork

Images, drawings, clipart, and special FontWork objects can be inserted in the text
document.

Positioning Objects
There are various ways of anchoring the objects on a text page, such as graphics and text
frames. The following describes the various options, based on the example of a frame:

Anchoring

Effect

as a Character Frames are placed in the document like any other character,
hence, they have an impact on the line size of the line and the
line break.

to Character Frame behaves with its X and Y coordinates associated to a
character, for example, in the X direction always to the margin
and in the Y direction always to the height of the character
(marginal frame). The frame should be set at “Flow”.

to Paragraph Frame is associated to a paragraph, changes its position with the
paragraph.

on the Page Frame has always the same position in relation to the page
margins.

on Frame Frame is inside the superior frame in a fixed position.

The anchor determines what specific text feature the object is bound to as the document's
content and formatting is altered. For example, it is possible to set the frame on a fixed
position in relation to a page margin, to a paragraph margin, to a text area, etc.
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The frame position on even pages can be automatically mirrored, so that a fixed position
in relation to the right side of the page produces a corresponding position on the left side
of the page. For example, a graphic can always be positioned inside the outer edge of
pages. Where the graphic is, say, an arrow pointing to the text, it is a good idea to mirror
this automatically on even pages too. To do this, use theMirror on even pages option on
the Type tab of the Graphics dialog (choose Picture in the context menu of the graphic).

Captions and Number Ranges
In text documents you can create separate, continuously numbered captions for figures,
tables and drawing objects.

Users can also define as many separate number ranges as desired. The captions are linked
to the figures, tables or drawing objects in a frame. Select the frame when the object is
moved.

Defining Captions

1. Select the figure or the object or place the cursor in the table that requires a caption.

2. Open the Caption dialog with the command Insert > Caption.

3. The dialog shows a preview of how the caption will look. Further text can be inserted
in the Caption field.

4. Click OK.

Note: If you would like to place a tab stop between the automatic captions (e.g., “Figure 1”) and the
additional text, it can be inserted in the document later. Press Ctrl-Tab to insert a tab stop at the beginning
of a paragraph.
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The paragraph format of an automatically applied caption is obtained from the Paragraph
Style “Illustration”, “Table”, “Drawing” or “Text”. All of these paragraph styles are
derived from the “Caption” Paragraph Style. So if all captions always are to appear in
green, for example, simply modify the “Caption” Paragraph Style accordingly in the
Styles and Formatting window. To examine this, switch the Styles and Formatting
window to the “All Styles” view or to the hierarchical view.

Editing or deleting captions

A caption is normal text which is placed together with an object in a common frame.

1. Edit the caption text just like normal text.

2. Delete the caption text just like normal text.

Inserting an object in a number range

Suppose your document contains illustrations as linked graphics, and these are labelled in
a number range called “Illustration”. Now you want to do a drawing and add it as a
further illustration. You can extend the automatic number range in “Illustration” as
follows:

1. Below the additional illustration, insert a new line and apply the Paragraph Style
“Illustration.”

2. Open the Insert > Fields > Other dialog. Pressing Cmd-F2 is another way to open
this dialog.

3. On the Variables tab, select the Type “Number range”. Under Selection select
”Illustration”.

4. Click Insert

5. Close the dialog box.

If illustrations and their captions are moved around by hand in the document so that the
sequence changes, it may be necessary to update the numbers by pressing Cmd-F9.

Numbering Illustrations by Chapters
Numbering illustrations by chapter, so that illustrations are labelled “Illustration 1.1”,
“Illustration 1.2”, etc. in the first chapter and “Illustration 2.1”, “Illustration 2.2”, et
cetera in the second is often useful. Here's how to proceed:

1. Organize the document by chapters if this is not already done. Select Tools > Outline
Numbering to number the chapter headings that are formatted, for example, with the
Paragraph Style “Heading 1”. Select the ”Heading 1” Style from the Paragraph
Style list box and the option “1, 2, 3,..” from the Number list box below it.

2. Select the first illustration to number.

3. Select Insert > Caption....

4. In the dialog that appears, select Illustration as the category and Arabic (1 2 3) as
the numbering. Caption text can also be entered in this dialog.
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5. Click Options. Specify the chapter numbering in the Number Range Options dialog.
For this example, select option “1” under Level and specify the separator wanted for
chapter-wise numbering.

6. Click OK.

7. In the Caption dialog, click OK. The illustrations are now numbered by chapters.

Do the same for all other illustrations in the document. The numbering occurs
automatically: All illustrations within one chapter level are numbered, and you can enter
the chapter level at which to switch the numbering in the Number Range Options
dialog.

Note: Choose Tools > Options > NeoOffice Writer > AutoCaptiondialog This is where you can, for example,
determine that from now on all illustrations in text documents receive a caption automatically.

Inserting Graphics
Graphic objects can be inserted in a text document in several ways. The following
sections describe the most useful.

Inserting Graphics via dialog

1. Set the cursor at the position in the document where you wish to insert the graphic.

2. Choose Insert > Picture > From File... The dialog Insert Picture will appear.

3. Select the desired graphic and click on Open.

By default, graphics are inserted with their alignment centered above the current
paragraph.

Note: In OS X, you can insert screenshots this way. The screenshot will usually show up on your desktop as
Picture 1.png, Picture 2.png etc, and you insert as above.

Inserting Graphics From the Clipboard

Graphic objects can be copied to the clipboard when you select it and press the Copy
icon, or via the keystrokes Cmd-C. The item can then be pasted as follows:

1. Set the cursor at the position in the document where you wish to insert the
graphic.

2. Press the Paste icon, or Cmd-V.

Inserting Graphics From NeoOffice Draw or Impress

Graphic objects can be copied and inserted from one document to another by dragging
and dropping the object.

1. Open the document in which the graphic object is to be inserted.

2. Open the document from which to copy the graphic object.

3. If the graphic has a hyperlink connected to it then the mouse pointer will change to a
Grabbing Hand when the mouse is over the graphic. In this case switch from HYP
mode (in the Status bar) to SEL (select) mode by clicking in the box where it appears.
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4. Select the graphic by clicking on it.

Note: This needs confirmation in NeoOffice - On some systems, pressing the OptionAlt key and clicking the
graphic object selects the object while in HYP mode without activating a hyperlink that may be connected to
it. On other systems the Option Alt key is used to shift the focus to the Menu bar.

5. While holding down the Cmd key, keep the mouse button pressed and drag the graphic
object into the other document. The cursor changes to a green plus sign.

6. Release the mouse button as soon as the gray text cursor is at the position to insert the
copy of the graphic object.

If the object is connected to a hyperlink you may use this method, rather than the one
outlined in the note above. The hyperlink may then be inserted instead of the graphic
object. Graphics inserted from a webpage are generally linked to the remote web site.
Use Edit > Hyperlink to embed the graphic in the document.

Inserting Graphics via Drag and Drop From the Gallery

A user can Drag and drop a graphic object from the gallery into a text document,
spreadsheet or presentation to insert it.

1. When dragging and dropping, without pressing a key or while pressing the Cmd key,
a plus sign appears on the mouse pointer and the graphic object is inserted as an
object.

2. When dragging and dropping while pressing the Shift and Cmd keys together, you
will see a linking arrow next to the mouse pointer, and the object is inserted as a
linked object. A linked object is not copied into the document but refers to an object
elsewhere. If the object elsewhere is modified, then all linked instances of it are also
changed. The size of the object in the document does not change, so NeoOffice will
automatically scale the view of the object if necessary.

When a graphic object is released directly on a drawing object, the following rules
apply:

1. When dragging and dropping, without pressing a key or while pressing the Cmd key,
a plus sign appears next to the mouse pointer and the graphic object is inserted as an
object on top of the existing object.

2. When dragging and dropping while pressing the Shift and Cmd keys together, a
linking arrow is seen next to the mouse pointer and the existing drawing object is
replaced by the object from the Gallery. The position and size of the object that is
replaced remains valid for the new graphic.

Adding Graphics To the Gallery via Drag and Drop

Graphic objects can be added to the Gallery and, thus, you may have them conveniently
available for use in any document.

1. SelectMy Theme in the Gallery themes box, or add a new graphic via the New
Theme button and select it. See the NeoWiki at
http://neowiki.sixthcrusade.com/index.php/Using_Clipart for detailed instructions and
tips about this topic, icluding how to build up a collection of free clipart.
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2. Press and hold the Cmd key while dragging and drop a graphic object from the
document to the Gallery images box.

3. Open the context menu of the new gallery image with a Ctrl-click or right-click and
select Title. Enter a name for the image and press OK.

Add any themes to organize personal, ready-use images.

Inserting Graphics With a Scanner

Note: Scanning in NeoOffice is not supported. Some have achieved success using the
free SANE drivers, but the recommendation of the programmers is to scan outside of
NeoOffice, do the manipulation as desired and then drag-and-drop, or insert the graphic
as described above. To carry out scanning in Writer, a scanner with appropriate driver
software must be installed on the local system. (Under Windows®,OpenOffice.org
supports the TWAIN standard while , under Unix, OpenOffice.org supports the SANE
standard.)

1. Set the cursor at the position in the document where the graphic is to be inserted.

2. Select Insert > Picture > Scan.

The submenu contains a command to open a dialog for selecting the scanning source.

3. From the submenu, select the command to request scanning.

The scanner driver opens a window in which to follow the scanner manufacturer's
instructions.

4. Once the scanning process is completed, the image is inserted in the document.

Inserting a Chart From NeoOffice Calc

Dragging and Dropping the Chart with Move or Copy

1. Open the NeoOffice Writer document into which the chart will be inserted.

2. Open the NeoOffice Calc document containing the chart.

3. Click and hold the mouse button on the chart. Wait until the mouse pointer changes to
the hand.

Drag the chart into the NeoOffice Writer document.

This will move the chart. To copy the chart, press and hold the Ctrl key while
dragging.

Note: If the Writer document is not visible, first arrange the windows appropriately. If the operating
system or windows manager provides a task bar, drag the chart to the Writer button on the task bar, hold
that position for a moment while the Writer window opens in the foreground and then drop it in the now
visible document.

4. In the Writer document, position the chart or modify the scale as you would any
object.

5. To later modify the chart data, double-click and edit it.
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Charts with Linked Data

If a chart depends on data in a Calc document and this data changes, a chart inserted by
the above method is not automatically updated. To keep the chart and the data up-to-date,
do as follows :

1. Create the chart so that it appears on first sheet of a Calc spreadsheet, filling it from
top left.

2. Save and close the spreadsheet.

3. In your Writer document, go to Insert > Object > OLE Object, or select the OLE
Object icon on the Insert Object toolbar.

4. In the dialog, select first your type of file (a chart in this instance), then Create From
File: browse to the file saved in 2. above.

5. Check the box Link to file .. this will load the last saved version of sheet and show
the chart. This is the critical step in making your link to your chart data.

6. Save the Writer document.

7. Use Tools > Update > Links (or Update All) to update your link from chart to chart.

8. Open the spreadsheet saved in 2 above; change the chart data and save the spreadsheet.

9. Open the Writer document; reply “yes” to the box which appears with "Update all
links?", and the document will show the updated and saved chart.

10.Go back to the spreadsheet; change the chart data and save your spreadsheet.

11.Go back to Writer document, go to Edit > Links ... > Update, and your document
will show the updated and saved chart when the screen is refreshed.

Note: this is different to the instructions in the OpenOffice.org user guide, which were found not to work in
NeoOffice.

Inserting Decorative Horizontal Lines
Choose Insert > Horizontal Ruler to open a dialog for selecting decorative lines.
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The lines are graphics anchored to the current paragraph and centered between the
margins.

These lines may also be found in a Gallery theme. If you want to continue using a line
from the Internet, add it to the relevant (lines) theme in the Gallery. The line can then be
selected from this dialog.

Inserting, changing and removing notes

You can place notes in a document to share thoughts and ideas with others working with
the same file. Notes are marked by a small yellow rectangle in the document and are read
either by holding the mouse pointer over it, or double clicking on it.

Notes are inserted by choosing Insert > Note... and then filling in the text box. If you
have entered your initials in the NeoOffice settings these will automatically be included
together with the comment.

To edit a note, you simply double click on the yellow marker and change the text.

Removing a note (ie. the yellow marker as well as its content) is done by putting the
cursor in front of the yellow marker and pressing the Delete button on the keyboard. If
you empty the comment text residing within the yellow marker, the marker itself will not
disappear.

Note: If you would like to print the notes together with a document you can have a look at the File > Print...
> Printer Options > Notes property. The default setting is not to include the notes in print.

Headers, Footers and Footnotes

Some Notes Concerning Headers and Footers
Headers and footers are always linked to the Page Style. All pages with the same Page
Style automatically have the same headers and footers. By using Fields in the headers and
footers, you can insert variable content in a text document, such as page numbers and
chapter headings.
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Headers and footers are also available for HTMLWriter documents. However, because
headers and footers are not provided in the HTML definition, they are exported as special
tags and are correctly interpreted again upon loading an Writer HTML page. Thus, web
browsers show the content of the header or footer as the text which was there at the time
of the HTML export while Writer inserts the fields again and updates these as and when
necessary. (Author and sender, on the other hand, are only inserted as fields if the user is
the author, or was the last one to modify the document.) Headers and footers are exported
in HTML documents if they are enabled inWeb Layout mode.
If the content of headers and footers needs to change at different points within a
document, it is best to create different Page Styles and apply these to the pages.

Choose Insert > Header or Insert > Footer to toggle headers or footers on/off for a
particular Page Style. These operations don't affect the current page, unless the current
page has that Page Style.

Format > Page may also be chosen to start a dialog that allows selecting headers or
footers for the current Page Style. Here you will find a check box Same content
left/right. If this is not marked, you may format different headers and footers on the left
sides than on the right sides.

Note: If you only want to assign a different header to a single page, you could also insert a text box to cover
the header text. Anchor the frame to the page, and assign the “Wrap Through” option and the background
color “White.”

Inserting Page Numbers in Footers
Suppose that the cursor is on a page that has a page style that now requires a footer to be
inserted. By doing so, you will ensure that all pages that also use this style will also
display this footer.

Note: This is the only way to edit the content of a header or footer, that is, by finding or creating a page with
the target page style first.

1. Choose Insert > Footer and select, from the submenu, the page style corresponding
to the style being used for current page. This will toggle the footer on for this page
style (assuming it was not on already). The cursor now appears in the footer.

2. Choose Insert > Fields > Page Number. The page number appears as a field in the
footer.
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3. That's it. If you now want to format this field, for example by centering it across the
page and adding some text so that it appears as “Page 9 of 12”, this is how it's done:
i. Place the cursor anywhere in the footer and click on the Centered icon on the
Formatting toolbar.

ii. Type the text “Page ” before the field and “of” after the field.
iii. Now choose Insert > Fields > Page Count.

Inserting Chapter Information in Headers
Fields containing the file name, date, time, chapter headings, et cetera can be inserted
into a header.

1. Enter text in a document. Apply the style “Heading 1” to chapter headings.
2. Activate the header for the page style used by the current page (Format > Page >
Header or Insert > Header).

3. Click within the header to position the cursor in it.

4. Type “Chapter: ”
5. Select the Insert > Fields > Other command.

a) In the Fields dialog:

b) Select the Document tab

c) Choose Chapter in the Type box,
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d) Format Chapter name. Where the header is to contain paragraphs formatted with
Heading2 instead of Heading1, enter a 2 under Layer.

e) Click Insert to add the desired information to the header, and then close the dialog
box.

f) Now every page of the document using this page style will automatically display
the chosen chapter heading in the header.

Other information can be inserted into a header in the same manner. Find other menu
commands under Insert > Fields. Choose from Date, Time, Page Number, Page
Count, Subject, Title and Author. Additional field commands can be selected or
defined under Other.

Formatting Headers and Footers
Headers and footers can be formatted with multiple objects - where an object could be
text, a field or whatever. The footer used in this document uses a table to contain the Title
field and the page number field.

Tabstops can also be used effectively for this purpose. The procedure for setting and
editing tabstops can be found via Help > Contents > Index > Search term > tab stops.

Defining Different Headers
A defined header and footer will appear in all pages that have the same Page Style.
However, different headers for the first page or for even and odd-numbered pages are
often needed. For example, you may want the name of the chapter to appear on the left
(even) pages and the name of the first subchapter to appear on the right (odd) pages.
Since headers are a property of the Page Styles, users need to define two different Page
Styles and apply them to the respective pages. There are preset Styles for First page,
Left page and Right page, which can be adapted to your specific needs.

Take the Page Style for left pages: this style might have different inner and outer
margins, while the style for right pages has a mirror image of those margins. If different
headers and footers are not needed, simply choose a mirrored page layout (under Page
Layout in the tab Page).
Switching between odd and even Page Styles and between First Page and Left Pages
can be done automatically by defining the Next Style. If you define the Page Style with
Next Style and apply the new Page Style to the first page, then NeoOffice will
automatically apply the correct Page Styles to the following pages. Here is a method:

1. Open a new text document.

2. Click the Page Styles icon in the Styles and Formatting window (Format > Styles
and Formatting).

3. Choose the Style First Page to use as the basis for a custom Page Style.

4. Open the context menu and choose New.

5. In the Page Styles dialog, go to the tab Organizer.

a) Give the Page Style a name, such as “Page1,” and
b) define “Left Page” as the Next Style.
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6. For the “Left Page” define “Right Page” as the Next Style, and for the “Right
Page,” choose “Left Page.”

Inserting Page Numbers of Continuation Pages
Footers are inserted using Insert > Footer.

1. After creating the footer, set the cursor in it and select Insert > Fields > Other....

2. Choose the Document tab and under “Type” select ”Page”, under “Select”
select “Next page” and under “Format”, select “As Page Style”.

3. Finally click Insert to insert the field command in the footer of the current
document.

The document will display the page number of the next page, with the exception of the
last page.

If you wish the words “Continue on page” to also appear in front of the page number
but not to appear if there is no next page, do this:

1. Set the cursor in front of the field that was just inserted in the document

2. Open the Fields dialog.

3. Select a field of the “Page” type, under Select, select “Next page” and under
“Format”, select “Text”.
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4. In the Value text box, enter the text to be displayed if a next page exists in the
document. Enter “Continue on page ” (note the space at the end!).

5. Click Insert.

Of course, you can also enter instead of “Continue on page” , something else. For
example, you can enter “.../”, to indicate the number of the next page.
Inserting Lines Under Headers
Adjust the appearance of the header directly in the header itself. For example, by clicking
on an existing header, you can format the text individually or as a whole paragraph.
Additional attributes are available in the Format > Page dialog under the tab Header.

Selecting the Header tab permits defining a document header for the first time. Mark
Header on. When the dialog is closed by clicking on OK, a header is created which can
then be filled out in the document.

Click theMore button on the Header tab to choose additional settings for the border and
background of a header.

Draw a line under the header by going to the Borders tab. Under Line arrangement
click between the two lower angle marks at the bottom of the rectangle. This tab page can
also be used to define the style of the line and the distance between the header text and
the line.

Footnotes and Endnotes
Footnotes in a text document can be displayed at the bottom of a page (or column where
there is more than one column) or at the end of a document. The settings are defined by
choosing Tools > Footnotes. The following information is also valid for endnotes.
Endnotes are footnotes that appear collectively at the end of a document instead of at the
foot of each page.

You can jump from a footnote anchor in the document to the footnote text quite easily, by
clicking on the footnote anchor. Press page up to return from the footnote to the text.
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• The footnote format can be changed by modifying the Paragraph Style “Footnote,”
which is automatically applied to all footnotes in a document.

• To delete a footnote, simply delete the footnote mark in the text and the footnote text
is automatically deleted as well.

Inserting and Editing Footnotes
Footnotes can be inserted in two ways: via an icon or via a dialog.

Inserting a footnote via an icon

1. Set the cursor at the point where the footnote anchor should appear.

2. Open the Insert floating toolbar.

3. Click on the Insert Footnote Directly icon (grayed out on the submenu in the
illustration below).
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Inserting a footnote via a dialog

1. Set the cursor in the document at the point where the footnote anchor should appear.

2. Select Insert > Footnote to open the Insert Footnote dialog.

When inserting a footnote using the icon, footnote numbering is automatic. The Insert
Footnote dialog, on the other hand, allows individual settings for the footnote.

Tips for Working with Footnotes

1. Click in the text of a footnote to allow editing or modification.

2. Press page up to jump from the footnote area to the footnote anchor in the text.
Place the cursor in a document immediately before the footnote character of a previously
inserted footnote to edit its properties, and choose Edit > Footnote; or, double-click
immediately before the footnote character.

When defining general settings applied automatically to footnotes in the document, select
Tools > Footnotes to open the Footnote Settings dialog.

Format footnotes with Page Setup by choosing Format > Page... >
Footnote.
In multicolumn pages, the footnote is inserted at the foot of the column where the
footnote anchor is located.

You can also use the mouse to jump from the footnote anchor to the footnote. The mouse
pointer changes its appearance to a pointing finger as soon as it is over the footnote
anchor.

Spacing Between Footnotes
If you would like a bigger distance between the different footnotes or endnotes, you can
add an invisible (white) line as the lower border to the corresponding paragraph format:

1. Set the cursor in a footnote.

2. Open the Styles and Formatting window.

3. Click on the footnote Paragraph Style to be modified.

4. Open the context menu by right-clicking or Ctrl-clicking.

5. SelectModify.

6. On the Borders tab page, select a top and a bottom line and give them both the color
white.

7. In the Spacing to contents area, uncheck Synchronize .

8. Increase/decrease the value of the upper or lower spacing.

9. Click OK.
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Spellcheck, Dictionaries, Hyphenation

Controlling Spellcheck via the dialog

Choose Tools > Spellcheck, click on the Spellcheck icon in the Standard toolbar,
or press F7.

Spellcheck compares words in the document with words in its dictionary/ies. Its job is to
alert you to words unknown to it, on the assumption that an “unknown” word is likely to
be a misspelled word. In a document where there are no unknown words, Spellcheck
will complete and display a message box to say as much. Clicking the OK button there
will close the Spellcheck dialog, so sometimes you need to deliberately spell a word
incorrectly to see how Spellcheck works. See a demonstration of this below, where we
deliberately misspelled “statement”

Normally the Spellcheck dialog appears when you call it up manually via the menu,
clicking on the icon, or by pressing F7. Selecting text before calling the dialog and then
checking the spelling only in the text that is selected can be an advantage, and a time-
saver. The Spellcheck dialog is described in detail in Help. A manually initiated
Spellcheck always begins at the cursor position, unless the text was selected (in which
case it begins at the beginning of the selected text and ends at its end). When the spell
checking does not begin at the beginning of the document, or if the end of the document
is reached during the checking process, a dialog appears asking you to confirm that
checking is to continue at the beginning of the document.

The system always searches first through the selected user-defined dictionaries and, if the
word is not found there, it searches through the main dictionary. Should the word not be
there either, the dialog, shown above, is displayed and this allows you to replace the
word. Either type it correctly in the Word field (the top box) or select a word from the list
of Suggestions, and click on Replace. Spellcheck will then continue to the next unknown
word.
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The word in theWord text box can be permanently added to the user-defined dictionary.
First, select the preferred dictionary from the Dictionary language pull-down list. Then,
click Add.

If needed, all unknown words in a text can be automatically entered in the active user-
defined dictionary. For instructions, refer to NeoOffice Help.

Automatic Spellcheck

• From within a text document, click the AutoSpellingCheck on/off icon on the
Standard toolbar. All words marked as incorrect by the spelling checker will then be
underlined in red.

• Right click or Ctrl-click on words underlined in this way and a context menu appears.

• The context menu often provides a list of suggested words, one of which may be
clicked to select it. The suggested word then replaces the word underlined in red.

If you accept a suggested word from the AutoCorrect context menu, that word and the
wrongly typed word are entered as a word pair in the AutoCorrect replacement table. To
call up this table, choose Tools > AutoCorrect > Replace tab.
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If the word underlined in red is correct, you may wish to make sure that Spellcheck does
not pick it up again. To do this, place it in a custom dictionary using the Add command.

To exclude words from the Spellcheck:

There are a number of reasons why you might want to exclude a word from being picked
up by Spellcheck. For instance, you might want Spellcheck to ignore a local abbreviation
that you often use, or words like “spellcheck” itself, that may not yet be in a dictionary.

1. Select the words.

2. Open the context menu of one of the words.

3. Select Character... Font tab, or select the Format > Character... > Font tab.

4. Select the language pull down [None].

Removing Words From User-Defined Dictionaries
1. Choose Tools > Options > Language Settings > Writing Aids tab.

2. Select the user-defined dictionary and click Edit.

3. Now the Edit User-Defined Dictionary dialog appears allowing you to search
through an alphabetic list.

4. Select the word
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5. Click Delete.

While in that window, look in the IgnoreAll list: you should find your own name there.
NeoOffice is making sure that it doesn't pick up your name each time it does a
Spellcheck.

Hyphenation
Hyphenation in text documents can either be done automatically or manually.

• Automatic hyphenation is an attribute of paragraphs and Paragraph Styles. This means
that you can switch the hyphenation on or off for a paragraph or for a paragraph
format and select its properties.

• Manual hyphenation gives individual control, but can be tedious.

Automatic hyphenation

In NeoOffice, automatic hyphenation is turned off by default. The following steps are
useful for enabling hyphenation on an “as needed” basis:

1. For one or more selected paragraphs, open the context menu and select paragraph.

2. For all paragraphs formatted with a certain Paragraph Style, open the context menu in
one of the paragraphs and select Edit Paragraph Style.

a) In the next dialog, click on the Text Flow tab.

b) Under Hyphenation, check on/off Automatically.

3. To enable hyphenation in all paragraphs, edit the parent paragraph style of all derived
paragraph styles.

a) In the next dialog, click on the Text Flow tab.

b) Under Hyphenation, check on/off Automatically.

To enable automatic hyphenation without queries, select Tools > Options > Language
Settings > Writing Aids > Options and select Hyphenate without inquiry.

Manual Hyphenation

• For manual hyphenation, place the cursor at the point where the word should be
separated and press Cmd and -.

The word will be separated if it is possible, even if automatic hyphenation is turned off
for the paragraph.

If a hyphen is entered directly, Writer will not apply the automatic hyphenation for that
word. Let's assume the word “Antarctica” would be hyphenated: An-tarcti-ca, but this
should be: Ant-arc-ti-ca. Enter all three hyphens manually (directly), including the one
between “i” and “ca”, as is used in automatic hyphenation.

There is a quick way to prevent a particular word from being affected by the hyphenation (or Spellcheck)
functionality:

• Select the word and choose Format > Character. On the Font tab select Language None.

If a word should be permanently set to prevent automatic hyphenation such that it will never be separated,
place it in an active user-defined dictionary with an equals sign after it:
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1. Choose Tools > Options > Language Settings > Writing Aids.

2. Select a User-defined dictionary.

3. Click the Edit button. Where there is no user-defined dictionary, as yet, create one by clicking the New
button.

4. In the Edit Custom Dictionary dialog, enter the word. e.g., ”Companyname=” (without quotation
marks)

5. Click Close to close the dialog.

6. Click OK.

Now, the word “Companyname” will never be hyphenated.

Selecting Tools > Language > Hyphenation avoids searching manually through the text
in order to find words to hyphenate. This starts the following dialog which shows all the
words that could be hyphenated with the current line break, one after the other. The
syllable at which the word could best be hyphenated at the current line break is
highlighted. In the case where the word to be hyphenated should have the hyphen at an
earlier place in the word, use the left arrow button to move the highlighting to the left.
Click on Hyphenate to hyphenate the word at the highlighted place, and the next word
that could be hyphenated is displayed.

When Spellcheck recognizes the word, the default hyphens are displayed as well.

Thesaurus
The NeoOffice thesaurus provides a means to look up words that may be used instead of
the highlighted word.

1. Highlight the word in the text for which an alternative is desired from the thesaurus.
For example, the word “clean”.

2. Select Tools > Language > Thesaurus or press Cmd-F7.

3. In the dialog which then appears, scroll down the two lower list boxes until a suitable
word is found. If the dialog is closed by clicking on OK, the selected word is replaced
by the word in the Replace field.

Note: Not all languages have a thesaurus to accompany an installed dictionary.
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When looking for alternatives for a word in another language for which a thesaurus is
installed, for example an English word:

1. Select the word in the text

2. Call up the thesaurus.

3. Click on the Language button to switch to “English (UK)” or “English (US)”, in
order to select British or North American spelling.

4. Then click on Search.

If English language attributes are applied to the English words in the text (Format >
Character, Font tab, Language list box), then Spellcheck, thesaurus and hyphenation
will automatically be in this language. You can assign a language to paragraph styles in
the same way.

Form Letters, Business Cards and Labels

Write form letters, design business cards and produce labels all from data obtained―
from a data source, or that is sequentially numbered.

Creating Form Letters
To aid in creating form letters, the following section first gives some brief instructions
and then detailed instructions.

Brief Instructions (For Quick Results)

1. Register an address data source in NeoOffice, if not done previously.

Instructions may be found with the search term “address book” in Help.
2. File > Wizards > Letter to open the dialog.

3. Set up the template.

4. Select the addresses for the form letter, or enter them manually.

5. Click Create. Writer can now create the form letter.

Fixed and Variable Fields

Fixed fields are fields which are filled out only once, i.e., when the field is inserted into
the document. For example, if writing an invoice based on an invoice template, use a
fixed date. By doing so when setting up the invoice document, you ensure that the field
position will contain the current date and will not change later on. That is, the date of the
invoice is determined only once. This can be useful when you need to send letters with a
particular date on them, e.g. if you are printing some one day and some a day or two
later.

On the other hand, a variable date is updated every time the document is opened and
printed. Amanual update of the fields sets the actual date in the field entered as Variable
date.

If, for example, when inserting a date as a field in a form letter, you must decide if it is to
be inserted as a fixed or as variable date:
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• Where the date should never change; that is, as if the date is typed in directly (without
a field), select a fixed date format. The advantage to using a fixed date field means
that the form letter can be saved as a template. Using this template to a create a new
form letter, will avoid having the date automatically updated to today's date.

• On the other hand, if you select a variable date, the date will be updated every time the
document is opened or printed.

(Note: This menu above is called up by Insert > Fields > Other... or Cmd-F2.)

Apart from the date, there are various other fields which can also be used in a form letter.
The most important fields are the ones which determine where the different elements of
the recipient's address are to be placed. These fields have a direct connection to the
database table which contains the address list. A field will be inserted in the form letter
for each data field, such as name, street, city, et cetera. When printing, Writer inserts the
desired data fields in the fields from each record. In most cases, create the form letter
template.

1. File > Wizards > Letter to open the dialog.

2. Set up the template.

3. Select the database containing the addresses for the form letter.

4. Set the fields as directed by the Wizard

5. With each dialog, select the features needed.
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6. Click Create to add this document to the templates and to open a Writer session to
complete the body.

7. If the body text will be used in the future, use File > Template > Save and overwrite
the initial instance of the template.

Having done this, you can use this template for other form letters:

1. Select Tools > Mail Merge Wizard to start the process of creating a form document
based on the template just created. The letter based on this template will be displayed
and already contain the fields for the address, date, sender, et cetera.

2. Choose From a template in theMail Merge dialog.

3. Press F4 to open the data source for the current document.

4. Select the records necessary for use in the form letter by clicking the row headers at
the left in the data source view. Press the Shift key and/or the Cmd key to make a
selection. To print a form letter for all the records in the table, click the empty field
above the row headers to select all records.

5. Edit to suit personal requirements.

6. Save the document.

7. Now click theMail Merge icon on the TableData toolbar at the top of the data
source view. The Form Letter dialog appears, where two choices are offered, to save
as file(s) or print. You can also choose to print selected records, all records or a
particular range. If printing a range (for example, records 1 to 5), ensure that the
numbers follow the order displayed in the data source view.

To sort or filter records in the data source view, click the respective icons on the database
bar. For example, to sort all records according to postal code, place the cursor in the
POSTALCODE (ZIP) field of any record and click Sort Ascending. Now the form letter
is all ready to go!

Note: If a completely new document containing the necessary form letter fields is being created, use drag
and drop to do so: Open the text document and press F4 to show the desired database table. Point to a
column header and, holding down the mouse button, drag it into the document. The field for inserting this
item from this database table is automatically placed in the document.

Creating and Printing Labels and Business Cards

Designing Business Cards via dialog

Choose File > New > Business Cards to open a dialog with several tabs that help design
the look of business cards. These are generally fairly simple, which may or may not be
what is wanted.

Designing Labels and Business Cards

Using File > New > Labels for designing business cards is often the best method, as
business cards may be regarded as a simplified, special kind of label. Like labels, all
business cards are the same and, as labels, can be filled with different contents, graphics,
data obtained from a database, or they can be marked with serial numbers.

1. Select File > New > Labels to open the Labels dialog.
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2. On the Labels tab, under Format, define the label format.

Writer contains many formats of commercially available sheets for labels, badges,
business cards etc. User-defined formats can also be added, and there are templates
freely available from a number of online sources.

3. On the Labels tab, under Inscription, choose what to write on the labels.

This often involves database fields, so that the labels can be printed with varying
content, when sending “Form Letters” for example. But it is equally possible to have
the same text printed on every label.

Use the pull-down lists to select the database and table from which the data fields are
obtained. Click on the big arrow to transfer the selected data field into the inscription
area. Press Return to insert a line break. Entering spaces and any other fixed text is
also possible.

Using the Format tab, define custom label formats, not covered by the predefined
formats. To be able to do this, the label type on the Labels tab must be set to “User-
defined”. On the Options tab, specify whether all labels or only certain ones are to be
created.

4. Enable Synchronize contents check box on the Options tab. If this is checked, only
one (the top left label) has to be entered and edited while the remainder will be
repeated identically

5. Upon clicking New Document, a small window opens with the Synchronize Labels
button. Enter the first label. When the Synchronize Labels button is clicked, the
current individual label is copied to all the other labels on the sheet.

6. Click on New Document to create a new document with the settings that have been
entered.

7. Print the new document.

Printing Labels With Serial Numbers

Printing lottery tickets or entry tickets with serial numbers on them is quite easy. This is
how to do it:

1. Select File > New > Labels. This opens the Labels dialog.

2. On the Labels tab, under Format, select the format in which to print.

3. Tickets, label tags or rolls are available from specialist suppliers and are often made
from stiff paper with tear-off perforations, or as self-adhesive labels on a backing
material.

4. To define a custom format, select the Format tab.

5. Check Synchronize contents on the Options tab.

6. Click on New Document.

7. A new document is now created, divided up as wanted. Only the top left label needs to
be edited. When satisfied, press Synchronize labels to make all labels appear the
same. This button is only visible if Synchronize contents is checked on the Options
tab.
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8. Enter the desired text in the top left label and format the contents.

9. Serial numbering can be applied by inserting a field.

10.Place the cursor at the point where the number should appear.

11.Press Cmd-F2 or choose Insert > Fields > Other.

a) In the Fields dialog, go to the Variables tab.

b) Select the type Set variable, if it is not already marked.

c) In the Name box, enter a name for the counting variable, for example Number.
d) To increment the variable from one label to the next by 1, enter the following
formula in the Value text box: Number+1.

e) Click Insert, then close the Fields dialog.

12.Click Synchronize Labels.

13.Now save and print the finished document.

Printing Address Labels
When printing address stickers for form letters that do not fit in window envelopes, do
the following:

1. Select File > New > Labels to open the Labels dialog.
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2. Select the format of the label sheets that will be printed from the dropdown menu.
Remember to check Synchronize contents on the Options tab.

3. Click on New Document to close the dialog.

4. When the label document opens, invoke the data source view by pressing the F4 key.

5. Click the Tack icon at the edge of the data source view to avoid having it cover the
first label.

6. In the data source view, select the address data source table.

7. Drag the data fields needed for the Address individually into the top left label. For
example, click on the column header NAME and, keeping the mouse button
depressed, drag it into the label. This inserts a field.

8. Put the fields in order to complete the address in the first label at top left.

9. Place the cursor at the last text position (after the last field) in the first label.

10.Open the Fields dialog by pressing the shortcut keys Cmd-F2.

11.Choose the Database tab.

a) Select the type Next record,

b) Select the database

c) Click on Insert

d) Click Close.

12.Now synchronize the labels by clicking the Synchronize button in the small window.

13.In the data source view, select the records that will be printed on the labels, by
clicking on the row headers to the left. Use the Shift or Cmd key in the usual way to
select several records at the same time.

14.On the TableData toolbar (the one which opens above the data display when you

press F4), click the Data to Fields icon.

Now save and/or print the label document.

After the last label on the page, the command Next Record is effected automatically. Therefore, do not insert
the command manually after the last label on a page.

Avoiding Blank Paragraphs
Sometime fields in a form letter can be empty and a blank line is printed. For example,
there is a field named COMPANY that should appear in the recipient field, but for some
records this field is empty. To prevent these empty fields from being included do the
following:

1. Place the cursor in the text document before the form letter field COMPANY.

2. Choose Insert > Fields > Other to open the Fields dialog.

3. On the Functions tab select the type Hidden Paragraph.
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4. In the Condition field, enter the following text (without quotation marks):

not(Company)
Now the COMPANY line will not be printed, and the rest of the lines will be moved
upward if the COMPANYdatabase field is empty.

Newsletters

In this section, you may learn how to create a newsletter/newspaper as a text document.
This is useful for creating newsletters for a company or club, or in celebration of a
special event. Currently NeoOffice does not have a resident newsletter template but there
is a nice one that works available from http://ooextras.sourceforge.net/ and this is one
used in this section.

To install the template after downloading, do the following:

1. Open the template in NeoOffice Writer.

2. Select File > Templates > Save

3. Choose where to save the template. Default is probably best as no special permissions
are needed.

4. Name the template

5. Click OK

Voila, there is now a newsletter template ready for use.
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Creating a Newsletter From a Template
In the File menu choose New > Templates and Documents. Locate and double-click to
open the Newspaper Template.

The document contains several useful elements that could be of good use of in a
newsletter. It contains, for example, an automatic page numbering system and a field with
the fixed date. You can now enter text and position graphic objects.

Modify the existing heading as needed, and insert any graphics.

A few other texts highlighted in gray are variables, which you can modify.

When the document is completed, save and print it.

Edit the template (File > Templates > Edit) for any personalization and layout changes.

Creating Page Styles

Where a page must include not only text but also several larger graphics, create a separate
Page Style for this purpose.

1. Open the Styles and Formatting window and click the Page Styles icon.

2. From the context menu, select the command New to open the Page Styles dialog.
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3. In the tab Organizer, assign a descriptive Name for the Style.

4. Next, click the Page tab and define the page format and margins.

5. Check Register-true and choose the reference Paragraph Style Text Body.

Note: If the register-true option is activated, the baselines of all paragraphs with the Text Body Style will be
exactly aligned so that they are at the same position in each column and on each page in relation to the
page. With double-side printing, the baselines of the register-true paragraph will have the same position.
Normally use the Paragraph Style used to create the actual text. To define another Paragraph Style as
register-true, call up the properties dialog of that Paragraph Style. Call it up, for example, in the Styles and
Formatting window via the context menu of that particular Paragraph Style, select the Modify command.
On the Indents and Spacing tab, in the field under Register-true, select Activate.

Editing Headers

To edit a header, click once in the header field in the document. Do a right-click or Ctrl-
click to bring up the context menu, and select Page.., to activate the Page Styles dialog.
Select the Headers tab and click Options. In the Background dialog, choose a
background color and click OK, then confirm the following dialog as well.

Editing Columns

To change the number of columns or create a dividing line between columns, activate the
Page Styles dialog via the Page context menu (right-click or Ctrl-click to bring up the
context menu, and select Page....

Click on the Columns tab. Change the number of columns in the spin box Amount, and
modify the distance between the columns in the spin box Spacing. Make sure that the
Automatic Width field is selected.

To create a dividing line, select a narrow line from the Line list box under Separator, set
the Height to 75%, and define the position as Centered. Finally, click OK to close the
dialog.
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To place headings or subheadings that are more than a column wide into a multi-column
text, try putting them in a text frame. The text frame can the be freely scaled and
positioned on the page. Insert a frame using the Insert Frame icon on the Insert floating
toolbar. Text frames can may also have borders, but this is not always necessary.

Editing Paragraph Styles

1. Click the Paragraph Styles icon in the Styles and Formatting window and select the
paragraph style to be modified.

2. Select theModify command from the context menu, call up the Paragraph Styles
dialog. In this dialog, there are several tabs with various settings and options.

Experiment with font effects, for example drop caps. Click the respective tab and select
Show Drop Caps. Drop caps may even be assigned a Style in the Character Styles list
box under Contents.

Note: Newsletters or newspapers require a variety of main headings, subheadings, and text wraps to make
them easier to read. In the Paragraph Styles dialog of the Styles and Formatting window context menu, it
would thus be a good idea to create several appropriate paragraph styles ( go to the Styles and Formatting
window > context menu > click New...).

Working with Frames

A frame positioned over one or more columns can give the newspaper a less crowded,
more interesting appearance. Such a frame can contain text, graphics, or even a chart.
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Click the Insert Frame Manually icon (grayed below) on the Insert toolbar . A drop-
down menu allows the selection of from one to four columns in the frame.

Draw across to select. Double-click. The mouse pointer changes to a small cross that is
dragged to open a frame and position it over one or more columns in the document.

Formatting a Frame

Put the cursor in the frame (deselect the frame first, then click inside it) and enter any
text or graphics. The appearance and properties of the frame can, of course, be modified
at any time. Select the frame by clicking it, call up the context menu and click Frame....
A dialog with several tabs will appear which allows you to apply, for example, a colored
shadow to the frame via the Borders tab.

Anchoring Frames

In the Frame dialog, click the Type tab and select the type of anchor under the heading
Anchor to. If the frame is to always remain on the same page— which is important for a
table of contents, for example,— select Page. For the frame to flow with the text, e.g.,
for small symbols which always appear in the margin accompanying a certain word in the
text, select ToCharacter. Or, in flowing text, where the frame should move with the text
as a character, select As Character. Select Paragraph to anchor a frame to a specific
paragraph,.

The type of anchor can also be specified from the context menu. Alternatively, click the
Change Anchor icon in the Object bar to quickly change the anchor.

Defining a Frame Wrap

Open the Frame dialog (context menu > Frame) to define the frame wrap and click the
Wrap tab. Select the desired wrap style, and under Spacing, define the spacing between
the frame and text. Finally, select the option First Paragraph.

The First Paragraph field (or the menu command in the context menu) ensures that
when a graphic is positioned between two paragraphs, only the first paragraph wraps
around the picture.

Defining a Wrap Region

Note: If you follow this procedure, but cannot find an icon in a toolbar to which the description refers,
check the Visible Buttons menu for the toolbar, accessed via the small back trangle at the right-hand end of
the toolbar, as below:
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Making a newsletter more attractive with objects or graphics is done easily by having the
text flow around an object. Simply draw a polygon using the Polygon icon in the Draw
Functions toolbar. Place the polygon over the text and assign the text theWrap >
Optimal with its context menu.

A wrap contour to 3D objects can also be defined. Create a 3D object with NeoOffice
Draw, copy it to the clipboard and paste it into the text document. Open the context menu
of the inserted object and chooseWrap > Optimal. In the context menu of an object
with a wrap contour is theWrap > Edit Contour command. This command calls the
Contour Editor from which manually re-editing the automatic contour is possible. Refer
to the instructions in Help.

Linking Frames and Facilitating Text Flow
If the text should be continued in the same manner as in a newspaper (i.e. from a frame
on page 1 to, say, a frame on page 4), and where the text flow from frame to frame
must be done automatically, use linked frames.

1. Create two (or more) frames by opening the Insert floating toolbar, clicking Insert
Frame Manually.

2. Select the first frame (click the border of the frame).

3. Click the Link Frames icon on the Frame toolbar.

4. Now, click the second frame.

5. To enter text in the linked frames, position the cursor in the first frame and type in
text or insert it from the clipboard.

Note: If certain text from a document is to flow in linked frames, first put the text cursor in the first
frame (first click the normal text to cancel the frame selection and then click the frame).

6. Now decide if the text should be a copy in the frame or if it should keep a link to the
original document (in this case it would always return to the actual stand of the
original document). If the text is only to be copied, choose the command menu Insert
> File.
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7. If the text is a section linked to another file choose Insert > Section. In the Insert
Sections dialog that appears, click Link and select the file wanted with the ...
button.

8. Finally, click the Insert button.

Using Colored or Graphic Backgrounds
To assign a colored background to a paragraph, place the cursor in that paragraph and
click the Background color icon in the Object bar. A floating color palette appears, from
which you select the desired color by clicking it once.

Note: When frequent use of a background color for certain paragraphs is used, it is best to create a
Paragraph Style for this purpose.

A background can be a graphic image rather than a color. The background graphic image
is assigned to a paragraph either via the Paragraph Style (in that case, all paragraphs
based on this Style will have the same graphic background), or use Format >
Paragraph.... to edit it. Click the Background tab and in the list box As select
“graphics” in order to pick out an appropriate graphic image from your collections. In
this case, we have chosen to see a preview of the graphic, which will be paced behind the
text.
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Creating a Table of Contents
Tables of contents can be created manually; however, if the contents are altered, the table
of contents must be manually updated, as well. It is much more convenient (and time-
saving) to have the program create a table of contents automatically. Here is where it is
vital that you are usign Styles: your table of contents is so much easier to set up.

1. With the text entered, creating a table of contents on the front page of the newspaper
or newsletter may be in order. To do so, follow these steps:

a) Draw a frame manually on the front page,

b) Select ToPage as anchor.

c) Press the Escape key to set the cursor in the frame.
2. Open the Insert Index/Table dialog (choose Insert > Indexes and Tables > Indexes
and Tables).

3. On the Index/Table tab page, select “Table of Contents” as Type,
4. Enter an appropriate heading, e.g., “In this issue...” in the Title field.

Ensure that one of the “heading” Paragraph Styles is assigned, so that chapter numbering
may be determined for the headings. These are determined by the Styles under Tools >
Outline Numbering. The predefined Paragraph Styles are “Heading1” through
“Heading10”.
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If the table of contents should use the headings in the document, specify the desired
outline structure using the Evaluate up to level spin box.

If other, customized Paragraph Styles for the headings have been defined, these can also
be incorporated into the table of contents. To do so, go to the Insert Index/Table dialog,
click the Index/table tab and in the Create from area, mark the Additional Styles check
box. Click the button to the right of the check box. The Assign Styles dialog will appear.
This is where the level of the Style is assigned, in the table of contents, for each Style
used in the document.

Choose more settings on the Entries and Styles tab pages and Click OK to create the
table of contents.

Once the newsletter or newspaper is finished, save and print it.

Further Information

Using Automatic Hyphenation

When working with columns, it makes sense to activate automatic hyphenation for every
Paragraph Style (do so by calling up the context menu of the Styles and Formatting
window and clickingModify... to access the Paragraph Style dialog > click the Text
Flow tab). Enter a “3” for Characters at line end and Characters at line begin to
ensure that hyphenated words have at least three characters at the beginning or end of a
line. For text alignment in columns, choose Justify on the Alignment tab.
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Letters With Envelopes

With NeoOffice Writer, a letter can be written in no time. These instructions show how
easy it is.

There are two really easy ways to get a result:

● Use a letter template,

or

● Use the Wizard to create a custom tailored letter template.

Using a Ready-Made Letter Template
1. Press Cmd-Shift-N to open the Templates and Documents dialog:

2. Select a template.

3. Enter the details required for the various wildcards, such as the salutation.

4. Type in the remaining text.

Templates include the user data that was entered in Tools > Options >NeoOffice > User
Data and which may be modified at any time.

Creating a Letter Template Using the Wizard
1. Start the Wizard by selecting File > Wizards.

2. Click Letter in the submenu to see the first page of theWizard for Letters.
3. Select Personal Letter.

4. Click Next to bring up a second page with additional options.

5. Choose the option No Logo.
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6. click Next. A dialog will appear in which you can enter the sender details.

7. The sender address is displayed at this point. Thus, under Show sender? select Yes.

8. Click the symbol top right in the Position and size area.

9. Click Next.

Note: If the input field does not contain a sender, the program will lack the necessary details. In this
case, click Cancel, open the User Data tab (in Tools > Options > NeoOffice) and enter the necessary
data. After that, re-open the Wizard and carry on as described up to this point. Sender details may also
be entered directly in the input field of the Wizard; however, these details are not currently entered in
Tools > Options > NeoOffice > User Data, this process for every must be repeated with new template
created with the Wizard. Some of these steps may be grayed out in your program.

10.Continue to click Next until reaching the page with the footer options.

11.Deactivate the check box Footer on

12.Click Next twice.

13.Enter the name of the template in the Name field. If necessary, enter any additional
information in the Info field. (The template will be stored in the template folder under
the name chosen.)

14.Click Next.

15.Enter the printer trays if different paper trays are to be used for the first and
subsequent pages. This is especially practical when the only the first page is to be on
letterhead paper.

16.The last step is to click Create.

After clicking the Create button, NeoOffice creates a document template and places it in
the template folder. At the same time, a new, unnamed document appears on the screen,
that has been generated as a copy from this template.

Now start entering text and then save and print the document. However, if you would like
to keep on working on the layout of the document template or create an envelope for it,
close the new document without saving it.

Creating an Envelope Template
This section contains a description of how to create a template for an envelope after
completing a letter template plus some tips on how to continue polishing template design.

As the envelope should be saved together with its template, open the letter template.

1. Select File > Templates > Edit.

2. Locate the letter template wanted and open it. The templates are found in the
NeoOffice directory user/template in the user's home directory. (Path names may vary
with different releases.)

3. Go to the Insert menu

4. Select Envelope. A dialog of the same name appears.
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5. On the tab pages Envelope and Format, specify the envelope format and the position
of the addresses of the sender and addressee on the envelope. Use the Printer tab page
to define appropriate print options.

Inserting an Envelope into a Document

Click on the Insert button in the Envelope dialog. The envelope will be inserted above
the first page of the active document. (In this case, before the first page of the personal
letter template)

To continue editing the envelope (for instance, to change the format again), open the
Page Style: Envelope dialog (use a right click or Ctrl-click to open the context menu of
the envelope, click Page... and select the Page tab).

Adjusting the Printer for the Printout

Printing envelopes depends very much on the type of printer used. Some printers require
a special cassette, while others have a multi-purpose tray that can feed envelopes. If in
doubt, consult the manual for the printer.

Specify any print options in the Page Style: Envelope dialog. To open this dialog, click
an empty spot on the envelope, open the context menu, and select Page.... Then select the
Page tab. Define the desired settings under Paper Format.

Check File > Print ... > Properties to ensure that the printer knows the size of the
envelope being used. When this step is skipped, printing of an envelope becomes
unpredictable.
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Creating and Printing a Letter With an Envelope
With the creation of a customized template for personal letters, write and print a letter.

1. Select File > New > Templates and Documents.

2. In the dialog select the template.

3. Click OK. NeoOffice creates a document based on the template without changing the
template itself no matter what modifications you make to the document as you are
working on it.

4. Enter the text of the letter in the document.

5. Check if the addressee information on the envelope is correct.

6. If this document is to be printed or edited later on, save it and enter a name.

7. Place an envelope in the printer.

8. Select the command File > Print and print page 1, which is the envelope.
9. Place normal letter paper in the printer, select the command File > Print again.

10.Print the second page. If the letter has more than one page of text, specify which
pagesto print under Pages.

Creating a Single Envelope
1. Open NeoOffice Writer

2. Insert > Envelope..

3. On the Envelope tab, enter the address info.

4. On the Format tab, set Size > Format to DL. Adjust layout to suit.

5. On the Printer tab, select the layout that reflects how to feed.

6. On the same tab, click on Setup. This opens a new dialog.

7. On the Setup dialog, select the printer and click Properties.

8. On the Properties dialog, select the envelope size in the Paper size dropdown list. In
this case, Envelope DL.

9. In the same dialog, select Orientation. This depends on how the envelope feeds (see
step 5) In any case, landscape means that the text is rotated 90 degrees so that it is
parallel to the long axis of the envelope and vice versa for portrait.

10. If there is a manual feed tray, select this under Device.

11. Click OK

12. Click OK

13. Select New Doc if you only want the envelope, or Insert to add it to the existing
document.

14. In the new window, check that all is okay and click the print icon.
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Adding a POSTNET Bar Code to an Envelope

Get a POSTNET font

First thing to do is get a suitable POSTNET font. Do not be duped by the shareware
notion of 'free', which must be interpreted as 'free download' of a demo or crippled
version of a commercial product for which users must pay but, thanks to the the tenacity
of Ross Johnson, there is one available that works. Please see
http://www.adams1.com/pub/russadam/fonts.html and in the POSTNET group select
http://www.adams1.com/pub/russadam/shareware/uspsbarcode.ttf. This is listed as “A
POSTNET TTF”- author unknown and which is unconditionally free.

Simply install this font set in OS X by following the instructions for installing fonts that
come with the Mac. Once you've done that, shutdown all NeoOffice windows and restart
them; the font will be listed in the font list.

Now, you can type some numbers, select them, then change the font and, Voila!,
POSTNET bar code that is almost correct. In other words, this bar code is incomplete and
will be unacceptable if printed on the envelope as it is.

Note: Disable the default font preview mode so that you can see the font name listed. Failure to do so will
cause this font set to appear as a blank entry in the list.

a) In NeoOffice2.x, Use Tools > Options > NeoOffic > View > Font Lists and uncheck Show
preview of fonts.

b) In NeoOffice1.x Use Tools > Options > General > View > Font Lists and uncheck Show
preview of fonts.

Building a Complete POSTNET Bar Code for Printing

While numbers can be represented by the bar code, a correct POSTNET bar code for
most postal services requires additional information.

The first piece of additional information is a check digit, which is calculated from the
postal code as follows :

1. Start with the Postal code, say '12345', and sum the digits:
1+2+3+4+5 = 15

2. Calculate the number that is needed to add to this number to make the last digit of
the sum a zero (0).That is, 15 + ? = ?0 The answer in this case is: '5'.
e.g.. 15 + 5 = 20

3. Add this number to the postal code as the last digit. In this example, the
POSTNET sequence is now: 123455

4. Finally, wrap the digit sequence in square brackets. The final text for the
POSTNET bar code should now be [123455]

When you format this text using the POSTNET bar code font, a POSTNET bar code
results. For example, enter [123455] into Writer, select the whole [123455] text and
change the font to the POSTNET bar code font that has been installed.

Note: Calculating this sequence, and putting it on an envelope easily may prove problematic. Perhaps others
can help out with automating the process; however, by using a database or spreadsheet to store an address
list, then you could simply add a POSTNET sequence column with the postal code pre-computed in
POSTNET format or perhaps as format the bar code as part of a database query. Using OpenOffice.org
macros is yet another way to obtain results .
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With respect to using 9 digit postal codes, where there is a 5 digit zip plus 4 digit suffix,
the rules are the same. Add all 9 digits, find the check digit (sum + check = ?0), append
that digit to make 10 digits and, finally wrap the sequence in square brackets. e.g.
[1234567895]
There is apparently another two digit code that can be added if it is wanted, and the same
rule applies for the 11 digit version to make a 12 digit code wrapped in [].

All three forms are valid.
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Chapter 4: Spreadsheets in Calc

Calc is the powerful spreadsheet program of the NeoOffice suite. It provides the
functions necessary for professional use with financial and statistical functions as well as
database functions and much more.

Overview of the Functions in Calc

This section contains a short overview of some important functions and capabilities of
Calc.

Calculating
Calc works primarily as a spreadsheet program, i.e. it provides a spreadsheet containing
cells into which text, digits and formulas can be entered and, from these, calculate simple
and complex results. Calc, like the other components of NeoOffice, has numerous
automatic functions to ease usage.

While Calc provides all the basic calculation types, it also has numerous calculation
methods that can be entered interactively via theWizard: Functions. In addition, it
allows entering text and flexibly arranging cells, so forms can be comfortably styled,
filled in, calculated and printed.

Database Functions
Data that can be summarized into records, such as addresses, inventory levels, customer
orders or similar, can also be managed by Calc. Even if there are no calculations, Calc
can quickly sort a database range and search the data for specific characteristics, such as
maximum or minimum values.

In addition, a sheet in Calc can serve as a data source for creating form letters and reports
with NeoOffice Writer.

Arranging Data
Data can be organized in easy-to-read lists. With just a few mouse-clicks, the view can be
reorganized to show or hide certain data ranges, or format ranges, according to special
conditions, or calculate subtotals and totals.

Examining and Extrapolating Data
The data in Calc tables can be examined in detail in many different ways. Calc is useful
for creating term papers because it supports many statistical functions such as regression
analysis. And for daily calculations at work, the integrated financial functions are helpful,
because they can be used to print detailed tables of current credits and loans and other
data.

What-If Calculations
Results of changes made to one factor of calculations composed of several factors can be
viewed immediately. For example, you can see how changing the period in a loan
calculation affects the interest rates or repayment amounts. Furthermore, larger tables are
made manageable by using different predefined scenarios.
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Dynamic Charts
Calc has a charting function that can display spreadsheet data graphically by selecting the
data to be displayed and clicking the Insert Chart icon. Drag open a frame at the
required position, define specific chart settings in the dialog that appears. The chart is
inserted at the selected position and, when the source data is modified. It is dynamically
updated.

Importing and Exporting Data
Data from other spreadsheet programs can be imported, edited in Calc and output in
different export formats.

You are presented with a dialog similar to the following when you select Text CSV as the
file type and the input file uses a character to separate the fields (tab in this example):

Importing into Calc

Where the input file is in fixed width fields, check the Fixed width box and set the
column widths in the measurement bar as shown below:
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Exporting from Calc

Usually, you would simply use the Save as... dialog. Other export options, such as PDF
are also available in the same manner as for Writer or the other NeoOffice modules.

Referencing Data in Networks and the Internet
Rather than being restricted to having only a fixed value or formula that refers to other
cells in the sheet, each Calc cell can also contain a reference to contents in other
documents. The documents referred to do not have to exist on the local computer:they
can also be stored on a network or anywhere in the Internet.
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The Calc Window

Toolbars from bottom left, clockwise are Theme Selection, Form Control, Insert
Object, Insert Cell, Insert, Drawing, and Navigator. The toolbar is launched by the
icon indicated by an arrow in each case.Structure of a Spreadsheet

A spreadsheet is made up of individual sheets. Each sheet contains various cells, arranged
in rows and columns. Each cell can contain either an arithmetic formula, text or value (of
virtually any length).

A calculation can be entered directly as a mathematical formula. For example, =4 + 5.
But the main reason for using a spreadsheet is that its formulas can refer to other cells.
An example of such a mathematical formula might be =SUM(A1:A8). This calculates the
sum of the values in cells A1 through A8 and enters the result in the cell containing the
formula. Additional formulas may also be entered in cells A1 through A8, each referring
to other cells and their contents, and so on. As you can see, this allows calculation of
extremely complex relationships.
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A new spreadsheet is opened with the command File > New > Spreadsheet. Initially it is
named “Untitled1” and retains that name until saved under a different name. Look at the
new, still empty document for the variouselements that are discussed in the following
sections.

Rows and Columns
On a spreadsheet, rows are numbered from 1 to 65536 and the columns are designated
with the letters A through Z, AA through AZ, and so on; the last column is labelled with
the letters IV. Each cell on the sheet can be uniquely referenced by row and column. For
example, cell A1 is the first cell in the upper left corner of the sheet.
These numbers and letters appear along the edge of the window. The row header contains
the row numbers, and the column header names the columns. Clicking on one of these
areas, selects the entire row or column. To select the entire sheet, click on the unlabelled
button (box) at the intersection of the row and column headers at the top left.

Enter some text in cell A1. As text is typed, notice that the text appears both in the cell
and in the input line of the formula bar. Continue typing to see that more text can be
added than appears to fit in the cell.

In fact, any cell can accommodate text longer than a cell. The whole length of the text is
displayed and printed, provided the adjacent cells to the right are empty. If the cell to the
right is not empty, a small triangle on the right hand edge of the first cell appears,
indicating that the cell contains more text than can be displayed.

Note: Turn off these triangles by choosing Tools > Options > NeoOffice Calc > View and unchecking the
Text overflow box.

When a number cannot be displayed in a cell because it is too long, or due to the
formatting, e.g., currency format,###” is displayed. In this case, increase the column
width. Set the width to optimal” by simply double-clicking the right divider in the
column header.

NeoOffice User Guide for 2.x 206



Chapter 4: Spreadsheets in Calc

Use all the usual functions to edit text. Notice, however, that the right and left arrow keys
will replace the cell cursor if Entry mode (by clicking in a cell and entering characters) is
enabled. Double-clicking or pressing the F2 key or clicking in the entry row, enters the
Edit mode. The left and right arrow keys now replace the text cursor. Upon pressing the
Enter key, the text in cell A1 is finished and the cursor automatically moves to cell A2.
The active cell is always the one with the cell cursor and that is where entries and
changes are made.

Multiple Sheets in a Document
At the lower edge of the spreadsheet document there are tabs for switching among the
various sheets of a document. A new, empty spreadsheet initially contains three sheets,
each titled SheetX (where X stands for the numbers 1 through 3).

Inserting Sheets

1. Using the mouse, put the pointer in one of the sheet tabs at the bottom of the window.

2. Right click to open the Context menu for the commands governing editing sheets.

3. Choosing the Insert command, opens the Insert sheet dialog .

4. Select the position and quantity of sheets to be inserted

5. Click OK.

Renaming Sheets

1. Right click or Ctrl-click the tab of the sheet for renaming, e.g. Sheet1.
2. Open the context menu and choose the Rename command.

3. A dialog box appears in which tou can enter a new name.

4. Enter a new name for the sheet

5. Click OK.

6. Note: In NeoOffice, you may alternatively, double-click on any sheet name to enter
the new name in a Rename pop-up window.

Note: The name of a sheet may consist only of letters and numbers. Spaces are also permitted.
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The name of a sheet is independent of the name of the spreadsheet. Enter the spreadsheet
name when saving it for the first time as a file. The document can contain up to 256
individual sheets, each of which can have different names.
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Values and Formulas as Cell Contents

Individual cells can contain text, numbers, dates or formulas. Cell contents are very
easily specified or modified and these may be updated at any time by recalculating the
formulas with current data.

Values in spreadsheets mean numbers, dates, times and results of formulas. Emphasize
values by marking ValueHighlighting in the Viewmenu, or Cmd-F8.

If desired, check this option in Tools > Options > NeoOffice Calc > View, or
Preferences > NeoOffice Calc > View, in which case this function will apply
permanently for the current document and all documents created in the future (other,
already existing documents retain their settings). If this function is enabled, numbers and
dates are automatically shown in blue, and values in cells containing formulas in light
green. Text remains in black. If ValueHighlighting is not marked, you are free to choose
the colors and other formatting of the content of your spreadsheet.

Text can be entered in a cell even if it appears to be too long for the cell. Now try
entering a very long whole number. If the number is too long to fit in the cell, the
overflow indicator ### appears. By double clicking the right hand edge of the heading of
this column, the column is automatically set to the optimal width.

The box at the bottom right in the status bar always displays helpful information. In a
spreadsheet, this box can be used to permanently display the sum of all selected cells.
Other values may also be displayed, such as the maximum value of all selected cells. Use
the context menu to change the value displayed in this field. In case of an error in the
spreadsheet, this field will also display an error message.

Calculating in Spreadsheets
The following demonstrates a simple percentage calculation that can be done in a
spreadsheet:

1. Position the cursor in cell A3.
2. Enter the number 150 and
3. press the Return key. The cursor then moves down to cell A4.
4. Enter the number 16 in cell A4.
5. Press the Tab key this time rather than the Return key and the cursor moves to the
right to cell B4.
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6. Enter the following in cell B4:

=A3 * A4 / 100
When input is started with an equals sign, this indicates that a formula is being entered
and the formula will be seen in the input line of the formula bar.

7. Press Return to finish the formula.

8. The result of the calculation is (16 percent of 150) in cell B4.
9. Click on cell A3, enter 200.
10.Press the Return key, at which time the calculation result is automatically adjusted.

11.Click on cell B4.
12.Click at the end of the formula in the input line of the Formula bar.

13.The blinking text cursor indicates a new entry can be made.

14.Add “+ A3” (without the quotation marks) to the formula.
15.Press the Return key.

16.The newly calculated value of the formula appears in cell B4: the previous 16 percent
of A3 plus the contents of A3.

These steps introduce the most important steps in working with spreadsheets: creating
and entering formulas, entering data (text and numbers), obtaining results, modifying
source data or formulas, and how to view results of new data or formulas.

Besides the four basic arithmetic operations, there are other operators, nested brackets

and many other functions. TheWizard: Functions button on the Formula

toolbar is a useful aid when inputting functions.Using Built-in Functions

Calc has many built-in functions, one of which converts Euros to another European
currency, against which the Euro exchange rate is fixed. The following provides an
example of using functions to achieve a goal.

Note: A list of functions is available from Help > Contents > Index > Search term > function list; Calc.
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1. Enter a formula (e.g. =4+5 or =A3*A4/100) in a cell.

2. Press the “Return” key.

3. The result of the calculation appears in the cell.

However, functions can also be entered in a formula. An example could be =SIN(1),
which will give a result of sine of one (rounded to two decimal places).

Calc has several other functions, too, and additional functions can be added using
StarBasic or AddIns. Help has a section outlining how to do this. In most cases though,
the standard functions provided in the program are sufficient for most requirements. The
function with the Syntax CONVERT(arguments) is shown here as an example that will
convert a sum of FRF 100 into Euros by entering the following formula in a cell:

=CONVERT(100;"FRF";"EUR")
The result will be the number of Euros per 100 French francs. The value for conversion
is always stated first within the parentheses. It can be entered directly, as shown, or by
reference. If the amount is, for example, in cell D2, enter D2 in the formula as the first
part of the function. The remaining parameters of the function name the unit of the
amount and the unit into which it is to be converted. All three parts of the function are
separated from each other by semicolons.
Thus, using the formula =CONVERT(50;"EUR";"FRF"), displays the number of French francs
that is the equivalent of 50 Euros. To try this, proceed as follows:

In a new spreadsheet, enter in column D, from D2 to D20 a number of FRF
sums

1. Designate column E from E2 to E20 as the cells in which the same sums in Euros
must appear.

2. Click in cell E2.
3. Enter =CONVERT(

4. Click in cell D2. D2 is now defined as the first part of the function. The cursor
remains at D2 in the formula.

5. Enter "FRF";"EUR". i.e. enter the text with both semicolons and the quotation marks.

6. Press the Return key.

7. This completes the entire formula which now reads

=CONVERT(D2;"FRF";"EUR").

8. Cell E2 will contain the result of the calculation.
9. Click cell E2, then the small filled square in the bottom right hand corner of cell E2
and, pressing the left mouse button, drag down to cell E20.

10.Release the mouse button there.

11.The formula is now copied from E2 to E20. And all references have been
automatically adapted so that they always refer to the neighbouring cell on the left.
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A Short Description of What Cells Can Contain
The previous examples show that cells can accommodate different elements. These are
described below.

Text
Text in a cell can be formatted and edited with most of the functions available in a text
document. For example, to select a word, double-click the word either in the input line or
in a cell. If a different font or other attribute from the text object bar is needed, the
modifications apply only to the selected word.

Pressing the Cmd-Return keys inserts a manual line break. This shortcut only works
directly in the cell, not in the input line.

When text must break automatically at the right border of the cell, proceed as follows:

1. Select all cells in which the text should break at the right border:

2. In Format > Cell > Alignment

3. Check the Wrap Text Automatically field

4. Click OK.
Calculations are possible even in text. For example, enter text in cell A1 and more text in
A2. In cell A3, insert the formula =CONCATENATE(A1;A2)which will concatenate the
two texts, in other words, to string them together.

Numbers may also be entered in the Text format. Format the desired cells as Text (open
the context menu of the cell, by right clicking, and choose Format Cells > Category >
Numbers > Text), and enter numbers in the cells. These will be interpreted as text. The
display of these numbers is left-justified just like normal text; however, calculations with
numbers in text format are not possible.

If normal numbers have first been entered in cells and the format of the cells has been
later changed to Text, these numbers remain normal numbers and will not be converted.
Only numbers entered later or numbers which are then edited become text numbers.

To enter a number directly as text, enter an apostrophe (') first, e.g. for years in column
headings '1999, '2000 and '2001. The apostrophe will be not visible in the cell, as it
only signals that the entry is text. This can be useful when entering numbers , such as a
telephone number or ZIP code, that begins with a zero (0) since a zero (0) at the start of a
sequence of digits is removed in normal number formats.

Numbers
While numbers are displayed in various ways, internally these always remain numeric.
For example, '1' and '1.0' are the same.
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Enter the number 12345.6789, for example, and the number will appear in the sheet
with only two decimal places, i.e. 12345.68. Nonetheless, the exact number with all four
decimal places is kept by the program.

Fractional numbers can also be entered in a cell and used for calculation:

1. Enter 0 1/5 in a cell.
2. Press the Return key and, in the input line, will be the value 0.2. This will be used for
the calculation providing that the cell format is number. Calc does recognize fractions
and will automatically use 1/5 and display this.

However, if 0 1/2 is entered, AutoCorrect replaces the three characters 1, / and 2
with a single character. Likewise with 1/4 and 3/4. This replacement is defined in the
Tools > AutoCorrect > Replace tab.

If multi digit fractions such as1/10 are needed, change the cell format to the fraction
view (Context menu of the Cell, choose Format cells). Fractions such as 12/31 or 12/32
may be entered; however, the fractions are automatically scaled down so that, in the last
example, 3/8 is displayed.
Select other display options by choosing Format > Cells. All the defined formats are
lists on the Numbers tab. A preview shows how the result will look. In this dialog, define
personal formats, that can then be applied to numbers or other content of a spreadsheets.

There are various ways to enter integers starting with a zero:

• Enter the number as text. The easiest way is to enter the number starting with an
apostrophe (for example, '0987). The apostrophe will not be entered in the cell and
the number will be formatted as text. Because it is in text format, no calculations are
possible.

• Format a cell with a number format such as \0000. This format can be assigned in the
Format code box under Format > Cells... > Numbers tab and defines the cell display
as always put a zero first and then the integer, having at least three places, and filled
with zeros at the left if less than three digits.

Entire columns, (with numbers in text format i.e. in the form of 000123) can be turned
into real numbers again (without zeros in front of them, i.e. in the form of 123) as
follows:

1. Select the column in which the digits are found in text format. Set the cell format in
that column as Number.

2. Call up Edit > Find & Replace

3. In the Search for box, enter ^[0-9]
4. In the Replace with box enter: &
5. Check Regular expressions

6. Check Current selection only

7. Click Replace All
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Cells in the Currency Format

In Calc, numbers can have any currency format. Clicking the Currency
icon in the object list formats the number, and the cell is given the default
currency format as set in NeoOffice under Tools > Options - Language
Settings > Languages.

Without currency formats, the international exchange of Calc documents could lead to
misunderstandings, e.g. where a Calc document is loaded by a user who uses a different
default currency format.

In Calc, you can define a number, formatted as “1,234.50 €”, to remain in Euros in
another country and not change to the local currency. Use the Format Cells dialog to
influence the currency format (Choose Format > Cells > Numbers tab) by two country
settings. In the Language list box select the basic setting for currency symbol, decimal
and thousands separators. In the Format list box select any deviations from the currency
symbol of the format defined by the language.

If, for example, the language is set to German (Germany), the currency format will be
1.234,00 € and, per the locale definition, a point is used before the thousand digits and a
comma before the decimal places. Now select the subordinate currency format $ English
(USA) from in the Format list box, to get the following format:$ 1.234,00. Note that
the separators remain the same and that only the currency symbol is changed and
converted. The underlying Format of the notation remains the same as it is set in the
locale setting, while the currency changes from euros to dollars.
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Calculating With Formulas
All formulas begin with an equals sign. Formulas may contain numbers or text, and other
data is also possible such as format details, that specify how the numbers are to be
formatted. Naturally the formulas will also contain arithmetic operators, logic operators
or function starts.

When using the basic arithmetic signs (+, -, *, /) in formulas, remember that using the Multiplication and
Division before Addition and Subtraction rule. Instead of writing =SUM(A1:B1) it's better to write
=A1+B1.
Parentheses are also useful for grouping. For example, the result of the formula =1+2*3 means something
different than =(1+2)*3.

Here are some typical Calc formulas:

=A1+10 Displays the contents of cell A1 plus 10.
=A1*16% Displays 16% of the contents of A1.
=A1 * A2 Displays the result of the multiplication of A1 and A2.
=ROUND(A1;1) Rounds the contents in cell A1 to one decimal place.
=EFFECTIVE(5%;12) Calculates the effective interest at 5% annually with 12

payments.

=B8-SUM(B10:B14) Calculates the value of B8 minus the sum of the cells B10 to
B14

=SUM(B8;SUM(B10:B14)) Calculates the sum of cells B10 to B14 and adds the value to
B8.

It is also possible to nest functions in formulas, as shown in the example. Functions may
also be nested within functions. For example, instead of simply =ROUND(A1;1),
calculate and round a sine function using =ROUND(SIN(A1);2). Use the Function
Wizard to help form nested functions.

Calculating With Dates and Times
In spreadsheets you can do more than just display dates and times (both taken from the
internal clock of the computer). You can also make calculations with dates and times. For
instance, to find out exactly your age in seconds or hours, follow these steps:

1. Open a new spreadsheet.
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2. Enter a date in cell A1. e.g. a birthday, such as.,1/3/48.
3. Enter the following formula in cell A3: =NOW()-A1

4. Press Enter or click the Accept icon on the formula bar . The result appears in

date format.

5. Right-click this cell (i.e. bring up its context menu) since the exercise is to see the
difference between two dates as a number of days, the format of cell A3 should be set
as a number.

6. Select Format Cells....

7. The Format Cells dialog appears.

1. On the Numbers tab, the Number category will appear highlighted. The format is
set to General which causes, among other things, the result of calculations
containing date entries to also be displayed as a date.

2. Set the number format to -1,234,for example.
3. Press OK to close the dialog.

8. Cell A3 will now contain the number of days between today's date and the specified
date.

9. Experiment with some additional formulas:

1. in A4 enter =A3*24 to calculate the hours.
2. in A5 enter =A4*60 for the minutes.
3. in A6 enter =A5*60 for seconds.
4. Press the Return key after each formula.

The time since the birthday will be calculated and displayed in the various units. The
values are calculated as of the exact moment when the last formula was entered and
confirmed by pressing the Return key. This value is not automatically updated, although
NOW continuously changes, of course. In the Toolsmenu, the menu item Cell Contents
> AutoCalculate is normally active; however, automatic calculation does not apply to
the function NOW. Consider that, if it were, the computer would use all its resources
updating the sheet.

When spreadsheets contain a very large amount of data or very complicated formulas that
may be modified before viewing the calculation results, it may be prudent to cancel or
disable the automatic calculation function. Calculation time naturally becomes longer as
the complexity and size of a spreadsheet increases.

Inserting, Editing and Removing Notes

A note may be assigned to each cell by choosing Insert > Note. All notes are indicated
by a small red square, the note indicator, in the cell. Notes made visible whenever the
mouse pointer is over the cell, provided Help > Tips or Extended Tips is active.
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• For a selected cell, choose Show Note from the context menu of the cell. Doing so
keeps the note visible until the Show Note command is deactivated from the context
menu.

• To edit a permanently visible note, just click in it. When the entire text of the note is
deleted, then the note itself is deleted.

• Another way to delete a note is by choosing Edit > Delete Contents, dialogand check
“Notes” only.

• Select Tools > Options > NeoOffice Calc - View to show or hide the note indicator
by checking or unchecking the Note indicator box.

For NeoOffice 2.1 and later, the above method for editing an existing note no longer
works. For those versions, follow these steps:

* Right-click or Ctrl-click the cell.

* In the context menu that appears, check Show Note.

* Double-click the note in order to edit it.

* Right-click or Ctrl-click the cell.

* In the context menu that appears, check Show Note again. The note will be hidden.

• To delete a note, simply erase the contents.

Handling Multiple Sheets

Spreadsheet are not limited to just one sheet. In fact, several sheets may be laid on top of
each other. Each sheet has its own unique name displayed on the sheet tab at the bottom
of the window.

Additional sheets can be appended to a document or inserted in front of the current sheet.
Activate the context menu of a sheet tab by right-clicking or Ctrl-clicking on it, and
choose the corresponding command. Choose Rename in the context menu to modify the
name of a sheet.

Displaying Multiple Sheets

Use these navigation buttons to display the sheet tabs of all the available
sheets. Click the button on the far right of this group to move to the the
last sheet tab to see its name. To display the sheet itself, click on the
name.

When there is insufficient space to display the sheet tabs on the lower window border,
increase it by moving the separator bar between the tab bar and the horizontal scrolling
bar with the mouse button. Keep the mouse button pressed and drag to the right.
Remember this shares the available space between the sheet tabs and horizontal scroll bar.
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Working With Multiple Sheets
In a spreadsheet document, each sheet is completely independent of the other sheets.
However the same data can be incorporated into several sheets. For example, the same
data should be inserted at the same location in the first three sheets. To do so, select all
three sheets together and enter the data in only one of the sheets.

Selecting several sheets together, is simply a matter of clicking the sheet tabs of the
sheets in question while pressing the Cmd key. All selected sheets will now have white
sheet tabs, instead of the gray sheet tabs of the unselected sheets. To undo the selection of
a sheet, click its sheet tab again whilst pressing the Cmd key. Clicking the Sheet tab of
the current sheet while pressing the Shift key, ensures that only this one is selected.

Calc includes the name of the sheet in the reference when assigning sheet references.
Thus, instead of referring to $A$1, Calc refers to $Sheet1.$A$1 which makes multi-
sheet referencing easy and straight forward as shown in the examples below:.

• To address the first cell from both Sheet1 and Sheet2 in a single reference, for
example, summarize, the 3D formula will read =SUM(Sheet1.A1:Sheet2.A1). The
sum function has one addend here, namely, the range from Sheet 1.A1 to Sheet
2.A1. In this range there are two cells (as long as no more cells are included between
Sheet 1 and Sheet 2). The simple formula (not a 3D formula) would only list two
addends: =SUM(Sheet1.A1;Sheet2.A1).

• To include any subsequently inserted sheets found between Sheet 1 and Sheet 2, the
formula would then be =SUM(Sheet1.A1:Sheet2.B2).

The full address of a cell also contains the complete path and file name of the spreadsheet
document. So, in its full form, the reference to cell A1 in Sheet1 of the document
name.sxc could be ='file:///home/username/name.sxc'#$sheet1.A1 under where
/home is the hard drive and username specifies the directory where the file is stored.

Note: the single quotes surrounding the file name, and the # character that describes the location within the
file, in accordance with URL convention.

Printing Spreadsheets
Clicking the Print File Directly icon in the Standard toolbar sends all the sheets in
the document to the printer. However, if there's a print range selected, then only
selection is printed. To set the print range, select the cells to be printed, then use

the Format > Print Ranges > Define command. There is further information on this
topic in the NeoOffice Help.

To print the only current sheet, go to menu File > Print.... In the Printer Options dialog,
select the Selected sheets option and click OK. The Printer Options dialog also gives
one the choice to supress the printing of empty pages.

If various sheets are to print simultaneously, for example, Sheet 1 and Sheet 2, select
them beforehand (hold down the Cmd key and click the sheet tabs). The white tabs are
the selected ones. Next, go to the Print dialog, enable the Selection option and only the
selected sheets will be printed. After having printed the desired sheets, remember to click
the sheet that is being worked on while holding down the Shift key so that only that sheet
is selected. Failure to do this will result in all modifications being applied on all sheets.
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Formatting a Spreadsheet

A spreadsheet is hardly ever used without formatting. Cell contents, such as texts and
numbers, are given certain formats, and the cells themselves are formatted with different
colours, borders and other attributes.

Either create the numbers format or use one of the many predefined formats. For cells, a
wide selection of cell Styles is provided and personal cell Styles can be defined in the
same way as one defines text Styles.

Certain values in spreadsheets are often given particular emphasis, e.g. in a table of
turnovers, to show all the values above the average in green and all those below the
average in red. This is possible using the Conditional Formatting for spreadsheet
documents (covered in a later chapter.)

Formatting Numbers
Enter a number into the sheet, for example, 1234.5678. This number will be displayed
in the default number format, with two decimal places. One will see 1234.57 when the
the entry is confirmed. Only the display in the document will be rounded off; internally,
the number retains all four decimal places after the decimal point.

1. Set the cursor at the number and choose Format > Cells to start the Format Cells
dialog.

2. On the Numbers tab there is a selection of predefined number formats. A preview
box, in the bottom right of the dialog, shows how the current number will appear with
a particular format.

3. This dialog also allows defining other attributes (in addition to number formats) which
apply to the selected cells or cell contents. For example, font, size, and color can be
defined on the Font tab page.

Modifying the number of the decimal places displayed in a cell is
sometimes required. The easiest method is to use the Number
Format: Add Decimal Place (icon shown at left) or Number
Format: Delete Decimal Place icons on the Formatting toolbar.

Dates

Likewise, from the list of options, the date and time can be formatted as desired.

The year in the date details is often stated as two digits. Internally the year is managed by
NeoOffice as four digits, so that in the calculation of difference from 1/1/99 to 1/1/01
the result will correctly be two years.

• Tools > Options > NeoOffice > General defines up to which year a two-digit year
“xx” should be displayed as “20xx” eg 1930 to 2029

This means that if a date of 1/1/30 or higher is entered, it will be treated internally as
1/1/1930 or higher. All lower years apply to the next century. So, for example, 1/1/20 is
converted into 1/1/2020.
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Formatting Cells and Sheets
The distinction between direct and Style formatting holds true for cells as well as for text
documents, e.g. a choice between applying a particular font size directly as direct
formatting to a cell or defining a Style to apply the desired font size. Styles make
particular sense for documents that are used extensively or are to be templates. It does not
make sense to use Styles for documents that are only printed and discarded.

Using AutoFormat for Tables
A quick way to format a table or a cell range is offered by the Format -> AutoFormat
function. In a spreadsheet, first select the cells where you want to apply AutoFormatting,
including the column and row headers and any sum rows or columns. At least 3x3 cells
must be highlighted before this menu item is activated. Then start the AutoFormat
dialog.

The preview shows an example of how each selected format in the Format panel will
look. Click OK to apply the format to the selected range in the spreadsheet.

Note: If there is no change in color of the cell contents, then under Tools > Options > NeoOffice Calc >
View > Show or in the View menu, Highlight values may be checked. In this case, the specified colours will
be used.

A user-format can also be set as an AutoFormat:

1. Format a spreadsheet as desired.

2. Select the whole sheet, e.g. by clicking the empty button in the top left corner (above
the first row header).

3. Call up the AutoFormat dialog and click Add.... A dialog will appear where you can
give the new format a name.

The format defined in this way can then be used in the future on other spreadsheets. By
choosing an appropriate background color and a pattern for the cells in the sheet, an
eye-appealing spreadsheet is created.
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Use theMore button to display additional options in the dialog. In the additional section
that is then displayed, select which properties of the chosen format are to be excluded
from the automatic formatting. For example, removing the check mark in front of Font,
means the font will not be taken into account by the AutoFormat.

Layout of Spreadsheets

Sheets do not have to have the look of any of the predefined formats. There are many
ways to apply a different layout for spreadsheets, as well as tables in text documents.

Designing Spreadsheets Clearly
Calc assists in designing a sheet in a variety of ways. For example, here are three
different views of the same sheet, varying only in layout:

Illustration: This is a sample sheet without any special formatting, as it appears by default.

Illustration: The above graphic shows the sheet formatted using one of the AutoFormats; it will look
appealing without requiring any further editing.

Illustration: In this example, the sheet has been formatted with certain cell attributes in the Format >
Cells dialog. In addition the view of the grid lines and sheet headers has been deactivated in Tools >
Options > NeoOffice Calc > View and a graphics file loaded as background in Format > Page >
Background.
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Note: An image loaded via Format > Page > Background, is only visible in print, OS X Print Preview or via
File > Page View.

For a background image to appear on screen as well, insert the graphic image by choosing Insert > Picture
> From File and put the image behind the cells by way of the context menu command Arrangement > To the
Background. To later select the background image, use the Navigator.

Formatting Text in a Spreadsheet
1. Select the text for formatting.

2. Choose the desired text attributes from the spreadsheet Formatting toolbar.

Note: Format > Cells is another choice. The Format Cells dialog allows choosing various text attributes on
the Font tab page.

Formatting Numbers in a Spreadsheet
1. Select the cells containing the numbers to be formatted.

2. To format numbers in the default currency format or as percentages, use the icons on
the spreadsheet object bar. For other formats, choose Format > Cells.... Choose from
the preset formats or define a personal format on the Numbers tab page.

Formatting Borders and Backgrounds for Cells and Pages
• Basically, a format can be assigned to any group of cells by first selecting the cells (for
multiple selection, hold down the Cmd key when clicking), and then activating the
Format Cells dialog via Format > Cell. In this dialog, select attributes such as
shadows and backgrounds.

• To apply formatting attributes to an entire sheet, choose Format > Page. This permits
defining headers and footers, for example, to appear on each printed page.

Addressing Cells

Cells can be addressed directly by means of their coordinates in the row-and-column
matrix. Use absolute or relative referencing, or give cell ranges their own names.

Addresses and References, Absolute and Relative

Relative Addressing

The cell in column A, row 1 is addressed as A1. Address a range of adjacent cells by first
entering the coordinates of the upper left cell of the area, then a colon followed by the
coordinates of the lower right cell. For example, the square formed by the first four cells
in the upper left corner is addressed as A1:B2. By addressing an area in this way, you are
making a relative reference to A1:B2. Relative here means that the reference to this area
will be adjusted automatically when the formulas are copied.

Absolute Addressing

Absolute references are the opposite of relative addressing. A dollar sign is placed before
each letter and number in an absolute reference, e.g., $A$1:$B$2.
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Calc can convert the current reference, in which the cursor is positioned in the input line,
from relative to absolute and vice versa by pressing Shift-F4. When starting with a
relative address such as A1, the first time this key combination is pressed, both row and
column are set to absolute references ($A$1). The second time, only the row (A$1), and
the third time, only the column ($A1). Pressing the key combination once more, both
column and row references are switched back to relative (A1)
Calc shows the references to a formula. If, for example, the formula
=SUM(A1:C5;D15:D24) is clicked in a cell, or highlighted in the input line, the two
referenced areas in the sheet will be highlighted in color. For example, the formula
component A1:C5 may be in blue and the cell range in question bordered in the same
shade of blue. The next formula component D15:D24 can be marked in red in the same
way.

When to Use Relative and Absolute References

First examine what happens without a relative reference. Assume a calculation in cell E1
that sums the cells in range A1:B2. The formula to enter into E1 would be:
=SUM(A1:B2). If, later, a new column must be in front of column A, the elements to be
added would then be in B1:C2 and the formula would be in F1, not in E1. After
inserting the new column, all formulas would therefore have to be checked and corrected
in the current sheet, and possibly in other sheets.

Fortunately, Calc does this work automatically. After inserting a new column A, the
formula =SUM(A1:B2) is updated to =SUM(B1:C2). Row numbers are also
automatically adjusted when a new row 1 is inserted. Absolute and relative references are
always adjusted in Calc whenever the referenced area is moved. But be careful when
copying a formula since in that case only the relative references will be adjusted but not
any absolute references.

Absolute references are used when a calculation refers to one specific cell in the sheet.
For example, if a formula that refers to exactly this cell is copied relatively to a cell
below the original cell, the reference will also be moved down if the cell coordinates are
not defined as absolute. Aside from when new rows and columns are inserted, references
can also change when an existing formula referring to particular cells is copied to another
area of the sheet. Assume, for example, the formula =SUM(A1:A9) is entered in row 10
but the calculated sum must be in the adjacent column to the right. In this case, simply
copy this formula to the cell to the right. The copy of the formula in column B will be
automatically adjusted to =SUM(B1:B9).
There are many methods to copy a formula, one of which is:

1. Select the cell containing the formula.

2. Choose Edit > Copy, use the Copy icon on the Standard toolbar, or press Cmd-C to
copy it.

3. Select the cell into which the formula is to be copied.

4. Choose Edit > Paste, use the Paste icon on the Standard toolbar, or press Cmd-V.
The formula will be positioned in the new cell, and all non-absolute references will be
updated.
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Copying a formula into multiple cells can be quick and easy. One way to copy into
adjacent cell areas is as follows:

1. Select the cell containing the formula.

2. Position the mouse on the bottom right of the highlighted border of the cell, and
continue holding down the mouse button until the pointer changes to a cross-hair
symbol.

3. With the mouse button pressed, drag it down or to the right over all the cells into
which the formula will be copied.

4. Upon releasing the mouse button, the formula will be copied into the cells and
automatically adjusted.

Where values and texts must not be automatically adjusted, hold down the Cmd key
when dragging. Formulas, however, are always adjusted accordingly when dragging.

Now look at what happened when rows and columns are added. Assume a calculation in
cell E1 that sums the cells in range A1:B2. The formula to enter into E1 would be:
=SUM(A1:B2). If, later, a new column must be in front of column A, the elements to be
added would then be in B1:C2 and the formula would be in F1, not in E1. After
inserting the new column, all formulas would therefore have to be checked and corrected
in the current sheet, and possibly in other sheets.

Fortunately, Calc does this work automatically. After inserting a new column A, the
formula =SUM(A1:B2) is updated to =SUM(B1:C2). Row numbers are also
automatically adjusted when a new row is inserted. Absolute and relative references are
always adjusted in Calc.

Addressing by Name
A neat way of making the references to cells and cell ranges in formulas legible is to give
the ranges names. For example, name the range A1:B2 as Start then in the formula
simply enter =SUM(Start). Following the insertion or deletion of rows and columns
NeoOffice also correctly assigns the ranges identified by name. Remember, range names
cannot contain any spaces.

For example, it is much easier to read a formula for sales tax if written as = Amount *
Tax_rate instead of = A5 * B2. In this case, cell A5 would be named as Amount and
cell B2 as Tax_rate.

In order to specify range names, follow these steps:

1. First highlight the area to be named.

2. Select Insert > Names > Define, or use the Cmd-F3 key combination.
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3. Enter the name for the first area.

4. Click Add.

Other cell ranges can also be named in this dialog by entering the desired name in the
field and then selecting the respective cells. Use the Define Names dialog to define
names for formulas or parts of formulas needed more often.

5. Close the dialog with OK.

Recognizing Names as Addressing
NeoOffice can correlate names with areas for the most part automatically, as long as the
row and column coordinates are entered. Refer to the following graphic.

The automatic formula recognition allows entering, for example, the formula
=SUM(July) in cell B8. This formula can then be copied to the right. Cell C8
automatically shows the formula =SUM(August), cell D8 =SUM(September), and so
on. This feature also works for horizontal calculations. Try it out by entering the formula
=SUM(London) in cell E4. The New York entry must be treated as a special case
because this name contains a space. Thus, it must be enclosed in single quotation marks:
=SUM('New York').
Automatic recognition does not work with formulas. You cannot enter the formula
=SUM(sum) in cell E8. Instead, enter =SUM(B8:D8) or =SUM(E3:E6). The latter
formula will also be inserted automatically if the cursor is placed in cell E8 and the Sum
icon in the Formula bar is clicked.

This function is active by default. To turn it off, select Tools - Options... > Spreadsheet
Document > Calculate and uncheck the box in front of Automatically find column and
row labels.

Use Insert > Names > Labels.... to define any names required as shown in the previous
section.

Note: To have names automatically recognized, names must consist of alphanumeric characters and the first
character must be a letter. To use non alphanumeric characters (including spaces), enclose the names in
single quotation marks ('). Where a single quotation mark appears in a name, e.g., Jan '97, enter a
backslash in front of the quotation mark (Jan \'97). This type of referencing is not compatible with earlier
versions of NeoOffice.

Calc automatically recognizes an area, called a range, of cells that belong together.
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Only Copy Visible Cells
Assume you have hidden a few rows or columns in a cell range and now only the visible
cells are to be copied.

Calc behaves differently depending on the method used to hide the invisible cells and
what is the intended action to be performed upon them.

Method Result

Cells were filtered by AutoFilters, standard filters
or advanced filters.

Copy, delete, move, or format a selection of
currently visible cells.

Only the visible cells of the selection are
copied, deleted, moved, or formatted.

Cells were hidden using the Hide command in the
context menu of the row or column headers, or
through an outline.

Copy, delete, move, or format a selection of
currently visible cells.

All cells of the selection, including the
hidden cells, are copied, deleted, moved,
or formatted.

Referencing a Cell in Another Document
Cells can also be referenced in other spreadsheets:

1. For the following example, the source document is named
'HD/User/Spreadhseets/test.sxc'; and it contains a sheet named Sheet1.

2. Open a different or new spreadsheet document.

3. Place the cursor in cell A1 and enter the following formula:
='HD/User/Spreadhseets/test.sxc '#Sheet1.A1

4. Alternatively, enter the file name as a URL designation:
='file:///HD/User/Spreadhseets/test.sxc '#Sheet1.A1. Similarly access a file on
the Internet by using: ='http://www.sun.com/test/test.sxc'#Sheet1.A1.

5. Drag the box in the lower right corner of the active cell to select a range of cells.
NeoOffice automatically inserts the corresponding references in the adjacent cells. As
a result, the sheet name is preceded with a "$" sign to designate it as an absolute
reference.
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Using References in Formulas

So far you have been introduced to formulas containing absolute values, absolute and
relative references and references to named ranges. Occasionally we have also mentioned
the Wizard: Functions. Here is an example of references used in formulas, with the help
of the Wizard: Functions.

Consider the example from the previous topic. Now, use the functions Wizard to calculate
the average of monthly sales for each location.

1. Position the cursor in cell B8, where the average will be displayed. Activate the
Wizard: Functions by clicking its icon on the formula bar.

2. Select the AVERAGE function. Where the category that contains this function is
unknown, simply leave the default set to all categories and repeatedly press the letter
A until the AVERAGE function is selected.

3. Click Next in the Wizard: Functions. On the right half of the Wizard, another input
area will appear where you can enter the arguments of the function.

4. Click in the input field into which values are to be entered, in this case starting with
field number 1. Enter either B3:B6 or July or use the mouse to select that range in the
sheet. To do so, simply click on the first cell, B3, hold down the mouse button and
drag to B6.
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While dragging the mouse to highlight the desired range, the Wizard dialog will be
automatically minimized so that only the active input field is visible. The field
indicates the area being selected with the mouse. The dialog can be reduced or
enlarged manually by clicking the Shrink / Maximize button to the right of the input
field.

5. Finally, click OK to close the Wizard.

The formula is calculated according to the given arguments, and the final result appears
in cell B8.
References to Other Sheets
In any sheet cell, you can show a reference to a cell in another sheet.

1. Open a new, empty spreadsheet.

2. For example, enter in cell A1 of Sheet1 the following formula and complete the input
with the Return key:

=Sheet2.A1
3. Now click the sheet tab labelled Sheet2 on the bottom window border to go to
Sheet2 of the current document. Set the cursor in cell A1 there and enter text or a
number.

4. Upon switching back to Sheet1, see the same content in cell A1 as was entered on
Sheet2. If the contents of Sheet2.A1 change, then the contents of Sheet1.A1 also
change.

In a corresponding way, a reference can also be made to a cell of another document.
Open another spreadsheet in addition to the new spreadsheet, which is already saved as a
file (this does not work unless a document has previously been saved).

1. If the samples from http://www.pathtech.org/OpenOffice.org/templates/ are installed
[Note: these were wiped out by a disk crash and Movie1 does not appear to have been
recovered], choose File > Open and open the Movie1 document from the spreadsheet
samples.

2. Change back to the new, still almost empty spreadsheet. Set the cursor in a free cell
and enter an equals sign to begin a formula.

3. Now switch to the document that has Movie1 loaded. Click cell C3.
4. Switch back to the new spreadsheet. In the calculation row notice that Calc has added
the reference to the formula. visits.C3

5. Confirm the formula by clicking the green check mark.

The reference to a cell of another document contains the name of the other document in
single inverted commas, then a hash #, then the name of the sheet in the other document
followed by a point and the name of the cell there C3.
The name of the sheet automatically receives a leading dollar sign, since the sheet has
absolute addressing.
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Examine the name of the other document in this formula and notice that it is written as a
URL. This means that a URL from the Internet can be entered too. For example,
supposing there is an Internet page containing current stock exchange information in
spreadsheet cells, just follow these steps to load this page in Calc:

1. In a Calc document, position the cursor in the cell where you wish to start inserting the
external data.

2. Select Insert > External Data. The External Data dialog appears.

3. In the dialog, enter the URL of the document or Web page. Write the URL in the
following way: (fictional example) http://www.my-broker.com/table.html. Enter a file
name from the local or network file system in the usual way, i.e., via the File > Open
dialog.

NeoOffice loads the Web page or file in the background, that is, without displaying it.
In the large list box of the External Data dialog are the names of all the sheets or
areas from which to choose.

4. Select one or more sheets or areas, optionally activate the automatic update function to
every n minutes and click OK.
The contents are inserted as a link in the Calc document.

5. Save the spreadsheet. Upon re-opening, Calc updates the linked cells.

6. Under Tools > Options > NeoOffice Calc > General, choose to have the update, on
opening, execute always, upon request or never. The update can be started manually in
the dialog under Edit > Links.

Using Charts

Data from spreadsheets can be represented graphically in a chart. A wide variety of charts
and diagrams suited for illustrating the structure of the data can be selected and created
from a spreadsheet.

1. Open an existing spreadsheet or enter data in a new sheet with row and column
headings.

2. Select the data together with the headings.

3. Click the Insert Chart icon found in the Main toolbar. The cursor will
change to a cross-hair symbol with a small chart symbol.

4. In the spreadsheet document, open a selection rectangle defining the location and size
of the chart. Both can be modified subsequently.

5. As soon as the mouse button is released, a dialog appears that makes further entries
possible. Simply clicking the Create button creates a chart with the default settings.
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This example, using Movie1.sxc from the sample archive mentioned above, shows the
number of times people of different age groups in various cities go to the movie theater
annually.

If the age groups, rather than the towns, should appear on the horizontal axis, tilt the
chart. As long as the chart remains selected, the main toolbar contains a Data in
Columns icon. Click and rotate it with the mouse.

Other changes to the individual elements of the chart are also possible. Either double-
click on the individual parts of the chart or, with the chart selected, choose the individual
functions from the Format menu. For example, double-clicking on the colour preview in
the legend automatically reformats all relevant data points. On the other hand, clicking on
the background in the box of the legend, formats the background to the legend.

If the chart was created from the data of a Calc spreadsheet, clicking on the data series in
the chart becomes highlighted.

Suppose there's a Calc spreadsheet in the background, and now it needs
to be selected for further editing. Open the Show Draw Functions
floating toolbar and select the first tool, the Select arrow. This allows
the chart to be selected by clicking.
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In a Calc chart, a data series can be forwards or backwards. A series can be arranged in
such a way that the lowest 3D representations are as far forward as possible, and the
higher ones further back. To change the arrangement in the chart, use the appropriate
command from the context menu of a data series or choose Format > Arrangement.
The output data in the Calc spreadsheet will not be rearranged.

Note: When a chart is inserted in a presentation or drawing document with the Insert > Insert Chart floating
toolbar, it is displayed with a set of sample data. To insert a chart in a spreadsheet, highlight the cells in the
spreadsheet whose values should be displayed in the chart.

In Writer documents too, charts can be inserted that are obtained from the data of a Writer table. Where no
data are selected in a NeoOffice Writer table, selecting Insert > Object > Chart also inserts a chart
containing sample data in NeoOffice Writer.

Values in a chart containing sample data can be changed by double-clicking on the chart and then choosing
Edit > Chart Data. When the values of a chart obtained from selected data are changed, the values in the
cells of the table must be changed. If the chart is in a text document, press (F9) to update the chart.

Modification of chart data is also possible if, for example, a chart is copied a chart from a Calc document
into a Writer document and is now double-clicked in the Writer document. Remember, however, only this
copy is being edited and not the original document.

The type of chart can also be changed, after the fact. Double-click on the chart and
choose Format > Chart Type.A dialog appears offering various types from which to
choose.
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Experiment with the different options in the Chart Type dialog. Try switching between
2D and 3D representations. With the Columns chart type, a Combination Chart of lines
and columns can be created.

• The three-dimensional representations make special effects possible. In 3D charts, one
can even adjust the illumination settings, such as light source, ambient light and the
colour filter.

• 3D charts can be rotated and flipped with the mouse for optimal design.

• By choosing Insert > Statistics, users can apply statistical indicators to XY charts,
such as standard deviations, with regression curves and more besides. A single or
double logarithmic representation of the axes can also be set here.

• In line charts. there are various icons that can be applied automatically via NeoOffice
Chart, as desired. Manual application is also possible, using graphic files or graphics
from the Gallery such as Bullets.

In a chart, individual data series or data points can be selected by clicking on them and
then opening the context menu to choose one of the numerous options to format the view.

Editing Chart Titles
Suppose you have inserted a chart in a Calc document and want to change the title.

1. Double-click on the chart.

A gray border appears around the chart and the menu bar now contains commands for
editing the objects in the chart.

2. Double-click on the default title text. A gray border appears around the text, which can
now be changed.

3. Press Return to create a new line.

4. A single-click on the title, instead of double-clicking, allows moving it with the
mouse.

5. Select Format > Title > Main Title to edit the formatting of the main title. This
opens the Title dialog.

6. Select the Characters tab to change the font or other similar attributes.

7. Click OK.

8. In the document, click outside the chart to exit chart editing mode.

Editing Chart Legends
Suppose there is a chart in a Calc document that requires application of a color gradient
to the legend.

1. Double-click on the chart.

A gray border appears around the chart and the menu bar now contains commands for
editing the objects in the chart.

2. Select Format > Legend or double-click on the legend. This opens the Legend
dialog.
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3. Select the appropriate tab, for example, the Area tab for modifying the background of
the legend.

4. From the pull-down list select Gradient.

5. Select a gradient from the list.

6. Click OK.

7. In the document, click outside the chart to exit chart editing mode.

Note: You can define custom gradients, hatching, bitmaps and colors in NeoOffice Draw.

To select the legend, first double-click on the chart (see step 1), then click on the legend. Now the legend
may be moved within the chart using the mouse.

If the legend is moved over another object of the chart, its Properties dialog can no longer be opened by
double-clicking on it, as Calc won't know which object is meant. To open the Properties dialog either use the
Format menu or click once on the legend, then open the context menu and select Object Properties. The
same applies to all other objects of the chart.

Adding Texture to Chart Bars
Assign a bar type to a bitmap rather than, say, using full color.

1. Switch to edit mode by double-clicking on the chart.

2. Double-click on the corresponding bar (all bars of this color are now selected).

3. From the context menu, select the Object Properties entry

4. Choose the Area tab page.

5. Click on Bitmap. Now select a bitmap from the list box as texture for this bar.

6. Click OK to accept the setting.

Editing Chart Axis
When the scale of the vertical Y axis requires changing, do the following:

1. Double-click on the chart.

A gray border appears around the chart and the menu bar now contains commands for
editing the objects in the chart.

2. Select Format > Axis > Y axis to edit the Y axis, or double-click on the Y axis. This
opens the Y axis dialog. Modify as needed.

Tomodify the scale of the y-axis,

1. Select the Scale tab and make any adjustments.

2. Click OK.

3. In the document, click outside the chart to exit chart editing mode.
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Database Functions in Calc

Spreadsheets in Calc are also able to manage records consisting of several fields, as in a
database. Think of each row of the Calc spreadsheet as a record, whose fields are
arranged in the individual columns. Then, for example, sort or group the Calc database by
rows, look for key words and calculate totals.

Note: The database ranges in Calc spreadsheets have nothing to do with the databases and spreadsheets that
are addressed in Tools > Data Sources and edited in the data source browser (F4).

In Calc, a spreadsheet can contain several sheets which are manipulated. Combining several adjacent rows
of a spreadsheet into a database area is a way, for example, to sort them together. Furthermore, external
files can be imported into a Calc spreadsheet, for example files in dBase format, The records from the dBase
file would then become rows and the data fields would become columns in a Calc spreadsheet.

In the data source browser, on the other hand, the dBase file (or other data source) is edited directly, and
SQL queries, for example, may be performed.

Defining Database Ranges
For example, if you would like to manage the household budget with Calc, enter the
records in an empty Calc spreadsheet and select the area as a database range.

Creating Records in a Spreadsheet
1. Open a new spreadsheet.

2. Enter the column titles in the first row, e.g. “Date” in cell A1, “Item” in cell
B1,“Amount” in C1. Then enter some information.

To format the sheet in the same manner as in the illustration above, proceed as follows:

1. Select row 1 by clicking on the row header.
2. Click the Bold icon.

3. Select the entire column A by clicking on the column header.
4. Open the context menu

5. Choose Format Cells.

6. In the Format Cells dialog, click the Numbers tab

7. Choose a date format for Column A.
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8. Select column C by clicking on the column header,
9. Apply a currency format. Clicking the Number Format: Currency icon on the object
bar is sufficient.
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Defining Database Ranges
1. Select the three column area and define the selected area as a database range by
choosing Data > Define Range.

2. The selected range already appears in the Define Database Range dialog. Be sure to
mark the check box Contains column headers so that the first row is correctly taken
into account. This box becomes visible when theMore button is clicked.

3. Enter a name for the range

4. Close the dialog with OK.

The selected range is now defined as a database range, which among other things, means
that the rows (records) can be conveniently sorted. Any sort lists and filters that have
been defined for the database range will also be updated.

Sorting Database Ranges
Select a range of cells and define these as a database range by choosing Data > Define
Range.

Set the cursor in the database range and choose Data > Sort. In the dialog that appears,
select the column to be sorted, for example, Amount, as the sort criterion and click OK.
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Up to two additional criteria can be specified, one to follow the other, for the sort
function. For instance, sort the expenditures first by date, as above, then by item if they
have the same date, and then by amount if they have the same date and item.

Filtering Database Ranges
To filter out only certain records so that they can be modified, use the spreadsheet
filtering function. Choose between using a dialog to specify the criteria exactly (in that
case range definitions are also possible), or creating an AutoFilter that will help filter
according to specific values or text.

Imagine that the output list is already 8000 records long. With this number of records it is
no longer possible to get an overview. Now, let's say that you decide to show only those
records that occurred after 1/2/2000 and which also involve an amount in excess of 100
currency units. Here is one way:

1. Set the cursor in the database range

2. Choose Data > Filter > Standard Filter to open the dialog.

3. Enter the following:

a) Date > 1/2/2000 AND Amount > 100.

In the dialog, the existing contents of the data fields in the pull-down lists can be
selected, or an amount, say100, can be entered directly.
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If OK is clicked at this time, only those records that meet all criteria are shown. Select
Data > Filter > Remove Filter to reset the view.

Displaying only records with a specific content is easily done with the aid of the
AutoFilter:

1. Place the cursor in the database range.

2. Click on the AutoFilter icon on the main toolbar. The column headers of the database
range have now been given small buttons.

3. Click on the button next to the Date field and select for example, 1/2/00. Only records
that contain this date will be shown.

On the main toolbar, reset the view with the AutoFilter icon.

Grouping Database Ranges and Calculating Subtotals
Assuming there is sample data that can be expanded and actually used for a budget, the
date should be summarized and printed in totals and subtotals. This can be done in just a
few steps.

1. Place the cursor in the database range.

2. Choose Data > Subtotals. The Subtotals dialog appears.

3. Specify the desired options for calculating the subtotals.

4. Group subtotals according to Date (i.e. calculates a new subtotal for each date), and
5. Use the function Sum (adds the subtotals) to calculate Amount.
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When you press the Return key or click OK, the sheet will be grouped according to the
subtotals. For every group of entries with an identical date, a subtotal is calculated. The
grand total is displayed at the bottom.
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Notice the controls to the left of the row headers. These enable you to view which
records (rows) have been summarized. Clicking on a minus sign shows only the row with
the results. The easiest way to control the display is with the small digits above the group
area, shaded in blue here.When 1 is clicked, only the grand total is displayed. Clicking 2
reveals the subtotals, while selecting 3 shows all elements.
Transferring Data From a Data Source to a Spreadsheet
Individual tables of data from the data source browser are transferable into a Calc
spreadsheet document.

There is a choice of two different methods for transferring the data. One, the desired
database file, in dBase or text format, can be loaded directly via the File > Open dialog,
in which case the whole database table is imported into a Calc spreadsheet document. Or,
two, the data can be transferred by dragging and dropping what is selected.

Opening a Database File in Calc

Open a dBase or text format document as one opens any NeoOffice file.
1. Choose File > Open.

2. In the dialog, go to the folder where the database file is located.

3. Enter the name of the file or go to the File type list box, select dBase, for example.
4. Select the name.

5. Click Open.

To open a text document, select the file type Text CSV.
When making a dBase import, a dialog opens, from which the user chooses the character
set of the file. The dBase IV format uses Codepage 437 (US).

After confirming this dialog with OK, the database file is loaded in the Calc spreadsheet
document.
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The first row provides information on the type and length of the individual data fields.
This information is contained as dBase header in the file. (When saving a Calc sheet with
the file type dBase, the first row of data is used to create the header information.)

Before working on the data in the spreadsheet, we would like to introduce the second
method for transferring selected records from the data source view to the Calc
spreadsheet.

Dragging and Dropping Copies into Spreadsheets
This method works with all formats, and users have the choice of transferring all or only
selected records into the spreadsheet document. To use this method, log into the data
source in Calc.

1. Choose Tools > Data Sources.

2. The Data Source Administration dialog opens.

3. Click New Data Source.

4. In the Database type field, select dBase to log into a dBase database.
5. Click the “...” button

6. Select the folder containing the database file(s) in *.dbf format.
7. Click OK.

8. In the Name field, enter a name to be displayed for the data source.

9. Click Apply.

10.Click the Tables tab. Put a check mark next to the names of the table(s) needed in the
data source view.

11.Click OK.

12.Open the data source browser (F4).

13.Click on the plus (+) sign next to Tables to view the existing tables in the database.
14.In a dBase database, each *.dbf file in the directory is a table of its own.
15.Click the name of the table. The records are displayed in the data source browser.

16.

Select the records and insert them into the spreadsheet.
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1. Tomanually select a record(s) for transfer into the spreadsheet, click the row header of
the record (the gray field without text at top left). Click the first and last record row
headers of a continuous range of records while pressing the Shift key to select the
range, or hold down the Cmd key and click the desired records individually.

2. Drag the selected records to the row headers in the sheet where the records are to be
inserted. Then release the mouse button.

To automatically transfer only specific records from a large database into the spreadsheet,
use the filters in the data source browser:

1. Set the cursor in the data field which contains the data (should be the same in all
filtered records). For example, to filter only records that have Main Street in their
address, place the cursor in a field containing Main Street.

2. Click the AutoFilter icon.

3. Now only the records containing the precise text, Main Street, are visible.
4. Select the Main Street records. For example, using the Shift key as described above,
drag the selected records into the spreadsheet document and release the mouse button
at the point where the first field should be inserted.

Evaluating Data With Calc

Calc provides several powerful tools for evaluating data. The DataPilot helps produce
any kind of sub-evaluation of the data as a separate spreadsheet. With the DataPilot,
analyzing the data thoroughly is made easy via consolidation, Goal Seek and multiple
operations.

DataPilot
The DataPilot helps to analyze and assess data that has already been entered.

It allows you to generate reports from a number of points of view, using one and the
same set of data.

Imagine a data analysis table containing a company's sales figures, not only for specific
product groups, but also for branches and years. Use the DataPilot to quickly find the
data which is interesting and pertinent to current requirements.
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What use is the DataPilot?
A table that has been created with the DataPilot is an interactive table, i.e. data can be
arranged, rearranged or summarized according to different points of view. This
functionality is especially useful for Sales Control. On the one hand it may be important
to view the turnover figures at regular intervals, while on the other hand it may be
relevant to analyze sales figures on a regional basis.

Creating DataPilot Tables
1. Select the data range of a table together with the row and column headings, i.e. On this
table leave the heading “Sales” off the selection.

2. Choose Data > DataPilot > Start. The dialog Select Source appears.

3. Select the option Current selection.

4. Confirm with OK..

5. The column headings of the table will be shown as buttons in the DataPilot dialog,
which can then be positioned via drag and drop as required in the layout areas
Column, Row and Data.

6. Drag the required fields into one of the three areas. The field will be dropped
accordingly.
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If the button is dropped in the Data area it will be given a caption that also shows the
formula that will be used in the data range to create the data. If the “1998” button is
dragged into the Data area, it shows as “Sum-1998”
• Double-clicking on one of the fields in the Data area calls up the Data Field dialog.

• Use this dialog to select the functions to be used for displaying the data in the data
area. Tomake a multiple selection, press the Cmd key while clicking the functions.

• The order of the buttons can be changed at any time, by simply moving them to a
different position in the area with the mouse.

• Replace a button by dragging it to the other buttons.

• When double-clicking one of the buttons in the Row or Column area, the Data Field
dialog appears. Here, select if and to what extent Calc should calculate and display
subtotals.

Exit the DataPilot by pressing OK. A Filter button will now be inserted into the table.
The default position is under the selected area, and two lines further down. The
DataPilot table is inserted with a bold outline as shown below.
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Use the Filter button to break down the elements of the chart. For example, to find out
how Miami had done in the 1998 figures, press the Filter button, select Area and use the
drop-down menu to select Miami.

The results are shown in the same area of the page:

Selecting DataPilot Output Ranges
Click the buttonMore in the DataPilot dialog. The dialog will be extended. Select a
named area from the list box Results to in which to create the DataPilot table. If the
required output area does not have a name, enter the coordinates of the upper left cell of
the area into the field to the right of the list box Results to. Clicking on the appropriate
cell with the mouse also enters the coordinates.

By activating the check box Ignore empty rows, you ensure that these will not be taken
into account when the DataPilot table is created.

If the check box Identify categories is activated, the categories will be recognized by
means of their headings and assigned accordingly when the DataPilot table is created.

Editing DataPilot Tables
Click one of the buttons in the table that the DataPilot has created and hold the mouse
button down. A special symbol appears next to the mouse pointer.

Dragging the button to a different position in the row alters the order of the columns. If a
button from the row to the left edge of the table is dragged into the line headings area, a
column can be changed into a row. The mouse pointer alters its appearance from the icon
for a column heading to that of a line heading.

NeoOffice User Guide for 2.x 245



Chapter 4: Spreadsheets in Calc

To remove a button from the table, just drag it out of the table. Release the mouse button
when the mouse pointer becomes a not allowed icon. The button is, thus, deleted.

Note: Double-clicking on the name of a table element hides or shows the merged elements below it.

Filtering DataPilot Tables
Although the DataPilot tables are usually created according to your requirements, there
may be occasions when not all of the data provided by the tables is of interest. If this
should be the case, filters should be used that apply conditions to the data such that if the
conditions are not met the excess data is removed from the tables.

Click the Filter button in the sheet to call up the entry mask for the filter conditions. The
Filter dialog will appear. This dialog provides different criteria which can be used for
selecting data.

Updating DataPilot Tables
If the data of the base table has changed, Calc recalculates the tables to bring the analysis
up-to-date. Here are the steps involved in recalculating the tables:

1. Click with the right mouse button or Ctrl-click on one of the button fields

2. Choose the Refresh entry or choose Data > DataPilot > Refresh.

Deleting DataPilot Tables
To delete a DataPilot table, select any cell in the analysis table, then choose Data >
DataPilot > Delete.
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Consolidating Data

During consolidation, the contents of the cells from several sheets will be combined in
one place. Choose a function so that, for example, you can display the sum, the standard
deviation or the variance of the data.

1. Open the document that contains the areas to be consolidated.

2. Choose Data > Consolidate to open the Consolidate dialog.

3.

4. From the Source Data Area list box, select an area as a starting point to consolidate
with other areas.

5. If the area is not named, click in the field next to the Source Data Area. A blinking
text cursor appears. Type a reference for the first source data area or select the area in
the sheet with the mouse.

6. Click Add to insert the selected area as a Consolidation Area.

7. Select additional areas and click Add after each selection.

8. Specify where to display the result by selecting a target area from the Copy results to
list box.

9. If the target area is not named, click in the field next to Copy results to and enter the
reference of the target area (or the top left cell in the target area). Alternatively, select
the area using the mouse or simply position the cursor in the top left cell of the target
area.

10.Select a calculation rule for determining how the values of the consolidation areas
should be linked. The sum function is the default setting.

11.Click OK to consolidate the area.

Let's say that you don't wish to create a new sheet, independent from the source areas.
Rather, you would prefer to retain links to the source areas or consolidating areas in
which the order of rows or columns varies. Click theMore button in the Consolidate
dialog.
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1. Select Link to Source Data at the bottom of the window to insert only the formulas
that generate the results in the target area, rather than the actual results. With linked
data, any values modified in the source area are automatically updated in the target
area. The corresponding cell references in the target area are inserted in consecutive
rows, which are automatically ordered and then hidden from view. Only the final
result, based on the selected calculation rule, is displayed.

2. Under Consolidate by do the following:

a) Select either Row Labels or Column Headers if the cells of the source area are to
be consolidated according to a matching row label or column header rather than to
the identical position of the cell in the area.

To consolidate by row or column headers, the text must be contained in the selected
source areas, or included in the selection with the mouse.

The data from the consolidation and target areas is saved when the document is saved. If
you later open a document in which consolidation has been defined, this data will again
be available.

Note: The text in the headers or labels must be identical, so that rows or columns can be accurately
matched. If the row or column label does not match any that exist in the target area, it will be appended as a
new row or column.

Applying Goal Seek

With the help of Goal Seek you can calculate a value that, as part of a formula, leads to
the result specified for the formula. Thus the formula is defined with several fixed values
and one variable value and the result of the formula.

Goal Seek is best illustrated by means of an example.

To calculate annual interest, create a table with the values for the capital (C), number of
years (n), and interest rate (i). The formula is: I = C * n* i / 100

Note: Formula can also be entered using the variable names:
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Interest = Capital * Year * Interest rate / 100.

In this example, the investment capital of $150,000 and an interest rate of 7.5% is
calculated to result in annual interest income of $11,250. (The cells are formatted after
calculation: A5 and E5 as currency, and C5 as percent. The cell width is adjusted
automatically.)

For ease of use, assign names to cells so that they can be used in the formula.

Naming Cells
Using the example graphic above:

1. Select cell A5 in the example
2. Select Insert > Names > Define. The Define Names dialog appears.

3. Enter the name C in the text field. At the bottom of the dialog, the reference:
$Sheet1.$A$5 is displayed.

4. Double-check for accuracy.

5. Click Add.

6. In the next field, enter n, set the cursor in cell B5.The number of years appears in B5.
7. Click Add.

8. Next, enter i in the empty field, set the cursor in cell C5. The interest rate appears in
C5.

9. Click Add.

10.Close the dialog with OK.

11.Now enter the formula in E5 using the variables = C*n*i instead of =A5*B5*C5.
Start Goal Seek
Assume an interest rate of 7.5% and that the number of years (1) will remain constant.
However, the user may want to know how much more or less investment would be
needed to attain a particular annual return. For example, calculate how much capital
would be required for an annual return of $15,000 by performing the following steps:
1. Place the cursor in cell E5.
2. Select Tools > Goal Seek and the Goal Seek dialog appears.
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3. The correct cell, (E5), should already be entered in the field Formula Cell.
4. Place the cursor in the field Variable Cell.

5. In the sheet, click in the cell (A5) that contains the value to be changed.
6. Enter the expected result of the formula (i.e., the desired value) under Target Value.
In this example, the value is 15,000.

7. Click OK.

8. A dialog appears with the result of the Goal Seek. The result is provided for use as
desired. If the result should be used, click Yes to enter the result in cell A5.

Applying Multiple Operations

Multiple Operations in Columns or Rows

If the data of a data range is one above the other (for columns) or next to each other (for
rows), select the data range together with the cell or cell range next to or below it as the
target range. In the Column/Row field, enter the cell reference to the first cell in the data
range. In the Formula field, enter the cell reference to the cell with the formula that
applies to the data range.

Examples

The company produces toys which sell for $10 each. Each toy costs $2 to make, in
addition to which there are fixed costs of $10,000 per annum. How much profit will be
made in a year, if a particular number of toys are sold?

Consider the following table:
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A B C D E F

1

Selling
price

10 Annual
sales

Annual profit Profit
per
item

2
Direct
costs

2 500
-6000

-12

3
Fixed
costs

10000 1000
-2000

-2

4 Quantity 2000 1500 2000 1.33

5
Profit = B4*(B1 - B2) -

B3
=B5/B4 2000

6000
3

Calculating With One Formula and One Variable

1. Open a new spreadsheet for this tutorial.

2. To calculate the profit, first enter any number as the quantity (items sold) > in this
example 2000. The profit is found from the formula Profit=Quantity * (Selling price -
Direct costs) - Fixed costs. Enter this formula in B5.

3. In column D enter certain annual sales one under the other, e.g. in steps of 500 from
500 to 5000.

4. Highlight the range D2:E11, and thus the values in column D and the empty cells
alongside in column E.

5. Choose Data > Multiple operations.

6. With the cursor in the Formulas field, click cell B5.
7. Set the cursor in the Column field and click cell B4. This means that the quantity in
B4 is the variable in the formula which is replaced by the highlighted column values.

8. Close the dialog with OK.

9. Profit will be displayed in column E.

Calculating with Several Formulas Simultaneously

1. Use the spreadsheet created above/

2. Delete column E.
3. Enter = B5 / B4 in C5:. This calculates the annual profit per item sold.
4. Select the range D2;F11. i.e all three columns.
5. Select Data > Multiple Operations.

6. With the cursor in the Formulas field, mark cells B5 through C5.
7. Set the cursor in the Columns field and click cell B4.
8. Close the dialog with OK.

9. Profit will be displayed in column E and the annual profit per item in column F.
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Multiple Operations Across Rows and Columns
Calc allows joint multiple operations for columns and rows in, so-called, cross-tables.
The formula cell has to refer to both the data range arranged in rows and the one arranged
in columns. Select the range defined by both data ranges and call the multiple operation
dialog. Enter the reference to the formula in the Formula field. The Row field is used to
enter the reference to the first cell of the range arranged in rows and the Column field
the first cell of the range arranged in columns.

Calculating with Two Variables

Consider columns A and B of the sample table above. Now try varying not only the
quantity produced annually, but also the selling price, and calculate the profit in each
case.

Expand the table shown above so that D2 through D11 contain the numbers 500, 1000
and so on, up to 5000. In E1 through H1 enter the numbers 8, 10, 15 and 20.

A B C D E F

1
Selling
price

10 Annual
sales

8 10

2
Direct
costs

2 500 -7000
-6000

3 Fixed costs 10000 1000 -4000 -2000

4 Quantity 2000 1500 -1000 2000

5
Profit = B4*(B1 - B2) -

B3
2000 2000

6000

1. Highlight the range D1:H11.
2. Select Data > Multiple Operations.

3. With the cursor in the Formulas field, click cell B5.
4. Set the cursor in the Rows field and click cell B1. This means that B1, the selling
price, is the horizontally entered variable (with the values 8, 10, 15 and 20).

5. Set the cursor in the Column field and click in B4. This means that B4, the quantity,
is the vertically entered variable.

6. Close the dialog with OK.

7. See profits in the range E2:H11. In some cases, pressing F9 is needed to update the
table [Note: this may conflict with Exposé operation in OS X: if so, the Exposé
shortcut can be turned off in System Preferences].

Using Scenarios

Scenarios are important aids for making numbers that are dependent on each other and
their resulting calculations visible.
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Modify specific basic requirements in the table and see the new result. Name a scenario,
created in this manner, and compare it with other scenarios.

Using Ready-Made Scenarios
If the samples from http://www.pathtech.org/NeoOffice/templates/ are installed, choose
one of the ready-made example scenarios with which to work.

Note: these samples appear to have been lost in a server crash in 2006.

1. Choose File > New > Templates and Documents and from the dialog open the
Samples.

2. Open the spreadsheet examples to see the spreadsheet documents available.

3. Double-click the document with Recar in the name.

This is a sample spreadsheet in which several scenarios have been created.

Areas in which the scenarios that differ by initial values are located are surrounded by
frames. Select the appropriate scenario in the list box appearing at the top of every frame.

Scenarios can also be selected in the Navigator:

1. Open the Navigator with the F5 key or the Navigator icon on the Standard toolbar.
2. Click the Scenarios icon in the Navigator (the icon with the three sheets).

In the Navigator, see the defined scenarios with the comments that were entered when the
scenarios were created.

Creating Personal Scenarios
Assuming that the spreadsheet used in the previous section is available, create a scenario
by selecting all the cells that provide the data for the scenario. For example, create an
additional scenario called High Dollar Rate using the following steps:
1. Select the cells that are already highlighted by the frame of the existing scenario.
Remember, multiple-select cells that are not contiguous, (i.e. that are distributed across
the table, may also be selected. To select multiple cells, hold down the Cmd key as each
cell is clicked. However, In this case, simply select the range F18:F23.
2. Choose Tools > Scenarios.... The Create Scenario dialog appears.
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3. Enter High Dollar Rate as the name of the scenario and leave the other fields at their
default values.

4. Close the dialog with OK. The new scenario is automatically activated.

4. Change any values in the frames to the values that are to apply to the new scenario. In
this case, modify the dollar rate and all other values that could be affected by it, i.e.
economic growth and sales prices. As changes are made, moments later the results from
these operating figures are displayed.

To discover which values in the scenario affect other values, choose Tools > Detective >
TraceDependents. Arrows appear, pointing to the cells that are directly dependent on
the current cell.
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Validity of Cell Contents

For each cell you can define, in advance, what type of contents will be valid for this cell.
This will make it easier for other users to employ these sheets correctly.

The validity rule is activated when a new value is entered. If an invalid value has already
been inserted into the cell, or if a value is inserted in the cell either with drag and drop or
by copying and pasting, the validity rule will not take effect. To determine and display
which cells contain invalid values, choose Tools > Detective at any time and select the
command Mark Invalid Data.
Additional details about Data Validity can be found in the NeoOffice Help.

Using Cell Contents Validity
1. Select the cells where you want to define a new validity rule. Where needed, select
multiple cells by clicking on all respective cells while holding down the Cmd key.

2. The validity rule is a component of the cell format. To copy the validity rule to other
cells, choose Edit > Copy and Edit > Paste Special, and select Format.

3. Select Data > Validity.... The Validity dialog appears.
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4. On the Criteria tab page, enter the conditions for new values entered into cells. Values
already entered will not be affected.

5. In the field Allow, All Values is selected by default. This means that there are no
restrictions. As needed, choose one of the other options:Whole Number, Decimal,
Date, Time, and Text Length.

6. This choice sets the first condition. By choosing, for example,Whole Numbers,
values such as 12.5 are not allowed, even if they satisfy the other conditions.
Choosing Date allows date information both in the form1/1/97 as well as in the form
of a serial date. Similarly, the Time condition permits time values as 12:00 or serial
time numbers. Text Length stipulates that cells are allowed to contain text only.

7. After setting the first condition under Allow, select the next condition under Data.
According to what is chosen, additional text fields (Source,Minimum and Entries)
may appear to further specify the condition.

8. A few possible conditions resulting from this register could be as follows:

Integer greater than 1, Decimal between 10 and 12.5, Date earlier than or equal to
1/1/2000 ,Time not equal to 00:00, Text with a length of more than 2 characters.

After the conditions for cell validity have been determined, if any values are
subsequently entered which do not meet the conditions, Calc displays a warning message.
Fill out the other two tabs in the dialog to specify more detailed messages to aid a user
working with a spreadsheet.

• On the Input Help tab page, enter the title and the text of the tip, which will then be
displayed if the cell is selected.

• On the Error Alert tab page, select the action to be carried out in the event of an
error.

• If Stop is selected as the action, invalid inputs are not accepted, and the previous cell
contents will be retained.

• SelectWarning or Information to display a dialog in which the entry can either be
cancelled (the cell value will be retained) or accepted (even if the new value violates
the validity rule).

• If Macro is selected, then specify the macro to be carried out in the event of an error
via the Browse button.

Sample macro:

Function Example Validity(CellValue as String, TableCell as String)

Dim msg as string
msg =Invalid value: &'” & CellValue &'"
msg = msg & in table: &'” & TableCell &'"
MsgBox msg ,16,"Error message"
End Function

Note: After changing the action for a cell on the Error Alert tab page and closing the dialog with OK,
another cell must be selected before the change takes effect.
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Printing or Exporting Spreadsheets
There are many print options for putting spreadsheets on paper. Another way of
distributing data is to publish it on the Internet in HTML format or as PDF files.

Printing Sheet Details
When printing a sheet you can select which details are to be printed:

• Row and column headers

• Sheet grid

• Notes

• Objects and graphics

• Charts

• Drawing objects

• Formulas

To choose the details proceed as follows.

1. Select the sheet for printing.

2. Choose Format > Page.

Note: This command is not visible or available if the sheet was opened with write protection on. In that
case, click the Edit File icon on the Standard toolbar.

3. On the Organizer tab, edit the name if needed. Details on the Page and Sheet tabs may
also need altering to suit (see below).

4. Click OK.

5. Print the document. The Print and Printer Options dailogues will follow as normal
in NeoOffice,

Defining Number of Pages for Printing
If a sheet is too large for a single printed page, Calc prints the current sheet evenly
divided over several pages. Since the automatic page break does not always take place in
the optimal position, you may define the page distribution yourself.

1. Go to the sheet to be printed.

2. Choose View > Page Break Preview.

3. This displays the automatic distribution of the sheet across the print pages. The
automatically created print ranges are indicated by dark blue lines, and user-defined
ones by light blue lines. The page breaks (line breaks and column breaks) are marked
as black lines.

4. The blue page break lines can be moved using the mouse. Look for further options in
the Context menu, including adding an additional print range, removing the scaling
and inserting additional manual line and column breaks (as below).
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Printing Sheets in Landscape Format
In order to print a sheet, use one of the number of interactive options available under
View > Page Break Preview. To make a hard copy in landscape format, proceed as
follows:

1. Go to the sheet for printing.

2. Select Format > Page.

This command is not visible if the sheet has been opened with write protection on. In
that case, click the Edit file icon on the Standard toolbar.

3. Select the Page tab.

4. Select the Landscape paper format

5. Click OK.

6. Choose File > Print to open the Print dialog .

Depending on the printer driver and the operating system, it may be necessary to click
the Properties button and to change the printer to landscape in that dialog.

In the Print dialog under Print range, select the pages to be printed:

• All > All sheets will be printed.

• From > Enter the pages to be printed. The pages will also be numbered from the
first sheet onwards. If one sees, in the Page Break Preview, that sheet1will be
printed on 4 pages and only the first two pages of sheet2, enter 1-6 here.
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If under Format > Print range you have defined one or more print ranges, only the
contents of these print ranges will be printed. In OS X, after the Print dialog for the
User's printer, a Printer Options diaogue appears:

Printing Rows or Columns on Every Page
Suppose a sheet is so large that it must be printed on four pages. The pages will be
arranged as follows:

Page 1 Page 3

Page 2 Page 4

The top two rows of the sheet should not be printed only on pages 1 and 3, but should be
the topmost rows on print pages 2 and 4. The first column A should not be printed only
on pages 1 and 2, but should also be on pages 3 and 4.
1. Select Format > Print Ranges > Edit and the Edit Print Ranges dialog opens.

2. Click the icon at the far right of the Rows to repeat area.

The dialog shrinks so that more of the sheet can be displayed.

3. Select the first two rows and, for example, click cell A1 and drag to A2.
In the shrunken dialog the user will see $1:$2. Rows 1 and 2 are now rows to repeat.

4. Click the icon at the far right of the Rows to repeat area. The dialog is restored again.

5. If one also wants column A as a column to repeat, click the icon at the far right of the
Columns to repeat area.

6. Click column A (not in the column header).
7. Click the icon again at the far right of the Columns to repeat area.

Note: Rows to repeat are rows from the sheet.

8. Define headers and footers, to be printed on each print page, independently of this via
Format > Page.
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Saving and Opening Sheets in HTML

Saving Sheets in HTML
Calc saves all the sheets of a spreadsheet together as one HTML document. At the start of
the HTML document a heading and a list of hyperlinks are automatically added, which
lead to the individual sheets within the document.

Numbers are shown as written. In addition, in the <SDVAL>HTML tag the exact
internal number value is written so that the exact values are available when opening the
HTML document with Writer.

1. To save the current Calc document as HTML, choose File > Save As.

2. In the area with the other Calc filters, choose the File type HTML Document.

3. Enter a File name and click Save.

Opening Sheets in HTML
HTML documents may be opened with write-protection enabled. To edit a read-only
HTML document, click the Edit File icon on the Standard toolbar.

NeoOffice offers various filters for opening HTML files, which may be selected via the
File > Open dialog in the File type field via a very long drop-down menu(pay particular
attention to the area, as the nameWeb pages is always the same):
• Open in Writer/Web filterWeb pages or as default which does not require selecting
a filter.

All the options of NeoOffice Writer/Webare now available, such as Show HTML
source.

• In the NeoOffice Writer filter openWeb pages.
All the options of Writer are now available. However, please note that not all editing
options that Writer offers can be saved in HTML format.

• In the Calc filter openWeb pages.
All the options of Calc are now available to you. Again, note that not all options that
Calc offers for editing can be saved in HTML format.
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Formulas and Values as CSV Files

CSV is an acronym for “Comma Separated Values.”CSV-files are pure text files, which
contain the contents of the cells of a table/area of a spreadsheet. Commas, tabs, spaces,
colons or semicolons can be used as the field delimiters between the cells. Text is
automatically put between either quotation marks or single quotes, as selected, while
numbers are written directly.

Exporting Formulas and Values as CSV Files
1. Select the area/table that is to be written as a csv file.

2. Where formulas are to be exported as formulas, e.g. in the form =SUM(A1:B5),
proceed as follows:

a) Choose Tools > Options > NeoOffice Calc > View.

b) Under Display, check the Formulas field.

c) Click OK.

To export the calculation results instead of the formulas, do not mark formulas.

3. Choose File > Save as to open the Save as dialog .

4. In the File type field select the format Text CSV.
5. Enter a name and click Save.

a) From the Export Text dialog that appears, select the records and the field and text
delimiters for the data to be exported.

b) Confirm with OK.

Caution: If the numbers contain commas as the decimal separator or
thousands separator, do not select the comma as the field delimiter. If the
text contains double quotation marks, select the single quotation mark as
separator and vice versa.

6. If necessary, after saving the document, uncheck formulas in order to see the
calculated results in the table again.

Importing a CSV File
1. Choose File > Open to bring up the dialog .
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2. In the File type field, select the format Text CSV.
3. Select the file from the list.

4. Click Open.

When a file has the .csv extension, the file type is automatically recognized.
5. The Import text files dialog opens.

6. Click OK.

7. If the CSV file contains formulas as formulas, uncheck formulas (in Tools > Options
> NeoOffice Calc > View), so that the calculated results are visible in the table.
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AutoFill

Copying text, values and other cell contents to a spreadsheet is very easily done, using
the mouse. Here you need to consider a few special features. When several values are
copied at once, Calc forms a logical series out of the initial values, such that, if certain
texts are entered that are in sort lists, the list will be continued accordingly.

Applying Sort Lists
By way of experiment, enter the text Jan or January in an empty cell. Select the cell and
click the mouse on the box in the lower right corner of the cell border. Drag over several
cells to the right or downwards. Upon releasing the mouse button, the highlighted cells
will be filled with the names of the months.

This predefined series can be found under Tools > Options > NeoOffice Calc > Sort
Lists. Custom lists can also be tailored to local needs, such as a list of a company's
branch offices. These lists are handy for expanding as headings and other repetitive tasks
by simply entering the name in the list with which to start and then expanding this entry
by dragging as described above.

Automatic Row Filling
1. Enter a number in a cell.

2. With the mouse drag the bottom right corner of the cell downwards.

3. When the mouse button is released, the cells selected in this manner are filled with
numbers. The starting number is increased by 1 in each case.

If two or more adjacent cells have been selected, that contain different numbers, and
these are dragged together, any recognizable arithmetic pattern of the numbers is
continued. For example, if A1 contains the number 1 and A2 the number 3, then joint
copying of the two cells by dragging downwards causes the progression to continue with
5, 7, 9, 11 and so on.
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1. First select the range in the table to completely fill.

2. Select Edit > Fill > Row to open the dialog

3. Select the type of progression. e.g. select 2 as the starting value, 2 as the increment
and geometric progression as the progression type.

In this way a list of the powers of 2 is produced.

The dialog also allows series of dates and times to be automatically filled in. For
example, to insert the first date of each month of the year as row headers, proceed as
follows:

1. Enter a date, e.g., 1/1/99 into a cell (without quotation marks).
2. Highlight this cell and the 11 cells below it.

3. Select Edit > Fill > Series.

4. In the dialog, select Date andMonth.

5. Click OK.

The first date of each month automatically appears in the selected cells.

Selecting and Filling a Range of Cells

– from the NeoWiki

Sometimes you might wish to fill an entire row or column in your spreadsheet with data
“automatically,” e.g., sequential dates or numbers. You can do this in NeoOffice using the
following steps:

Selecting a range
1. In the “Input field” in the left top of the sheet, type the name of the beginning cell
and then the name of the ending cell of the desired range, separated by a colon (:),
e.g. A1:A20, and press the Return key.
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2. You can also select the range with the mouse, or by clicking in the top-left cell in the
range and shift-clicking in the bottom right cell in the range, if you do not have the
cell references memorized.

3. You can save that range for easier future use by giving it a significant name. Open the
Insert menu, then the Names sub-menu, and select the Define… item. Type in a
name and press Add. (This name will now be visible in the Range names section in
the Navigator window.)

4. Afterwards, it will be easy to select the range by double-clicking its name in the
Range names section in the Navigator.

Filling a range
1. Select a cell range and choose the Edit menu then the Fill sub-menu and the
Series… item.

2. Four types of series Linear, Growth, Date and AutoFill are available.

3. The automatic filling is done from a sort list. You can see all the available lists by
selecting Sort Lists in the NeoOffice Calc section of the Preferences sub-menu
of the NeoOffice menu.

4. You can add here your personal lists:

● Click New

● Enter the successive values of your list, separated with a line break. Click OK

● That series will be available via the Series… item in the Fill sub-menu of the
Edit menu by checking the case AutoFill in the Series type section and
choosing the first element of the list as the Start value.
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Drag-and-Fill
You'll notice a little black square in the bottom-right corner of the current cell. This is a
drag-and-fill tool; click-and-drag the square along the row/column you wish to fill, from
the 'source' cell to the last cell you want filled, and then release the corner. The tool
behaves differently depending on what's in the current cell (or cells - note that this also
works with blocks of cells, though only in one direction at a time):

1. Text - copies the same text into all the target cells

2. Number - adds 1 to each suceeding cell, useful for filling a column/row quickly
with 1-50 (disconcertingly. it also does this with non-integer cell values, so you can
get the sequence e.g. -1.1, -0.1, 0.9, 1.9!)

3. Formula - equivalent to copying/pasting the formula (see Copying Formulas
below), i.e. the cell references get updated for each cell filled, unless the cell
reference in the formula is absolute, i.e. $B$1 will stay $B$1 all the time, but B1
will become B2, B3 etc. (or C1, D1 if you're filling a row)

Copying formulas
The Fill function allows you to apply a recurrent formula to a cell range.

Example :

1. Select the range A1:A20, enter 1 in A, choose the Edit menu then the Fill sub-
menu, click Series.

2. Set up the Type to Linear, the Start value to 1, the End value to 20 and the
Increment to 1.

3. Click OK.

4. The series of the first 20 integers appears in the selected range.

5. Enter 1 in the cell B1.

6. Select the cell B2 and enter in the formula line, in the top of the page : "=B1+A2"
(without quotes). Press Return. The sum 3 appears in the cell B2.

7. Select the range B2:B20, choose the Edit then the Fill sub-menu and the Down
item. Now every cell of the selected range contains the sum of the successive
integers and the cell B20 contains the sum of the first 20 integers, i.e. 210.

Showing the formulas
If in the View section of NeoOffice Calc of the Preferences sub-menu of the NeoOffice
menu, you check the Value highlighting option, the cells which contain values will be
displayed in blue, and those which contain formulas in green. If you choose that option,
you'll not be able to change the character color in those cells.

- end of NeoWiki section

Protecting Sheets
To prevent the values entered in a sheet from being modified by another person, protect
the sheet. To do this, follow these steps:
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1. Display the Protect Sheet dialog (Tools > Protect Document > Sheet).

2. Enter a password,

3. Click OK.

Likewise the entire document can be protected so that it is only possible to open it by
entering the password.

• All cells in a newly created spreadsheet document have the protected attribute. This
attribute can be turned on and off via the Cell Protection tab page of the Format
Cells dialog, which is opened by choosing Format > Cells or via the Format Cells...
context menu command.

• The Protected attribute can be set or removed for each cell individually. In any case, it
does not take effect until the entire sheet and/or the entire document is protected.
Apply this protection using Tools > Protect Document > Sheet... or Tools > Protect
Document > Document....

• While a password can be applied for protecting the sheet and the document, this is not
required. However, if a password is set, then protection can only be removed later by
entering the correct password. If no password is set, there is still effective protection
against a document being accidentally modified.

• Sheet protection prevents modification of the contents of this specific sheet. Document
protection prevents the sheets from being inserted, deleted, resorted or renamed.

• If you have a document with confidential data that should be protected from being
opened by unauthorized persons, protect it with a password. The password makes this
protection of the entire document dependent on the protection mechanism of cells,
sheets and documents described above. To save a document with a password, select
File > Save As... and check the Save with Password check box.

Creating a Reference
If you want to insert a value (say, the result of a profit calculation) into another sheet or
into another spreadsheet document, a reference must be created.

1. Select the cell where one wants to insert the result

2. Enter =.
3. Next select the cell that contains the original result

4. Press Return.
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This cell can also be included in another spreadsheet or in another file. The result is
automatically inserted into the reference cell and is also updated when changes are made
later.

The content of a cell can be dragged to a cell in another document. With this action,
either choose to transfer a copy of the cell, as it now stands, into the other document or
create a link so that the other document always reflects the current content of the cell.

After setting all the necessary preferences and changes, save the document and print it.

Further Information
The document based on this template is protected. In order to make modifications in the
protected cells, first disable the protection via Tools > Protect Document >
Spreadsheet. This must be done individually for every protected sheet, including the
hidden sheets.

Inserting a note
To keep a note, perhaps reminding you to sell a certain share later on, select the relevant
cell and choose Insert > Note. A shadowed area in the document appears in which you
can enter text. To make this note visible all the time, click in the relevant cell (cells with
notes have a small red dot in the corner, provided "Note Indicator” in Tools > Options >
NeoOffice Calc > View is marked), open the context menu and choose Show Note.
Otherwise, you only see the note when the mouse pointer is moved on to the cell.

Inserting a sheet into another document
Select the cell range and copy it to the clipboard (Copy icon on the Standard toolbar).
Open the document into which to insert the sheet (generally a text document) and insert
the sheet with Paste command or Paste icon [Alternatively, one may select Insert >
Object >OLE Object. This brings up a menu from which you can select to create a new
NeoOffice spreadsheet within the text document. Then the cell range can be inserted
within that nested spreadsheet.]

Displaying Formulas
To display the references in the spreadsheets, choose Tools > Options > NeoOffice Calc
> View and check Formulas. The best way to examine an individual formula is to click
the cell containing the formula, and the formula appears in the input line on the formula
bar.

Using print ranges
Print ranges have been used in the sample document to print specifically targeted cells.

Freezing Columns
Select the column to the right of the column to be frozen, say a list of names, by clicking
on the column header, and click Freeze in theWindow menu. This makes is possible to
scroll horizontally, while the area to the left of the freeze line remains fixed. This fixes
the display so that the column containing the names is always in view. This function is
especially useful for large sheets.
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Splitting a Calc Window
Sometimes you may need to work with a spreadsheet in which the active data is in
different rows. Scrolling up and down can be inconvenient. In this case splitting the
display can be an advantage. Select the cell at which to split the display, and click Split
in theWindow menu. This makes it possible to scroll vertically in each of the split
sections. This function can be especially useful for large sheets.
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Conditional Formatting
With this function, information can be displayed simply by entering a letter. For example,
if this is an employee list, use this feature to instantly find out if a particular employee is
present, sick, or on vacation.

To do so, use the following steps:

1. Open the Styles and Formatting window (click the icon in the Standard toolbar)

2. Create three Cell Styles.

3. For the Cell Styles, choose names that correspond to the information to be
represented. In the case of the employee list , choose: Sick, Vacation and Present.

4. Click in the Styles and Formatting window, and open the context menu and click the
New command to activate the Cell Style dialog.

5. On the Organize... tab, enter the word Sick and assign a background colour to the
Cell Style by way of the Background tab page.

6. Click OK .
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7. Repeat this process for the two remaining Cell Styles.

8. Now, using the mouse, select the range to which to apply the conditional formatting.
Choose Format > Conditional Formatting to open the Conditional Formatting
dialog.

9. For Condition 1 define: Cell value > equals -“s” (s=sick). In the Cell Style list box,
select the Style Sick.

10.For Condition 2 define: Cell value > equals -“v” (v=vacation). In the Cell Style list
box, select the Style Vacation.

11.For Condition 3 define: Cell value > equal -“p” (p=present). In the Cell Style list
box, select the Style Present.

Note: The use of quotation marks is absolutely necessary to define conditions!

Upon entering a “v” (without quotation marks) in a cell in the previously selected area
and pressing the Return or Arrow key, the cell will be displayed in the defined colour.

Note: A maximum of three conditions is possible.

Defining Validity
To avoid invalid entries in a spreadsheet, define a validity condition. Select the cells to
which the validity condition is to apply, and open the Validity dialog (in the Data menu).
On the Criteria tab, define the acceptable entry criteria (in this example: Text length,
equal and 1) in the appropriate lists and fields.
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Next, click on the Error Alert tab. Select the option Show error message when invalid
values are entered and click Stop in the Action list box. Under Error message, enter an
appropriate text (e.g. Only v (vacation), p (present), or s (sick) are valid entries.) .
If you were to now enter more than one letter in the corresponding cell in the sheet, the
message defined above appears.

Creating Input Help
Using the Validity dialog, custom help functions can be created for a previously selected
area. Select the Input Help tab and check the box Show input help when cell is
selected. Enter a title in the respective field, and enter the help text in the field below.
This text is then displayed as a Help tip for the user.

Linking Sheet Information
The information contained in a schedule can also be used by linking it to the vacation
accounts and automatically subtracting used vacation days, for example.
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The Solver

- from the NeoWiki

The Solver in Calc is a tool that helps you to calculate the conditions which maximize
profit and minimize cost while satisfying some constraints. It can solve linear or non-
linear problems, but keep in mind that the non-linear problems are much more difficult to
solve. The example below shows the utilisation of the Solver function in Calc.

Problem Presentation
Let us assume that a factory produces three types of machines, A1, A2, A3. Let pi be the
cost of the raw material and hi the number of hours which are necessary to produce a
machine of the type Ai. The profit per machine of the type Ai is equal to bi.

The decision variables are the numbers xi of machines of the type Ai which are produced.
Wewant to calculate the values of the numbers xi which maximize the total profit.

These data have to satisfy some constraints, for example:

○ every number xi must be an integer. Wewant to produce at least 30 machines of
each type.

○ the total cost of raw material must be less than or equal to $10,000

○ the total number of working hours must be less than or equal to 5,200.

Machines A1 A2 A3

Number of
machines

x1 x2 x3

Cost of raw
material per
machine

p1 p2 p3

Number of
working hours
per machine

h1 h2 h3

Profit per
machine

b1 b2 b3

Profit to
maximize

b1x1+b2x2+b3x3

Constraints x1 >= 30, x2 >=
30, x3 >= 30

p1x1+p2x2+p3x3
<= 10 000

h1x1+h2x2+h3x3
<= 5 200

Solving the Problem
1. Open a Calc document

2. In the spreadsheet, enter the data as in the table below:
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The value 1890 contained in the cell B8 is the sum of working hours necessary to
produce 30 machines of each type, namely SUMPRODUCT(B2:D2;B4:D4).
The value 6300 contained in the cell B9 is the cost of raw material necessary to produce
30 machines of each type, namely SUMPRODUCT(B2:D2;B3:D3).
Wehave to maximize the total profit: SUMPRODUCT(B2:D2;B5:D5)

3. Choose Solver… from the Toolsmenu. The Optimization Solver window
appears.
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4. Define the model:

Note: All the references are automatically translated into absolute references by the solver. That
explains the presence of the prefix "$" in the cells adresses.

○ Click on the little green arrow to the right of the Set target cell field, then

○ Click on the cell which contains the measure to optimize, here B7 which
contains the formula giving the total profit.

○ Click on the arrow to the right of the input field again, the value
$Sheet1.$B$7 is automatically placed in the Set target cell field.

○ Click onMaximize. That is the goal to calculate.

○ Click on the little green arrow to the right of the By changing cells field, in
order to choose the cells containing the decision variables whose values
allowing the profit maximization have to be computed

○ Select the three cells B2, C2, D2 by dragging the mouse.
○ Click on the arrow to the right of the input field again. The range
$Sheet1.$B$2:$D$2 is automatically placed in the By changing cells field.

5. Define the constraints:

Let us set the following constraints:

SUMPRODUCT(B2:D2;B4:D4) ≤ 5 200
SUMPRODUCT(B2:D2;B3:D3) ≤ 10 000
B2 ≥ 30
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C2 ≥ 30
D2 ≥ 30

○ Click the Add button on the Optimization Solver window. The
Constraint window appears.

○ Click on the little green arrow to the right of the Cell reference field and
click on the cell B8, then on the arrow again.

○ In the Constraint field enter the value you desire, namely 5200.
○ Click OK.

○ Click on the Add button again and add the four other constraints in turn, in
the same way. Click OK after each constraint input. Change the sign "<="
into ">=" for the constraints that are imposed on the values xi.

6. Choose the options:

○ Click on the Options button

NeoOffice User Guide for 2.x 276



Chapter 4: Spreadsheets in Calc

○ In the Options window that appears, leave the default option Assume
linear model checked and check the Allow only integer values option.

○ Click OK.

○ Click on the Solve button.

○ The message Solution found appears in a dialog box.

○ Click OK.

The values of cells B2 to D2 have been changed so that the profit may be the maximum,
under the conditions set by the constraints.

In that example we get x1= 82, x2 = 31 and x3 = 30.
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You can save that model by clicking the Save button. By clicking the Load button,
you will be able to display it later and, for instance, modify the values of the
constraints or of the production costs.

Controls, Fields, Buttons
From http://wiki.services.openoffice.org/wiki/Optimization_Solver#User_Interface

Name Type Description

Target cell text input This field takes the address of the cell whose value is to be
optimized.

Goal radio
button

This radio button defines whether the target cell value is to
be maximized or minimized.

Variable
cell

text input This field takes the range address of cells that whose values
will change during optimization run.
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Constraint
box

list box This list box maintains a list of currently defined constraints.

Add button Add a new constraint to the list of constraints.

Change button Modify the highlighted constraint definition.

Delete button Delete the highlighted constraint definition.

Solve button Optimize the highlighted constraint definition.

Reset button Reset all input values. This essentially removes all input
values.

Options button Launch a separate Options dialog.

Save button Save the current input values to document's metadata
section. Note that clicking this button only puts the data into
the document model on memory. You still need to save the
file after clicking this button to permanently save the data to
disk.

Load button Load input values from document's metadata section.

Close button Close this dialog.
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You can use presentations to link several slides to form a slide show, to animate the
elements on the slides and to assign special transition effects between slides. Slides often
contain text which, in the Outline Viewmode, is displayed and entered in a hierarchical
structure. You can change the text or rearrange the order of the slides at any time.

There are several ways to create a presentation:

• UseWizard Presentation.

• Use the templates and sample documents supplied, which are modified as necessary.

• Start with an empty document, and design your own from scratch.

NeoOffice Impress provides many graphics features for creating presentations, all of
which are found in NeoOffice Draw, too. Please take the time to also read chapter 6 on
NeoOffice Draw to discover the complete capabilities of Impress.

There are many locations on the internet where you can find free templates for
OpenOffice.org, and these should all be seamlessly compatible with NeoOffice. Check
out the NeoWiki for information.

Note: Some sample documents referenced in this section were previously found at
http://www.pathtech.org/OpenOffice.org/templates/Samples/ but these appear to have been lost in a server
crash.

A good presentation will tell a story succinctly and dramatically. On the other hand, a
bad presentation can be as dull as a bad speech. What we do in this chapter is show you
how to use the program Impress. How to use it well takes practice and thought.
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NeoOffice Impress Toolbars and Windows

Zoom Toolbar Symbols Shapes Toolbar
Text Toolbar Slide Sorter
Lines Toolbar Styles and Formatting Window
3D Objects Toolbar Slide
Circles and Ovals Toolbar Block Arrows Toolbar
Connectors Toolbar Navigator Window
Task Pane Color Bar
Align Toolbar Navigator Icon
Position Toolbar Presentation Toolbar
Insert Toolbar

How to Create a Basic Presentation
The following brief step-by-step example demonstrates different methods of how to
create a presentation document.

As with text documents, there are various ways to start creating a presentation in
NeoOffice:

• Open theWizard Presentation by choosing File > Wizards > Presentation. The
Wizard starts automatically each time a new presentation is created. If desired, switch
off the automatic mode on the first page of the Wizard. The Wizard is described in
detail in the Help.
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• By turning off the Wizard in Tools > Options > NeoOffice Impress > General, a
new, empty document (for example, by choosing File > New> Presentation) is
opened.

• Alternatively, open an existing presentation document that is modified and saved
under a different name.

• Or use one of the many templates available in the Templates and Documents dialog.
Pressing Cmd-Shift-N opens this dialog, or use File > New > Templates and
Documents.

For more information on the various dialogs used here, refer to Help.

Creating a Presentation With the Wizard
1. Choose File > New > Presentation.

The Wizard Presentation opens automatically. The first page allows you to start with
an empty presentation, a template or the last presentation opened. If you click the
From template option, NeoOffice Impress collects all existing presentation templates
and displays them in the list box.

For the purposes of this example, select the template “Recommendation of a Strategy”
and click Next. On page two of the Wizard dialog choose another Page Style if needed.
The selection of presentation layouts available to choose from are from the predefined
template directories. As on the first page of the Wizard, all templates are displayed as
Page Styles.
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On this page, however, the default is “Presentation Backgrounds”. At the bottom
of the dialog, select the output medium for the presentation: Slide, Overhead,
Screen or Paper. The dimensions, margins, and orientation of the presentation will
depend on these selections.

2. To continue following this example, do not change the background or output medium
of the presentation. Click Next.

3. Page three of the Wizard deals with the slide transition.

a) In the first list box select the slide effect “Uncover Left”. This determines what
happens as you change from one slide to the next.

b) Select the default “Medium” for the speed of the change.
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4. Select Automatic as the presentation type (i.e. slide show repeatedly runs through
presentation, with fixed time lapses, until the Esc key is pressed).

5. Now you can determine further parameters:

a) Use the Duration of page spin box to determine how long each slide is shown
before the next one appears. Once the presentation is completed, a different
duration for each slide can be set individually.

b) Use the Duration of pause spin box to determine how long the pause will be at end
of the presentation before it starts again. If the Show Logo check box is marked, a
NeoOffice logo will be displayed on the pause page. The Default presentation type
runs the presentation from beginning to end with manual slide transition, e.g. by
mouse click.

6. Click Next.
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7. On page four, enter any additional text which should appear in the presentation. Click
Next.

The fifth and final page of the Wizard determines the number of slides needed in the
presentation. A list of names of all the slides in the presentation is also presented. If
there are some slides to be removed from the presentation, click the check mark next
to the name. The check mark/s will disappear, which indicates that that slide/s will not
be included in the presentation. To reverse this action, click the page icon again.
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8. Click the triangle in front of a slide. The headings from the first outline level will be
shown.

9. If you check the Create summary check box at bottom left of the dialog, the Auto
Pilot creates an additional last slide with a summary of all the titles of the previous
slides in the presentation. Normally this is not necessary, since most templates already
include such a page.

10.Click Create to create the presentation.

• Clicking Create on any of the Wizard pages creates the presentatio and eliminates
the need to go through all the remaining pages of the Auto Pilot.

• Once you have created the presentation, edit, save, and print or run it, et cetera.

To start a presentation on a computer screen, simply press Cmd-F2 key
or click the Slide Show icon on the main toolbar.

Creating a Simple Presentation Without the Wizard
This section explains, with the help of a simple example, how to create a presentation
based on one of the existing templates.

• Open a new presentation document based on one of the supplied templates by
choosing File > New > Templates and Documents, or with Cmd-Shift-N.

• In the Templates and Documents dialog that appears, click the Templates icon on
the left and then double-click “Presentation Backgrounds”. Double-click one of the
templates, such as “Note Pad”.

• Now there is a slide in which any predefined text can be replaced with the text of
choice.

Note: If the document is in the Master view mode when opened, switch to
the Slide view mode using the Master View toolbar. A presentatio will
always be opened in the view in which it was last saved. If Tips and/or

Extended tips is enabled, hovering the mouse pointer over one of these will popup to tell you.

To create a second slide, in normal View, click the Insert > Slide command
from the menu bar, or click on the Add Slide icon on the Presentation
toolbar, or the Insert Toolbar. In the next dialog, select a page layout and
confirm with OK.

You will then see “Slide 2”.
1. Press OK.

2. Click once on the lower text frame and delete it, say, with the Delete key.

3. Click in the text frame at the top and enter a title.

4. View > Toolbars > 3D Objects. This will open the 3D Objects floating toolbar.

NeoOffice User Guide for 2.x 288



Chapter 5: Creating Presentations With Impress

5. Select the Sphere icon.

6. Click on the slide, drag open a 3D rectangle, and then release the mouse button. Voila,
a 3D sphere.

7. Drag the sphere into the centre of the slide and enlarge it by dragging one of the
handles in one of the corners. When dragging, hold down the Cmd key so that the
sphere remains a sphere.

8. Assign an interesting color or color gradient to the sphere by way of the list boxes on
the object bar. Placing a bitmap as a pattern on a 3D object, for example, a world map
from the Gallery is covered in another chapter.

Save the presentation by either pressing the Cmd-S shortcut keys and specifying the name
and location for the file, or use File > Save as and again specify the location for storage.

Drawing
If you found the previous section difficult, you may benefit by jumping to the next
chapter, on the program Draw. The Draw and Impress programs work hand-in-hand
within the NeoOffice suite.
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Switching Presentation Views
Notice the bar at the top of the slide with five buttons, for the different viewing modes.
This is an important set of shortcuts, which will be referred to often after this. Youmay
switch views by pressing on the buttons at the top of the slide:

Task Pane
It is recommended that you use the task pane at all times with Impress, unless you have
limited screen space. It can be opened by View > TaskPane. The pane gives you access
to a number of powerful and quick functions within Impress. It can be docked or
retained as a floating toolbar. Docking requires you to click on the little arrow top right
of the pane next to the word “View”, and selecting Dock Task Pane.

Arranging Slides
Switch to the Slide View by clicking on the Slide Sorter button at the top of the slide.
Now the position of individual slides can be rearranged, and effects defined for the
transition between slides.
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In the Slide Sorter view, change the sequence of the slides by dragging them to any other
position in the presentation.

To copy a slide in the slide view use drag and drop while pressing the Cmd key. The
mouse pointer will have a small green circle next to it when dragging, to indicate a copy.
Drag and drop is also possible between the slide views of two NeoOffice Impress
documents.

If the context menu of a selected slide is called up, the Show/Hide Slide command will
be seen. You can use this command to temporarily remove the current slide from the
presentation, without deleting it from the actual document. A slide that is not to be shown
in the current presentation receives a number with a box round it highlighted in gray.

Incorporating Slide Show Effects
In the Slide Sorter mode, define transition effects to precede the display of each slide:

1. In Normal view, select the slide that you want to add the transition effect to.

2. On the TaskPane, click Slide Transition.

3. Select a slide transition from the list.

4. Click the Play button bottom left on the task pane to preview the selected effects
inside the document window.

5. Save the presentation again using Cmd-S or from File > Save menu item.

You can preview the transition effect fullscreen by pressing the Slide Show at the bottom
of the Task Pane.
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In-Slide Effects

NeoOffice 2.x offers in-slide effects such as fade-in et cetera. To add effects within a
slide use Custom Animations.

Showing a Presentation
By following the previous steps you now have a finished presentation ready for display.

To run it, in Slide Sorter View, click the Slide Show icon on the Slide
Sorter toolbar, and the presentation will start automatically in default
mode, that is to say, in full-screen mode.

Click once with the mouse and the second slide will be displayed (preceded by the
defined transition effect). After the last slide, a black slide is displayed, which means that
the presentation is over. End the presentation by pressing the Esc key. The Esc key may
also be used to stop the presentation before the end, as necessary.

At this point, more slides may be added to the presentation or some of the other effects
attempted.
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Editing Presentations

This section shows how to use the versatile features of Impress to fine tune a
presentation. Many of the methods available in Draw can also be used in Impress, such as
entering text and converting it into 3D, turning objects into curves and polygons, editing
connectors and glue points and so on. For details, please refer to chapter 6 on Draw.

Defining Background Colors
The background of a slide in a presentation or drawing document can be handled either in
the master view or by assigning another Page Style to the slides, or by modifying the
current Page Style.

Switch to the MasterView by using theMaster
View toolbar if it is available, or by using View >
Master > Slide Master

• The Master View permits editing the background for all slides. All objects that are
entered in this view, whether company logos, lines or text, are displayed in the
background on all slides that use the current Page Style (the master page). This allows
headers and footers to be reproduced on all presentation slides. Objects inserted in the
Master View are protected: they cannot be modified in the normal Slide View.

• Change only the background used in the presentation using the following steps:

a) Click in any slide

b) Choose Format > Page Setup

c) Select the Background tab

d) Choose a color, gradient, hatching or bitmap for the background.

e) Click OK

f) The next dialog asks if the settings should apply to all slides, or just to the current
slide. By answering “Yes” to the question “Background settings for all pages?",
you ensure that the Background Presentation Style will be modified for the current
master page, and all slides with this Page Style will have the modified background.
Answering “No”, means that only the background of the current slide is modified.

• Modify the Presentation Styles in the Styles and Formatting window by following
these steps:

1. Open the Styles and Formatting window,

2. Click the Presentation Styles icon if it is not already selected, to see all
existing Styles of this type in the Styles and Formatting window.

3. Select the Background Style.

4. Right-click or Ctrl-click to open the context menu for this Style and choose
Modify.

5. Choose the background for all slides with the current Page Style.
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6. Click OK.

Note that this modification is only valid for the current presentation document.

Switching Page Styles
The underlying designs which make up the overall slide design determine the way an
object looks, including its background. The slide design can also be called a “Master
Slide”. In Impress, assign a different slide design to each slide as desired.

1. Go to the slide that is to have a different Master page.

2. Select Format > Slide Design to open the dialog

3. Click Load....at bottom right to see the Load Slide Design dialog.
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4. Select a new slide design from the dialog, e.g. from the area “Presentation
Backgrounds”. Youmay want to click on theMore button at right to ope up the
selections at the bottom of the above screenhsot.

5. Confirm this with OK.

6. If the Exchange background page check box is checked, the new slide design applies
to all pages of the current document. If there is no check mark in it, then this action
only applies to the current slide. This provides the flexibility to define a different slide
design, and thus a different background, for example, for one single slide. Assuming
that Exchange background page is not checked, the background selected will now be
assigned to the slide currently in use.

Presentation Styles
As part of slide design there are a whole set of Presentation Styles that may be assigned
to the slides. Open the Styles and Formatting window to see a list of the predefined
Styles. Existing Styles may be modified but any modifications are valid only for those
slides in the current document that uses this slide design or new Styles created.

The built-in Styles, Outline 1 through Outline 9, enable you to give the outlined headings
and topics on the slides a uniform look.

Open a new, empty presentation with a slide layout that allows greater structural depth.
The slide layout called “Title, Text” is suitable for this purpose.

Activate the outline view mode by clicking View > Outline (starting in the Menu bar).

Note: The slide layout chosen determines the number of levels of outline. If a slide layout which does not
permit any outline is chosen, notice that the outline functions are not available.

NeoOffice User Guide for 2.x 295



Chapter 5: Creating Presentations With Impress

Using Outline View

One way to create a completely new presentation is in the Outline Viewmode. All slide
titles appear in a list along with the headings and sub-topics. The hierarchy of the
headings as well as the sequence of the slides can be easily modified.

1. The Task Pane preview window should have opened; if not, it can be shown by
choosing View > Task Pane. By clicking on the triangle, one can select Master Pages,
Layouts etc. The Master Page view allows you to view the slide layout, including
text, background, and background objects. View > Slide Pane shows a view of each
page in a scrolling window at the side of your display

2. Now open the Styles and Formatting window either by choosing Format > Styles
and Formatting or with the Ctrl-F11 key or opening it if it is docked.

3. The cursor should now be blinking next to the small icon for slide 1.
4. Enter the desired text, for example Introduction. This will be the title for slide 1.
5. Press the Return key. This displays a small icon for slide 2 in the next line of the
Outline view.

6. Enter a title for the second slide, for example, Overview. Don't use titles like Page 1,
Page 2, etc., unless you are very confident that you will not be changing the page
order, adding or subtracting pages.

7. Press the Return key again to get the small icon for slide 3.
8. Now press the Tab key before entering any text. This action ensures that the text
entered here will be a subtitle on slide 2.

9. Continue to enter more subtitles of the first level on page two.

10.Pressing Shift-Tabmoves one level up. This enables you to make a new slide out of a
first level sub-topic.
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The levels created by following these steps automatically contain the Presentation Styles
title, outline 1, outline 2, et cetera. These Styles can be modified by having a new slide
design assigned to them, for example, a new font, font size and font colour. These
designs can, of course, be edited (for example, via the Styles and Formatting window's
context menu).

As suggested previously, you may switch views by pressing on the buttons at the top of
the slide:

Slide Transitions, Effects and Animation

With Impress, grabbing an audience's attention using animated objects and interesting
slide transitions is easy.

Automatic Slide Transition
When showing a series of slides, use the slide transition effects to present them in an
interesting way. For example, the current slide can roll out of the window while the new
slides rolls in. This effect is called “roll from left”.
The best thing to do is to assign this effect in the Slide Sorter View.Simply click on the
third icon from the top in the scroll bar on the right of the presentation window or choose
View > Slide Sorter.

In the slide view, all slides which have a slide transition effect, can be previewed via the
Play button on the Slide Transition tab in the TaskPane. Click this button to preview
the selected effect.

The Slide Transitionwindow is described in detail in NeoOffice Help.

Effects for Objects
The objects in a slide can have various effects; for example, they can roll into the
presentation from the left side, the text can be slowly drawn on screen, et cetera.

All these effects can be assigned in the Custom Animation tab in the TaskPane.
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1. Highlight the item/items to which the effect will apply (e.g. a series of dot points).

2. Click Add... in the TaskPane > Custom Animation window. The Custom
Animation Window will open.

3. Select the the desired effect and the speed required.

4. Click on OK.

Animations and effects are described in detail in NeoOffice Help.
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Selecting Hidden Objects

• Note: In OpenOffice.org one may select an object that is completely covered by another
object, and click on its position while holding down the Alt/Option key. However, this may cause a
crash in NeoOffice. The following steps must be regarded with caution.

• If several objects are lying on top of one another, every Option-Click selects a different
object lying in this position. Hold down Shift as well to click through the objects in the reverse order.

• Press the Tab key to select an object. Press Tab again to select the next object. Press
Shift-Tab to go through the objects in the reverse order.

Individual Presentations
A slide show presents the slides in sequence, from beginning to end. To start presenting
the slides in the presentation, either click the Slide Show icon on the main toolbar, or use
the keyboard shortcut Cmd-F2.

Presentations usually start with the first slide; however, to begin with the currently
selected slide, proceed as follows:

1. Choose Tools > Options > NeoOffice Impress > General.

2. In the area Starting the presentation, check the Always with current slide box.

Note: that this setting has priority over the Individual Presentation described below.

Other options permit you to show only or to never show certain slides:

1. To prevent display of a slide, go to the Slide View (for example by choosing View >
Slides Sorter), select the slide and select the icon Show/ Hide Slide on the

Slide View toolbar, or Slide Show > Show/Hide Slide in the main menu.

The number of the selected slide will now appear highlighted in gray inside a square,
meaning that the slide will not be shown.

2. Click on the Show/Hide Slide icon or Slide Show > Show/Hide Slide again when
the slide should be included again.
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Amore elegant way to keep individual slides hidden in certain presentations can be found
under Slide Show > Custom Slide Shows.

1. Open the Slide Show > Custom Slide Shows dialog,

2. Click the New button. The Define Custom Slide Show dialog appears.

3. In this dialog, enter a name for the presentation. In the left-hand box, there is a list of
the existing slides. Select a slide you want to be part of the custom presentation and
click the button with the arrows pointing to the right.

4. The slide will be inserted in the right field. Any slide listed on the right will be shown
in the custom slide show.

5. Rearrange the order of the slides in the right field via Drag & Drop.
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Exporting, Printing and Presenting

There are many possible ways of outputting finished presentation documents. For
example, you can electronically display finished presentations, print the pages in color on
paper or print high resolution transparencies, or transfer them wholly or partially to other
applications and then use them within those applications. Printing offers a choice between
outputting the document directly to a printer, or printing it to a file that may then be
copied to a printer.

Printing a Presentation Slide
In Impress, the current document is easily printed by clicking the Print File Directly
icon in the Standard toolbar. Printing proceeds to the installed printer screens. dialog.
(There is an exception in text documents where a certain area of text is selected and, in
this instance, a dialog appears upon clicking the Print icon. This dialog asks for
confirmation of printing the entire document or only the selected area.)

When printing via the Print dialog, Impress offers choices of whether to print only a
selected range of pages, only certain pages identified by their page numbers or all pages
of the document. Take a look at the print dialog, which is opened via File > Print or by
pressing Cmd-P. The appearance of the Print dialog may vary according to the selected
printer. However, in most cases, there are options to specify whether to print the entire
presentation, certain slides, or only the current selection. Other options specify how many
copies to print and how these should be collated.

Click the Options... button in the Print dialog to display additional options. When
printing text, drawing and presentation documents, the Brochure option is available for
two-to-a-page text on a single sheet. The size of the pages is reduced and printed in two
columns per page and double-sided, so that the pages need only be folded and fastened in
the middle to create a complete brochure.
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Since presentation objects are usually in the form of vector graphics, they can be printed
out in any resolution supported by the local printer or film recorder. Where the slides are
to be sent to a film recording service or to be printed on a high-resolution color printer in
a print shop, Export as PDF File from the File menu.dialog It will then be printed to a
PDF file that can be sent to the film recording service or commercial printer.

Note: You may need to first install and select the printer driver for the printer or film recorder that will be
used by the printing or film recording service. Most printing and film recording services require files created
for a PostScript printer. If there is no PostScript printer available, NeoOffice permits installation of a
PostScript printer driver that can be used to print to a file.

Exporting Presentations as Web Pages
When theWeb Page export file format is chosen, Impress automatically starts a Wizard
to help produce an attractive HTML presentation. A number of HTML pages are created
that are connected to one another by hyperlinks. The graphics in these pages are saved as
GIF or JPEG images. You can work on these HTML pages in Writer to give them
headings and additional hyperlinks, for example.

1. Select File > Export...

2. Choose the file format HTML.

3. Enter a file name

4. Click Save.

This opens the HTMLExportWizard. This Wizard is described, in detail, in NeoOffice
Help.

In the HTMLExport Wizard, you can choose whether the created Internet presentation
should contain frames, be able to be navigated using graphic buttons or with text links
and whether a link should be offered on the home page allowing you to download the
original Impress presentation.
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In addition to the export of default HTML documents and HTML documents with
frames, Impress documents can be exported as WebCast or in the automatic mode.

• WebCast export automatically produces scripts for web servers with Perl or ASP
support. This format allows a presenter (e.g. during a telephone press conference with
accompanying slide show over the Internet) to change the slides on the viewers'
browsers.

Note: For those confident to open the Application Package, examples may be found in
Applications/NeoOffice 2.x/Contents/share/config/webcast

• Automatic export takes over the settings for the viewing time of each page in the
presentation. A default HTML presentation is the result, in which the pages are
“turned” automatically.

Sound reminders for turning the pages can also be exported, if desired. The sound files
would then be copied in the target directory and played back when a HTML page is
loaded.

Exchanging Data via the Clipboard
Objects in a drawing or presentation document can also be copied to the clipboard and
then inserted elsewhere. The objects are stored as vector graphics on the clipboard using
the following procedure:

1. Select an object in the current document
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2. Copy it to the clipboard with Cmd-C.

3. Switch to the application into which to insert the object.

4. Insert the contents of the clipboard at the desired location with Cmd-V

Creating a Business Report

This section explains how to create a business report for a presentation. In the following
example, it is assumed that the presentation will be shown via a computer.

Creating a Business Report in Presentation Form
Since NeoOffice Impress has no business report template, this section will start with a
completely new document. To start, follow these steps:

1. Create an empty presentation document (File > New > Presentation). UsingWizard
Presentation is described quite well in NeoOffice Help.

2. Select Empty presentation

3. Click Create. This brings up the viewer. Use the Slide sorter or Normal viewer to
select the second slide [one with text]. dialog

4. On this “Title slide” click on the existing text and overwrite it with appropriate text,
for example “Elegy Software” and “Annual Report 2007”.
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5. To insert another slide, click the area next to the tab at the bottom of the screen.
Assign a name for the new slide and choose a layout (Ctrl-click or right-click while
the cursor rests somewhere on the slide itself to bring up the context menu, select
Rename Slide, rename it and save, by pressing OK, then via the contect menu again,
Modify Slide).

Note: Do not assign a name like “Slide2.” If the order of the slides needs to be changed later, the label
might not describe the content of this slide. Clear, descriptive names like “Overview” or “Introduction” are
more useful.

Insert additional slides, as necessary, from the Insert > Slide menu on the main toolbar (a
long click may be needed). Ctrl-click or right-click on the thumbnail of the slide to edit, e.g.
Overview, and then click the Outline View button at the top of the slide.

Entering Text in the Outline View
To establish an outline, use the Outline Viewmode. The Outline toolbar is added to the
top menu bar. Using the icons in the Outline toolbar, promote or demote an outline point
one level, or move it up or down in the hierarchy. The icons in the main toolbar can also
be used to determine which outline levels are to be displayed.
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In the Outline view, all slides in the presentation document are listed hierarchically, and
the title of each slide is preceded by a generic slide icon.

Enter the desired text and use the icons in the Main toolbar to structure the outline.
Create a subsection to a slide by placing the cursor at the start of the respective line and
(if the slide icon is showing there) pressing the Tab key. Use the Shift-Tab key
combination to move the line up one level in the hierarchy. Or use the icons on the
Outline toolbar [above] to shift up and down levels. After completing the edit of the
presentation outline, click the Normal View button on the top of the slide to return to the
Normal view.

Note: In NeoOffice, Normal View may sometimes be referred to as Drawing View

Changing the Slide Layout
Changing the slide layout can only be done while in the Normal View (the first button in
the row of buttons at the top of the slide). Right-click or Ctrl-click while the cursor is
somewhere on the slide. This brings up a context menu. The first selection, Slide, has a
submenu which allows editing of the slide layout and/or design.

Designing Slides

Designing a slide can only be done in the Normal View, and the Selection tool
must be activated.

To change the font size and style of the title, for example, turn on text formatting by
View > Toolbars > Text Formatting, select the characters/words/lines for change and
assign new attributes from the Font and Font Size fields in the Text Formatting bar.

Borders may be defined by clicking the paragraph to which to apply the border and
defining the attributes in the list boxes Line Width and Line Style.

To apply a uniform background and recurring elements (company name, subject) to all
slides, click View > Master > Master Slide or View > Toolbars > Master View .
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Youmay safely ignore the default texts in the Master View.These are not visible on the
slides. The only text visible on the slides is that which you entered. If there is no click-to-
edit text, use the Text icon on the Drawing toolbar, to open a frame for background text,
or use View > Toolbars > Text to open the floating Text toolbar and click on the Text
icon.

Using the Styles and Formatting window is an excellent method for managing the
appearance of the slides. Here is a step-by-step procedure:

1. Open the Styles and Formatting window by View > Styles and Formatting .

2. Click the Presentation Styles icon.

3. Select a background style, and

4. Open theModify dialog via the context menu.

5. Click the corresponding slide tab and make any changes.

By modifying the Background Style, you can assign the same background to all slides.

Note: Since the Master View can be activated at any time, it is always possible to make changes at a later
time.
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Creating a Slide Show

In completing a slide show, it is necessary to take a few additional steps to ensure a
successful presentation.

Defining or Changing Slide Order
To change the slide order, click the Slide Sorter button at top of the slide. In this mode,
all slides in the presentation document are displayed in reduced size. Click the slide to be
moved and drag it with the mouse to the desired position. The position where the slide
will be inserted is indicated by a vertical black bar.

Creating Cross-Fade Effects
To apply cross-fade effects, one must have Impress in the Slide View or Normal View.
Ensure that the Task Pane is open (activated from the Viewmenu). Click on the slide
when in the Slide Sorter mode.

Set the effect and transition period that is to apply to the slide Transition using the
controls above.

In Normal View, choose Slide Show > Slide Transition to bring up the same dialog in
which slide transition effects are defined. In the Slide Transition dialog, select the option
“Advance slide... on mouse click”. This will switch from one slide to the next in the
presentation when you click the mouse or press the right arrow key.
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Starting Presentations
The easiest way to start a presentation is by selecting from the main menu Slide Show >
Slide Show. Alternatively, click the View > Toolbars > Presentation to bring up the
toolbar below. Click on the Slide Show icon, , or choose Slide Show > Slide Show. The
on-screen presentation starts immediately. Presentation settings can be adjusted under
Slide Show > Slide Show Settings.

This dialog also lets you determine which slides to include in the presentation. Select any
other desired options, and click OK.
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Working with Connectors

In addition to the individual frames, connectors are important components of an
organization chart because they help represent the relationships within the organization.
Impress provides a variety of connector types. When you click on the Connectors icon in
the Main toolbar, a floating window with the available types appears.

Frames and connectors can be linked either from “edge to edge” or from “middle to
middle,” or a combination of both. These possibilities are described below.

"Edge to Edge” Connectors
Select the desired connector by clicking it, and then drag it to the first frame. A small
symbol is displayed on every edge of the frame. Put the mouse pointer on one of the
symbols (the symbol will be given a dashed-line border). Press the mouse button and
drag the connector to the desired frame. As soon as the mouse touches the frame,
symbols appear on each edge here as well. Continue dragging the connector to the
desired symbol(that symbol also receives a small, black border) and release the mouse
button.

When a frame that is connected to another frame is moved, notice that the connector also
changes position. The actual connection line between the two frames remains the same,
so that for minor shifting of the frames, the connector usually does not have to be edited.
With major frame movements, however, it is often necessary to reedit, because the
connector may shift to a different position.

To change the position of a connector, simply click on it. Small points appear, at both the
beginning and end of the connector. If the cursor is rested on one of the points, a small
square appears next to the mouse pointer. Press the mouse button and drag the beginning
or end point to the desired frame.

"Middle to Middle” Connectors
Select a connector from the Connectors floating toolbar. Click in the middle of one of
the frames, and a black, dashed-line border appears around the entire frame. Press the
mouse button and drag the connector into the middle of another frame, which also
receives a black border, and release the mouse button.
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The advantage of this method is that when the frames are moved later, the connector fits
perfectly, so that the beginning and end of the connectors lie in the middle of each frame.
This function comes in handy in switching the position of two frames because the
connectors need not be edited manually.

Editing Connectors
To change the properties of a connector, select it and click Connector... in the context
menu to open the Connector dialog.

Choose the desired connector type from the list box. The Standard Connector is the
default. The user can also modify the line skew and the line spacing in this dialog. All
changes will be shown in the small Preview window. To apply a different color to the
connector, open the Line dialog with the context menu.

Hints and Tips for a Successful Presentation

Using a Snap Grid
Towork with greater precision, use the grid function. To display a grid, click the option
Snap to Grid under Tools > Options > NeoOffice Impress > Grid. In addition, you can
also select Visible Grid to help position the objects more easily.

Editing Glue Points
By default, the connectors dock to the handles in the centre of the object pages. However,
using the glue points, you can make the connectors dock to any point of an object. For
detailed instructions, refer to the Help > Contents > Index > Search term > glue
points.
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Using the Mouse as a Pointer
There are occasions when using the mouse as a pointer is preferable to other methods,
such as a laser pointer. To use the mouse, select the optionMouse pointer as pen in the
Slide Show Settings dialog. This allows highlighting charts or pointing to important
aspects during a presentation. To change slides manually, double-click the mouse.

Changing Bullet Symbols in Outline View
To change a bullet symbol whilst in the Outline view, place the cursor in the desired
line/paragraph and click the Bullets and Numbering icon (only visible in the menu bar
of the Outline View). A dialog appears from which you can choose a different symbol.

Inserting, Deleting and Renaming Slides
1. To insert, delete, copy or paste a slide, or to insert an additional slide, do the
following:

a) In Slide Sorter, select the slide that precedes where the new slide will be put.

b) Now Ctrl-click the slide.

c) A context menu appears. The options it provides are:

Alternatively, to insert a new slide, choose Insert Slide from the main menu .
dialog

2. Other useful shortduts, achieved in Slide Sorter view by first highlighting the slide on
which to carry out an action:

a) Cmd-C to copy a slide.

b) Cmd-V to paste a slide.

c) Cmd-X to delete a slide.
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Creating and Printing Handouts
Providing handouts, to help the audience follow a presentation, is often useful. To
prepare handouts, use the Handout Viewmode. Since the handouts contain both the
individual slides and space for notes, they can be a very helpful presentation aid.

At the top of the slide, press the Handout button at the top of the slide. The Task Pane
should be open, and will allow you to dialogspecify how many slides are printed on a
single sheet of paper (see Task Pane below). If the TaskPane is not open, open it by
View > TaskPane.

Click on the most appropriate selection and click OK to create the handouts. To print
them, choose File > Print and click Printer Options to open a dialog in which you
choose how the handout should be printed.

Organizing and Printing Notes
Enter notes for individual slides in the Notes view. Access the Notes view using the
Notes icon located at the right of the document window scroll bar.

• Once notes are entered, print them by selecting File > Print... then click Options....
The Printer Options dialog appears.

• In the Printer Options dialog, in the Contents area, select Notes. Click OK. In the
Print dialog, select the slides for printing (all or specific ones) and click OK. Be sure
to go back and deselect Notes in the Printer Options dialog, otherwise the document
will always be printed with notes.

Note: The settings in Printer Tools apply only to the current document. For specific settings for all
presentations, choose Tools > Options > NeoOffice Impress... and select the Print tab.

Using the Navigator
Move quickly from slide to slide by opening the Navigator . All the slides of the
presentation are listed here. Simply double-click the relevant slide title to jump to that
slide.
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Edit Jump Targets

[Note: this works in OpenOffice.org, but may cause crashing in NeoOffice: In the bottom corners are areas
for which one can define an interaction. To edit or view the interaction, click (again in background mode) on
the area while pressing the Option key and open the context menu and choose the Interaction command.]

Modifying Object Size
To change the object size, drag a selection frame around the respective objects.

After selecting the frames, open the Position and Size dialog from the context menu. In
the tab Size, apply the same size to all selected frames under the group box Size.

Note: Alternatively, rather than using a selection frame, click on the individual objects and press the Shift
key at the same time to make a multiple selection.

Creating Additional Objects
For additional objects, copy one and simply insert it as often as necessary. Then, position
the rectangles in the document and align them using the snap lines.

Note: To display vertical and horizontal snap lines, click on the respective ruler and drag a snap line from
the ruler to the desired position.

Changing Font and Font Size
Change fonts and font sizes using a Style, so that these changes only have to be made
once. Click in one of the frames and open the Styles and Formatting window. The
Graphics Style Object with shadow is selected. In the context menu, chooseModify to
open the Graphics Style: Object with shadow dialog, and click on the Font tab to
define the desired font type and size. When you click OK, the text in all of the frames
will be displayed according to the selected settings.

Modifying Colors
To assign a different color to a frame, use the mouse to drag a selection frame around the
respective frame. Select Area in the context menu to open the dialog of the same name.

Select a color on the Colors tab. Further design options are available with the various
color schemes in the Gradients tab. Choose one of the existing color gradients, all of
which can also be edited and modified.

Shortcut Keys in Slide Shows

Shortcut Keys Effect
Esc or Backspace or (-)
Minus key on the numerical
keypad

End presentation.
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Spacebar Next animated object or next
slide.

Enter or Arrow Down or N Go to next slide.
[number] - Enter Type a number of a slide and

press Enter to go to the slide.
Arrow Left or Arrow Up or P Go to the previous slide.
Arrow Right Go to the next slide.
Home Jump to first slide in the slide

show.
End Jump to the last slide in the

slide show.
Ctrl+Page Up Go to the previous slide.
Ctrl+Page Down Go to the next slide.
B Toggle screen to black.
W Toggle screen to white.

Navigating with the Keyboard in Slide Sorter

Shortcut Keys Effect
Esc Moves the focus to the first

slide.
Arrow key Moves the focus to the next

slide.
Spacebar Makes the slide with the focus

the current slide.
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Chapter 6: Creating Drawings with Draw

NeoOffice Draw can be used to create drawings with different degrees of complexity.
This ranges from a simple drawing to an interactive multi-page document. To create
drawings or graphics, open an empty document and design all the elements by hand, or
work with the templates and sample graphics that can be reached by selecting File > New
> Templates and Documents or directly from the Gallery, in the case of graphics.

Draw enables creation and saving of vector graphics. These graphics can also be exported
as pixel graphics. Furthermore, it is also possible to insert pixel graphics (bitmaps) into
Draw pages at any time.

NeoOffice Draw Functions

This section contains an overview of some of the NeoOffice Draw capabilities.

Creating and Publishing Vector Graphics
NeoOffice Draw is an object-oriented vector graphic drawing program. The objects can
be lines, rectangles, 3D cylinders or other polygons. All objects already have set
properties, such as size, color of the surfaces, color of contours, linked files, associated
actions when clicked and much more. Any or all of the properties can be modified at any
time.

Because of the vector technology, objects can be rotated in any direction and have their
size altered, without unsightly step effects (“jaggies”) occurring on the edges.
Furthermore, as all of the objects can be controlled individually, they can be moved and
overlapped as required.

Creating 3D Objects
Draw does not restrict graphics to two dimensions. Cubes, spheres, cylinders and other
3D objects, can be created, rotated at will - and each object can be illuminated
individually by means of various light sources. These features together with default or
freely defined color gradients, allow quick and easy creation of eye-catching company
and Internet presentations.

Manage Organization Charts
NeoOffice Draw is object-oriented. The objects could be rectangles, for example,
containing text and linked to each other. If rectangles are moved, connectors will
automatically follow. This makes drawing and maintaining a company or departmental
organizational chart much easier. The connectors can also be freely placed at glue points,
which makes the creation of technical drawings with explanatory texts easier.

Drawing
Make straight lines, free lines, bezier curves and other types of rectangles and
geometrical figures in the usual ways. The 3D functions can be used to create 3D objects
such as cubes, spheres, cylinders, tori and more. Rotate two dimensional contours in the
third dimension. Choose coloring, coloring with bitmap textures, perspectives and/or
illumination to create impressive 3D objects for invitation cards, brochures, business
cards and other stationery.
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To insert additional elements into a drawing use clipart available in the gallery. It doesn't
matter if they are vector or pixel graphics.

Export
Use Draw to quickly and easily create buttons and icons for Web pages et cetera and
export them as GIF, JPG, PNG or other formats.

Construct
There are many tools that help create exact drawings. For example, define a grid to which
an object can be snapped during construction and moving, or temporarily snap new
objects to the edges and points of existing objects. The size of the object can be altered at
any time by entering the required measurements in the Properties dialog. It is also
simple to insert dimension lines which can be used in a variety of ways.

Integrate
And, in case it is not obvious, Draw allows you to add texts, tables, charts and formulae
from the other program modules of NeoOffice into any drawing.
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The NeoOffice Draw Window

Toolbars and Windows in NeoOffice Draw
The above graphic shows the various floating windows that enable NeoOffice Draw.
Each window has a corresponding icon on one of the toolbars (e.g. Basic Shapes, Lines,
Insert, Block Arrows, Connectors). Most are icons located on the Drawing toolbar that is
on the left of NeoOffice main window in this screenpic. This toolbar and many others
can be turned on by the path View > Toolbars > [Select toolbar]. Please ensure that at
least Help > Tips is enabled so that hovering the cursor over an icon provides a
meaningful explanation of what each does. Enabling Extended Tips gives even more
information.

Note: that you can also access functions through the context menu instead of using menu commands, which
makes for less work with the mouse.
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Drawing Rectangles and Ellipses and Entering Text
The drawing module in NeoOffice (Draw) has many functions for creating and editing
vector graphics. This section introduces the most commonly used functions.

More detailed information can be found in NeoOffice Help.

Open a new drawing document by choosing File > New> Drawing. In addition to the
blank drawing page, notice the main toolbar on the left and the object bar for drawings at
the top of the work area. With the View > Toolbars command, adding the option bar
and/or the color bar at the bottom edge of the window is easy and useful as shown in the
following illustration:

These instructions may be used to create a presentation document instead of a new
drawing document.There are a number of visible differences between Impress and Draw:
eg the Task Pane in Impress, and the tabs along the bottom of the Draw document.

Draw and edit vector graphics in the drawing view. The other views, which are only
available in Impress by clicking the buttons at top right, help create presentations. They
are introduced in the chapter on Impress and are also described in Help.

In the Slides view of Impress, you work on the individual slides of the presentation,
whereas the Master View allows you to define a uniform background for all slides. In
addition, the layer view can be turned on and off as desired. For example, the layer view
is where objects that are not always supposed to be visible can be managed.

The main Drawing toolbar contains several floating toolbars. When opened, these
toolbars provide additional related icons. The floating toolbars are indicated by small
triangles on icons and are opened by long-clicking the corresponding icon on the main
toolbar until the floating toolbar appears. When a toolbar is “floating”, it can be moved
from its original position and placed anywhere else in the work area.

Long-click the Basic Shapes icon to open the floating toolbar and click on the
Rectangle icon. The pointer changes to a cross-hair symbol with a small square.

1. Draw a rectangle on the slide. It has preset attributes, including a blue fill and a thin
black line as a border. There are eight handles with which can be dragged to change
the size of the object.

2. Draw further rectangles. These can be overlaid with the existing rectangles.
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3. Click the Basic Shapes icon again, and draw a few ellipses. Also try drawing a few
3D objects, as shown in the illustration. Several examples are available in the 3D
(three-dimension) theme in the Gallery, if your Gallery collection contains that theme

4. Click each of the objects and modify the fill color, line color, and the line width using
the list boxes and icons on the object bar.

Note: Clicking once on any tool, makes the tool available for only one single task. Double-click the icon to
allow it to remain active until another tool is chosen.

Defaults, such as blue as the filling color, can be changed. Make sure that no object is selected and choose a
different color on the object bar as the new default.
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Rotating and Resizing Objects
When clicking an object for the first time, eight handles appear with which the size may
be changed. The whole object can also be dragged to move it to another position on the
slide.

Click the Rotate icon on the main Drawing toolbar under Effects and directly on
the main toolbar in Impress.

When the mouse pointer is positioned over a handle,
the pointer indicates that the object can be rotated
by dragging the mouse. In the middle of the object,
a small circle indicates the pivot point. It can be
moved to any other position with the mouse. When
the corners of the object are dragged with the
mouse, the object rotates around the pivot point.
Dragging the middle points on the sides slants the
object in relation to the opposite edge.

Click on the object once again to display the eight handles. By double-clicking within the
object, the handles change and the text cursor appears positioned in the middle of the
object. Text can now be entered which is automatically connected to the object. Some
interference may appear on screen. Press Cmd-Shift-R to refresh the screen.

To resize an object, simply click on one of the handles and drag until the object is the size
needed.

Arranging and Aligning Objects

Arranging Objects

Where objects are overlapping and the position of the
individual objects in the foreground or background must be
changed, use either the context menu commands, or use the
icons on the Arrange floating toolbar, accessed on the main
Drawing toolbar

• Click on the object which is to move either in front of or behind other objects. Then
click on one of the icons in the upper row of the Arrange floating toolbar, for
example, to move the object completely to the back. To position it directly behind
another object, click the Behind Object icon. Then click on the object behind which
the current object is to be positioned. This effect will only be seen if the objects are
presently overlapping or are moved to do so later.

Select two objects at the same time by holding down the Shift key
and clicking the objects, one after the other, and then clicking
Reverse. This switches the order of the two objects.
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Aligning Objects

Position objects anywhere using the mouse. However, to
position an object at exactly the upper margin of a slide, for
instance, or center two objects vertically above each other,
use the icons on the Alignment floating toolbar, accessed on
the main Drawing toolbar.

• If an individual object is selected and then one of the icons on the Alignment floating
toolbar is clicked, the object is aligned at the page margins. Two or more objects
selected together, will be aligned to each other.

• A special type of alignment is the Distribution of objects. When at least three objects
are selected at once, use the Distribution command. In Impress, this command can be
found in the context menu, while in Draw it is found as an option in theModify menu.

The selected objects are distributed so that their borders or midpoints are the same
distance apart. The two objects that are the horizontally or vertically farthest apart from
each other are fixed points, i.e. immovable. The other objects between the outermost
objects can be moved using this function.

Note: Remember that everywhere in NeoOffice a multi-level undo function is available. Activate this
function by clicking the Undo icon on the Standard toolbar or by pressing Cmd-Z. Each time this command
is used, it reverses a previous action.
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Drawing Sectors and Segments

Note: to go through these examples, the Circles and Ovals (known as Ellipse in OpenOffice.org) toolbar
may need to be added. To do this, follow this path Tools > Customize... This brings up a window, where you
may select the Circles and Ovals Toolbar: Save it In Draw as indicated at the bottom of the menu. Or it
may be necessary to create a new toolbar by selecting New..., naming the toolbar Circles and Ovals, saving
it in Draw, and then pressing Add... to select the circle and ellipse icons one by one. Press Close to save
finally, and you should find that when you go to View > Toolbar.

The Ellipse or Circles and Ovals floating toolbar contains several icons for drawing
sectors and segments. Sectors look like “perfectly cut pieces of pie”. Segments look like
halves of a pie.

Drawing sectors of an ellipse or circle requires multiple steps, though the process
functions intuitively:

1. Open the Ellipse or Circles and Ovals floating toolbar by this path View > Toolbars
> Ellipse or View > Toolbars > Circles and Ovals and make sure that there is now a
check mark next to the word Ellipse. Click on the Circle Pie icon. The pointer
changes to a cross-hair symbol accompanied by a small sector symbol.

2. Use the mouse to drag open the shape of a circle. The outline of a circle follows the
movement of the mouse.
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Note: The first click defines the first corner of the delimiting rectangle which surrounds the circle. The
delimiting rectangle will later be obvious from the eight handles that appear when selecting the circle. To
draw the circle such that the first click defines the centre, press the Option key while dragging the mouse.

3. Release the mouse button when the circle has
reached the desired size. Now notice that a
radius which follows the movement of the
mouse is drawn in the circle.

4. Position the radius at the point where it is
wanted so as to place one boundary of the
sector and click once.

5. Now when moving the mouse, notice that the
first radius is set and a second radius follows
the movement of the mouse. Click again to
complete the circle pie.

Drawing ellipses is done in a similar fashion. The dimensions of the delimiting rectangle,
formed when first drawing the shape, determines the dimensions of the ellipse. When
drawing a segment, proceed in exactly the same manner as described above for sectors.
The only difference is that in the last step no second radius follows the movement of the
mouse, but rather a secant (straight line) cuts through the circle.

The other icons in the Ellipse floating toolbar can be used to draw ellipses and arcs. This
process also functions as described above although, only the perimeter of the ellipse or
the circle is drawn.
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Entering Text
To enter a text in a drawing, decide if the text should have a “normal” format as in a text
document or if the text should be handled as a graphic object that can be rotated,
expanded, minimized, et cetera. “Normal” text can also appear in the form of a legend (in
a frame with an arrow).

Open the TextObject floating toolbar from this path View > Toolbars > TextObject
from the main toolbar.

Note:Where Asian language support is enabled under Tools > Options >Language
Settings > Languages, there will be additional icons for entering vertical text.)

1. Enter “normal” text by clicking the Text icon in the Drawing toolbar.

2. Ctrl-click or right-click on the text box. From the context menu, select Edit Style... A
window will open with lots of tabs to select from. On the Text tab page, select the Fit
to frame checkbox. Click OK. Drag open the frame in the document which sets the
position and maximum width the text area should have. If the text is long, extend the
frame in order to incorporate the whole text. The position and the size of the frame
can later be changed using the mouse; but the frame cannot be made smaller than the
text itself.

3. Enter the text. Select the text by holding down the Shift key while using the arrow
keys or use the mouse. The font and font size can now be modified as in regular text
documents.

4. When the mouse is clicked anywhere on the document other than the text, text edit
mode is no longer in effect. Clicking the text once again, the text will be selected as an
object. Now, it can, for example, be rotated or the entire text moved. By double-
clicking the text it can be edited again, for example, delete characters or set additional
font attributes.

Adding a Text Frame

1. Click the Text icon and move the mouse pointer to where you want to
enter the text.

2. Drag a text frame to the size you want in your document.

3. Type or paste your text in the text frame.

Double-click the text to edit it or to format text properties, such as font size or font color.
Click the border of the text object to edit the object properties, such as border color or
arranging in front or behind other objects.

Fitting Text to Frames
1. Create a text frame as described in the steps above. The size of the frame
determines the size of the text.
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2. With the text object selected, choose Format - Text. The Text dialog opens,
allowing the changing of any asapect of the format.

Callouts

1. Using the Callouts icon, select a callout shape. The cursor chages to a cross-
hair. Drag the mouse. The starting point will be where the bottom of the callout
frame will sit. The crosshairs will show where the top of the callout will be.

2. Release the mouse button.

3. Edit the size of the frame of the callout.

4. To start entering text into the callout, just double-click the line. The callout frame
appears with eight markers on its rim and a blinking cursor, indicating text edit mode.

5. Enter the callout text.

6. Change the line properties by right-clicking (Ctrl-clicking) on the line, opening the
context menu and clicking on the Line command. Select arrowheads for the lines in
the Style pull-down list on the Line tab page.

Converting Text Into 3D
Selected text can be transformed into a 3D body by choosing Convert > To 3D from the
main menu. If the Convert to 3D is grayed out, double-click on an area outside the frame
and start again. The 3D body will fill the area created for the text frame. This example
has been colored for effect.

3D text can be rotated using the Rotate icon from the Effects floating toolbar on
the main Drawing toolbar.

By clicking inside the delimiting frame and dragging with the mouse button pressed, the
object will rotate on all the axes at the same time. However, by clicking one of the eight
handles and dragging it with a pressed mouse button, the object rotates on only one axis.

The pivot point, which first appears as a small circle in the middle, can be moved. Thus,
while rotating the object, it rotates around the new pivot point. Open the 3D Effects
window by right-clicking or Ctrl-clicking to open a context menu and select 3D Effects,
from which another, different illumination can be applied to the 3D object.The 3D
Effects window is described in more detail in Help.
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With the text object selected, choose Format > Text. The Text dialog opens, allowing
you to change any aspect of the format.
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Drawing, Editing and Converting

Curves and Objects
With vector graphics in drawing and presentation documents, you can design not only
ellipses and rectangles, but also irregularly shaped curves forming open or closed figures.
Both Impress and Draw make it very easy to draw and edit even quite unusual figures.

Drawing Curves

1. The tools for drawing special shapes are found in the Curves floating toolbar

indicated by this icon on the main Drawing toolbar. Drag the floating toolbar
away from the Main toolbar into an empty drawing or presentation document.

2. Select the Curves icon . The cursor appears as a cross-hair symbol.

3. Create a curve using the mouse.

a) The point where the mouse button is first clicked determines the starting point.

b) Move the mouse in the direction the curve should take from the starting point. The
point where the mouse button is released, defines this direction.

c) Move the mouse without holding the button down and the curve will follow the
movement of the mouse.

d) Click where the second point of the curve should be.

By holding down the mouse button, the direction of the curve from the second point
can be defined to the next point (in the same manner as was done at the starting point);
release the mouse and move to the third point, click again and keep the mouse button
pressed, and so on.

Notice that, when the mouse button is released after clicking on the second point of
the curve, and another point in the slide is clicked, the second point will be defined as
a corner point. At a corner point, the curve abruptly changes direction, thus forming a
corner. If there is a point three defined as a corner point in this way, a straight section
between points two and three will appear.

When the Shift key is held down, directions are limited to multiples of 45 degrees. By
holding down the Option key, the curve will be closed, and an additional curve can be
drawn. These can be combined with the first one to form a single object.
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4. To end curve drawing, double-click the last point to be set then continue working with
other tools.

The curves, that have been drawn using the above steps, are Bézier curves. The points on
a Bézier curve are called data points.
• Each data point on the Bézier curve can be “symmetric”. The curve then has the same
curvature either side of the point.

• Or, the data point is “smooth”. The curve then has different curvatures either side of
the point.

• If the curve is not steadily continued at the data point, but instead forms a corner or
tip, it is a corner point. Any type of data point can be converted into any other, thus
giving good control over the shape of the curve.

Note: When precisely linking two existing points in a drawing using lines, click the Line icon on the main
toolbar and also activate the Option bar via View > Toolbars > Option Bar. Select the Snap to Object Points
icon on this toolbar.

Editing Curves
Data points can be edited if they are displayed as small rectangles. To work on a curve

later, when it is no longer selected, click the Edit Points icon on the Drawing
toolbar and select the curve.

1. Now click Edit Points on the far left of the object bar or on the option bar.

2. Click once on the point for editing. It will appear as a filled square, and there should
be two Bézier lines with control points at the ends. (Please note that sometimes one of
the control points is directly on top of the Bézier point and thus hard to see.) In the
case of corner points, which define right angles, the control points lie directly on the
Bézier point.

Now move the Bézier point and the control points as needed. Note how the curve
changes accordingly. The change in form of the cursor indicates in each case the
function that can be executed.

The object bar contains several icons with which can, among other options, change the
type of the selected point. A detailed explanation of the various options can be found
in Help.

3. To convert the type of data point, select the point. The object bar shows the type of
point: corner point, smooth transition or symmetric transition.

4. Click one of the icons to change the type of point.

Of course, curves can also be edited in the “conventional” manner, i.e., changing width,
color, and (in the case of a filled curve) the object fill. The options for changing these
attributes are found in the context menu, or the Format andModify menus.

Also try out the other icons on the Curves floating toolbar. When a filled curve is
finished by double-clicking, it is automatically closed and all “internal areas” are filled.
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Vectorizing Bitmaps
With NeoOffice Draw or Impress, you can transform pixel images, so called bitmaps,
into vector drawings. One of the advantages of vector graphics is that they look good in
any scale when printed. This is different to printing scaled bitmaps, since unattractive
effects may appear in bitmap images, such as missing or zigzag lines, et cetera.

1. Select the bitmap to vectorize, for example by clicking once on the object.

2. SelectModify > Convert > To Polygon from theModify command in the main
menu. For Impress, select from the context menu of the selected object.

The Convert to Polygon dialog enables setting some parameters for the conversion
and previewing the result.

3. Click on OK and the selected bitmap is now a vector graphic.
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Converting Text Characters to Curves
Sometimes you need to fancy up some text, say for a logo or sign, such that the text is
non-linear. The following procedure shows one way to accomplish this task.

1. Use the Text icon from the Drawing toolbar and then type the text, letters or
special characters in a Draw document. Remember to use a reasonable font size and
font type to avoid unnecessary editing later.

2. With the text object still selected, choose the commandModify > Convert > to
Curve. The text is converted to a vector object that can be edited.

3. If the text consists of more than one character, the characters maybe displayed as a
grouped object. To edit a single character, enter the group. To do this, use the Enter

Group command in the context menu of the group, or just double-click
somewhere in the document, then click the character to be edited.

4. Now, click the Edit Points icon on the Drawing toolbar (top left in the graphic
below). Click the object to see all the Bézier points of the object. The Edit Points bar
provides various icons for editing, inserting and deleting points.

5. Use the Zoom floating toolbar to enlarge the view. If the black filling of the characters
is a distraction during the editing process, temporarily change it to, say, 10% gray by
choosing Format > Area.

Converting to Curves, Polygons, 3D
Many objects can be quite effectively edited by converting them. The following examples
illustrate this concept:

• Open a rectangle. This has the default settings for color, line thickness etc. and should
now be selected.

• ChooseModify > Convert (in Impress the corresponding command can be on the
context menu of the rectangle). The menu subcommands are: To Curve, To Polygon,
To 3D, To 3D Rotation Object.

• ChooseModify > Convert > ToCurve to convert the rectangle into a Bézier curve.
Now edit the existing points. As shown in the following graphic, move the points,
convert them from corner points into rounded points, delete them, insert new points et
cetera as the rectangle is converted into a heart shape. All these options are described
in detail in Help under the search words Edit points and Bézier object bar.
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ChooseModify > Convert > To Polygon to convert the original rectangle into a
“Polygon with 4 points”, as will then be stated on the status bar. Now, for example, a
polygon down can be broken down into its basic parts by choosing Break from the
Modify menu. The status bar will then read “4 Lines selected”. Each of the lines can be
shifted separately.

With a polygon selected, click the Edit Points icon to modify points, insert new ones and
anything else needed in this mode.
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SelectModify > Convert > To 3D to generate a three-dimensional object from the two-
dimensional object in red above. This conversion uses an extrusion method such that the
polygon is “pulled” perpendicular to its plane by a certain amount into the third
dimension.

3D objects can be rotated and edited via the 3D Effects window that is called up from the
context menu.

To create a 3D object by means of a rotation extrusion, chooseModify > Convert > To
3D Rotation Object. A polygon will be rotated 360 degrees around an axis into the third
dimension. See how our red heart is converted into an interesting shape as a 3D Rotation
Object.

By rotating a rectangle a little bit before converting it into a 3D rotation object, a more
striking object will be created.

While these examples showed conversion of only basic objects, such as simple
rectangles, imagine how much can be done when converting complex objects.

For example, drag a drawing from the Gallery to the page and convert it, first into a
Metafile (Modify > Convert > Metafile) and then into a 3D object. Draw positions the
objects contained in the drawing in various 3D levels corresponding to their arrangement
in 2D levels. For example, in 3D the stars from the European flag stand out vividly from
the blue background of the flag.
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Most objects can be converted to 3D:

• Groups can be converted as long as they contain convertible objects.

• Bitmaps will be laid as a texture over a rectangular object of adequate size.

• Metafiles will be broken down into a group of polygons and then converted.
(Sometimes you can observe the program re-drawing the polygons, if it is a
particularly intensive operation.)

• Draw objects with text on them display the text in raised form on their surface (e.g. a
rectangle which was double-clicked and on which text was placed).

Illustration: 3D letters on a 2D background: use Modify > Convert > Metafile then Modify > Convert >
To3D
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Illustration: Two versions of a graphic, one 2D and one 3D
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WorkingWith Objects

Individual objects in an Impress or Draw document can be selected, copied, cut and
pasted in much the same way as words in text. Other actions are also possible that are
only available for graphic objects. For example, objects may be duplicated, cross-faded
or grouped. Figures placed in the drawing area, such as rectangles, circles, lines et cetera,
are treated as objects.

Duplicating Objects
Objects, in Draw, are easily duplicated. This feature allows you to make a set number of
copies of an object which differ in consistent degrees from one copy to the next in
position, orientation, size, and color.

For example, to create a stack of coins, use the duplicate function.

First create the bottom coin by doing the following as shown in the graphic below:

1. Draw an ellipse or circle at the bottom of the slide.

2. Choose the Edit > Duplicate... command to open the Duplicate dialog.

3. Enter the following values:

Follow these steps to create a stack of coins as shown on the right of the above graphic:

1. Select 13 as the number of copies. The x-axis is the horizontal axis from left to right.
Entering positive values in the field for the x-axis placement causes a shift to the
right. If the stack of coins should increase from the bottom up, enter a negative value
in the y direction (vertical).

2. Tomake the coins become smaller the higher they get, enter a negative value for the
width and height.

3. Finally, define a color scheme from bottom to top. Select, for example, a darker
yellow for the beginning color (bottom) and a lighter yellow color for the end color
(top).
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4. Click OK to create the duplicates.

5. To create piles, hold down the mouse button as the cursor covers the whole pile. A
dooted rectngle will show what has been selected. Notice that each of the coins in the
pile is highlighted. Press Cmd-C to copy and Cmd-V to paste the new pile. Move the
new pile to an appropriate location. Click outside the picture somewhere. Now it is
possible to highlight each “coin” individually and remove some from the top of a pile
to create different-sized piles.

Cross-Fading Between Two Objects
The cross-fading function is only available for drawings in Draw and not in Impress
documents. To insert into a presentation an object that was created by cross-fading two
objects, copy it from the drawing into the presentation document by way of the clipboard.

In the process of cross-fading a transition between two objects is calculated and the
increments will be positioned on the page. In the increments, the form, orientation, and
color of the objects, as well as other attributes, are adjusted uniformly.

1. For example, in an empty drawing document, draw an object at the bottom left and
another one at the upper right (use two different colors).

2. Select both objects.

3. Select the command Edit > Cross-fading. A dialog appears where further settings can
be defined.

4. Click OK.
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Draw calculates the increments and displays the
results. This new object is a group which consists
of the specified number of individual objects. Enter
the group and then edit the individual objects. The
Modify menu in Draw contains all the necessary
commands for working with groups and these
functions can be also found in Impress under the
Format > Group menu command or in the context
menu. Further information can be found in Help.

Working With a Group of Objects
Several objects at one time can be selected, grouped, combined, merged, subtracted and
intersected.

• Selecting several objects at the same time has a temporary effect; i.e. whenever the
mouse is clicked elsewhere on the page or slide, the grouped area is deselected.

• Grouping and combining are valid until the group or the combination is deselected
using the command from the context menu or theModify menu.

These commands can also be used to group together several groups, add a combination
and combine the results as a group or combination.

Grouping Objects

Several objects can be combined into a group. To do this, select them together by
pressing Shift, right-click to bring up the context menu and choose Group, or go to the
main menu Modify > Group. Any and all changes made to a group have an effect on all
objects in the group. In particular, groups can be moved, rotated, etc. as a single object.

For example, in drawing a bicycle, first construct a wheel, composed of a tire, rim,
spokes, and hub, and then group these objects together. This makes it easy to rotate the
wheel, duplicate it, and move the second wheel to the appropriate position. Finally, draw
the frame and the rest of the bicycle, and form a new group.

To edit an object that is part of a group, there is no need to redefine the group. Use the
Enter Group command on the context menu, which allows editing any object in the
group. When edits are completed, exit group and re-save as Group.

Entering Groups

Enter a group by first selecting it, either by clicking it or by using the keyboard. Once
selected, you can decide whether to employ the context menu command or double-click
the group to enter it.

Exiting Groups

Exiting a group may be accomplished in these two ways: using a menu command, or
double-clicking outside all of the objects in the group. The group remains selected upon
exit; thus making it possible to quickly enter and exit a group using the keyboard.
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Navigating Between Objects of a Group

Using the Tab and Shift-Tab keys you can move forward and backward along the row of
objects in a group on a page. If the keys are pressed again on a final object while going in
one direction, the first object selected will appear next.

Combining Objects and Constructing Shapes

In Draw and Impress graphic objects may be combined in different ways. Several single
objects can be brought together to create new objects by using Boolean set operators on
the original geometry.

Combining Objects
1. Select several objects.

2. Choose Combine from the context menu.

In contrast to groups, which consist of single objects, a combination fuses the component
objects into one single new geometric object with its own new properties. The
combination may be undone again later, but the individual objects may not be
recoverable.

You should recognize the property that stands out the most in a combination when the
individual objects overlap. In this case, the combination is the result of the
Boolean/logical operator XOR, and shapes, discussed later, are other logical
combinations. The areas of overlap are the ones which stand out the most in a
combination, as they will be converted into “holes”.

In the illustration, several objects are shown to the left as they are before being
combined, and at the right after being combined. The combination is given the attributes
of the object farthest to the back (i.e. undermost object).

Constructing Shapes
The commands Shapes > Merge, Subtract and Intersect also form a new geometric
object out of the original objects. The new object comes into being through the use of
logical amount operators (boolean O) on the source geometries.

1. Select several objects.

2. Choose Shapes from the context menu. In the submenu, chooseMerge, Subtract or
Intersect.
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In the following illustrations the original shapes are shown on the left and the result on
the right.

Shapes - Merge

The selected polygons are merged so that they make one object,
the surface of which is the sum of all the parts (Boolean OR).

Shapes – Subtract

All other polygons selected are subtracted from the undermost
polygon. This entails the other polygons first being merged
and then subtracted from the polygon positioned under/behind
all the others. Holes are taken into account. Logically this
operation corresponds to the following formula: A - (B1 | ... |
Bn)

Shapes - Intersect

The selected polygons are joined into one single
polygon that corresponds to the intersection area
(Boolean AND).

Only the area where all polygons overlap remains.

Choosing Shapes > Subtract and Shapes > Intersect also permits cutting parts out of a
bitmap. The illustration below shows an example.

Graphic Objects in Drawings and Presentations

Both Draw and Impress use a vector graphic format. However, pixel graphics or bitmap
graphics may also be inserted into presentations or drawings and documents or certain
sections of a document can be exported in a pixel graphic format.
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Inserting Bitmaps
Bitmap images can be inserted in any Writer, Calc, Draw or Impress document.

1. Choose Insert > Picture > From File....

2. Select the file. With the File type field you can limit the selection to certain file types.

3. Check the Link box to hyperlink to the original file where embedding is not needed.

If the Link box is checked, whenever the document is updated and loaded the bitmap
image is reloaded, and any editing steps, that have been applied to the local copy of
the image in the document, are re-applied and the image is displayed.

If the Link box is not checked, the copy created with the first insertion is embedded
and used.

4. Click Open to insert the image.

Editing Bitmaps
When a bitmap image is selected, the toolbar offers the tools for editing the image. Only
a local copy is edited in the document, even if an image is inserted as a link.

The toolbar may look slightly different depending on the module being used. The
illustration shows the Picture toolbar in Draw:

A number of filters are located on the Filter floating toolbar,
that you can open with the icon on the far left of the object bar.

Some of the filters open another dialog when started, and you
can use these options, for example, to select the intensity of the
filter.
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Text and graphics can be added to the bitmap image by selecting these objects together
and exporting the selection as a new bitmap image.

Applying Text to Bitmaps

To apply text to a pixel image and save it in JPEG format, for example, follow these
steps:

1. Open a new drawing document.

2. Insert the pixel image by choosing Insert > Picture.

3. Unselect the image by clicking somewhere else in the document.

4. Click the Text icon on the main Drawing toolbar.

5. The mouse changes to a crosshair symbol. Hold down the mouse button and draw a
frame around the pixel image with the mouse.

6. Enter some text inside this frame.

7. If desired, select this text and assign another color to it. The background of the text is
automatically transparent.

8. Select the pixel image and the text by drawing a frame around both with the mouse.
The Status bar will read “2 draw objects selected”.

9. Choose File > Export and, in the Export dialog,

10.Select the file type “JPEG - Joint Photographic Experts Group”
11.Enter a name.

12.Check the Selection check box to export only the selected objects.

13.Click Save dialog

14.During Save, another dialog permits setting options to define the quality of the JPEG
image, up to 100%, and in grayscale. Remember that the higher the quality, the larger
the file will be.

When a graphic object (for example, an inserted Pixel image) is selected in Impress or
Draw, the Picture toolbar will be automatically displayed, some via the Color list menu
(see below). This Picture toolbar enables modification of the color tone, brightness and
contrast of the graphic object.

Changing the transparency value of graphic objects is also possible via the Picture
toolbar. At higher transparency values, a graphic object becomes see-through, and objects
lying behind it will be visible. When the work is saved as a NeoOffice document, the
transparency is saved too.

NOTE: When exported as a graphic format, transparency is only saved where the graphic format supports
the transparency and this function is enabled at the time of export.

Saving Bitmaps
Saving changes to a bitmap image as an image file, for example in one of the GIF, JPEG
or TIFF file formats, is only possible in Draw or Impress by selecting and exporting the
bitmap image. The following provides a step-by-step procedure:
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1. Select the bitmap image.

Also select any additional objects as necessary. Press the Shift key for each selection or
open a frame around all objects, to include, say, text with the bitmap image.

2. Choose File > Export to open the dialog.

3. In the File type field select the file format desired. For example GIF, JPEG, PNG et
cetera.

4. To only export the selected objects, check the Selection box.

If Selection is not checked, the entire page of the document is exported.

5. Enter a name for the file.

6. Click Save.
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Working with Colors

The Picture toolbar has two color control icons. Click the one on the left to produce the
Color list box, which allows a huge range of selction of the R, G, B colors, and also of
transparency and contrast and brightness. Click the icon on the right and another (Area)
dialog appears. This allows you to choose redefined colors via the Colors tab.

The Color Bar
If wanted or needed, the color bar can be displayed on the edge of a drawing or
presentation. The color bar offers a choice of colors. Selected objects can be colored by
simply clicking on a color. To display the color bar, select View > Toolbars > Color
Bar.

The color bar displays all predefined colors with their respective names in the same order
as in the Color tab list box of the Areamenu. User-defined colors appear at the end of the
color bar and the bottom of the list box.

The field at top left of the color bar is for the color “Invisible”.
Change the size of the color bar using the mouse. Alternatively, dragging the color bar
with the mouse converts it to a movable, variable-size window that can be manipulated in
the same way as most other windows. For example, it can be moved by dragging the title
bar and its size changed by dragging the edges or corners of the window. To dock the
window again, hold down Ctrl and double-click on a gray area of the floating color bar.
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Defining Custom colors
Any number of colors can be defined by the user, have names assigned and be saved in
color palette files.

1. In a drawing document, choose Format > Area... to open the Area dialog.

2. In the dialog, click the colors tab.

This provides everything needed to modify the color of a selected object. Here, you can
also define and organize new colors.

To apply a color that is not yet in the color palette, first define the new color and assign a
name to it.

Note: Modifications to the standard color palette are permanent. These are saved automatically, and are
irreversible. This should not present problems if only adding a new color to the palette, but it can create
difficulties if the standard colors are changed.

1. To define a new color, the best thing to do is choose a color from the color palette
which resembles the new color. It will be displayed in the upper of the two preview
boxes.

2. The list box provides two settings , RGB and CMYK, for defining the color via the
spin button. Select the color model in the list box that corresponds to what is needed
for this color.
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The color models RGB and CMYK are just two of the models most used to define
colors. RGB stands for red-green-blue and this model is particularly useful for colors
being displayed on a computer monitor as it combines the three basic colors used.
CMYK stands for Cyan-Magenta-Yellow-blacK or Cyan- Magenta-Yellow-Key
and is the color model that best describes the subtractive colors used in printing. Select
the color model that corresponds to the desired output medium (monitor or a printer).
When exporting image files, it is best to ask the photo-exposure service in which color
model and format the image is expected.

Define the colors by modifying the values in the spin boxes. Enter values directly, or
click the buttons to change the existing values. The result is shown immediately in the
lower preview box.

If selecting colors from a color spectrum is preferable to specifying the values with the
spin buttons, click Edit. This opens the color dialog. In this dialog it is also possible to
specify the color in the HSV or HSB (Hue-Saturation- Value/Brightness) model.
Select the color and click OK.

3. Once a new color is chosen, specify whether it should replace the original color or be
defined independently.

Note: It is recommended that only custom-defined colors be replaced.

1. To replace the color displayed in the upper preview box, clickModify.

2. To set the new user-defined color, assign a name to the color in the Name field, and
click Add and OK.

The new color will immediately be added to the palette of existing colors; however, if the
dialog is exited by using the Cancel button, the color of the current object does not
change.

Nonetheless, the modifications in the color palette do remain in effect.

Further instructions on saving and loading the color palette and other palette files are
found in Help.
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Replacing Colors using the Eyedropper
In Draw and Impress, images inserted in a bitmap format such as, GIF, JPEG, PNG and
metafile images like WMF can have their colors edited using the Eyedropper. To open
the Eyedropper window, choose Tools > Eyedropper.

The Eyedropper can replace selected colors and, to a point, similar colors, with other
colors, up to four colors at one time. If the replacement is not what is desired or needed,
reverse it with one click on Undo on the Standard toolbar. Use the Eyedropper to match
the colors of different bitmaps or to redo a bitmap with, say, the colors of a company
logo.

To replace colors with the Eyedropper

1. Insert an image in a Bitmap format (e.g., BMP,GIF, JPG, TIG, PNG) or in a metafile
format like WMF. To do this, choose Insert > Picture in Draw and Impress.

2. Open the Eyedropperwindow by choosing Tools > Eyedropper.

3. In the Eyedropper window, click the Eyedropper icon in the upper left-hand corner.
The mouse pointer can then be used as a pointer with which one can indicate the color
to be replaced in the current document. The color box next to the eyedropper icon in
the Eyedropper window displays the color the mouse pointer is resting on. Notice
how it changes as it hovers over different colors in the picture.

4. Click the (left) mouse button when the color is found which is to be replaced. This
color will automatically be registered in the first of the four rows in the Eyedropper
window.

5. Now, in the list box to the right in the same row, select the new color which should
replace the selected color in the whole bitmap image.

6. If in the same editing step you want to replace another color, click the check box in
front of the next row. Now select the eyedropper icon in the upper left hand corner
again and choose a new color. Up to four colors can be replaced in one editing step.

7. Select the bitmap image or the metafile image in which the colors are to be changed,
by clicking in it.
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8. In the Eyedropperwindow click Replace. If too many similar colors were replaced,
undo the step using Cmd-Z and decrease the color tolerance in the spin button. Then
click Replace.

The Transparency attribute also serves as a color. Transparency in an image with a color
can be replaced, for example, with white. This is helpful when, say, the printer driver has
problems with printing transparent graphics.

If you want to produce an image on HTML pages to publish in the Internet, like the
illustration of a product, for example, it usually looks better when we do not see a
rectangular picture, but rather see only the illustration of the product against the uniform
background of the web page. If there is a white background in the picture behind the
product, use the Eyedropper to replace the color white with “Transparent” (i.e. no color)
and save and/or export the image in a format that supports the transparency attribute
(such as GIF). See how this has been done with the liberty lamp below, which had a
white background previously. When using this method, be sure that the illustration of the
product itself does not contain any white parts, since these would also become transparent
just like the background.
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Gradients and Patterns for Objects and Background

The objects in drawings and presentations do not have to have uniform colors. They can
also have color gradients, transparency gradients, patterns and hatching effects. You can
also define a color, a gradient or a pattern for a background that is visible in all slides of a
presentation.

Defining Gradients
To assign a predefined gradient to an object, proceed as follows:

1. Select the object.

2. From the context menu or under Format on the menu bar, choose Area....

3. Select the Gradient option in the spin button, then make a selection from the gradient
list.

Defining a Custom Color Gradient
Before defining a new, custom color gradient, save the current color gradient list as a file
to ensure there is a backup or load a different list from another file.

If you have selected an object and then defined a new gradient, the new gradient is
immediately assigned to the selected object. If you do not want immediate assignment,
undo the selection before opening the dialog for defining gradients. To do this, click with
the selection tool on a position where there are no objects.
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1. In the Area dialog, click the Gradients tab. This tab enables definition of all of the
options for new color gradients.

2. From the list of existing color gradients, click the gradient to use as a basis for
creating the new color gradient.

3. Click the Add... button.

a) In the dialog, assign a name for the new gradient. For example, enter the name
“UFO”.

b) Click OK. The name will appear as a new entry at the end of the list and is selected
for editing.

4. ClickModify to save the changes in the new gradient. The preview shows how the
gradient looks.

5. Close the Area dialog with OK.

The new color gradient may be used immediately.

Interactively Defining a Color Gradient
Color gradients can be modified by clicking and dragging them with the mouse.
However, in order to be defined interactively, the object must already have a color
gradient.

1. Select an object which has a color gradient.

2. In Draw, open the Effects floating toolbar from the Drawing toolbar.

3. On the Effects floating toolbar, click the Gradient icon.

Two objects in color which are linked by a vector should now be visible.

Depending on the type of gradient, one or both of the objects can be moved with the
mouse and thus determine the origin, end and angle of the color gradient. When the color
bar is displayed, assign colors by dragging and dropping the selection to each object to
determine the start and end colors.
In a similar manner, the transparency of an object can be set using the Transparency
icon. (The user may need first to call up the context menu of the object by right-clicking
or Ctrl-clicking on it, select Area, then the Transparency tab, to check that transparency
is “on”.) With the tool, defining a grayscale gradient which spans from black (0%
transparency, i.e. opaque) to white (100% transparent) is possible.
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Organizing the Attribute Tables

The buttons Load Gradients List and Save Gradients List in the Gradients
tab, open dialogs for opening and saving gradients. The current gradient list, for
instance, might consist of all gradients which are custom defined for a certain project.
Save the list, then reload the standard list. This way the list (and the memory space) can
be kept free from resources that are not needed. To continue working on this project later,
simply reload the custom gradient list. The same procedure applies for loading and
saving lists of hatchings and bitmaps.

3D Globe

This section describes how to create a three-dimensional globe with Draw in just a few
steps. When finished, rotate the finished Globe using the mouse.

Creating Texture on a 3D Object

Note: If only the globe shown here is needed, and creating a similar one is not needed, use the finished globe
from the Gallery in the 3D Effects theme. Drag the globe into the document.

To create a custom 3D globe, first open an empty draw document, insert a globe and then
apply a world map as a texture to the globe (worldmap2.wmf from the StarOffice
collection is a good choice but there are others available via the Internet). Then adjust the
illumination.
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1. Open an empty drawing document by choosing File > New> Drawing.

2. Open the 3D Objects floating toolbar on the left of the Drawing toolbar.

3. Select Sphere from the toolbar,

4. Drag open a area to create the globe. All 3D objects can be opened in this way. If
creating an oblong shape is preferable, press the Shift key while dragging. This
behaviour for 3D objects is opposite to the way other objects such as ellipses and
rectangles behave.

5. Open the Gallery. The Gallery themes appear as subdirectories (folders in OS
X).

6. Locate the map to be used. If there is aMaps theme, click on it and the Gallery shows
the maps. If not, see the section on importing clipart, or check the NeoWiki.

7. Click any rectangular world map, say, worldmap2.wmf.

8. Hold down the Shift and Cmd keys and drag the map of the world onto the sphere.
This lays the map of the world on the sphere as a texture.

9. If the Gallery hides the globe, users can fix the Gallery window so that it no longer
overlaps with the document. At the bottom edge of the Gallery window is a dotted
handle. Click on this with the mouse and drag it up as far as is needed,

The texture is laid onto the sphere in its original size in the default setting. Since the map
of the world is much larger than the sphere, only a small segment is seen as a green area
on the sphere. This will soon be changed.

1. Click the sphere to select it.

2. Display the context menu for the sphere and choose Area. The Area dialog appears
with the Area tab page.
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3. Select the Bitmap field, removing the mark in the Tile field.

4. Close the dialog with OK.

Now the world map can be seen as texture on the sphere. NeoOffice has automatically
selected the most appropriate projection method. To see this, double-click on the sphere
and then rotate it.

In Tools > Options >NeoOffice > View tab, check the appropriate box for 3D objects to
refresh during interaction.

Using Illumination
Now you need to provide illumination for the world globe. Select an overall blue
illumination, for example, so that the oceans will have a blue color, and a yellow
highlight that will shine on the side of the earth facing the sun.

1. Select the world globe since the illumination preferences being set always refer to the
currently selected object.

2. Open a context menu by right-clicking or Ctrl-clicking on the globe. Select 3D
Effects.

In the 3D Effects window, click the Illumination button.
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a) Use this feature to change the default setting of the light source to “blue” and move
it down and to the left.

b) Click Assign.

3. Repeat step 3 to apply a second light source in “yellow” to shine on the earth from the
above right.
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More 3D Effects

Take a look at the 3D Effects window. The individual tabs and icons are described in
detail in Help. What follows is just a brief overview:

3D Effects: Favourites

This dialog window offers a few special effects
that can be used on the 3D object. To save
interesting effects so that they are available for
selection on this tab, file the appropriate 3D
object in the Gallery, more specifically in the 3D
theme folder.

3D Effects: Geometry
By using this feature, the user can control the
manner and quality of how the object surface is
geometrically calculated and displayed. For
example, interesting effects can be produced by
deliberately reducing the number of segments of
a sphere. Properties of the 3D font, such as the
slant of the edge (bevel), depth, et cetera are
determined here.
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3D Effects: Shading
This feature permits specifying the setting of the
shader (flat, phong or Gouraud) to be used to
display the 3D object. Gouraud provides the
best shading, but requires the most computing
time. Also use this feature to specify a shadow
for the 3D object and to select the camera
distance and focal length.

3D Effects: Illumination
Control of illumination of a selected 3D object
is easily done in a variety of ways. In addition to
the general ambient light, eight additional light
sources are available, all of which can be
aligned, adjusted for color, or turned on and off
individually.

3D Effects: Textures and Material

With these two sections, control the appearance of the surface of 3D objects. See Help
for an explanation of the numerous possibilities.
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Designing 3D Objects From Font Characters
The step-by-step methodology described below is particularly useful in preparing objects
that could be used for logos and other identifiers. What follows is presented in tutorial
form.

First Step:

1. Open an empty drawing document either using File > New> Drawing or the New
icon on the Function toolbar.

2. Create a text box containing a single capital letter. In this procedure, the letter “P” is
used.

3. Choose a character set for formatting.

4. Set the font size to about 400 pt.
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This font size is to provide a usably sized object that, when converted to 3D, the text
takes up exactly the space that is drawn for the text, independent of the font size
selected.

5. Draw the text box using the Text icon on the floating toolbar.

6. Select the letter and then manually enter 400 in the Size field on the text object bar. At
this point, other attributes, such as another typeface or emphasis attribute, like bold,
may be selected.

Second Step:

Select the text field with the letter and choose Convert > To 3D on theModify menu.
Modify the color of the object by selecting Area on the Format menu. Of course it is
also possible to assign a gradient or a bitmap graphic to the object.

Third Step:

Select the letter “P” again so that it can then be modified in a different way. Use a right-
click or Ctrl-click to bring up a context menu and select 3D Effects menu item. The
options available include options for setting the depth of the object and the focal length
of the camera. In addition, you can set the individual illumination and the texture model.
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• The sample object was given its special shape by adjusting the camera to an extremely
short focal length (4 cm in this case, at a distance of 0.10 cm.).
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Fourth Step:

Now add some text to the logo. Start by inserting a text box and populate it with name of
the company and in a format that is suitable. To put a border around the text, convert the
text to a polygon by choosingModify > Convert > To Polygon. Of course, the surface
of the newly created object can also be modified.

• For a border around the company name, convert it into polygons. Then select a line
width greater than 0.00 and a line style not equal to “transparent” on the object bar to
make the borders of each letter visible.

Fifth Step:

Create a simple drawing object as a background for the logo, for example an ellipse.
ChooseModify > Arrange > Send to Back to place the object all the way to the back.
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Now there is a perfect 3D logo created with NeoOffice in only five steps!

Note: that you can also access the functions through the context menu instead of using menu commands,
which makes for less work with the mouse.

Using a Grid
Towork with great precision, for example to place rectangles one on top of the other, use
the grid function. To turn on the grid, choose Tools > Options > NeoOffice Draw >
Grid and select the Snap to Grid option. As an additional aid, selecting Visible Grid
makes it easy to place documents exactly on top of each other in the document.
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Mechanical or Construction Drawings

This section explains how to produce a mechanical drawing with NeoOffice. The same
method can be used to create other similar drawings, such as, construction blueprint,
garden layout et cetera.
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Creating a Construction Plan
To create a drawing like the preceding illustration, click the Rectangle icon and drag the
floating toolbar into the work area. Then, select Curves and Lines and Arrows and drag
these floating toolbars into the work area as well. Choose a tool with which to begin,
such as the Rectangle, and use it to drag open an area to represent the first surface.
Finally, draw in the details with the Line tool.

Add some more details.
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Complete the drawing.
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Using Snap Lines

It is advisable to use snap lines to position lines and objects more precisely.

To display a snap line, click on a ruler and hold down the mouse button to drag it into the
document. Tomove the snap line, rest the mouse pointer on it until a double arrow
appears. Shift the line by holding down the mouse button and dragging the line to the
desired position. To delete a snap line, simply drag it back onto the ruler. In Draw, snap
lines can also be positioned in a numerically exact way using the Edit Snap Line...
command from the context menu of the snap line.

Note: Snap lines are lines which are visible only on the screen and are used for the sole purpose of precise
positioning and alignment. An unlimited number of horizontal and vertical snap lines can be created.

Using Dimension Lines
With Draw, dimension lines can be directly inserted into a drawing. Drag the snap lines
from the ruler into a document and position so that there is a snap line over every major

line in the drawing. To do this, click the Dimension Line icon on the Arrows
floating toolbar, called up via Views > Toolbars > Arrows. The mouse pointer will turn
into a cross and a dimension line may be dragged directly from one side to the other, or,
even better, from one snap line to another.

To edit the look of dimension lines, select them, open the context menu and click
Dimensions.... The dialog that appears, permits determination of the appearance and
position of the dimension lines.
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To increase the space between a dimension line and the measured object, move the mouse
pointer to one of the points on the dimension line. The mouse pointer will turn into
another icon, enabling either expansion or reduction of the space. Note: To obtain an
absolutely horizontal or vertical dimension line or one at a 45° angle, press the Shift key
while dragging the dimension line.

Working with Multiple Layers
The next step is to position the details in the motor drawing. It is a good idea to use the
layer function if testing several different variations.

The Layout layer is the default workspace. The Layout layer determines the location of
title, text, and object placeholders on your page.

The Controls layer can be used for buttons that have been assigned an action, but that
should not be printed. Set the layer's properties to “not printable”. Objects on the
Controls layer are always in front of objects on other layers.

The Dimension Lines layer is where you draw, for example, the dimension lines. By
switching the layer to show or hide, you can easily switch these lines on and off.

To insert a new layer, open the dialog Insert Layer. It can also be opened through the
context menu of the tabs Layout, Controls and Dimension Lines arranged at the bottom
of the screen, or by right-clicking or Ctrl-clicking on the gray area at the end of that tab
bar. Enter a unique name, e.g. “Sketch1”. Repeat this procedure for another level and
enter the name as “Sketch2”.
Now click the Sketch1 tab and place the details of this level; for example, by dragging
the desired clipart from the Gallery into the document.

After the details are positioned on Layer1, do the following:

1. Click the Sketch2 tab and arrange elements there as well. Notice that the elements
from Sketch1 are visible.

2. To change this, click the Sketch1 tab and call up the context menu and selectModify
Layer.
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3. In theModify Layer dialog, remove the check from the Visible check box

4. Click OK to view only the Layout level and the Sketch2 level.

As a rule all layers will be displayed. To view a particular layer, deactivate the Visible
field on all the other layers.

After completing the drawing, save and/or print the document as needed.

Note: Visualize layers as transparent sheets, one on top of the other, which together form a complete picture.
It is also possible to view individual “transparencies”, i.e. Layers.

Using One Color per Layer
If more than one layer at a time is displayed, apply an identical color to all elements on
the same layer for a better overview.
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Chapter 7: Databases and Data Sources

Versions of OpenOffice.org Base prior to 2.x required a connection to an external data
source. While 2.x retains this functionality, it also introduces the ability to create an
HSQLDB database as an internal data source. Now all the data tables, forms, queries and
reports for a database can reside in one .ODB file. NeoOffice previously did not have a
database program built-in. Now it has one, called simply Base.

This chapter introduces built-in HSQLDB databases and touches on some of the
functionality still retained from earlier versions of (OpenOffice.org) Base. The examples
found in this chapter are some of the steps used to create the Calendar example database.

The large amount of preparatory work done when you are actually designing a database is
beyond the scope of this chapter. Briefly, the preparatory work for creating the Calendar
database involved sketching out what you wanted to see as the end result and working
from there to design tables that would follow good database design theory or, failing that,
that would at least be easy to implement and maintain.

Creating a Database File

After the preparatory work, a file or container must be created to hold all the parts of the
database.

If NeoOffice is already open, you can choose File > New > Database. You can also open
NeoOffice Base itself using the NeoOffice program icon.

The Database Wizard opens to Step 1, Select database.

Make sure the option is set to Create New Database and click Next.

In Step 2, Save and proceed, you will want the option regarding registering the database
(Do you want the wizard to register the database in NeoOffice?) set to Yes, register
the database for me.

When you register a database, NeoOffice now knows where the data is located and how it
is organized. In spreadsheets and text documents, you can use View > Data Source to
connect to the data.

Under After the database file has been saved, what do you want to do?Make sure
you check Open the database for editing.

The other option, Create tables using the table wizard check box opens the Table
Wizard. The TableWizard offers a set of sample tables from which fields, with
corresponding types and formats, can be chosen to create a new table. Fields can be
chosen from multiple tables to create the particular table.

Click Finish.

1. In the Save As window that opens, name the database and select a location in
which to store it. Leave the Save as type set to OpenDocument Database.

2. Click Save.
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ANeoOffice Base window will open for the new database. At this point, we have created
an empty database file.

Creating a Table

An empty database file is not much use. The next step is to create a table in which to
store the data. In previous versions of OpenOffice.org Base, you would connect to an
external data source such as Adabas, JDBC, ODBC, dBase, ADO, Text, Spreadsheet, or
Address Book. You can still do this (as discussed below) but, as mentioned above, you
can also create HSQL tables that will reside in the database file itself.

Each field in a table is represented in the design of that table by a row. Each row has
fields for Field Name, Field Type and Description. Description is an optional field that
can be used to provide a description of what the field is used for.

Additionally, each of the table fields have Field Properties. These vary based on the type
of field.

The main table in our Calendar database is the Appointments table and the following
steps explain how that table was created.

1. In the database window, click the Tables icon in the left-hand
column.

2. In the Tasks pane at the top of the window, click the Create Table in Design
view icon. ATable Design window opens.

3. In the first row in the Table Design window, in the Field Name box, type ID and
hit the Tab key on the keyboard.

4. In the Field Type box that the cursor jumps to, hold down the mouse on the text
displayed, and a drop-down list appears. Choose Integer [INTEGER].

5. In the Field Properties section at the bottom of the window, change the value for
AutoValue to Yes.

6. Create the fields listed below by repeating steps 3 through 5 using the information
in the table below. Obviously, do not go back to the first row in the design
window and do not set the AutoValue option on any other fields to Yes.

Field
Name

Field Type Field Properties

Subject Text [VARCHAR] Entry Required = Yes; Length = 50

Location Text [VARCHAR_
IGNORECASE]

Entry Required = No; Length = 50

Start
date

Date [DATE] Entry Required = Yes
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Start
time

Time [TIME] Entry Required = No

End date Date [DATE] Entry Required = No

End time Time [TIME] Entry Required = No

Note Memo
[LONGVARCHAR]

Entry Required = No

Type Integer [INTEGER] AutoValue = No; Entry Required = No

Your screen should look like this on the next page:

7. Right-click or Ctrl-click the field selector for the ID field (this is the area to the
left of the word ID, probably showing a green arrow) and choose Primary Key
from the list presented. A key will now appear next to the green arrow:
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8. Click File > Save.

9. Enter Appointments for the TableName and click OK.

10. Close the table design window by clicking File > Close.

11. In the database window, click File > Save to save the work done so far on the
database.

Note: The type VARCHAR_IGNORECASE is a special type of VARCHAR specific to HSQLDB. It is case-
insensitive which means entries such as Home and HOME are the same.

Note: Each field can only accept data corresponding to the specified field type. It is not possible to enter
text, for example, in a number field. Memo fields in dBase III format are references to internally-managed
text files which can hold up to 64KB text.

Creating a Related Table

The last field of the Appointments table is the Type field. Since we are trying to follow
good database design procedures here, we want to put our appointment types in another
table and link the tables using an ID field. The basic reason for this is that, because so
many of our appointments are going to have the same type, we want to cut down on data
entry errors and make it easier to update all the records if we decide to change the name
of a type.

To create the Types table in the Appointments database.

1. Go to the opening screen of the New Database file, and click once on the Tables
icon.

2. In the database window, click Create Table in Design View.

3. Create the table using steps 3 through 5 in the previous example and the
information below. Make the appropriate changes to the field properties at the
bottom of the database window.

4. Right-click or Ctrl-click the field selector for the ID field [see above 7.] and
choose Primary Key.

5. Click File > Save As.

6. Enter Types for the table name and click OK.

7. Close the table design window by clicking File > Close.

8. Click File > Save in the database window to save your work.

Field
Name

Field Type Field Properties

ID Integer [INTEGER] AutoValue = Yes

TypeName Text [VARCHAR] Entry Required = Yes; Length = 50
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Creating a Relationship between Tables

Now, to make the Types table more useful to us, we need to create a relationship between
the two tables. A relationship means that two or more tables share information. They link
a primary key to a foreign key. A primary key is unique. In the Calendar database, the
primary key for the relationship we set up in the follow steps is the ID field in the Types
table. The foreign key is the Type field in the Appointments table.

1. Open a database by File > New > Database. Instead of Create a new database,
open an existing database and navigate to to the “New Database” file made
earlier. (Alternatively, double-click on that file to start it up).

2. Click Tools > Relationships. The Relation design window is displayed with the
Add Tables dialog in front of it.

3. Click the Appointments table in the list and click Add.

4. Click the Types table and click Add. Both tables should appear in the Relation
design window.

5. Click Close in the Add Tables dialog.

6. In the Relation design window, click the lower edge of the Appointments table
and drag down to make the window for the table larger.

7. Click the Type entry in the Appointments table and drag it over the ID entry in
the Types table. A curved arrow will appear at the end point. When you release
the mouse button, a line will connect the two entries.

8. Click File > Save to save your work.

9. Close the Relation design window.

10. Save the database.
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At this point in the creation of the sample database, a form was created to simplify data
entry into the Types table. For the sake of brevity, these steps are skipped. Data may be
directly entered into a table, though it is not recommended.

Creating a Data Entry Form

However, the following steps for creating the data entry form for new appointments are
presented here.

1. In the database window, click the Forms icon on the left side.

2. Click the Use Wizard to Create Form button.

3. The Form Wizard opens to Step 1, Field Selection. Click the Tables or queries
drop-down and choose Table: Appointments, if it is not already selected.

4. Move all the fields except ID to the Fields in the form list by clicking the >
button for each desired field. Click Next.

5. Step 2, Set up a subform, is not needed for this form since we will not be
including a subform. Simply click Next.

Note: A subform allows you to access related data for a database. For example, if multiple types were
allowed per appointment, they might be displayed in a subform.

6. The wizard automatically skips steps 3 and 4 since they are related to subforms.

7. Step 5, Arrange controls, allows you to design a rough, basic layout for the form
controls. This choice is open to preference but, in creating the sample database,
we chose In Blocks – Labels Above, the fourth option. Select by clicking on that
diagram. Click Next.
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8. Step 6, Set data entry, is where the designer of the database can narrow the use
of a form. In this example, this is a new appointment form so we only want user
to be able to enter data. Set the option here to The form is to be used for
entering new data only. Existing data will not be displayed. Click Next.

9. Step 7, Apply styles, is also open to personal preference. The Flat field border
style does have some nice built-in visual effects and was chosen for the example
database. We also chose Ice Blue as the style. Click Next after selecting the
options.

10. Step 8, Set name, allows us to name the form. Enter New Appointment for the
name.

11. Set the option toModify the form and click Finish.

12. The form opens to edit mode, as opposed to data entry mode. Now the form can
be modified.
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Making Data Entry Easier

The easiest thing to do to simplify data entry is to move the fields around. This can be
done by clicking and dragging the fields while the form is in edit mode. The following
sections detail other ways to simplify data entry. These example steps assume that the
New Appointment form is open in edit mode.

Modifying a Date Field
A text box that is related to a date field can very easily be turned in to a date picker
control.

1. Click once on the Start Date field.

2. Right-click the field and choose Group > Edit Group.

3. If the text box itself is not selected, click away from the text box.

4. Double-click the text box for the Start Date field, not the label.

5. The Properties: Date Field dialog box opens.

6. On the General tab, make sure the following options are set (you will probably
have to scroll down to see them):

○ Spin Button should be set to Yes.

○ Repeat should be set to Yes.
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7. Repeat steps 1 through 6 for the following:

○ End Date- Dropdown: Yes; Repeat: Yes

○ Start Time- Default Time: 9:00:00; Spin Button: Yes; Repeat: Yes.

○ End Time- Default Time: 9:30:00; Spin Button: Yes; Repeat: Yes.

8. Close the Properties dialog box.

9. Click File > Save to save our modifications to the form.

For the time fields, we made them easier to use by giving them a default time other than
midnight. Additionally, the spin button may be used instead of keyboard entry.

Adding a List Box to a Form
If the database has a related field (such as the Calendar database's Type field) that will
have a finite, usually fairly short, list of entries, it may simplify data entry to create a list
box to replace the text box on a form. With a list box, we choose one value and actually
add a related value to the table.

1. In the Form Controls toolbar, usually at the bottom of the screen, or by this path

View > Toolbars > Form Controls, click the List Box button .
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2. Click and drag in an empty area of the form to create a box about the size of the
Type field that is already on the form.

3. The List Box wizard opens.

4. On the first screen, Table Selection, click Types. This is the table that contains
the data for the list box.

5. Click Next.

6. On the second screen, Field Selection, click TypeName. This is the field
containing the display text for the list box entries. Its name appears now in the
Field from the List Table box.

7. Click Next.

8. On the third screen, Field Link, in the Field from the Value Table list, click
Type and, in the Field from the List Table list, click ID. The names appear in
their respective boxes without the need for typing in. This creates the link
between the key value that underlies the displayed value and the field that the
value is written to.

9. Click Finish.

The new form control might have a different look from the other controls on the
form. In the Calendar database, we had to do the following:

1. Double-click the list box to bring up the Properties dialog box.

2. Set the Border color property to Black.
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3. Click the ellipsis (three dots (...)) button that is to the right of the Background
color property field.

4. In the Color dialog box, set the Red, Green and Blue values each to 221. Click
OK.

5. Close the Properties dialog.

Field background colors may be matched by checking the background color values of the
other fields on the form. Now, however, the form seems to have two Type fields and one
Type label.

1. Click the Type field that was created by the wizard.Right-click the field and
choose Group > Edit Group.

2. If the text box itself is not selected, click away from the textbox then back on it to
select just the field, not the label.

3. Delete the field by pressing the Delete key on the keyboard.

4. Move the Type list box to where the text field was so that the list box replaces it.

5. Select both the list box and the label (click one, hold down the Shift key and click
the other).

6. Right-click the selection and choose Group > Group.
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Adding a Combo Box to a Form
Another way to make data entry easier is to add a combo box to a form. The combo box,
unlike the list box, can only display the value it is adding to the field. That is, when
choosing from a list box, an identifier (such as a number) is put into the related field
whereas with a combo box the actual value of the combo box is put into the field.

The Location field is a good candidate for a combo box. While editing the New
Appointment form:

1. On the Form Controls toolbar, usually at the bottom of the screen, click the

Combo Box button.

2. Click and drag a combo box in an empty area of the form. The Combo Box
wizard will open.

3. On the first screen, Table Selection, click Appointments.

4. Click Next.

5. On the second screen, click on Location in Existing Fields.

6. On the third screen, Database Field, set the option to Yes, I want to save it in
the following database field: and choose Location from the drop-down list.

7. Click Finish.

The look of this field should also be made consistent.

1. Double-click the combo box to bring up the Properties dialog box.

2. Set the Border color property to Black.

3. Click the ellipsis button (to the right of the Background color property).

4. In the Background Color dialog box, set the Red, Green and Blue values to 221
(assuming that the same color scheme is being used – this is a light gray).

5. Close the Properties dialog.

6. Move the combo box so that it matches up with the Location label.

Changing the Tab Order of a Form
The tab order of the form we have been creating and modifying through these steps
probably does not make sense because we added some form controls and may have
moved others. To change the tab order of a form:
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1. Click on any control on the form.

2. Click the Activation Order button on the Form Design toolbar. Youmay
need to follow this path: View > Toolbars > Form Design.

3. Set the order as follows:

1. txtSubject

2. ComboBox

3. datStart date

4. timStart time

5. datEnd date

6. timEnd time

7. ListBox

8. txtNote

This can be accomplished by clicking a control name in the list and using theMove Up
andMove Down buttons to change the order of the controls.

ComboBox is the default name provided for the Location combo box and ListBox is the
name provided for the Type list box.

Obviously this order assumes the form is set up similarly to the form in the Calendar
database. If it is not, use a different order for the fields.

Remember to save the form and, after it is closed, save the database container.

Viewing Data

The database still does not have a convenient way to view the appointments it stores. We
could look at the table itself but this is neither attractive presentation nor good database
design. Additionally, because the New Appointment form is a data entry form, we cannot
use it to view previously entered records.

Since a lot of time and effort was put in to creating the New Appointment form and its
format is also good for viewing data, the following sections will discuss copying a form
and changing some of the properties of the new form.

Copying the Form
1. In the Forms section of the database, right-click the New Appointment form.

2. Click Copy.

3. Right-click in the (Forms part of the ) database window and choose Paste.

4. In the dialog box that appears, enter All Appointments for the form name and
click OK.

5. Save the database.
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Changing the Form's Properties
Obviously, since the New Appointment form was a data-entry only form, we will need to
change the related form property.

1. Right-click the All Appointments form and choose Edit.

2. Click the Form Navigator button on the Form Design toolbar. This
toolbar is generally found at the bottom of the NeoOffice Writer window. (Writer
is the application used to edit forms in NeoOffice.) If not, View > Toolbars >
Form Design.

3. In the Form Navigator dialog, right-click theMain Form item and choose
Properties.

4. On the Data tab of the Properties dialog, set the Add data only property to No.

5. Close the Properties dialog.

6. Close the Form Navigator.

7. Save the form.

8. Click the Design Mode On/Off button on the Form Design toolbar.

9. You can now use the Form Navigation toolbar to navigate through the records in
the database.

Setting a Sort Order for a Form
The records are currently in the order in which they were added to the database. This is
not very useful in the long run. Adding a sort order to the form will make it more useful
for viewing all the appointments in the database.

1. Re-enter form design mode by clicking the Design Mode On/Off button again.

2. Click any control on the form.

3. Click the Form button on the Form Controls toolbar.

4. In the Form Properties dialog, on the Data tab, click the ellipsis button to the
right of the Sort property.

5. For the first field name, choose Start Date and leave the Order as ascending.

6. For the second field name, choose Start Time. Leave the Order as ascending.

7. The third field name should be set to End Date. Leave the Order as ascending.

8. Click OK in the Sort dialog box (see illustration below).

9. Close the Form Properties dialog, save the form and close it.

10. Save the database.
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Creating a Query to Find Today's Appointments

Queries extract information from a database. A list of today's appointments would be a
useful query.

1. Click the Queries icon on the left side of the database window.

2. Click Create Query in Design View.

3. The Add Tableswindow opens in front of the Query Design window. Add both
tables to the query.

4. Click Close in the Add Tableswindow.

5. Add the following fields from the Appointments table: Subject, Location, Start
date, Start time, End date, End time, Notes. This can be done by double-
clicking on each of these terms in order. They will be placed at the top of their
own column.

6. Add the TypeName field from the Types table.

7. In the Start date column, on the Criterion row, enter any date such as 3/9/1972.

8. Click the Switch Design View On/Off button . The SQL statement that
underlies the query is now visible. Toward the end of the statement something like
the following appears: AND (("Appointments"."Start date" = {D '1972-03-
09'})). This statement finds records where the Start date equals the date 3/9/1972.

9. Replace {D '1972-03-09'} with the text CURRENT_DATE and click the Switch
Design View On/Off button again.

10. Click the Run Query button . The query results appear at the top of the
resulting window.
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11. Save the query as Appointments for Today and close the query.

If the database does not contain appointments for today, add an appointment for today
and rerun the query by double-clicking on it.

Add a Sort Order to the Query
There will be days with more than one appointment. In that case, it would be useful to
sort the results of the query.

1. Open the query for editing by right-clicking the icon for the query and choosing
Edit.

2. To add a sort order to a column, click in the Sort row in that column. The Sort
row is just below the Table row. Click the Sort row in the Start time column.

3. Click the drop-down for Sort and choose Ascending.

4. Set the Sort to Ascending for the End date and End time fields as well.

5. Save the query.

If the database contains appointments for the current day, try running the query.

Changing the Join Type in the Query
When the query is run, as it exists currently, some appointments won't appear.

The default type of join is an Inner join, which only returns records where the joined
fields are equal. If the Type field for an appointment does not contain data, the join field
for that appointment's record would not match any entries in the join field in the Types
table.

We can fix this by changing the join type in the query.

1. Right-click the join line between the tables in the top portion fo the query design.

2. Choose Edit.

3. In the Join Properties dialog, in the Options section, click the Type drop-down
and choose Left join.
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4. Click OK.

5. Save the query.

6. Close the query.

7. Save the database.

Creating a Report

A query can, of course, be viewed and used by double-clicking to execute the query. It
can also be used as the underlying data for a form. The form wizard has already been
discussed. Copying a form and changing the underlying data has also been discussed.

A query or a table can also be used to generate a report. The following section uses the
Appointments for Today query created in the steps above as the basis for a report.

1. Click the Reports icon on the left side of the database window.

2. Click Use Wizard to Create Report.

3. The Report Wizard opens to Step 1, Field Selection. Change the Tables or
queries drop-down to Query: Appointments for Today.

4. Click the >> button to move all the fields from the Available fields list to the
Fields in the report list.

5. Click Next.

6. In Step 2, Labeling fields, click Next to use the default labels.

7. Step 3, Grouping, can also be skipped since this report does not really need
grouping. Click Next without moving any fields

.Note: Grouping is a way of collecting records that share certain data. For example, we could create another
report grouped by Type. This report would list all of the appointments of each type together. Grouping
creates the first levels of sorting in any report with grouping.

8. Step 4, Sort options, is automatically skipped because a query is selected. This
may be changed in later versions.
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9. In Step 5, Choose layout, Align Left – Modern was chosen for the Layout of
data and Generic for Layout of headers and footers. Click Next when this step
is complete.

10. In Step 6, Create report, leave Title of Report as Appointments for Today.
This report is a Dynamic report so leave that option set. The option to Create
report now should also be set.

11. Click Finish.
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The report is generated and will appear after a few moments. The report will need to be
modified to be more attractive and useful. Since the report is simply a Writer document
and the data itself resides in a table, modifying the report is not covered here.

However, to open a report for modification:

● In the Reports section of the database, right-click the report and choose Edit.

Some Tips for Using the Calendar Database

The following tips, while specific to the Calendar sample database, can be generalized to
other Base databases.

Adding Data to a Related Table
Occasionally, you may wish to add an appointment type while working in an appointment
form. While the types appear on the form, the actual type names reside in a separate table
and the new type must be added to that table. There are at least two ways to accomplish
this, by opening the form for the related table (assuming there is one) or by opening the
Data Sources window.

Open the form for the related table

If the related table has its own form, as it does in the case of the Calendar database:

1. Switch to the database window.
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2. Open the form, in this case the Types form.

3. Add the data to the form.

4. Be sure to click the Save Record button.

5. Close the form.

Open the Data Sources window

Youmay use the following steps if the related table does not have a form. On an
appointment form:

1. Choose View > Data Sources or press the Cmd-F4 key on the keyboard.

2. This opens the Data Sources pane at the top of the form window. Make sure the
database is expanded.

3. Expand the Tables icon by clicking the triangle next to it next to it.

4. Click the icon for the Types table.

5. Enter a TypeName.

6. Click the Save Current Record button at the top left of the Data Sources pane.

7. Close the Data Sources pane by choosing View > Data Sources

8. Or, by pressing the Cmd-F4 key combination.

The example below shows a similar outcome:

Refreshing the form

Once a new type is added, the Types list box must be updated by clicking the Refresh

button at the bottom of the form.

The drop-down should contain the new type.
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Filtering Data
If you wish to see only a certain day's appointments it is possible to create a query that
only returns that particular day. However, it is also possible (and easier) to use the All
Appointments form and filter for a particular day.

One way to filter data is as follows:

1. Go to a record for the particular day.

2. Click in the Start Date field.

3. Click the AutoFilter button on the Form Navigation toolbar (usually at
the bottom of the screen).

The form is filtered based on the record chosen in step 1.

Note: In the original Guide for OpenOffice.org 2.0, the reader is offered a second way to filter data, which

appears not to work in NeoOffice: Click the Form-Based Filters button, also on the Form
Navigation toolbar.The Form Filter toolbar opens, as does a blank copy of the form. Enter a date in the

Start Date field. Click the Apply Form-Based Filter button.

The form is now filtered based on the data entered.A filter can be removed by clicking

the Remove Filter/Sort button. Please see the section “Searching With a Form
Filter” below for further information.

Note: The rest of this chapter, though originally written for versions prior to NeoOffice 2.x, has been verified
and updated.

Registering a Data Source

When you are creating a database, NeoOffice allows you to register the database with the
currently running copy of NeoOffice To register a data source for viewing and/or editing
in NeoOffice at a later time (or after copying the database to a new computer), do this:

1. Select Tools > Options. This command opens the Options dialog.

2. In the category list at the left of the dialog, expand NeoOffice Base then click
Databases.

3. Click New. The Create Database Link dialog opens.
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4. Click Browse. The Open dialog is displayed.

5. Navigate to the location of the database, select the database and click Open.

6. If desired, change the Registered name of the database.

7. Click OK. The Create Database Link dialog closes.

8. Click OK. The Options dialog closes.

Connecting to Other Typesof Databases

The Database Wizard also allows you to link to other types of data sources rather than
creating a new database.

NOTE for 2.0 dBase users: To open a connection to a dBase database, you must select the "Connect to an
existing database" radio button and choose "dBase" from the drop-down list box. This should work even if
you have never had any dBase installed on the computer, because a basic dBase functionality is built in to
%PRODUCTNAME.

To create a database that links to external data source:

1. In any NeoOffice window, click File > New > Database.

2. Set theWhat do you want to do? option to Connect to an existing database.
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3. Select the appropriate type from the drop-down. The various types are briefly
discussed in the table below.

4. Refer to Help > NeoOffice Help for information on registering particular
database types. Check the Index for Database Wizard.

Select from the following database types (depending on the operating system):

Database type Meaning

MySQL The MySQL migation tools are for Mac OS X are available at
http://dev.mysql.com/downloads/gui-tools/5.0.html

JDBC Link to databases contacted via a JDBC driver.

ODBC Link to databases contacted via an ODBC driver.

dBase Files can be edited directly with the driver for direct access in the
file system.

Oracle ODBC See below

Text Register text files, such as comma-separated CSV files (read-only).

Spreadsheet Can register NeoOffice Calc and MS Excel spreadsheets (read-only).

It is advisable to check the NeoWiki for the latest advice on the use of Base with existing databases.
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Address Books

Registering an Address Book
As seen in the table above, a NeoOffice database can connect to an external address book.
Available address books include Mozilla, Thunderbird, LDAP and certain operating
system address books.

NeoOffice templates and Wizards, such as the letter and mail merge wizards, use fields
that can represent the contents of an address book. When the document is connected to
the data source, the general fields used in the templates are replaced by the actual fields
from the data source.

While an actual Base database allows more flexibility, the data is still read only. Because
of this, NeoOffice allows you to register address books as data sources.

Using the Wizard to Import an Address Book
Select File > Wizards > Address Data Source. This Wizard is described in Help.

Manually Registering an Existing Address Book
1. Choose File > Templates > Address Book Source. The Templates: Address Book
Assignment dialog appears.

2. In the Data source box, select the system address book or the data source to use as the
address book.

If the system address book is not yet registered in NeoOffice as a data source, click the
Administrate button. This opens the Address Book Data Source Wizard, in which
the address book can be registered as a new NeoOffice data source. Read further how
to do this in the next section, System address book as data source.

3. In the Table box, select the database table to use as the address book.

4. Under Field assignment, set the fields for company, department, first name, et cetera
to the actual field names used in the address book.

5. Click OK. After this point, the address book is recognized as a NeoOffice address
book data source.
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System Address Book as Data Source
1. Select File > Templates > Address Book Source.

2. Click the Administrate button to call the Address Book Data Source Wizard (see
also instructions above).

3. Select the type of external address book and click Next.

4. Data sources vary at this point. Additional settings may need to be chosen. Some
address books have multiple tables, only one of which can be used per data source.
Click Next after completing this step.

5. In the Data Source Name step, choose a location in which to save the database and a
name for NeoOffice to use as the name for the data source.

6. Click Finish.

Importing Data Into NeoOffice
If you are exchanging data with a database that does not have an ODBC link and which
does not allow dBase import and export, it is often possible to exchange the data via a
common text format.

Importing and Exporting Data in Text Format
To exchange data in a text format use the Calc import/export filter.
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1. Export the desired data from the source database in a text format. The CSV text
format is highly recommended since it separates data fields by using commas and
records by inserting line breaks.

2. Open the data with the Text CSV file filter. Select this file filter in the Open
dialog in the Files of type list box. Select the file and click Open.

3. This displays the Text Import dialog. Here you can decide which data to include
from the text document.

Once the data is in a Calc spreadsheet, it can be edited as desired. You have two ways of
saving the data as a NeoOffice data source:

• Save the current NeoOffice Calc spreadsheet in dBase format in the folder of a dBase
database. To do this, choose File > Save As, then select the File Type dBase and the
folder of the dBase database.

• Check the data range in the NeoOffice Calc spreadsheet and drag the area into a table
container in the data source view. The table container is the area on the left of the
database explorer that is designated Tables (see diagram). A wizard is started
automatically.

•

Exporting in CSV Text Format
The current Calc spreadsheet can be exported in a text format which can be read by many
other applications.

1. Choose File > Save as.

2. In Save as type select the filter Text CSV.
3. Enter a file name.

4. Click Save.

5. A dialog warning the document may contain formatting or content that is incompatible
with the CSV format is displayed. Click Yes to save the file in CSV format.

6. This opens the Export of text files dialog, in which to select the character set, field
delimiter and text delimiter.

Click OK. A warning informs you that only the active sheet was saved.
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Form Design

Forms in NeoOffice
In some situations, you may want to create a document that contains some fixed text, but
allows others to enter some items and perhaps take some actions on those items. Such a
document is called a form, analogous to the preprinted forms everyone has filled out
dozens of times. You can create custom forms in most of the NeoOffice applications;
forms that you create without using the Form Wizard do not have to connect to a data
source (though they can - see below). If the form isn't connected to a data source, any
information you enter is simply saved with the form. (This method is handy when
sending a form to a group of people for them to fill out and return.) Writer, Calc,
Impress, and Draw all support forms.

To create a form, start with a document in the appropriate application. Click View >
Toolbars > Form Controls. (In some cases, you may have to add the button to the
toolbar first.) The Form Controls toolbar (top illustration) appears. The toolbar includes
an assortment of controls that can be put on forms, as well as buttons for managing the
form as a whole.

As with the other toolbars, docking it is an option. When designing a form involving a
number of controls, this can be a very handy feature.

Most items on the Form Controls toolbar are controls. Others are a variety of options for
working with forms and controls. Most of them are discussed later in this chapter.

To add a control to a form, click it on the Form Controls toolbar. The cursor changes to
crosshairs. Click and drag the new control to the location desired. Once a control is
chosen from the Form Controls toolbar, continue dropping that type of control. To turn
off that control type, either click another control to select it, click the form itself without
dragging, click the same control on the Form Controls toolbar, or click the Select button
on the Form Controls toolbar.
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Available controls

Control Use

Check Box Used for on/off or yes/no choices.

Text Box Used to enter free-form text.

Formatted Field Used to enter text applying formatting codes as in Calc.

Push Button Used to execute commands.

Option Button Used, with one or more other option buttons, to allow choice among
mutually exclusive options. See Group Box.

List Box Offers a list of choices. User can choose one or, in some cases, several.

Combo Box Offers a list of choices. User can choose one or enter a new value.

Label Field Used to provide labels for other controls. Doesn't accept input.

Spin Button Used to increment and decrement the displayed numeric value by
clicking with the mouse.

Scroll Bar Provides navigation through the content by scrolling horizontally or
vertically.

Image Button Used to execute commands; has a picture rather than a text caption.

Image Control Displays a picture on the form.

Date Field Used to enter a date. Supports up arrow and down arrow to change
portions of the date.

Time Field Used to enter a time. Supports up arrow and down arrow to change
portions of the time.

File Selection Allows user to point to a file.

Numerical Field Used to enter numbers. Optionally has spinner arrows to change value
with the mouse.

Currency Field Used to enter monetary values. Supports up arrow and down arrow to
change value. Optionally has spinner arrows to change value with the
mouse.

Pattern Field Used to enter text, applying a specific formatting pattern.

Group Box Used to visually combine several controls, as well as create groups of
option buttons.

Table Control Used to display data from a table or query in a grid format.

Navigation Bar Reproduces most of the Form Navigation toolbar on the form itself

Table. The selection of controls available for use in NeoOffice forms is extensive. Controls are shown
here in the order in which they appear on the Form Controls and More Controls toolbars.

Customizing controls

With some controls, you can simply drop them on a form and use them as is. That works
for things like a Text Box, Date Field, or Time Field. With others, though, once the
control is added, you may need to provide additional information. Even for those that
work immediately, you may customize their appearance or behavior.

To set up a control, click it to select it (sizing handles appear around the edges), and then
choose Control from the shortcut menu, Format > Control from the menu, or Control
from the Form Controls toolbar. The Properties dialog for the control appears. The
contents of the Properties dialog vary, depending on the type of control.
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Just as the contents of the Properties dialog vary with the type of control, so does what
you need to do to get it working. The table following lists some of the items common to a
number of controls.

Property Meaning

Name Identifies the control. In some cases, including option buttons, assigning the
same name to several controls turns them into a group.

Label The caption that appears on the control.

Label field Links the control to a Label Field control. Used for controls (like Text Boxes)
that don't have their own label.

Enabled Determines whether the control is available to the user.

Tabstop Determines whether the control is part of the tab order, that is, whether the
user can reach it by tabbing from one control to the next.

Order Determines the position of the control in the tab order.

Character set Specifies the font characteristics for the control.

Default value Specifies the initial value displayed in the control.

Background
color

Specifies the background color for the control.

Help text Specifies the tooltip for the control.

Table. The Properties dialogs for the various controls lets you set them up as wanted. The properties
shown here are common to a number of the controls.
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Individual controls have additional properties related to their purpose. For example, a
Check Box has a Default Status property that determines whether it's initially checked
and a Text Box has a MultiLine input property that determines whether you can put
multiple lines of text into the control.

Some controls need certain properties specified in order to be useful. In some cases,
wizards are available to help you specify the necessary information. The next few
sections consider some of those controls.

Creating a group of option buttons

Option buttons (also known as radio buttons) let you choose one item from among a
mutually exclusive group.

The easiest way to set up a group of option buttons is:

1. Make sure theWizards On/Off button on the Form Controls toolbar is switched

on . (When it's on, it has a thin border around it.)

2. Put a group box on the form by click the Group Box button on theMore
Controls toolbar and then clicking and dragging in the form. The Group
Element Wizard – Data appears, to guide creation of an option group.

3. On the first page, specify the options to appear in the group. For each, type it in,
and then press Enter or click the >> button. When all the items have been entered,
click Next.

4. On the second page, indicate which item in the list should be initially selected.
You can also specify no item be selected. Click Next.

5. On the third page you can associate a value with each item. Specifying a value is
particularly significant when data on the form is tied to a data source. (See
"Activating form controls in a document" below.) To specify the value for an item,
click that item in the list, and then type the appropriate value in the text box. By
default, character items are associated with numbers starting from 1. Click Next
to move to the Database Field page.

6. The Database Field page lets you automatically save the your choice to a field in
a table. If preferred, you can specify that the value is available only in the form.
Click Next to reach the final page of the wizard.

7. On this page, you specify a name for the option group - the name appears as a
caption on the surrounding box. Click Finish to exit the wizard and create the
option group.
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Do Any Other Controls Have a Wizard?
Most of the remaining controls are simple enough to configure that no wizard is needed

or provided. However, the Table control is fairly complex. It provides a grid type
display of the data in a table, along with navigation controls. The Table Element wizard
lets you choose which fields display and in what order.

Attaching a data source to a form

Using the wizards for some kinds of controls requires you to specify a data source for the
form. However, sometimes, you may want to do so even if you are not creating a combo
box or list box.

To link a data source to a form:

1. In the database window, right-click the form and choose Edit to enter Design
mode.

2. Click the Form Navigator button on the Form Design toolbar.

3. In the Form Navigator dialog, right-click theMain Form item and choose
Properties.

4. Click the Data tab.

5. Make sure the Content Type is set correctly (Table, Query, SQL command).
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6. Choose appropriate table or query from the Content drop-down or click the
builder button (the ellipsis button) to create an SQL command.

Associating data with a field

Once the form has a data source, you can link fields to controls. To do so:

1. Add the control to the form or click once to activate an existing control.

2. Ungroup the control by right-clicking and choosing Group > Edit Group.

3. Deselect the ungrouped controls.

4. Right-click the data control, not the label, and choose Properties.

5. Click the Data tab.

6. Choose a field from the Data Field drop-down.

7. Close the Properties dialog box.

8. Regroup the control by selecting the control and the label then right-clicking and
choosing Group > Group.

Be aware that when linking a field to a control in this way, every time that control is
used, changes that are made are stored in the actual data source.

Activating form controls in a document

While editing a data source is one use for forms, you may want to use a form for other
things. For example, you can use forms to add a button to a spreadsheet that performs a
calculation or to a presentation that runs a video clip.

Each control has a number of events associated with it. An event is something that occurs
due to user action. For example, when the mouse is moved, an event fires each time it
enters the area of a control and each time it leaves that control's area. Typing a character
also fires an event. So does clicking the mouse.

The Events tab of the Properties dialog for each control lists the events available for that
control. For each event, you can specify what happens when that event fires. Do so by
clicking the ellipsis button (three dots) next to the event, and then pointing to the
NeoOffice macro that performs the desired action.

The form itself has events, as well. To access these:

1. When editing the form, click the Form Navigator button on the Form
Design toolbar.

2. In the Form Navigator dialog, right-click theMain Form item and choose
Properties.

3. Click the Events tab.

As with control events, you can assign a macro to any form event.

How to use the form

Once you finish laying out a form, it can be "run" by clicking the Design Mode On/Off
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button on the Form Design toolbar. When design mode is off, the controls
operate as expected – you can select and clear check boxes, open combo boxes and
drop-down lists, and so forth.

Ordinarily, when you open a saved form, design mode is automatically turned off. So, a
user opening a form the designer supplies, sees it as they would expect. (Be aware,
however, that a user can turn design mode on and change the form.)

When a form linked to a data source has design mode turned off, the Form Navigation
toolbar appears at the bottom of the form.

NeoOffice doesn't have a mechanism to prevent users from changing forms to Design
mode. In Microsoft Office, you can protect a form document and give it a password to
prevent users from seeing inside.

Searching in Tables and Form Documents

In spreadsheets and documents in which form functions are used, you can click the Find

Record icon to open a dialog to find any text and values. Use the icon on the
Form Navigation toolbar, not the similar looking icon on NeoOffice's Standard toolbar.

There are various search options, including searching in one field rather than all fields,
position of the value with in the field, which direction to search in the database, etc.

The ? and * wildcards can also be used, as in the Find and Replace dialog. Additional
information about the database search function can be found in Help.

Searching With a Form Filter
To search with a form filter:

1. Open a form.

2. Click the Form-Based Filters button, on the Form Navigation toolbar.

3. The Form Filter toolbar opens. Enter a value in the appropriate field.

4. Click the Apply Form-Based Filter button .

5. The form is now filtered based on the data entered.

A filter can be removed by clicking the Remove Filter/Sort button .

When formulating filter conditions, various operators and commands are available. Apart
from the relational operators there are SQL-specific commands that query the content of
database fields. If these commands are used, in the NeoOffice syntax, NeoOffice
automatically converts these into the corresponding SQL syntax. SQL commands can
also be entered directly. The following tables give an overview of the operators and
commands:

NeoOffice User Guide for 2.x 404



Chapter 7: Databases and Data Sources

Operators

Operator Meaning Condition is satisfied if...

= equal to ... the content of the field is identical to the indicated
expression. The operator = will not be displayed in
the query fields. If a value without any operator is
entered, the operator = will be automatically adopted.

<> not equal to ... the content of the field does not correspond to the
specified expression.

> greater than ... the content of the field is greater than the specified
expression.

< less than ... the content of the field is less than the specified
expression.

>= greater than or
equal to

... the content of the field is greater than or equal to
the specified expression.

<= less than or
equal to

... the content of the field is less than or equal to the
specified expression.

Commands

NeoOffice
command

SQL
command

Meaning Condition is satisfied if...

IS EMPTY IS NULL is null ... The field is empty. For Yes/No
fields with three states, this command
automatically queries the
undetermined state (neither Yes nor
No).

IS NOT EMPTY IS NOT NULL is not empty ... the field is not empty.

LIKE (placeholder *
for any number of
characters
placeholder ? for
exactly one character)

LIKE (%
placeholder for
any number of
characters
Placeholder _ for
exactly one
character)

is an element of ... the data field contains the
indicated expression. The (*)
placeholder indicates whether the
expression x occurs at the beginning
of (x*), at the end of (*x) or inside
the field content (*x*).Either the
SQL % character or the familiar (*)
file system placeholder can be
entered as a placeholder in SQL
queries in the $[officename]
interface. The * or % placeholder
stands for any number of characters.
The question mark (?) in the
$[officename] interface or the
underscore (_) in SQL queries is used
to represent exactly one character.

NOT LIKE NOT LIKE Is not an element
of

... the field does not contain the
specified expression.

BETWEEN x AND y BETWEEN x
AND y

falls within the
interval [x,y]

... the field contains a value that lies
between the two values x and y.
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NeoOffice
command

SQL
command

Meaning Condition is satisfied if...

NOT BETWEEN x
AND y

NOT BETWEEN
x AND y

Does not fall
within the
interval [x,y]

... the field contains a value that does
not lie between the two values x and
y.

IN (a; b; c...) Note that
the semicolons are
used as separators in
all value lists!

IN (a, b, c...) contains a, b, c... ... the field contains one of the
specified expressions a, b, c,... Any
number of expressions can be
specified, and the result of the query
is determined by an Or link. The
expressions a, b, c... can be either
numbers or characters

NOT IN (a; b; c...) NOT IN (a, b,
c...)

does not contain
a, b, c...

... the field does not contain one of
the specified expressions a, b, c,...

= TRUE = TRUE has the value
True

... the field has the value True.

= FALSE = FALSE has the value
false

... the field has the value false.

Examples of Usage

Command/Operator Result

='Ms.' returns records with the field content “Ms.”

LIKE 'g?ve' returns records with field contents such as “give” and “gave”

LIKE 'S*' returns records with field contents such as “Sun” or “Stop”.

BETWEEN 10 AND 20 returns records with field contents between the values 10 and 20.
(The fields can be either text fields or number fields).

IN(1; 3; 5; 7) returns records with the values 1, 3, 5, 7.

NOT IN ('Smith') returns records that do not contain “Smith”.

In the form view, click the Apply Filter icon to change to the filtered
view.

The filters that have been set can be removed by clicking on the icon
Remove Filter/Sort.

If several filter conditions are to be connected with OR, click the Filter
Navigation icon on the Form Filter toolbar. The Filter Navigator
window appears.

The filter conditions that are set, appear in the Filter Navigator. As soon as a filter is set,
at the bottom of the Filter Navigator notice a blank filter level in which Or can be
selected by clicking on it. Once the blank filter level is selected, enter other filter
conditions in the form. These conditions are linked by Boolean OR to the previously
defined conditions.
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The context menu can be called for every entry in the Filter Navigator. Edit the filter
conditions in this area directly as text. In addition you can also select the filter conditions
(SQL: “Is Null” or (SQL: “Is not Null”) to check if a field has content or not. It is also
possible to delete the entry by using the context menu.

Filter conditions can also be moved within a form in the Filter Navigator by Drag&Drop
or copy them by holding down the Cmd Key.

While designing a form, set the Filter proposal property for each text box in the Data
tab of the corresponding Properties dialog. These fields allow subsequent searches in the
filter mode, selections via a pull-down list all the summarized information contained in
such fields. The field contents can also be easily selected using the AutoComplete
function. Please note however, that this function requires a lot of memory space
especially when used in large databases and should, therefore, be used sparingly.
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Use this section as a guide on customizing the user interface of NeoOffice. This should
be mainly of interest to advanced users of NeoOffice.

Modifying and Customizing the User Interface of NeoOffice

There is a great deal of freedom in configuring menus, toolbars and keys to suit personal
preferences.

You are free to change:

• Items on the menu bar. These can be deleted, new ones added, copied from one menu
to another, renamed, and so on.

• Toolbar configuration. Toolbars may be freely configured to suit.

• Shortcut keys as desired.

Tomake configuration changes, select Tools > Customize… to open the Customize
dialog. Help also provides much useful guidance for configuring NeoOffice.

Configuring the Keyboard
In most instances, you configure new keyboard shortcuts to enable a macro to perform a
certain action on a document. Other actions can also be given a shortcut: for example,
inserting the date with a single command to shortcut keys or to a separate icon. The
following procedure is a simple example which illustrates how to enable a keyboard
shortcut in NeoOffice:

1. Open a text document.

2. Choose Tools > Customize…. The Customize dialog appears.

3. Select the Keyboard tab to specify a key combination.

4. Search for an available key combination in the Keyboard list box such as F4.

5. ClickModify.

6. Select Category > Insert area at the lower left of the Keyboard tab.

7. Select the Date function next to it.

8. ClickModify.

9. Close the dialog with OK.

Now, by pressing the F4 key or whatever shortcut keys were selected, you can insert the
date in the active document.

Configuring Menus
Configuring a menu item is similar to configuring a keyboard shortcut as shown above.
The step-by-step procedure that follows should help in setting up a new menu item, in
this case, the ”Pagination Addon” from ooomacros.org. Pagination provides a dialog
where you can choose some options for numbering the pages of your documents.
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First, download Pagination from the sourceforge.net site. You have to install Pagination
via the Tools > Extension Manager….

To configure the menu item, proceed as follows:

1. Open a document.

2. Choose Tools > Customize to open the Customize dialog.

3. Click theMenu tab. Click New.

4. In dialogue that opens, give a name to the new menu: Pagination. You can choose the
menu position using the black directional arrows. Click OK.

5. In the Customize window, the Pagination menu is selected. Click Add. In the section
Category, click the little triangle near NeoOffice Macros, then click the triangle near
My Macros, and the one near Pagination.

6. Select Pagination, and in the Commands section, clickMain.

7. Click Add.
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8. You can rename the menu entry. SelectMain. ClickModify and Rename. Choose a
better name, Numbering Options for example.

9. In the Customize window click OK. The new menu command is inserted in the menu
bar.

Deleting Menus
1. Choose Tools > Customize to open the Customize dialogue. Click theMenu tab.

2. In the drop-down menuMenu, select the menu you want to delete. ClickModify,
then Delete.

3. Close the Customize dialogue by clicking OK.

Changing Toolbars
1. To have a separating dash after an icon on the toolbar, open the Customize Toolbar
dialogue, by clicking the little triangle at the right end of the toolbar.

2. Click the corresponding command in the ToolbarContent > Commands then click
Modify > Begin a Group.

3. To delete a separating dash, click it in the ToolbarContent > Commands, then click
Modify > Delete.
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The context menu of a toolbar contains a Visible Buttons command. This opens a
submenu with a list of predefined icons. Icons with check marks beside them are visible
on the selected toolbar. Click on an item to switch the icon from visible to hidden and
vice versa. NeoOffice automatically remembers the configuration of the toolbars.

The Visible buttons command in the context menu of the toolbars may also be used to
have a quick overview of the icon names and their functions.

Inserting, Moving and Deleting Icons on Toolbars
Open a document of the type which has the toolbar to modify. For example, to modify
the text object bar for all text documents, open a text document, and then do the same for
the other document types.

If you want to insert an icon, proceed as follows:

1. Open the context menu of the toolbar by clicking the little triangle at the right end of
the toolbar and select the Customize Toolbar… command.

2. In the dialogue that opens, click Add.

3. Select the desired function category then the command. Click Add.

4. If no suitable icon is displayed for this function, clickModify in the Customize
dialogue. Then click Change Icon... and select an appropriate icon. Confirm with OK.

5. Close the Customize dialogue.

If you want to move an icon, proceed as follows:

1. Open the context menu of the toolbar by clicking the little triangle at the right end of
the toolbar and select the Customize Toolbar… command.

2. Select the icon that you will move. Click the appropriate button showing a black arrow
to move the icon upward or downward.

If you want to delete an icon, proceed as follows:

1. Open the context menu of the toolbar by clicking the little triangle at the right end of
the toolbar and select the Customize Toolbar… command.

2. Select the icon that you will delete. ClickModify.

3. Click Delete.

To display toolbars:

1. To open a toolbar, follow this menu path: View > Toolbars > [ToolbarName]

2. Drag the toolbar to its new position.

3. Alternatively, a docked toolbar can be used as a floating toolbar by clicking the
handle (the knurled edge) at the left hand edge of the toolbar and dragging the toolbar
into the window.

4. To attach a floating toolbar it is sufficient to drag it right to an edge of the window. A
shaded shape should appear indicating the location of the docked toolbar. Release the
mouse button and the toolbar should be docked.
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Changing Icon Views
Icon views can be changed between several choices, that appear in the two menus in the
section Icon size and style.

1. Choose NeoOffice > Preferences > NeoOffice.

2. In the View section choose the size and the style of the icons. The default style is
Automatic. It is the new Akua set of toolbar icons with a more Aqua appearance.
Other choices include Crystal (a KDE style iconset) and Industrial (originally a
GNOME style, but from version 2.3 an iconset based on Tango).

3. Click OK to confirm the new settings and close the dialogue.

Changing the Look of the User Interface

Selecting Measurement Units
You can select separate measurement units for Writer, Writer/Web,Calc, Impress and
Draw documents.

1. Select NeoOffice > Preferences.

2. Click on the document type that is to have its measurement unit changed. For
example, click on NeoOffice Writer to select the measurement unit for Writer.

3. Click on General.

4. On the General section, under Settings, is a drop-down menu for selecting the
measurement unit.

5. Close the dialogue with OK.

Customizing Colors
To customize the colors of user interface elements, for example the application
background, proceed as follows:

1. Select NeoOffice > Preferences > NeoOffice > Appearance.

2. In the General section, choose Gray 10% in the drop-down menu facing
Application background. Click OK.

Now, the document windows have a more "Mac-like" background .

Sending Faxes

To send a fax directly from NeoOffice, a fax modem must be installed. If your computer
has a modem that is connected to a phone line, it is automatically configured to send
faxes.

1. Open the Print dialogue by choosing File > Print or click the Print File Directly
icon in the Standard toolbar, and choose Fax PDF from the PDF pop-up menu.

2. Type the fax number in the To field.

3. Make sure the correct modem is selected from theModem pop-up menu.

4. Click Fax.
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Further Information
You can find further information about NeoOffice customization, in the NeoWiki.
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This contains topics of interest to advanced users of NeoOffice including information on
revision marking function (redlining) in Writer and Calc.

Copying and Moving Data Using Drag and Drop

The easiest and often most intuitive way to copy and move data in NeoOffice is by
dragging and dropping with the mouse.

Dragging and Dropping Within a NeoOffice Document
There are many options for moving or copying objects using drag and drop. Selected
text, text areas, draw objects, graphics, buttons and other form functions, hyperlinks,
table areas and many more can be moved with the mouse.

Pay attention when dragging using the mouse pointer. The mouse pointer shows a plus
sign when copying and an arrow when making a link or hyperlink.

Mouse Pointer Shape Description
Arrow Moving

Arrow with green ball Copying
Curved arrow Creating a Link

As with other OS X applications, drag-and-drop is carried out by highlighting the words
or image to be moved, then holding down the mouse button while dragging to a new
location. Pressing Cmd when dragging will copy the object. The pointer is accompanied
by a green ball with a plus sign . To insert a hyperlink, click on the Navigator icon on the
main menu. In the submenu, select Drag Mode icon, which will adopt one of three
guises, depending on whether link, hyperlink or Copy has been selected (so, with Tips
turned on, hover your cursor over the menu bar of Navigator to locate it – see below)
specify whether to copy the object, insert it as a link or insert it as a hyperlink. Drag and
drop operations in NeoOffice can be cancelled at any time by pressing the Esc key before
releasing the mouse button.

Illustration: How and where to find the drag mode in Navigator
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Inserting Objects From the Gallery
Objects can be inserted in a document as either a copy or as a link. A copy of an object is
independent of the original object. It is a whole new object. Changes to the original
object have no effect on the copy. Links, on the other hand, remain dependent on the
original object; thus, changes to the original object are also reflected in the link.

Inserting an object as a copy

1. Open the Gallery, e.g. by clicking on the Gallery icon on the main menu.

2. If necessary, drag down the top bar of the gallery view by dragging on the dotted
section.

3. Choose a theme from the left area.

4. Select the object by a single click.

5. Drag the object into the document or right-click [or Ctrl-click] to open the context
menu and select Insert and Copy.

Inserting an object as a link

1. Place the object in a location that is easy to navigate to (e.g. the Desktop)

2. Follow this path: Insert > Section. The Insert Section window opens, and you may
select Link.
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3. Or, right-click [Ctrl-click] on the image to open the context menu and select Insert
>Link.

Inserting an object as a background graphic

1. Open the Gallery.

2. Choose a theme from the left area.

3. Select the object by a single click.

4. Open the context menu and choose Insert > Background > Page or Paragraph,
depending on whether you wish the graphic to be a background for a whole page or
only a paragraph.

Note: these two functions from OpenOffice.org do not appear to work in OS X :
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a. Inserting an object as a texture (pattern) for another object

1. Open the Gallery.

2. Choose a theme from the left area.

3. Select the object by a single click.

4. Drag the object on to the other object in the document while pressing Ctrl.

b. Copying Graphics From the Gallery

Graphics, dragged from the Gallery, are inserted into a text, spreadsheet or presentation document where
they are dropped.

If the graphic is released directly on a draw object, please note the following:

• If it is moved, by dragging without pressing any key (no additional symbol appears next to the mouse
pointer), only the font attributes are copied from the graphic and applied to the draw object where the
mouse button is released.

• If it is copied by dragging while holding down the Cmd key (a plus sign appears in a green sphere next to
the mouse pointer), the graphic is inserted as an object, e.g. it will displace text around it.

• If a hyperlink is created, by dragging while holding down Cmd-Shift (a linking arrow appears in place of
the pointer), the drawing object is replaced by the graphic from the Gallery; however, the position and
size of the replaced draw object are retained.

Inserting Graphics From a Document in the Gallery
Graphics, from HTML pages and other similar sources, can be placed in the Gallery by

drag-and-drop.

1. Display the Gallery theme to which you want to add the graphic.

2. Position the mouse pointer above the graphic, without clicking.

3. If the mouse pointer changes to a hand symbol, the graphic refers to a hyperlink. In
this case, click the graphic while pressing the Option key to select it without executing
the respective link.

However, if the mouse pointer does not change to a hand symbol, simply click the
graphic to select it.

4. Once the graphic is selected, release the mouse button.

5. Click again on the graphic image, keeping the mouse button pressed for more than two
seconds, to copy the graphic image to memory.

6. Without releasing the mouse button, drag the graphic into the Gallery.

Note: a. Draw objects that are created using the Draw functions floating toolbar, cannot be incorporated in
the gallery.

b. This function works as described in OpenOffice.org. It may not work in NeoOffice. If so, there is a
workaround. Carry out steps 1-3 above. Then right-click or Ctrl-click to bring up a context menu and Copy
the image. The image is now in the clipboard. You may wish to open Preview and File > New From
Clipboard, and Save the file as .png in a place that's easy to find eg your desktop. Close Preview. Move to
select the theme where you want to store this image. Right-click or Ctrl-click on its name to bring up a
context menu and select Properties. Click on the Files tab and Find Files. Now you need to navigate to the
Clipboard (or to wherever you stored it) to find your copied image. Select Open to add the image.
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Copying Graphics Between Documents
Graphics can be copied from one document to another.

Note: If the document is to be published, please observe copyright laws and, for safety, obtain the consent of
the authors of the original.

1. Open the document in which you want to insert the graphic object.

2. Open the document from which you want to copy the graphic.

3. Click the graphic to select it.

4. Right-click or Ctrl-click to open the context menu and select Copy, or use Cmd-C, or

press the Copy icon on the Standard menu.

5. This will place the graphic into the clipboard.

6. Bring the target document into focus.

7. Select the location for the graphic.

8. Right-click or Ctrl-click to open the context menu and select Paste at the position

where you wish to insert a copy of the picture or select the Paste icon on the
Standard toolbar, or use Cmd-V.

9. If the graphic is connected with a hyperlink, the hyperlink and not the graphic is
inserted.

Copying Draw Objects into Other Documents
In NeoOffice it is possible to directly copy draw objects between text, spreadsheets and
presentation documents.

1. Select the draw object or objects.

2. Copy the draw object to the clipboard by using Cmd-C or by right-clicking to open the
context menu and selecting Copy, or use the Copy icon [above].

3. Switch to the other document and place the cursor at which to insert the draw object.

4. Insert the draw object at the target position by using Cmd-V or use the Paste
command from the context menu, or the Paste icon [above].

Inserting a Draw Object in a Text Document

An inserted draw object is anchored in a
text document at the current paragraph.
Anchors can be changed by selecting the
object and clicking on the Change Anchor
icon on the object bar. This opens a popup
menu that permits changing the possible
types of anchor.
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Inserting a Draw Object in a Spreadsheet

An inserted draw object is anchored to a spreadsheet in the current cell.
Change the anchor between cell and page and back by selecting the
object and clicking on the Change Anchor on the object bar.

Drag and Drop With the Data Source View
The simplest and quickest way of transferring data from a data source into a text or
spreadsheet document, or creating forms based on a data source, is the drag-and-drop
method.

Copying with Drag&Drop

To reverse a mistake made during a drag and drop operation, position the cursor in the
document and choose the Undo command from the Edit menu (or via the keyboard with
Cmd-Z).

Note: Copying by drag and drop is possible in both directions:

• A text table or a selected range of a spreadsheet can be dragged using drag and drop to a table container
in the data source explorer or vice versa.

• Likewise, simpler text can be copied using drag and drop from one document to a data field in the data
source view. Read up on how this happens in Help.

Using data in a text document
A database field e.g. <Address> can be inserted in a text document by dragging a field
name from the column header of the data source view into the document. This inserts a
field for this database field in the document. This is especially useful when designing
form letters. Simply drag the desired fields (such as home address, form of address et
cetera), into the document.

The best way to insert a complete record is to select the corresponding header by clicking
once in the empty box to the top left of the table in data source view, and dragging it into
the document. When the mouse button is released, the Insert database columns dialog
appears, where you can decide whether to use all database fields, and whether to copy the
data into the document as text, a table or fields. All currently selected records will be
inserted.
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Applying data to a table document
One or more records can be inserted into the current sheet of a spreadsheet by selecting
the rows in the data source view [click once to bring up a green arrow to the left of the
row required, then click and drag that arrow] and dragging and dropping them into the
spreadsheet. A green sphere with a “plus” sign follows the cursor arrow. The data is
inserted in the place where the mouse button is released.
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Inserting controls in a text form
When a text form, linked to a database, is created, you can generate controls by drag-and-
drop from the data source view: When a database column is dragged into the text
document, a field is inserted. If you hold down Cmd-Shift while dragging, the pointer
turns to a curved linking arrow, and a text field is inserted, grouped with an appropriate
label field. The text field already contains all the database information that is needed for
the form.

Copying Sheet Areas to TextDocuments: OLE Objects

This process, like much of the above, is fairly intuitive for OS X users, since it uses
familiar drag-and-drop and mouse-clicking procedures.

1. Open both the text document and the spreadsheet.

2. Select the sheet area to copy.

3. Point to the selected area and press the mouse button. Keep the mouse button pressed
for a moment, then drag the area into the text document.

If the documents are not visible next to each other, first drag the mouse pointer to the
destination document button. Continue to hold down the mouse button. The document
addressed in this way is displayed, and the mouse pointer can be moved within the
document.

4. Once the cursor is located in the place where you wish to insert the sheet area, release
the mouse button. The sheet area is inserted as an OLE object, i.e. one whose
components can be edited.

Select and edit this OLE object at any time.
• To edit the OLE object, simply double-click on it.

Alternatively, select the object and choose Edit > Object > Edit or choose Edit
from the context menu. The object can be edited in its own frame within the text
document, but the icons and menu commands needed for spreadsheets are visible.

• Choose Open to open the source document of the OLE object.

Inserting Data From Spreadsheets
When you want to copy the contents of a cell (text or numbers), using the clipboard is
best. Copying formulae that are in the cells into the clipboard, such as from the input
lines of the formula bar, is also possible; thus. they can now be inserted into the text.

To copy a simple, rectangular area of cells into a text document as a sheet, select the cells
in the sheet and then use either the clipboard or drag & drop to insert them into the text
document. This will be an OLE object in the text document that can edited.

If cells are dragged to the normal slide view of a presentation document, they will also
re-appear there as OLE objects. Once dragged into the outline view, each cell will form a
line of the outline view. Dragging using drag-and-drop will move the cells. Press the
Shift key, when dragging, to create a copy.
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Inserting Data From Text Documents
Text can be transferred into other document types such as spreadsheets and presentations.
However, there are differences depending on whether the text should be set in its own
text frame, transferred into a spreadsheet cell or transferred into the structure of a
presentation.

• If text is transferred via the clipboard, you can paste it to the destination with or
without text attributes. Use the shortcut keys Cmd-C to copy and Cmd-V to paste.

• To select the format in which the clipboard contents will be pasted, do a long click on
the Paste icon on the Standard toolbar, or click on the little triangle next to it. Select
the format from the submenu.

• To obtain the same selection of formats via the keyboard, choose Edit > Paste Special.

• In a text document use File > Send > Outline to presentation to create a new
presentation document that contains the headings from the text document as the
outline. The headings must be formatted with a corresponding Paragraph Style before
the user can see this command.

• To transfer the same headings to the first superordinate paragraph (or several
paragraphs) of the text, select the File > Send > AutoAbstract to presentation
command. Again, the headings must be formatted with a corresponding Paragraph
Style before you can see this command.

Copying Text Using Drag and Drop
• If you select a text section and drag it into a spreadsheet with drag & drop, it will be
then be inserted as text into the cell where the mouse is released.
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• When a text section is dragged to the normal view of an Impress presentation, an OLE
object is inserted as a NeoOffice plug-in. Highlight this paragraph and drag and drop it
onto an Impress slide in Normal view. Double-click on it and you will find that the
rulers will still be there and you will be able to alter spelling, add words, change
indents etc., as if it was still in this Writer document.

• If text is dragged to the outline view of a presentation, it is inserted at the point where
the cursor is positioned. (This is intuitive behaviour for drag-and-drop users.)

Revision Marking Function

The revision marking function in Writer and Calc highlights changes to documents so
that whoever is editing the file can see who changed what and when.

Recording and Displaying Changes
When several authors are working on the same text or spreadsheet, the review function
(marking changes, redlining) makes it possible to document who made which changes, so
that this is clear to everyone. On the final edit of the document, it is then possible to look
at each individual change and decide whether it should be accepted or rejected.

For purposes of illustration, imagine having to deliver a report. Now, before publication,
the report must be read by the senior editor and the proofreader, and both will add their
changes. Perhaps the senior editor writes clarify after one paragraph and crosses out
another entirely. The proofreader checks the spelling of the document and notes two cases
where explicit references to the gender of an imaginary person could be reworded to
avoid gender entirely. The edited document comes back to you and you can choose to
incorporate or ignore the suggestions of the two reviewers. Plus, you also e-mailed a
copy of the report to a good friend and colleague who has done research on a similar
topic in the past, asking for a few suggestions, and the document is now returned by e-
mail with suggestions. It is now a simple matter to produce a final version of the
document from the results that are returned.

Accepting or Rejecting Changes
When bringing a document in which others have noted their changes back together again,
you can accept or reject the changes individually or all together.

• If you have put multiple copies of the document in circulation, first of all, merge these
into one document (seeMerging Versions just below).
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• Open the document and choose Edit > Changes > Accept or Reject. The Accept or
Reject Changes dialog appears.

• Select a change on the List tab. The change is selected and displayed in the document
and now you make a decision with one of the dialog buttons.

If one author has changed another author's change, you will see the changes
hierarchically arranged with a plus sign for opening up the hierarchy.

When the list of changes is too long or confusing, switch to the Filter tab in the dialog
and specify only the changes of certain authors, or only the changes of the last day, or
that the list should be restricted in some other way.

Changes can also be filtered by the descriptions. Wildcards (as with regular expressions
in the Find & Replace dialog) are permitted when entering the filter.

Text document changes that have not yet been accepted are displayed in the list. Changes
that have been accepted are removed from the list and appear in the text without any
further marking.

Spreadsheet changes that have been accepted are combined in the list in a single entry, so
that you can continue to see which changes have already been accepted.

Color-coded entries inform you about the result of the filter that is set. Entries in black
can be accepted or rejected and match the filter criteria. Entries in blue do not,
themselves, match the filter criteria but have subentries that are included by the filter.
Grayed entries cannot be accepted or rejected and do not match the filter criterion. Green
entries do match the filter but in spite of this cannot be accepted or rejected.

Comparing Versions of a Document
Perhaps one of the authors who received a copy of the document made changes but did
not record them by choosing Edit > Changes > Record. Nonetheless, the delivered copy
of the document can be compared with the original document.

1. Open the original document and then choose Edit > Compare Document.

2. From the file selection dialog, select the copy of the document.

3. Confirm the dialog.
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Now NeoOffice combines both documents in the original document. All text passages
that occur in the document but not in the copy are identified as having been inserted, and
all text passages that are missing in the original document are identified as deletions.

Now start the revision process by accepting the “insertions”, in which case the relevant
texts stay in their original form, or accepting the “deletions”, in which case the marked
text contained in the copy are not inserted in the document.

Merging Versions
It is not always one and the same document that is edited by different authors and passed
from one to the next author. It often makes more sense to give a separate copy of the
document to each author. For example, three copies are returned in addition to the
original document, with different changes in each copy.

It is easy to merge these documents into the original. The only requirement is that the
documents differ only and exclusively in the recorded changes. In other words, all
“normal” text must be identical.

1 Open the original document into which to merge all the copies.

2 Select Edit > Changes > Merge Document.... This opens a typical file selection
dialog from which you can choose a copy of the document.

3 After merging the documents, the designated changes from the copy in the original
document will be visible.

Recording Changes
The review function is available in NeoOffice for both text documents and spreadsheet
documents. Not all changes are recorded (for example, the changing of a tab stop from
align left to align right is not recorded). However, all usual changes made by a
proofreader are recorded, such as additions, deletions, text alterations, usual formatting et
cetera.

1. To start Revision Marking, open the document to be edited and choose Edit >
Changes and click Record (this will display a check mark when enabled).

2. Now start making any changes. Note that all new text passages entered are underlined
in color, while all deleted text remains visible but is crossed out and shown in color.

3. If a marked change is touched with the mouse pointer, one will see a reference to the
type of change, the author, date and time of day for the change in Help Tips.

If Extended Tips is also enabled (on the Help menu), any available comments on this
change will be displayed.

Changes in a spreadsheet document are highlighted by a border around the cells; when a
cell is pointed to more detailed information on this change is seen in Help Tips when
Extended Tips is also enabled (on the Help menu).
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Comments on each marked change may be entered by placing the cursor in the area of
the change and then choosing Edit > Changes > Comment.... In addition to Extended
Tips, the comment is also displayed in the list in the Accept or Reject Changes dialog.

To stop recording changes, choose Edit > Changes > Record again to disable the
function (the check mark is removed). Now the document can be saved and returned to
the person who asked for the changes.

In a text document, you may highlight all lines that have changed with an additional
marking. This can be in the form of a red line in the margin, for example.

Select the type of additional selection under Tools > Options... > Text Document on the
Changes tab or under Tools > Options > NeoOffice Calc on the Changes tab. In these
dialogs, determine how and in what color the changes should be flagged, where on the
page the dash should be and so forth.

Version Management

The File menu contains a Versions command. The Versions function allows you to save
multiple versions of the same document in the same file. You can choose to view
individual versions of a document, or display the differences between versions with color
markings. In the dialog for opening a document, choose which version of the document is
wanted for editing from a list box.

Protecting Contents in NeoOffice

The following is an overview of the different ways of protecting contents in NeoOffice
from being modified, deleted or viewed.

Protecting All Documents When Saving
All documents that are saved in XML format (OpenOffice.org or NeoOffice Format) can
be provided with a password. These documents can no longer be opened without the
password. The content is secured, so that it cannot be read with an external editor either.
This applies to content, graphics and OLE objects.

Turning on protection

1. Select File > Save As

2. Check Save with password.

3. Save the document.

Note: As always with passwords, make sure it is one you will remember, or you may lock yourself out of
this document.

Turning off protection

1. Open the document and enter the correct password.

2. Choose File > Save As and uncheck Save with password.

Information that is entered under File > Properties, such as the name of the author, date
created, word and character counts et cetera, is not encrypted.

NeoOffice User Guide for 2.x 430



Chapter 9: Advanced Techniques

Protecting Revision Marking
With every change made in Calc and Writer, the review function records who made the
change. This function can be turned on with protection, so that it can only be turned off
when the correct password is entered. Until then, all changes continue to be recorded and
acceptance or rejection is not possible.

Turning on revision protection

1. Choose Edit > Changes > Protect Records.

2. Enter and confirm a password of at least 5 characters.

Turning off revision protection

1. Choose Edit > Changes > Protect Records.

2. Enter the correct password.

Protecting Cell Ranges in Calc
In Calc, protection can be applied to spreadsheets and the whole document. As part of the
process, choose whether the cells are protected against accidental changes, whether the
formulas can be viewed, whether the cells are visible and/or whether the cells can be
printed.

Protection may be password protected, but this is not always necessary. Once protection
is assigned a password, protection can only be removed by entering the correct password.

Note: Cell protection for cells, setting the Protected attribute, is only effective when the whole table is
protected. The default condition of a protected table is that every cell receives the Protected attribute. Thus,
in cells where the user may make changes, the attribute must be removed selectively for those cells. Once
this is done then protect the whole table and save the document.

Turning on protection For cells: Select cell range. Choose Format > Cells > Cell Protection
tab.

For spreadsheets: Choose Tools > Protect Document > Sheet.
For documents: Choose Tools > Protect Document > Document.
Enter and confirm a password of at least 5 characters.

Turning off
protection

For spreadsheets: Choose Tools > Protect Document > Sheet.
For documents: Choose Tools > Protect Document – Document.
Where a password has been assigned, enter the correct password.

Protecting Sections in Writer
Any section of a NeoOffice Writer text document can be protected against changes with a
password.

Turning on protection

1. Select the section.

2. Choose Insert > Section > Section,

3. UnderWrite protection mark the Protect andWith password check boxes. (If the
section already exists: Format > Sections.)

4. Enter and confirm a password of at least 5 characters.
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Turning off protection

1. Choose Format > Sections > Section

2. UnderWrite protection, uncheck Protect.

3. Enter the correct password.

Protecting Cells in a NeoOffice Writer Table
The contents of individual cells of a Writer text table can also be protected from changes.

Turning on protection Place the cursor in a cell or select cells. Choose Table > Protect
Cells

Turning off protection First, ensure that Tools > Options > NeoOffice Writer >
Formatting Aids > Cursor in protected areas has Enable
checked. Place the cursor in the cell or select the cells.
Right-click or Cmd-click to bring up the context menu and select
Cell > Unprotect.

Automatic Protection of Indexes and Tables
Tables of contents, alphabetical indexes and so on that are created automatically in
Writer, are automatically protected against accidental changes.

Turning on protection

1. Place the cursor in the index/table of contents.

2. From the context menu choose Edit Index/Table.

3. On the Index/Table tab page, check Protected against manual changes.

Turning off protection

1. Ensure that Tools > Options > NeoOffice Writer > Formatting Aids > Cursor in
protected areas has Enable checked.

2. Place the cursor in the index.

3. From the context menu choose Edit Index/Table.

4. On the Index/Table tab page, uncheck Protected against manual changes or, in the
Navigator, select the index, open the context menu and select Index > Read-only .
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Protecting frames, graphics and OLE objects
Many objects can be inserted in NeoOffice documents. You can protect the content,
position and/or size of inserted graphics. The same applies to frames (in Writer) and OLE
objects.

Turning on protection For graphics inserted in a document: Choose Format > Picture> Options
tab. Under Protect, mark Contents, Position and/or Size.

Turning off protection For graphics inserted in a document: Choose Format > Picture> Options
tab. Under Protect, uncheck as appropriate.

Protecting Drawing Objects and Form Objects
Draw objects, that are inserted in a document using the Draw Functions floating toolbar,
can be protected from being accidentally moved or changed in size. Likewise, you can do
the same with form objects inserted using the Form Functions floating toolbar.
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Turning on protection

1. Select Format > Object > Position and Size > Position and Size tab.

2. Check the Protect check box respectively for Size and/or Position.

Turning off protection

1. Choose Format > Object > Position and Size > Position and Size tab.

2. Uncheck the Protect check box for Size and/or Position as appropriate.

Protecting Records
Changes made in a document can be recorded by choosing either Edit > Changes >
Record or Edit > Changes > Protect Records. If Protect Records is selected, you must
enter the correct password in order to turn off the function or accept or reject changes.

1. Select Protect Records. This opens the Password dialog.

2. Enter a password consisting of at least 5 characters and confirm it.

3. Click OK.

Digital Signatures and Encryption1

Overview
Use of Digital signatures in NeoOffice is new to NeoOffice 2.0 and is relatively new in
other office applications. Nonetheless,, the requirement to protect data from being
modified has existed for a long time.

1 Specification -- http://specs.openoffice.org/appwide/security/Electronic_Signatures_and_Security.sxw
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While NeoOffice 1.1.x offered protection for documents with encryption and passwords,
digital signatures offer enhanced secure protection of document content, both inside
NeoOffice 2.0 and externally.

Another aspect of using digital signatures, is for ensuring Macro security. This can be a
very important topic because when you access a document containing macros, or receive
them via email, you cannot know if these can be trusted or whether they may harm the
system. Given there is no easy way to determine whether a macro is harmful, the decision
whether to trust a macro or not to trust must be based on the trustworthiness of the macro
author. Unfortunately, you cannot know that the macro really comes from the author or
that it has not been modified by somebody else. Digital certificates and signatures are the
solution. Authors can sign the macro with a private key and you can then verify the
signature with the author's public keys. An added benefit of using digital signatures is the
assurance that the content has not been modified.

Certificates

How to get a Certificate?

There are really only two ways to get a certificate. One, to create one for yourself or, two,
to obtain one from a trusted signing authority.

Self-signed certificates

These are user-created using certificate creation tools. The following list provides some
that are known at the time of writing this section. In this case, users are expected to know
and understand the basics of the procedure.

Product OS Vendor

SelfCert.exe Windows Microsoft – part of Office

abylon
SELFCERT

Windows http://www.abylonsoft.com/frame.htm

Certificate
Assistant

Mac OS X Built-in, via Applications/Utilities/Keychain
Access/Certificate Assistant

CA.pl Linux, BSD, Solaris10 Comes with OpenSSL.

keytool JDK or JRE Part of Java (Solaris)

Please see the instructions in the Operating System documentation for your system.

Certificates from a Certificate Authority

Depending on your needs, getting a certificate from a Certificate Authority may be free
or have a cost attached. Some Certificate Authorities offering certificates are listed
below:

Vendor Cost Type Contact

Thawte Free Email http://www.thawte.com/

Comodo Free 30 day trial Server and email http://www.instantssl.com
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Vendor Cost Type Contact
/

Verisign Cost All types http://www.verisign.com/

CAcert Free All types http://www.cacert.org/

Integrating a Certificate with NeoOffice
See Help > Contents > Index > Search term > digital signatures for instructions on
enabling Digital Signatures in NeoOffice for instructions.
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Changing Defaults and Other Configuration Items

Saving Configuration With Document
You can set a global configuration (so that it applies to all documents of this type), or can
connect the configuration to a specific document, which must exist as a file.

1. Load the document to which you wish to connect the configuration, or open any
document of the same type.

2. Set the configuration. For example, select the toolbars that should be visible or
define what is on the toolbars, menus or status bar and so on. All such
configuration options are found under Tools > Customize.

3. Click Save in in the dialog under Tools > Customize. Select from the drop-down
menu.

4. Click OK to confirm overwrite.

5. Select File > Save As.. and select from among file-types.
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The configuration is now connected to the active document. Check this by loading the
document and choosing File > Template > Organize then double-clicking the document
name.

As soon as you load or open this document, the configuration that was saved with it
becomes active. The global default configuration is restored when another document is
loaded or opened that does not contain custom configuration information. Select manual
settings at any time by choosing Tools > Customize and clicking the Reset button.

Inserting and Editing Tab Stops
Set a tab stop by clicking on the ruler. Alternatively, you can set tab stops by choosing
Format > Paragraph. Both methods affect the current paragraph or all selected
paragraphs.

Click the ruler once to set a left-justified tab. Right-click a tab icon on the ruler to see the
context menu in which the tab type can be changed.

To set several decimal tabs one after the other, keep clicking the icon to the left of the
ruler until the desired tab type is shown, then click on the ruler.

Selection Description:
Setting left tabs
Setting right tabs
Setting decimal tabs
Setting centered tabs

Double-click the ruler to open the Paragraph dialog.

Double-click the white area of the ruler to set one tab. The Paragraph dialog appears
with the Tabs tab page.

Note: To assign tabs directly to a current Paragraph Style, open the context menu of that paragraph and
choose Edit Paragraph Style to call the Paragraph Style dialog where tabs are then entered.

Moving Tabs on the Ruler

There are three ways to set tabs:

1. Move individual tab stops on the ruler using the mouse.
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2. Tomove several tab stops on the ruler, press the Shift key before clicking a tab. Drag
one tab while continuing to press Shift to move that tab as well as all the tabs to the
right of it. The spacing between those tabs remains the same.

3. Press Ctrl instead of Shift when dragging a tab on the ruler to move that tab and all the
tabs to the right of it. This results in the spacing between those tabs changing
proportionally to their distance from the margin.

Note: while the hint in 3. above works in OpenOffice.org, it may not work in OS X

Changing the Properties of Tabs

To change tab type, click the tab to be changed on the ruler, then open the context menu
by right-clicking or Cmd-clicking.

Deleting Tabs

Deleting a tab with the mouse is easy. Simply hold down the mouse button while
dragging the tab outside the ruler e.g. down onto the document itself.

Changing the Defaults

To change the settings of the default tab stops, see the settings in Tools > Options >
(Document Type) > General. The Context Menu of the ruler toolbar allows changes to
the displayed units to centimetres, inches, point, pica et cetera. These changes are only
valid until exiting NeoOffice, and they only apply to the ruler from which context menu
the changes were made. To change the ruler measurement units permanently, choose
Tools > Options > NeoOffice Writer > General and change the measurement unit there.

Changing the Color of Text

Click the Font color icon in Writer and other modules, and keep the mouse
button pressed to obtain a floating toolbar from which to choose from the range of colors.
The example above has the color red selected, indicated in the bar below the “A”.

Drop-down menu for selection
of your font color. The menu
contains over 90 pre-set colors,
and you may add more to it
easily.

The following applies to all modules (Writer, Calc, Draw, Impress): select the text that is
to take another color, then click the color desired on the floating toolbar.

Note: Only in Writer: If you click on the Font Color icon with a short-click while no text is selected, the
mouse can then be used to identify the text whose color is to be changed. Use the mouse key pressed to drag
across a text area. This text area takes the selected color. The function remains active for as long as the
symbol is “pressed”, or until clicked without dragging, or until the Esc key is pressed.
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Inserting Landscape pages into a Portrait-oriented Document
1. Open the Styles and Formatting window (Format > Styles and Formatting or
Ctrl-F11)

2. In the Styles and Formatting window, click on the Page Styles icon (fourth icon
from left)

3. The type "Standard" or similar title should already be highlighted; do a right-click
or Ctrl-click while on the highlighted title to see the context menu and choose
"New..."

4. In the dialog that appears, give the new page style a descriptive name; for
example, Landscape

5. Click on the Page tab and change the page orientation to Landscape by clicking
on the corresponding radio button. At the same time, make other changes to the
page style, as needed (such as adjusting the margin sizes).

6. Click on OK. The new style will appear as one of the style choices.

7. Place the text cursor in the document at the location at which to insert the
Landscape page

8. Select Insert > Manual Break

9. In the dialog that appears, select Page Break and in the Style list, select the new
page style, e.g. "Landscape";

10. Click OK
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More on Templates

Changing Default Templates
When a new document is opened using File > New, a blank document appears based on
the default NeoOffice template for that document type. You can edit or modify this
document or replace it with an existing document so that the new document contains
personalized custom format attributes or other contents.

Modifying Default Templates
If there is an existing NeoOffice document which is satisfactory, use it. However, if you
find that there is no suitable example, you can do the following to create a new template:

1. Open a new, empty document

2. Edit it until it makes a good template. For example, edit the styles in the Styles
and Formatting window.

3. By way of example, the following describes how to proceed for text documents
and these steps can be applied for other types of NeoOffice documents.
Templates, of course, can be defined for each NeoOffice module.

a. Now save the document, created in step 2, by choosing File > Templates >
Save and saving the document in, say, the Default category.

b. Select File > Templates > Organize.

c. Double-click Default in the list on the left. This will display the user-defined
templates in the User/Library/Preferences/NeoOffice-2.x/user/template
directory.

d. Select the template which was just saved and open the context menu or open
the submenu of the Commands button.

e. Choose Set as default template.

That is all that is needed. The next time a new text document is opened, the new
document will correspond to the template defined as “Default” in step 5 above.

Resetting Default Templates
To reset the modified text template to the original default template, proceed as follows:
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1. Select File > Templates > Organize.

2. Open the context menu and choose Reset default template. In the submenu,
select the document type to restore. Thereafter, when you open an empty text
document, it will again correspond to the NeoOffice default template for text
documents.

Using Custom Templates
There are several ways to make work easier by using custom templates. One of the most
important ways is via quick access to the templates. Templates can be stored in different
locations in NeoOffice. The process of opening a new document using a custom template
will then differ accordingly.

New templates are saved using File > Templates > Save or by selecting the “Template”
file type in the “normal” Save dialog. User templates are usually stored in the
User/Library/Preferences/NeoOffice-2.x/user/template directory.. The template is made
available, anytime, by selecting it in the New dialog (File > New > From Templates and
Documents). When the template is opened, a new document will be created, based on
that template.

Remember to update the view of the templates in the dialog to ensure that newly created
templates are visible. In this case, select File > Templates > Organize and in the
submenu of the Commands button, choose Update. To modify the template oneself, call
this file via File > Templates > Edit and then edit it.

NOTE: This may or may not work depending on whether or not the network filesystem is set up correctly.
Please see the NeoWiki, or check your file locations.
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Macros

NeoOffice provides a number of sample macros to help guide you in programming
macros, but also to serve as useful aids that can be used immediately. Use these to get an
overview of how to write a macro.

These macros are only available in English, regardless of the installation language.

Accessing the Sample Macros

Calling the Sample Macros
1. Select Tools > Macros > Run Macro. TheMacro Selector dialog appears.

2. In the Library field, double-click NeoOffice Macros

3. The list will expand; double-click Gimmicks, or click on the triangle next to it. The
Gimmicks modules appear.

4. Choose one of the modules (e.g. the AutoTextmodule) by clicking the entry.

5. ClickMain in theMacro name field.

6. Click the Run button to run the module.
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7. A new document is created, listing the AutoText entries available to this installation of
NeoOffice.

Since the object of this exercise was to run a macro, Run Macro was selected. Below an
alternative, Organize Macros, is used to uncover other features.
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Editing the Sample Macros
1. Select Tools > Macros > Organize Macros > NeoOffice Basic. The NeoOffice
Basic Macros dialog appears.

2. In theMacro from field, double-click NeoOffice Macros.

3. The list will expand; double-click Gimmicks. The Gimmicks modules appear.

4. Choose one of the modules (e.g. the AutoTextmodule) by clicking the entry.

5. ClickMain in the Existing Macros in: field if it is not already selected.

6. Click the Edit button.

The Basic IDE appears. This is where you can view and edit the program code.
The following illustration shows some of the code you would see by following these
instructions.

You can find instructions on how to use the Basic IDE by opening NeoOffice help (Help
> NeoOffice Help) and choosing the Contents tab. From there:Macros and
Programming > General Information and User Interface Usage > NeoOffice Basic
IDE. The NeoWiki may also have some tips.
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Note: Tools > Macros > Organize Macros also contains entries for Python, BeanShell, and JavaScript.
These are other languages that can be used to write NeoOffice macros. Each language has samples for
review.

The Sample Macros

The following sample macros are in the Gimmicks module.

AutoText
Use the Main macro.

This macro opens an empty Writer document and inserts a table in which the names of all
the AutoTexts are listed.

You can print the document to have a handy list of the available AutoTexts.

ChangeAllChars
Use the ChangeAllChars macro.

Use this macro in a text document to replace all text and numbers with the characters "x"
and "X". This can be helpful, for example, if the document is to be used as a template but
the original text is not to be legible.

If you edit this macro, other replacement characters can be defined in the program code.

GetTexts
Use the Main macro.

This macro carries out a search in the active document (text document, spreadsheet, or
drawing) and compiles a list of the contents.

This sample will help you learn how to reference objects in the documents.

ReadDir
Use the Main macro.

Use this macro to see how a NeoOffice Draw document can be filled with content and
how the contents of directories are read.

A dialog asks for a directory and then the macro creates a graphic list (tree view) of all
the files and subdirectories.

Userfields
Use the StartChangesUserfields macro.

This macro helps users manage several sets of user data and allows switching back and
forth between them. This can be quite helpful when more than one person uses the same
copy of NeoOffice and each person wants to see his or her own user data in the fields.
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NeoOffice Math

Most people who are using Math will know what it is for, so this explanation is for those
new to the program. It is a specialist program described as OpenOffice.org's (and hence
NeoOffice's) component for mathematical equations. It is most commonly used as an
equation editor for text documents, but it can also be used with other types of documents
or stand-alone. When used inside Writer, the equation is treated as an object inside the
text document. Similarly, one can also insert these equations into other NeoOffice/
OpenOffice.org programs like Calc and Impress.

Using Math, there are three main ways of entering a formula:

○ Typemarkup in the equation editor.

○ Right-click on the equation editor and select the symbol from the context
menu.

○ Select a symbol from the Selection toolbox.

(- reference, http://www.openoffice.org/product/math.html)

It is similar to Microsoft Equation Editor. It supports multiple fonts and can export to
PDF.
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Formula Entry

Main View of NeoOffice Formula.

Tool bar
The tool bar is divided into two parts.

The upper part is for adjusting the on screen size of the image. It is only active when you
open an independent formula: File > New > Formula. The lower part contains an icon
for an interactive cursor, and an icon for inserting special characters. It is always active.

Command Icon Box
The command icon box provides a method of writing an equation using GUI similar to
other word processors.
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The upper two rows in the icon box are menus that call the actual command buttons into
the lower portion of the command box. The command buttons are used to insert the
appropriate command at the cursor position in the command field.

Command Dialog Box

The command dialog box displays the commands that create the equation. The dialog box
can be edited directly.

Creating an Equation with Dialog Commands
To create an equation with equation editor, enter the programming commands in logical
sequence into the dialog box. The commands entered are similar to the commands used to
generate equations in TeX ( a scientific publishing format).

Maintaining logical consistency of the commands entered into the dialog box is
important. The brackets used in the dialog box must be matched, for example all "(" must
have a corresponding ")".

Here are some examples. As can be seen, it is really simple to type formulae in the dialog
box.

Command Input Field Formula
1+1=2 11=2
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The next example shows how round brackets ( ) and braces { } are used. The parenthesis
are used when it is desired to display grouping in the equation, the brace is used to group
the commands, but to not display. If braces are needed in an equation, then the lbrace
and rbrace commands are used.

Command Input Field Formula
(1+2) over (2+3) 12

 23
{ 1+2 } over { 2+3 } 1 2

2 3
lbrace 1+2 rbrace over lbrace 2+3 rbrace {12 }

{23 }

Here is a more complicated example.

Command Input Field Formula
{{1 over 5} +4} over {5+{4+1}over{3+3+1}} 1

5
4

5
41
331

NeoOffice User Guide for 2.x 454



Chapter 11: Using NeoOffice Math

Special Formatting

Of course there are many other types of groupings that can be created with NeoOffice.

Exponentiation:

Command Input Field Formula
2^3 23

5^(1+3+3^2) 5 133
2 

Subscripting:

Command Input Field Formula
a_3 a3
(1 over i)_%alpha +%delta_3

1
i



3

Leading and trailing superscript and subscript:

Command Input Field Formula
2 lsub ( 123 ) 2123
2 rsub ( 123 ) 2 123
2 lsup ( 123 ) 2123

2 rsup ( 123 ) 2 123

Bi lsup{209}+fe lsup{58} toward Mt
lsup{266}lsub{109} +n lsup {1}

Bi209  fe58  Mt109
266  n1

In the last example, the 'Mt' has both leading superscript and subscript applied. This
requires only typing both commands after 'Mt'.

NeoOffice User Guide for 2.x 455



Chapter 11: Using NeoOffice Math

Centre subscript / superscript:

Command Input Field Formula
{2-4*3} csub ( 123 ) 2− 4∗3

123 
+18 csup ( plus ) - (1+2+3+4) csub {minus}

 18
 plus 

−123 4
minus

Under brace / Over brace:

Command Input Field Formula
+ 18 underbrace plus - ( 1 + 2 + 3 + 4)
underbrace minus

18
plus

−123 4
minus

+ 18 overbrace plus - ( 1 + 2 + 3 + 4)
overbrace minus 18

plus

−123 4
minus

Various types of Brackets
In almost all equations various types of brackets are required. NeoOffice formula allows
the use of several kinds of brackets.

{ } structural braces: used to group parts of an equation for programming purposes.

( ) Parenthesis: used to group parts of an equation. Parenthesis are displayed in the final
equation.

[ ] square brackets: usage is the same as parenthesis ( ).

{ } braces: as the keyboard characters { } are used for program commands and are not
displayed in the resulting formula, braces must be typed as lbrace for '{' and rbrace for
'}'

The size of brackets can be controlled with the commands 'left' and 'right'

Command Input Field Formula
(1+2 - 2 cdot (2 over (2 - 1 )))

12−2⋅
2

2−1


left (1+2-2 cdot left (2 over {2-1} right ) right ) 12−2⋅ 2
2−1 

left lbrace a^2+b^2=c^2 right rbrace {a2b2= c2 }

Special Characters

Many equations use special characters in addition to the usual characters of the alphabet.
NeoOffice provides an easy method to use Greek characters, while any other character in
the available fonts can be used.

NeoOffice User Guide for 2.x 456



Chapter 11: Using NeoOffice Math

The Sigma appears in the tool bar when NeoOffice Formula is active. This activates the
dialog for special characters.

The Greek letters and other symbols can be entered directly into the command dialog box
by entering the name of the special character preceded by %, for example %SIGMA
produces Σ and %mu gives μ.
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Special Operators

The following examples show the use of some special operators

Integral Sign:

Command Input Field Formula
int from {1} to {+infinity}{x^{-3 over 2}over
3} dx = "?" ∫

1

∞
x
−3
2

3
dx=?

Summation Character:

Command Input Field Formula
sgn (%sigma) cdot sum from {%SIGMA in
%PHI}{1 over {1 - aleph_%sigma^2}} sgn ⋅∑

∈

1

1−ℵ
2

Product Character:

Command Input Field Formula
prod from {i=1} to {i=100}{{ (x_i+1) cdot
x_i^3} over { x_i^2 -1 } } = "?" ∏

i=1

i=100 x i1⋅x i
3

x i
2−1

=?
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Vectors and Matrices

Vectors and Matrices are created by the 'stack' and 'matrix' commands respectively. These
commands are used with the octothorp # to indicate elements, and double octothorp ##
to indicate new line. An empty element is indicated by structural braces {}.

Vector
Vectors are composed using the 'stack' command as follows:

Command Input Field Formula
left (stack {A # B # a+b=c } right )  A

B
ab= c

left( stack {alignr 1 # 2 } right) + left( stack
{ 2 # 3 } right) + left( stack { 3 # 1 } right)  1223  31
Matrix
Matrices are composed using the matrix command as follows:

Command Input Field Formula
left( matrix { 1 # 2 ## 2 # 3 } right) = x 1 2

2 3= x
abs matrix { a # b ## c # {} } = y ∣a b

c ∣= y
left[ matrix { {1 over 2} # b ## c # d } right] =
z [12 b

c d ]= z
Formatting

There are some additional formating commands that are available in NeoOffice Formula.
These allow adjustment of the size, colour, and layout of the equation.

Size
The instruction size changes the size of text in the equation.

Command Input Field Formula
size -2 { a+b} = size +10 {C}

ab=C

Colour
The instruction “colour” changes the colour of the text in the equation.

Colours available are red, blue, green, yellow, white, and black (default),

NeoOffice User Guide for 2.x 459



Chapter 11: Using NeoOffice Math

Command Input Field Formula
colour blue A A
left( matrix { { colour red 1} # { colour blue
2} ## {colour green 3} # 4 } right) = colour
black {x}

1 2
3 4= x

Layout
Various text formating commands are available to change the layout.

Command Input Field Formula
bold {"bold"} newline "newline" bold

newline

Alignment
The alignment commands are available to change the position of the elements of an
equation with respect to each other.

Command Input Field Formula
stack{ alignr a ={} # alignr b+c+d ={}}
stack{ alignl 12 # alignl b^2-2 }

a=
b cd=

12
b2−2

NeoOffice User Guide for 2.x 460



Chapter 11: Using NeoOffice Math

Examples

Now for the complicated examples:

Command Input Field Formula
nroot{4}{nroot {3} {1 over 3+x^2} }

4 3 13x 2
ldline R_ %alpha rdline =left ldline matrix
{sin %alpha # -cos %alpha ## cos %alpha #
sin %alpha} right rdline

∥R ∥=∥sin  −cos
cos sin  ∥

{partial over {partial t} x(t)}+a(x)=%lambda
cdot F(x,t)

∂
∂ t
x  t  a x =⋅F x , t 

matrix{
a_11 # a_12 # dotsaxis #a_{"1m"} ##

a_21 # a_22 # dotsaxis # a_{"2m"} ##
dotsvert #dotsvert #dotsdown #dotsvert ##

a_{"n1"} # a_{"n2"} # dotsaxis #a_{"nm"}
}

a11 a12 ⋯ a1m
a21 a22 ⋯ a2m
⋮ ⋮ ⋱ ⋮
an1 an2 ⋯ anm

sqrt{1-x} = 1 - x over 2 - 1 over 2 x^2 over 4
- dotslow 1− x=1− x2−

1
2
x 2

4
−

t= size +6 int from {r_0} to {r_t} size -8 {dr
over sqrt {2 over %mu [E_cm - V(r)] - l^2
over {%mu^2 r^2} } } t=∫

r0

r t
dr

 2 [Ecm−V r ]− l 2

2 r2

left ( stack{n # k} right ) = fact n over {fact k
cdot fact (n-k)} nk = n!

k !⋅ n− k !
f(x) = left lbrace matrix {1# "if"# x in setZ ## 1 over
x # "if" # x in setQ ##0 #"if"# x in setR } right none

f x ={1 if x∈ℤ
1
x

if x∈ℚ

0 if x∈ℝ
[a;a_0,a_1,a_2,dotslow ] = a+{1 over {a_0+1
over {a_1+{1 over {a_2+1 over dotslow}}}}} [ a ; a0, a1, a2,]=a

1

a0
1

a1
1

a2
1
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Chapter 12: Building Forms with Xforms

NeoOffice 2.0 now allows you to create forms based on the open W3C XForms standard.
With XForms it is very easy to implement simple logic without any programming.

This simple example describes creation of a forms document which can be used to create
and collect data-sets of a predefined structure in order to exchange this data with other
parties.

1. You create a new document as shown below.

2. You add form controls and layout of the document.

3. When your layout is completed, you can start to work on the properties of the
individual form controls. The first step is binding the controls to their respective
counterparts in the instance data.

4. You add a submission control. Normally the instance data is saved together with the
document or to a linked instance. By using a submit button, the instance data can be
sent to a server, to an email recipient or can be saved to a file.

5. You can now switch off Design Mode to use the form. Where the finished form is to
be shared with others, you should also set the form to open in usage mode (i.e. not
in Design Mode) by default.

Step-by-Step Procedure

1. Start with File > New > XML Form Document as shown below:
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2. Then Use View > Toolbars and ensure that the Form Control and Form Design
toolbars are checked.

3. Youmay dock any that are floating.

NeoOffice User Guide for 2.x 465



Chapter 12: Building Forms with Xforms

4. Ensure that Data Navigator is enabled as shown below (bottom of the window).

5. Edit the form and add text boxes (click on the Text Box icon in the Form
Control menu) for those fields that are needed.
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6. Select one of the text boxes and right-click or Ctrl-click to bring up the context
menu. Select Control as shown here.

7. When the window comes up for each text box, adjust these values as shown: you
will need to type in the words “NameBox” and “AmountBox”, and the “Binding”
values; other selections can be made via buttons.
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8. Use the Data Navigator at the right hand side of your window. Under the
"Bindings" tab the defined bindings should be visible and the default model
should be listed in the drop-down menu on the left side of the "Models" button.
In the Data Navigator pick a binding, do a right-click and select Edit Binding:

9. In this dialog, select the settings needed. For this example, these are

○ Name: type in “Binding 1”
■ Binding Expression: type in “Name”
■ Data type as “String”
■ Check “Required” as Condition

○ Name: type in “Binding 2”
■ Binding Expression: type in “Amount”
■ Select Data type “Decimal”
■ Check “Required” as Condition
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10. Now deselect Design mode by clicking on Design Mode On/off icon on the
Form Control toolbar. We do this so that the form may be tested in Run mode.

11. Enter data in the fields. Note in the graphic below, the red frame and the error
message indicate that the Amount field is mandatory and must filled in:
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12. Because you usually want to do something with the data from the form, it is
important to add a "Submission". Therefore toggle back to the Design mode, go
to the Data Navigator window again then click on the "Submission" tab and
click the Add icon.

13. Next, fill out the "Add Submission" dialogue as shown below. In this example
data is simply saved to a file, like this one following:
file:///Users/yourname/Desktop/Contractor_payments1.xml Youmay employ
more complicated methods as suits your requirements.

14. With the Design Mode toggled On, click on the box next to the title “Contractor
Payments” in the Data Navigator window, and drag to a position on the form.
When you release the mouse button, a click-button with that title should appear
on the form. Alternatively, you may add a button as shown below via the
commands Form Controls > Push Button. Use the cross-hairs to draw and place
the button, then select it and use a right-click or Ctrl-click to bring up a context
menu. Select Controls and you should see the Propertiesmenu as shown. Fill
in as shown.
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15. Toggle Design On/Off to Off and test.

16. This graphic shows the content of the submit as stored in the files specified above.
Repeat with different amounts and the previous instance is recorded at the front of
the report.

The instance data are saved with the document.
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Using Xforms and further xml processing can thus produce very usable reports et cetera.
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This section contains hints and tips for using Tools > XML Filter Settings to create new
filters.

Flat XML filter

There are two different ways to get OpenOffice.org to output Flat Xml files:

1. Using the method from the SDK (See http://api.openoffice.org/ )

2. Using Tools > XML Filter Settings

Outputting Flat XML files and importing them is fairly straight forward with the built-in
tool. The following is a step-by-step procedure that will let you save and open flat XML
files:

1. Click on Tools > XML Filter Settings

2. Click on New
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3. Enter your settings as shown in the following illustrations:
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An XML filter may be useful if you work in an organisation which has proprietary XML
formats.
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4. Test your filter using the current document. A display will open that provides
output similar to the following:

<?xml version="1.0" encoding="UTF-8"?><office:document
xmlns:office="urn:oasis:names:tc:opendocument:xmlns:of
fice:1.0"
xmlns:style="urn:oasis:names:tc:opendocument:xmlns:sty
le:1.0"
xmlns:text="urn:oasis:names:tc:opendocument:xmlns:text
:1.0"
xmlns:table="urn:oasis:names:tc:opendocument:xmlns:tab
le:1.0"
xmlns:draw="urn:oasis:names:tc:opendocument:xmlns:draw
ing:1.0"
xmlns:fo="urn:oasis:names:tc:opendocument:xmlns:xsl-
fo-compatible:1.0"
xmlns:xlink="http://www.w3.org/1999/xlink"
xmlns:dc="http://purl.org/dc/elements/1.1/"
xmlns:meta="urn:oasis:names:tc:opendocument:xmlns:meta
:1.0"
xmlns:number="urn:oasis:names:tc:opendocument:xmlns:da
tastyle:1.0"
xmlns:svg="urn:oasis:names:tc:opendocument:xmlns:svg-
compatible:1.0"
xmlns:chart="urn:oasis:names:tc:opendocument:xmlns:cha
rt:1.0"
xmlns:dr3d="urn:oasis:names:tc:opendocument:xmlns:dr3d
:1.0" xmlns:math="http://www.w3.org/1998/Math/MathML"
xmlns:form="urn:oasis:names:tc:opendocument:xmlns:form
:1.0"
xmlns:script="urn:oasis:names:tc:opendocument:xmlns:sc
ript:1.0"
xmlns:config="urn:oasis:names:tc:opendocument:xmlns:co
nfig:1.0"
xmlns:ooo="http://openoffice.org/2004/office"
xmlns:ooow="http://openoffice.org/2004/writer"
xmlns:oooc="http://openoffice.org/2004/calc"
xmlns:dom="http://www.w3.org/2001/xml-events"
xmlns:xforms="http://www.w3.org/2002/xforms"
xmlns:xsd="http://www.w3.org/2001/XMLSchema"
xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
office:version="1.0" office:mimetype="application/x-
vnd.oasis.openoffice.text">

<office:meta>

<meta:generator>OpenOffice.org/2.0$Linux
OpenOffice.org_project/680m3$Build-8968

</meta:generator>

<dc:title>Using Data Sources</dc:title>

<meta:initial-creator>Ian
Laurenson</meta:initial-creator>

...

5. Use Save As and select the Flat filter from the list.
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Of course, you need to supply an XSLT file to provide the instructions needed to do
the conversion. Here is a simple example that you can use and it is the the content of
the file simple.xsl that was used above.:

<xsl:stylesheet version="1.0"

xmlns:xsl="http://www.w3.org/1999/XSL/Transform">

<xsl:strip-space elements="*"/>

<xsl:template match="/">

<xsl:copy-of select="."/>

</xsl:template>

<xsl:output method="xml" indent="yes"/>

</xsl:stylesheet>
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Note: The bulk of this chapter has been taken from the NeoWiki at
http://neowiki.neooffice.org/index.php/Main_Page

What is printed here has been edited: much more detail is available in the NeoWiki.

In the case of problems with NeoOffice, you are advised to check the NeoWiki as a matter of
good practice. The second step, if the solution is not available on NeoWiki, should be to
post questions on the support forum at Trinity,NeoOffice's forum base:
http://trinity.neooffice.org/modules.php?name=Forums

Always make sure that you are using the latest iteration of Mac OS X (e.g., 10.3.9 or 10.4.8)
and the latest available security and Java updates from Apple (see below for instructions on
using Software Update and checking your Java version) as well as the latest NeoOffice
patch, from http://www.planamesa.com/neojava/en/patch.php

Installation

Before Installing
Users of NeoOffice often ask if they need to uninstall NeoOffice before installing a
newer version. The short answer is NO; in fact, completely uninstalling NeoOffice using
the linked instructions before launching the new version may actually cause your old
preferences to be reset and dictionaries, macros and other user files to be deleted.

NeoOffice 2.0 will install over top of an existing NeoOffice 1.2.2 installation, replacing
the old version while preserving a number of "user" files that live inside of the
application bundle. On first launch, NeoOffice 2.0 will also offer to import your
NeoOffice 1.2.2 preferences. After upgrading, you should be sure to install the most
current version of any language packs and check for upgrades to any installed
dictionaries.

Upgrading from NeoOffice/J 1.1
NeoOffice 2.0 installs separately from NeoOffice/J 1.1 in /Applications and will offer to
import the NeoOffice/J 1.1 preferences into its new preferences folder the first time it
launches. You can use either version without affecting the other after this point. After
installing NeoOffice 2.0, you should be sure to install the most current version of any
language packs and check for upgrades to any installed dictionaries.

If you no longer want to keep one of the versions, follow the Uninstalling NeoOffice
instructions; be sure to empty the trash, or documents may fail to open in the remaining
version (this is an Apple bug).

Installation Issues
1. When double-clicking on the .dmg file, there is an error about "No mountable file
systems":
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1. This error usually means that the NeoOffice .dmg was not completely
downloaded. Some combinations of browsers and internet connections
frequently cause large downloads like NeoOffice to stop before the entire file
is downloaded but do not inform you that the download has failed.

2. In this case, you might try using the command-line curl tool to complete the
download (this tool is also useful if you are on a dial-up connection and may
need to stop and start the download to use the phone line). Instructions on
using curl to download NeoOffice can be found via the NeoWiki.

2. When running the NeoOffice installer, the "test" returns with "NeoOffice can not
be installed on this computer":

○ This can sometimes occur simply because your current version of NeoOffice
is open. Check whether that is the case, and quit NeoOffice if it is open. Try
again to install.

○ The BSD subsystem is installed by default on 10.3.x and 104.x as part of the
BaseSystem.pkg. If this problem occurs on 10.3.x machines, your BSD
subsystem may have been somehow removed or messed up. It is not
recommended that you reinstall BaseSystem.pkg alone, since this may leave
your system in an unusable state. Instead, reinstall Mac OS X from your retail
CD; select the "Upgrade" option to preserve all of your settings, documents,
etc. Then reinstall the latest Mac OS X updates and security updates to return
you system to an up-to-date state.

○ N.B.: Since this requires a fairly significant amount of work, and perhaps
time, you should probably check the trinity forums first, to see if someone can
determine if something else is the problem and find another solution.

3. Installation stalls when it gets to the "Select Destination" screen

○ Installation sometimes stalls or hangs when it gets to the "Select Destination"
screen (and no drives will appear to choose from). The Apple Installer is
known to hang when probing all of the volumes on your system, if any of
your volumes are unreadable.

○ Try opening each of the volumes on your desktop in the Finder and
unmounting any iPods. Once you can open all volumes, then try re-running
the installer. If opening any volumes causes the Finder to hang, you have
found the cause of the problem and you might need to reboot to force Mac OS
X to unmount the offending volume.

4. Installation fails with a "generic" error message

○ For some users, installation will fail and the following error message will
appear:

■ There were errors installing the software

■ Please try installing again.
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○ If you see this message, you need to open the System Preferences application
(/Applications/System Preferences), click on the International icon, select the
Languages tab, move English to the top of the list, log out, login again, and
then rerun the installer. After installation, you can (and should) revert to your
preferred language.

○ This behavior is required to work around a rare but serious bug in the Mac OS
X Installer on some versions of Mac OS X; for more information, see the
NeoWiki.

Post-Installation Issues

NeoOffice fails to start, or crashes during startup
If NeoOffice fails to start, or crashes during startup or right after starting

1. Check the Console.log (via /Applications/Utilities/Console.app) for messages
about Java, soffice.bin, or NeoOffice

◦ If NeoOffice starts but “hangs” during startup (longer than a minute or so on

recent Macs), take a sample before force-quitting NeoOffice. One of the
developers or community support team might be able to deduce the problem
based on the log information.

◦ If NeoOffice crashes, check for a current entry in

~/Library/Logs/CrashReport/soffice.bin.crash.log (the crash log for NeoOffice
and also, unfortunately, OpenOffice.org)

◦ These logs will often contain useful information, and even if they are

gibberish to you, one of the developers or community support team can often
deduce the problem based on log info.

2. Check to see if you are running the most up-to-date version of Java 1.4.2 (or Java
1.5 on Mac OS X 10.4)

3. Run the Mac OS X Software Update application (from the Apple menu) and
install any Mac OS X Updates, Security Updates, and Java Updates that are
offered. Youmay need to run Software Update multiple times in order to
completely update your system.

Check the Java Version

Open the Terminal (/Applications/Utilities/Terminal.app) and type the first line below,
and then press return. You should get a message like that below:

java -version

+ Mac OS X 10.3.9:

java version "1.4.2_12"

Java(TM) 2 Runtime Environment, Standard Edition (build 1.4.2_12-270)
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Java HotSpot(TM) Client VM (build 1.4.2-70, mixed mode)

+ Mac OS X 10.4.8:

java version "1.5.0_07"

Java(TM) 2 Runtime Environment, Standard Edition (build 1.5.0_07-164)

Java HotSpot(TM) Client VM (build 1.5.0_07-87, mixed mode, sharing)

Check for a corrupt Java 1.4.2 installation

Create a plain-text file called Test.java and put the following lines in it, saving
afterwards:

import java.awt.*;

public class Test {

public static void main(String[] args) {

Frame f = new Frame();
Panel p = new Panel();
f.add(p);
f.setSize(500, 500);
f.show();

}

}

*

1. Open the Terminal (/Applications/Utilities/Terminal.app) and "cd" to the folder
that you put the Test.java file in.

2. Compile the Test.java file using the following terminal command:

javac Test.java

3. Run the compiled program with Java 1.4.2 using the following terminal
command:

/System/Library/Frameworks/JavaVM.framework/Versions/1.4.2/Commands
/java -classpath . Test

4. If a blank window appears when you run the program, then you know that Java
1.4.2 is working.

Haxies

Haxies work by injecting their code into running applications in order to customize the
behavior of Mac OS X or an application in a way that neither Apple nor the application
developer intended. A haxie may have a bug that causes an application to crash, or it may
simply create a condition that the application is not prepared to handle and thereby cause
a crash.

Because of the scope of the NeoOffice project and the limited time and resources of the
NeoOffice developers, no effort will be made to fix a bug that only occurs when a haxie
is present.

● Disable any installed haxie(s), or add NeoOffice to the exclusions list for the haxie(s)
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Corrupted user preference files

(Force-)Quit NeoOffice, move your NeoOffice preferences folder aside, and restart (don't
let NeoOffice 2.x (re-)import your NeoOffice 1.x preferences). Here is where the
preference folder for respective versions of NeoOffice is located:

+ NeoOffice 2.x: ~/Library/Preferences/NeoOffice-2.x

+ NeoOffice 1.2.x: ~/Library/Preferences/NeoOffice-1.x

+ NeoOffice/J 1.1: ~/Library/NeoOfficeJ-1.1 Error Message contains “Get Storage:
"No Content"”

Performance

Common causes of slow or lackluster performance
1. Background processes

Constantly-running background processes can degrade the performance of NeoOffice

◦ Folding@Home

◦ Seti@Home

◦ DNET client (http://www.distributed.net/)
○ Dashboard/widgets - disable all inessential widgets for best performance
○ Others?

2. Turn off Auto Spellchecking, because the wavy lines are a problem to draw. This is
due to the fact that OOo code sets individual pixels but Cocoa and Java, used in
NeoOffice, don't have any functions for setting individual pixels; so NeoOffice must
do a much more expensive operation of drawing a 1x1 pixel filled rectangle

3. Less than 512 MB of RAM: NeoOffice is a big suite of programs, and generally
requires at least 512 MB of RAM to run comfortably. While NeoOffice will run on a
Mac with less than 512 MB of RAM, it will run (and launch) more slowly, particularly
if you have other applications also running (Mac OS X really runs best with 512 MB
or more of RAM).

4. Large number of fonts installed. Font Book allows the OS X user to manage fonts
very quickly and effectively. Take a minute to disable fonts that are rarely used.

5. OpenOffice.org 2.0: OpenOffice.org 2.0 by default creates converted copies of all
of your installed Mac fonts. Because these fonts are stored inside an application bundle
in OpenOffice.org 2.0 (as opposed to simply being in a normal folder in
OpenOffice.org 1.1.2), all of the duplicate fonts are loaded by the Apple Type Server
(ATS) process and made available to Mac OS X apps. These duplicate fonts seriously
degrade the performance of NeoOffice, may cause fonts to display incorrectly, and
may even cause crashes. To remedy this,

○ Do not use the standard OpenOffice.org 2.0 .app package; use Start
OpenOffice.org and the "stand-alone" OpenOffice.org 2.0 instead

○ After using OpenOffice.org 2.0, reboot before using NeoOffice to clear the
extra fonts from ATS.
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6. Virus-scanning applications:

○ Some virus scanners scan all files when the files are opened
○ Some virus scanners scan archive files (.sit, .tar, .gz, and .zip and its cousins,
like .jar) when those files are accessed

○ NeoOffice opens and accesses a large number of files at startup, including a
number of .zip and .jar archives, so they may all be scanned in turn by the virus
scanner.

○ To remedy, disable virus scanning of the NeoOffice application and preferences
directory (~/Library/Preferences/NeoOffice-2.x), or of archive files in the
NeoOffice application and preferences directory.

Hints and Tips

Preferences don't seem to stick
When preferences or settings changes don't seem to apply or don't stick between restarts
of NeoOffice, the most likely cause is a some sort of corruption of your
profile/preferences. Allowing NeoOffice to create a fresh set should fix the problem.

1. Move or rename your ~/Library/Preferences/NeoOffice-2.x folder
(~/Library/Preferences/NeoOffice-1.x folder for NeoOffice 1.x; in this case, also rename
or move aside your ~/Library/NeoOfficeJ-1.1 folder, if you had ever installed
NeoOffice/J 1.1)

2. Launch NeoOffice; it will then create a fresh user profile and settings (for NeoOffice
2.0, be sure not to let the "wizard" import preferences from older versions when starting)

In some cases the corruption may only be present in the NeoOffice 2.x or 1.x profile. In
this case, allowing NeoOffice to re-import your NeoOffice 1.x or NeoOffice/J 1.1 profile
could restore some of your settings without reintroducing the corruption. In that case,
simply move or rename only the ~/Library/Preferences/NeoOffice-2.x
(~/Library/Preferences/NeoOffice-1.x for NeoOffice 1.x) folder before launching
NeoOffice.

How to get the page count to ignore a title page
- (How do I “offset” the page count?)

If you have a title page or cover page in the document, Writer's "page count" field still
counts those pages, and so your overall page count will be too high.

1. Place the cursor directly in front of the page number (in the header or footer) on
any page. If the pages are yet to be numbered, follow the instructions for
numbering, then start this process again.

2. Double-click to bring up the Edit Fields dialog
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3. Enter -1 in the Offset box at the bottom [or -x, where x is the number of pages to
be kept un-numbered at the start]

4. Press OK.

Note: If there are pages added later at the beginning of the dcoument, this process may need to be repeated.

NeoOffice refuses to print Landscape
There is a tendency for OS X users to expect that all they need to do to change from
printing portrait to printing landscape (and back) is to change settings via File > Page
Setup. Unfortunately, this is not sufficient in NeoOffice. The key is to go to Format >
Page. Select the Page tab, and you will see the selections of Portrait and Landscape
there. Select as relevant and close the menu. This is counter-intuitive for Mac users, but
it works.
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Accents......................................................................65

Accessibility..............................................................57
Shortcuts....21p., 29, 43, 65, 76, 104, 119, 155, 184,
212, 399, 410, 426

Adabas.....................................................................373

Adding...........................................................................
Backgrounds.....................110, 147, 167, 191, 220p.
Bullets............................................................87, 132
Buttons in toolbars............................................412p.
Captions........................................................137, 160
Command buttons................................401, 403, 464
Conditions for XForm items............................6, 464
Line numbers........................................................143
Objects from Gallery....63, 163, 335, 353, 368, 419,
421

Address Book..................................................373, 395

Address books...............................................................
Registering...........................................................395

Address labels from databases................................183

Adjacent Paragraph Format......................................78

ADO........................................................................373

Akua............................................................................2

Aligning.........................................................................
Objects..................................................................323
Objects in Draw...................................................324

Alphabetical indexes...............................................123

Anchoring......................................................................
Objects..................................................................159

Anchors.........................................................................
Changing..............................140, 155, 167, 189, 422

Animating text.........................................................110

Appearance options.................................................414

Areas..............................................................................
Fill..................................................................83, 101
Patterns.........................................................110, 220
Shadows.................................................71, 114, 189
Slanting.................................................................323
Transparency...........................................344, 350pp.

Assigning scripts.....................................................410

Attachments in e-mails.............................................28

Auto Pilot......................................................................
Impress.................................................................288
Templates and Documents...................................288

Auto-correction.........................................................65

AutoAbstract function for sending text to
presentations.........................................................426

AutoComplete...............................................................
In text and list boxes............................................407

AutoComplete function..................................104, 106

AutoCorrect...............................................................37
Disabling..............................................................102

AutoCorrect function....................................................
Adding exceptions................................................106
Dashes....................................................................70
Options...................................................................40
Replacement table.................................40, 103, 175
Switching on and off............................................107
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Editing..................................................................233
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Backgrounds..................................................................
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Bold...............................................................................
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Brochures......................................................................
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Bullets...........................................................................
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Changing view.....................................................414
Toolbars................................................................412

Calc...............................................................................
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AutoFormat function............................................220
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Public Documentation License, Version 1.0
1.0 DEFINITIONS.

1.1. "Commercial Use" means distribution or otherwise making
the Documentation available to a third party.

1.2. "Contributor" means a person or entity who creates or
contributes to the creation of Modifications.

1.3. "Documentation" means the Original Documentation or
Modifications or the combination of the Original Documentation
and Modifications, in each case including portions thereof.

1.4. "Electronic Distribution Mechanism" means a mechanism
generally accepted for the electronic transfer of data.

1.5. "Initial Writer"means the individual or entity identified as
the Initial Writer in the notice required by the Appendix.

1.6. "Larger Work"means a work which combines
Documentation or portions thereof with documentation or other
writings not governed by the terms of this License.

1.7. "License" means this document.

1.8. "Modifications" means any addition to or deletion from the
substance or structure of either the Original Documentation or
any previous Modifications, such as a translation, abridgment,
condensation, or any other form in which the Original
Documentation or previous Modifications may be recast,
transformed or adapted. Awork consisting of editorial revisions,
annotations, elaborations, and other modifications which, as a
whole represent an original work of authorship, is a
Modification. For example, when Documentation is released as a
series of documents, a Modification is:

A. Any addition to or deletion from the contents of the Original
Documentation or previous Modifications.

B. Any new documentation that contains any part of the Original
Documentation or previous Modifications.

1.9. "Original Documentation" means documentation described
as Original Documentation in the notice required by the
Appendix, and which, at the time of its release under this License
is not already Documentation governed by this License.

1.10. "Editable Form" means the preferred form of the
Documentation for making Modifications to it. The
Documentation can be in an electronic, compressed or archival
form, provided the appropriate decompression or de-archiving
software is widely available for no charge.

1.11. "You" (or "Your")means an individual or a legal entity
exercising rights under, and complying with all of the terms of
this License or a future version of this License issued under
Section 5.0 ("Versions of the License"). For legal entities, "You"
includes any entity which controls, is controlled by, or is under
common control with You. For purposes of this definition,
"control" means (a) the power, direct or indirect, to cause the
direction or management of such entity,whether by contract or
otherwise, or (b) ownership of more than fifty percent (50%) of
the outstanding shares or beneficial ownership of such entity.

2.0 LICENSEGRANTS.

2.1 Initial Writer Grant.

The Initial Writer hereby grants You a world-wide, royalty-free,
non-exclusive license to use, reproduce, prepare Modifications
of, compile, publicly perform, publicly display, demonstrate,
market, disclose and distribute the Documentation in any form,
on any media or via any Electronic Distribution Mechanism or
other method now known or later discovered, and to sublicense
the foregoing rights to third parties through multiple tiers of
sublicensees in accordance with the terms of this License.

The license rights granted in this Section 2.1 ("Initial Writer
Grant") are effective on the date Initial Writer first distributes
Original Documentation under the terms of this License.

2.2. Contributor Grant.

Each Contributor hereby grants You a world-wide, royalty-free,
non-exclusive license to use, reproduce, prepare Modifications
of, compile, publicly perform, publicly display, demonstrate,
market, disclose and distribute the Documentation in any form,
on any media or via any Electronic Distribution Mechanism or
other method now known or later discovered, and to sublicense
the foregoing rights to third parties through multiple tiers of
sublicensees in accordance with the terms of this License.

The license rights granted in this Section 2.2 ("Contributor
Grant") are effective on the date Contributor first makes
Commercial Use of the Documentation.

3.0 DISTRIBUTION OBLIGATIONS.

3.1. Application of License.

The Modifications which You create or to which You contribute
are governed by the terms of this License, including without
limitation Section 2.2 ("Contributor Grant"). The Documentation
may be distributed only under the terms of this License or a
future version of this License released in accordance with Section
5.0 ("Versions of the License"), and Youmust include a copy of
this License with every copy of the Documentation You
distribute. Youmay not offer or impose any terms that alter or
restrict the applicable version of this License or the recipients'
rights hereunder. However, Youmay include an additional
document offering the additional rights described in Section 3.5
("Required Notices").

3.2. Availability of Documentation.

Any Modification which You create or to which You contribute
must be made available publicly in Editable Form under the
terms of this License via a fixed medium or an accepted
Electronic Distribution Mechanism.

3.3. Description of Modifications.

All Documentation to which You contribute must identify the
changes Youmade to create that Documentation and the date of
any change. Youmust include a prominent statement that the
Modification is derived, directly or indirectly, from Original
Documentation provided by the Initial Writer and include the
name of the Initial Writer in the Documentation or via an
electronic link that describes the origin or ownership of the
Documentation. The foregoing change documentation may be
created by using an electronic program that automatically tracks
changes to the Documentation, and such changes must be
available publicly for at least five years following release of the
changed Documentation.

3.4. Intellectual Property Matters.

Contributor represents that Contributor believes that Contributor's
Modifications are Contributor's original creation(s) and/or
Contributor has sufficient rights to grant the rights conveyed by
this License.

3.5. Required Notices.
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Youmust duplicate the notice in the Appendix in each file of the
Documentation. If it is not possible to put such notice in a
particular Documentation file due to its structure, then Youmust
include such notice in a location (such as a relevant directory)
where a reader would be likely to look for such a notice, for
example, via a hyperlink in each file of the Documentation that
takes the reader to a page that describes the origin and ownership
of the Documentation. If You created one or more
Modification(s) Youmay add your name as a Contributor to the
notice described in the Appendix.

Youmust also duplicate this License in any Documentation file
(or with a hyperlink in each file of the Documentation) where
You describe recipients' rights or ownership rights.

Youmay choose to offer, and to charge a fee for, warranty,
support, indemnity or liability obligations to one or more
recipients of Documentation. However, Youmay do so only on
Your own behalf, and not on behalf of the Initial Writer or any
Contributor. Youmust make it absolutely clear than any such
warranty, support, indemnity or liability obligation is offered by
You alone, and You hereby agree to indemnify the Initial Writer
and every Contributor for any liability incurred by the Initial
Writer or such Contributor as a result of warranty, support,
indemnity or liability terms You offer.

3.6. Larger Works.

Youmay create a Larger Work by combining Documentation
with other documents not governed by the terms of this License
and distribute the Larger Work as a single product. In such a case,
Youmust make sure the requirements of this License are fulfilled
for the Documentation.

4.0 APPLICATION OF THIS LICENSE.

This License applies to Documentation to which the Initial Writer
has attached this License and the notice in the Appendix.

5.0 VERSIONSOF THE LICENSE.

5.1. New Versions.

Initial Writer may publish revised and/or new versions of the
License from time to time. Each version will be given a
distinguishing version number.

5.2. Effect of New Versions.

Once Documentation has been published under a particular
version of the License, Youmay always continue to use it under
the terms of that version. Youmay also choose to use such
Documentation under the terms of any subsequent version of the
License published by G Roderick Singleton [Insert name of the
foundation, company, Initial Writer, or whoever may modify this
License]. No one other than G Roderick Singleton [Insert name
of the foundation, company, Initial Writer, or whoever may
modify this License] has the right to modify the terms of this
License. Filling in the name of the Initial Writer,Original
Documentation or Contributor in the notice described in the
Appendix shall not be deemed to be Modifications of this
License.

6.0 DISCLAIMER OFWARRANTY.

DOCUMENTATION IS PROVIDEDUNDER THIS LICENSE
ON AN "AS IS'' BASIS,WITHOUTWARRANTYOF ANY
KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING,
WITHOUT LIMITATION, WARRANTIES THATTHE
DOCUMENTATION IS FREEOF DEFECTS,
MERCHANTABLE,FIT FOR APARTICULAR PURPOSEOR
NON-INFRINGING. THE ENTIRE RISK AS TO THE
QUALITY,ACCURACY,AND PERFORMANCEOF THE
DOCUMENTATION IS WITHYOU. SHOULDANY
DOCUMENTATION PROVEDEFECTIVE IN ANY RESPECT,
YOU (NOT THE INITIALWRITEROR ANYOTHER
CONTRIBUTOR)ASSUMETHE COST OF ANYNECESSARY
SERVICING, REPAIROR CORRECTION. THIS DISCLAIMER
OFWARRANTYCONSTITUTESAN ESSENTIAL PARTOF
THIS LICENSE.NO USE OF ANYDOCUMENTATION IS
AUTHORIZED HEREUNDEREXCEPTUNDER THIS
DISCLAIMER.

7.0 TERMINATION.

This License and the rights granted hereunder will terminate
automatically if You fail to comply with terms herein and fail to
cure such breach within 30 days of becoming aware of the
breach. All sublicenses to the Documentation which are properly
granted shall survive any termination of this License. Provisions
which, by their nature, must remain in effect beyond the
termination of this License shall survive.

8.0 LIMITATION OF LIABILITY.

UNDER NO CIRCUMSTANCESAND UNDER NO LEGAL
THEORY,WHETHER IN TORT(INCLUDING NEGLIGENCE),
CONTRACT,OR OTHERWISE, SHALLTHE INITIAL
WRITER, ANYOTHER CONTRIBUTOR,OR ANY
DISTRIBUTOR OF DOCUMENTATION, OR ANY SUPPLIER
OF ANYOF SUCH PARTIES, BE LIABLE TO ANY PERSON
FOR ANYDIRECT, INDIRECT,SPECIAL, INCIDENTAL,OR
CONSEQUENTIALDAMAGESOF ANY CHARACTER
INCLUDING,WITHOUT LIMITATION, DAMAGES FOR
LOSSOF GOODWILL, WORK STOPPAGE,COMPUTER
FAILUREOR MALFUNCTION, OR ANYAND ALLOTHER
DAMAGESOR LOSSESARISINGOUT OF OR RELATING
TO THE USE OF THE DOCUMENTATION, EVEN IF SUCH
PARTYSHALLHAVEBEEN INFORMEDOF THE
POSSIBILITYOF SUCHDAMAGES.

9.0 U.S. GOVERNMENTEND USERS.

If Documentation is being acquired by or on behalf of the U.S.
Government or by a U.S. Government prime contractor or
subcontractor (at any tier), then the Government's rights in
Documentation will be only as set forth in this Agreement; this is
in accordance with 48 CFR 227.7201 through 227.7202-4 (for
Department of Defense (DOD) acquisitions) and with 48 CFR
2.101 and 12.212 (for non-DOD acquisitions).

10.0 MISCELLANEOUS.

This License represents the complete agreement concerning the
subject matter hereof. If any provision of this License is held to
be unenforceable, such provision shall be reformed only to the
extent necessary to make it enforceable. This License shall be
governed by California law, excluding its conflict-of-law
provisions. With respect to disputes or any litigation relating to
this License, the losing party is responsible for costs, including
without limitation, court costs and reasonable attorneys' fees and
expenses. The application of the United Nations Convention on
Contracts for the International Sale of Goods is expressly
excluded. Any law or regulation which provides that the
language of a contract shall be construed against the drafter shall
not apply to this License.

Appendix

Public Documentation License Notice
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The contents of this Documentation are subject to the Public
Documentation License Version1.0 (the "License"); you may
only use this Documentation if you comply with the terms of this
License. A copy of the License is available at
http://www.openoffice.org/licenses/PDL.rtf.

The Original Documentation is OpenOffice.org User Guide for
Version2.x. The Initial Writer of the Original Documentation is G
Roderick Singleton (C) 2005. 2006. All Rights Reserved. (Initial
Writer contact(s): grsingleton@openoffice.org[Insert
hyperlink/alias].)

Contributor(s): Erwin Tenhumberg, Mary Ellen Dawley indexing
and Ross Johnson (OpenOffice.org User Guide for Version2.x)

Peter Mitchell and Jacqueline Gouguenheim-Desloy (NeoOffice
User Guide for 2.x).

Portions created by Peter Mitchell and Jacqueline Gouguenheim-
Desloy are Copyright (C)2007[Insert year(s)]. All Rights
Reserved. (Contributor contact(s):NeoOfficeUser@pbm-
au,net[Insert hyperlink/alias]).

Note: The text of this Appendix may differ slightly from the text
of the notices in the files of the Original Documentation. You
should use the text of this Appendix rather than the text found in
the Original Documentation for YourModifications.
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